1. 32509f1 Resolve placeholder expressions before trying to deduce by John McCall · 13 years ago
  2. 1bf9a9e Represent an APValue based on a Decl as that Decl, rather than a DeclRefExpr by Richard Smith · 13 years ago
  3. 180f479 Constant expression evaluation: support for evaluation of structs and unions of by Richard Smith · 13 years ago
  4. 66f8571 constexpr: static data members declared constexpr are required to have an by Richard Smith · 13 years ago
  5. 839046a Add test missed from r143234. by Richard Smith · 13 years ago
  6. 5c27ee0 Undo unnecessary change by Douglas Gregor · 13 years ago
  7. c2c1144 Make the -Wc++11-compat warnings ignored by default, so we don't break by Douglas Gregor · 13 years ago
  8. 0661bd0c Attach class template attributes to the templated CXXRecordDecl, by Peter Collingbourne · 13 years ago
  9. 7a8a2e3 Permit auto SCS on parameter declarations, C++03 [dcl.stc]p2 by Peter Collingbourne · 13 years ago
  10. 5f31f08 Switch to the C++11 warning flags in tests. Patch by Ahmed Charles! by David Blaikie · 13 years ago
  11. 762bb9d Update all tests other than Driver/std.cpp to use -std=c++11 rather than by Richard Smith · 13 years ago
  12. b3df138 Switch diagnostic text from "C++0x" over to "C++11". by Douglas Gregor · 13 years ago
  13. 6e43375 constexpr: Disable checking of constructor member initializer lists for by Richard Smith · 13 years ago
  14. b5a0187 Diagnose attempts to declare a non-static data member with a by Douglas Gregor · 13 years ago
  15. 9f569cc constexpr: semantic checking for constexpr functions and constructors. Based in by Richard Smith · 13 years ago
  16. 55dec86 constexpr functions are implicitly const. More tests to follow. by Richard Smith · 13 years ago
  17. c6d990a constexpr: semantic checking for constexpr variables. by Richard Smith · 13 years ago
  18. 82d0b0a Add support for alignment-specifiers in C1X and C++11, remove by Peter Collingbourne · 13 years ago
  19. af130823 Don't allow template argument deduction to deduce a placeholder type, by Douglas Gregor · 13 years ago
  20. 87e96eb PR10458: Last part of providing 'auto' type specifier as an extension in C++98: permit it within type-ids. by Richard Smith · 13 years ago
  21. 8f4fb19 PR10458: Finesse behaviour of C++0x features when in pre-0x mode. Accept for-range and auto with an ExtWarn, and produce a -Wc++0x-compat warning in C++98 mode when auto is used as a storage class. by Richard Smith · 13 years ago
  22. af1fc7a Track in the AST whether a function is constexpr. by Richard Smith · 13 years ago
  23. 31862ba [ARC] When casting from a pointer to an objective-c object with known ownership, if the by Argyrios Kyrtzidis · 13 years ago
  24. 9a636e8 Extend the deduced/actual argument type checking of C++ by Douglas Gregor · 13 years ago
  25. 0f9dc86 When an explicit specialization has a storage specifier, error if that by Douglas Gregor · 13 years ago
  26. 51d7cdd Downgrade the error complaining about presence of a storage class by Douglas Gregor · 13 years ago
  27. 7a614d8 Implement support for C++11 in-class initialization of non-static data members. by Richard Smith · 13 years ago
  28. e885e18 Diagnose the presence of storage-class-specifiers on explicit by Douglas Gregor · 13 years ago
  29. 1804174 PR9908: Fix the broken fix for PR9902 to get the template argument lists in the right order. by Richard Smith · 13 years ago
  30. 3e4c6c4 Implement support for C++0x alias templates. by Richard Smith · 13 years ago
  31. 3b88735 Extend Sema::ClassifyName() to support C++, ironing out a few issues by Douglas Gregor · 13 years ago
  32. 162e1c1 Support for C++11 (non-template) alias declarations. by Richard Smith · 13 years ago
  33. fc8f0e1 fix a bunch of comment typos found by codespell. Patch by by Chris Lattner · 13 years ago
  34. ad762fc Add support for C++0x's range-based for loops, as specified by the C++11 draft standard (N3291). by Richard Smith · 13 years ago
  35. abea951 Add -fcxx-exceptions to all tests that use C++ exceptions. by Anders Carlsson · 14 years ago
  36. 12e3ece Provide Fixit warning when 'auto' is intended as storage by Fariborz Jahanian · 14 years ago
  37. e7397c6 Fix a few auto-related issues: by Richard Smith · 14 years ago
  38. 24d44ed Add reference to PR 9278 for archaeologists. by Richard Smith · 14 years ago
  39. ddc83f9 C++0x's deduced auto is illegal in typedefs. by Richard Smith · 14 years ago
  40. 483b9f3 Tweaks to C++0x deduced auto type support: by Richard Smith · 14 years ago
  41. 34b41d9 Implement the C++0x deduced 'auto' feature. by Richard Smith · 14 years ago
  42. e41721e Pass -fexceptions to all tests that use try/catch/throw. by Anders Carlsson · 14 years ago
  43. 604eb65 Improve our handling of user-defined conversions when computing by Douglas Gregor · 14 years ago
  44. ed328c6 Diagnose the use of "inline" on block-scope function declarations in by Douglas Gregor · 14 years ago
  45. 7378012 Commit my WIP on constexpr support. This commit: an XFAILed test and treating constexpr as a top-level const. by Sebastian Redl · 14 years ago
  46. 06245bf Improve handling of friend types in several ways: by Douglas Gregor · 14 years ago
  47. 1eabb7d Improve diagnostics when an elaborated-type-specifer containing a by Douglas Gregor · 14 years ago
  48. 4033642 Change the representation of dependent elaborated-type-specifiers by Douglas Gregor · 14 years ago
  49. 7c2342d When pretty-printing tag types, only print the tag if we're in C (and by John McCall · 15 years ago
  50. 3cb0ebd Create a new InjectedClassNameType to represent bare-word references to the by John McCall · 15 years ago
  51. 0757c8c Implement [dcl.fct.spec]p6. by Anders Carlsson · 15 years ago
  52. 05f6500 C++0x [dcl.typedef]p4, take 3, where we actually figure out what "that by Douglas Gregor · 15 years ago
  53. 3970099 Use isa<ElaboratedType> rather than getAs<ElaboratedType>, since the by Douglas Gregor · 15 years ago
  54. 93dda72 Allow redefinitions of typedef-names within class scope when the type by Douglas Gregor · 15 years ago
  55. a572887 Update tests to use %clang_cc1 instead of 'clang-cc' or 'clang -cc1'. by Daniel Dunbar · 15 years ago
  56. d739021 Switch XFAIL format to match LLVM. by Daniel Dunbar · 15 years ago
  57. 8c8d919 Add CheckCallReturnType and start using it for regular call expressions. This will improve error messages. For by Anders Carlsson · 15 years ago
  58. e3af023 Refactoring around friend class templates. Better error message for friend enums. by John McCall · 15 years ago
  59. d85bea2 Rework the Parse-Sema interaction for friends to better support friend by Douglas Gregor · 15 years ago
  60. 9cc7807 Track a class template specialization's point of instantiation separately by John McCall · 15 years ago
  61. 136a698 When stringizing a NamedDecl for a diagnostic, treat the template by John McCall · 15 years ago
  62. c4e7019 Support elaborated dependent types and diagnose tag mismatches. by John McCall · 15 years ago
  63. a0f71de Add another test. by Anders Carlsson · 15 years ago
  64. 6a75cd9 Implement more of C++0x 'auto'. A variable with an auto type specifier must have an initializer. Also, move some tests around to match the C++0x draft better. by Anders Carlsson · 15 years ago
  65. baf45d3 More auto work. by Anders Carlsson · 15 years ago
  66. e2bb224 An auto variable can't appear in its own initializer. by Anders Carlsson · 15 years ago
  67. 60a9a2a C++ decltype support (N2343) by Anders Carlsson · 15 years ago
  68. cb8845f Add some random C++ standard tests. by Daniel Dunbar · 15 years ago