blob: 415967fcf4fbf6aa5054fc8bfd21355ae866cf42 [file] [log] [blame]
Michael Fulbright62e8e801998-09-25 16:58:38 +00001# Note that this is NOT a relocatable package
2%define ver 0.30
3%define rel 1
4%define prefix /usr
5
6Summary: libXML library
7Name: libxml
8Version: %ver
9Release: %rel
10Copyright: LGPL
11Group: X11/Libraries
12Source: ftp://ftp.gnome.org/pub/GNOME/sources/libxml-%{ver}.tar.gz
13BuildRoot: /var/tmp/libxml-root
14Packager: Michael Fulbright <msf@redhat.com>
15URL: http://www.gnome.org
16Prereq: /sbin/install-info
17Docdir: %{prefix}/doc
18
19%description
20This library allows you to manipulate XML files.
21
22%package devel
23Summary: Libraries, includes, etc to develop libxml applications
24Group: X11/libraries
25Requires: libxml
26
27%description devel
28Libraries, include files, etc you can use to develop libxml applications.
29
30
31%changelog
32
Daniel Veillard8631b781998-10-04 14:50:58 +000033* Sun Oct 4 10:49:04 EDT 1998 Daniel Veillard <Daniel.Veillard@w3.org>
34
35- Added xml-config to the package
36
Michael Fulbright62e8e801998-09-25 16:58:38 +000037* Thu Sep 24 1998 Michael Fulbright <msf@redhat.com>
38
39- Built release 0.30
40
41%prep
42%setup
43
44%build
45# Needed for snapshot releases.
46if [ ! -f configure ]; then
47 CFLAGS="$RPM_OPT_FLAGS" ./autogen.sh --prefix=%prefix
48else
49 CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%prefix
50fi
51
52if [ "$SMP" != "" ]; then
53 (make "MAKE=make -k -j $SMP"; exit 0)
54 make
55else
56 make
57fi
58
59%install
60rm -rf $RPM_BUILD_ROOT
61
62make prefix=$RPM_BUILD_ROOT%{prefix} install
63
64
65%clean
66#rm -rf $RPM_BUILD_ROOT
67
68%post -p /sbin/ldconfig
69
70%postun -p /sbin/ldconfig
71
72%files
73%defattr(-, root, root)
74
75%doc AUTHORS ChangeLog NEWS README COPYING COPYING.LIB TODO
76%{prefix}/lib/lib*.so.*
Daniel Veillard213c1781998-10-04 14:48:06 +000077%{prefix}/bin/xml-config
Michael Fulbright62e8e801998-09-25 16:58:38 +000078
79%files devel
80%defattr(-, root, root)
81
82%{prefix}/lib/lib*.so
83%{prefix}/lib/*a
84%{prefix}/lib/*.sh
85%{prefix}/include/*