Brian Paul | 7b2c0f9 | 2000-06-09 00:22:02 +0000 | [diff] [blame] | 1 | Name |
| 2 | |
| 3 | MESA_release_buffers |
| 4 | |
| 5 | Name Strings |
| 6 | |
| 7 | GLX_MESA_release_buffers |
| 8 | |
| 9 | Contact |
| 10 | |
Brian Paul | d3b09fe | 2004-03-25 01:42:41 +0000 | [diff] [blame] | 11 | Brian Paul (brian.paul 'at' tungstengraphics.com) |
Brian Paul | 7b2c0f9 | 2000-06-09 00:22:02 +0000 | [diff] [blame] | 12 | |
| 13 | Status |
| 14 | |
| 15 | Shipping since Mesa 2.0 in October, 1996. |
| 16 | |
| 17 | Version |
| 18 | |
| 19 | Last Modified Date: 8 June 2000 |
| 20 | |
| 21 | Number |
| 22 | |
Brian Paul | dd18a4f | 2000-06-23 17:34:47 +0000 | [diff] [blame] | 23 | 217 |
Brian Paul | 7b2c0f9 | 2000-06-09 00:22:02 +0000 | [diff] [blame] | 24 | |
| 25 | Dependencies |
| 26 | |
| 27 | OpenGL 1.0 or later is required. |
| 28 | GLX 1.0 or later is required. |
| 29 | |
| 30 | Overview |
| 31 | |
| 32 | Mesa's implementation of GLX is entirely implemented on the client side. |
| 33 | Therefore, Mesa cannot immediately detect when an X window or pixmap is |
| 34 | destroyed in order to free any ancilliary data associated with the window |
| 35 | or pixmap. |
| 36 | |
| 37 | The glxMesaReleaseBuffers() function can be used to explicitly indicate |
| 38 | when the back color buffer, depth buffer, stencil buffer, and/or accum- |
| 39 | ulation buffer associated with a drawable can be freed. |
| 40 | |
| 41 | IP Status |
| 42 | |
| 43 | Open-source; freely implementable. |
| 44 | |
| 45 | Issues |
| 46 | |
| 47 | None. |
| 48 | |
| 49 | New Procedures and Functions |
| 50 | |
| 51 | Bool glXReleaseBuffersMESA( Display *dpy, GLXDrawable d ); |
| 52 | |
| 53 | New Tokens |
| 54 | |
| 55 | None. |
| 56 | |
| 57 | Additions to Chapter 3 of the GLX 1.3 Specification (Functions and Errors) |
| 58 | |
| 59 | The function |
| 60 | |
Brian Paul | dd18a4f | 2000-06-23 17:34:47 +0000 | [diff] [blame] | 61 | Bool glXReleaseBuffersMESA( Display *dpy, GLXDrawable d ); |
Brian Paul | 7b2c0f9 | 2000-06-09 00:22:02 +0000 | [diff] [blame] | 62 | |
| 63 | causes all software ancilliary buffers (back buffer, depth, stencil, |
| 64 | accum, etc) associated with the named drawable to be immediately |
| 65 | deallocated. True is returned if <d> is a valid Mesa GLX drawable, |
| 66 | else False is returned. After calling glXReleaseBuffersMESA, the |
| 67 | drawable should no longer be used for GL rendering. Results of |
| 68 | attempting to do so are undefined. |
| 69 | |
| 70 | |
| 71 | GLX Protocol |
| 72 | |
| 73 | None, since this is a client-side operation. |
| 74 | |
| 75 | Errors |
| 76 | |
| 77 | None. |
| 78 | |
| 79 | New State |
| 80 | |
| 81 | None. |
| 82 | |
| 83 | Revision History |
| 84 | |
| 85 | 8 June 2000 - initial specification |