blob: 1bb7d3b801866fca30cd58ac6fcaf5822f3f7d1f [file] [log] [blame]
Jeff Brownf76f96e2012-03-02 16:23:23 -08001Summary: Tracks and displays system calls associated with a running process
The Android Open Source Project34d6eab2009-03-03 19:30:45 -08002Name: strace
Elliott Hughesbb0c2d52014-01-07 17:34:14 -08003Version: 4.7
Jeff Brownf76f96e2012-03-02 16:23:23 -08004Release: 1%{?dist}
The Android Open Source Project34d6eab2009-03-03 19:30:45 -08005License: BSD
6Group: Development/Debuggers
7URL: http://sourceforge.net/projects/strace/
Jeff Brownf76f96e2012-03-02 16:23:23 -08008Source: http://downloads.sourceforge.net/strace/%{name}-%{version}.tar.xz
9BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
The Android Open Source Project34d6eab2009-03-03 19:30:45 -080010
Jeff Brownf76f96e2012-03-02 16:23:23 -080011BuildRequires: libacl-devel, libaio-devel, time
12
13%define strace64_arches ppc64 sparc64
The Android Open Source Project34d6eab2009-03-03 19:30:45 -080014
15%description
16The strace program intercepts and records the system calls called and
17received by a running process. Strace can print a record of each
18system call, its arguments and its return value. Strace is useful for
19diagnosing problems and debugging, as well as for instructional
20purposes.
21
22Install strace if you need a tool to track the system calls made and
23received by a process.
24
25%ifarch %{strace64_arches}
26%package -n strace64
27Summary: Tracks and displays system calls associated with a running process.
28Group: Development/Debuggers
29
30%description -n strace64
31The strace program intercepts and records the system calls called and
32received by a running process. Strace can print a record of each
33system call, its arguments and its return value. Strace is useful for
34diagnosing problems and debugging, as well as for instructional
35purposes.
36
37Install strace if you need a tool to track the system calls made and
38received by a process.
39
40This package provides the `strace64' program to trace 64-bit processes.
41The `strace' program in the `strace' package is for 32-bit processes.
42%endif
43
44%prep
45%setup -q
46
47%build
48%configure
Jeff Brownf76f96e2012-03-02 16:23:23 -080049make %{?_smp_mflags}
The Android Open Source Project34d6eab2009-03-03 19:30:45 -080050
51%install
52rm -rf %{buildroot}
Jeff Brownf76f96e2012-03-02 16:23:23 -080053make DESTDIR=%{buildroot} install
The Android Open Source Project34d6eab2009-03-03 19:30:45 -080054
55# remove unpackaged files from the buildroot
56rm -f %{buildroot}%{_bindir}/strace-graph
57
Jeff Brownf76f96e2012-03-02 16:23:23 -080058%define copy64 ln
59%if 0%{?rhel}
60%if 0%{?rhel} < 6
The Android Open Source Project34d6eab2009-03-03 19:30:45 -080061%endif
Jeff Brownf76f96e2012-03-02 16:23:23 -080062%define copy64 cp -p
63%endif
64
65%ifarch %{strace64_arches}
66%{copy64} %{buildroot}%{_bindir}/strace %{buildroot}%{_bindir}/strace64
67%endif
68
69%check
70make check
The Android Open Source Project34d6eab2009-03-03 19:30:45 -080071
72%clean
73rm -rf %{buildroot}
74
75%files
76%defattr(-,root,root)
Elliott Hughesbb0c2d52014-01-07 17:34:14 -080077%doc CREDITS ChangeLog ChangeLog-CVS COPYRIGHT NEWS README
The Android Open Source Project34d6eab2009-03-03 19:30:45 -080078%{_bindir}/strace
Elliott Hughesbb0c2d52014-01-07 17:34:14 -080079%{_bindir}/strace-log-merge
The Android Open Source Project34d6eab2009-03-03 19:30:45 -080080%{_mandir}/man1/*
81
82%ifarch %{strace64_arches}
83%files -n strace64
84%defattr(-,root,root)
85%{_bindir}/strace64
86%endif
87
The Android Open Source Project34d6eab2009-03-03 19:30:45 -080088%changelog
Elliott Hughesbb0c2d52014-01-07 17:34:14 -080089* Wed May 02 2012 Dmitry V. Levin <ldv@altlinux.org> 4.7-1
90- New upstream release.
91 + implemented proper handling of real SIGTRAPs (#162774).
92
93* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.6-2
94- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
95
Jeff Brownf76f96e2012-03-02 16:23:23 -080096* Mon Mar 14 2011 Dmitry V. Levin <ldv@altlinux.org> - 4.6-1
97- New upstream release.
98 + fixed a corner case in waitpid handling (#663547).
99
100* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.5.20-2
101- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
102
103* Tue Apr 13 2010 Roland McGrath <roland@redhat.com> - 4.5.20-1
104- New upstream release, work mostly by Andreas Schwab and Dmitry V. Levin.
105 + fixed potential stack buffer overflow in select decoder (#556678);
106 + fixed FTBFS (#539044).
107
108* Wed Oct 21 2009 Roland McGrath <roland@redhat.com> - 4.5.19-1
109- New upstream release, work mostly by Dmitry V. Levin <ldv@altlinux.org>
110 + exit/kill strace with traced process exitcode/signal (#105371);
111 + fixed build on ARM EABI (#507576);
112 + fixed display of 32-bit argv array on 64-bit architectures (#519480);
113 + fixed display of 32-bit fcntl(F_SETLK) on 64-bit architectures (#471169);
114 + fixed several bugs in strings decoder, including potential heap
115 memory corruption (#470529, #478324, #511035).
116
117* Thu Aug 28 2008 Roland McGrath <roland@redhat.com> - 4.5.18-1
118- build fix for newer kernel headers (#457291)
119- fix CLONE_VFORK handling (#455078)
120- Support new Linux/PPC system call subpage_prot and PROT_SAO flag.
121- In sigaction system call, display sa_flags value along with SIG_DFL/SIG_IGN.
122
123* Mon Jul 21 2008 Roland McGrath <roland@redhat.com> - 4.5.17-1
124- handle O_CLOEXEC, MSG_CMSG_CLOEXEC (#365781)
125- fix biarch stat64 decoding (#222275)
126- fix spurious "..." in printing of environment strings (#358241)
127- improve prctl decoding (#364401)
128- fix hang wait on exited child with exited child (#354261)
129- fix biarch fork/vfork (-f) tracing (#447475)
130- fix biarch printing of negative argument kill (#430585)
131- fix biarch decoding of error return values (#447587)
132- fix -f tracing of CLONE_VFORK (#455078)
133- fix ia64 register clobberation in -f tracing (#453438)
134- print SO_NODEFER, SA_RESETHAND instead of SA_NOMASK, SA_ONESHOT (#455821)
135- fix futex argument decoding (#448628, #448629)
136
137* Fri Aug 3 2007 Roland McGrath <roland@redhat.com> - 4.5.16-1
138- fix multithread issues (#240962, #240961, #247907)
139- fix spurious SIGSTOP on early interrupt (#240986)
140- fix utime for biarch (#247185)
141- fix -u error message (#247170)
142- better futex syscall printing (##241467)
143- fix argv/envp printing with small -s settings, and for biarch
144- new syscalls: getcpu, eventfd, timerfd, signalfd, epoll_pwait,
145 move_pages, utimensat
146
147* Tue Jan 16 2007 Roland McGrath <roland@redhat.com> - 4.5.15-1
148- biarch fixes (#179740, #192193, #171626, #173050, #218433, #218043)
149- fix -ff -o behavior (#204950, #218435, #193808, #219423)
150- better quotactl printing (#118696)
151- *at, inotify*, pselect6, ppoll and unshare syscalls (#178633, #191275)
152- glibc-2.5 build fixes (#209856)
153- memory corruption fixes (#200621
154- fix race in child setup under -f (#180293)
155- show ipc key values in hex (#198179, #192182)
156- disallow -c with -ff (#187847)
157- Resolves: RHBZ #179740, RHBZ #192193, RHBZ #204950, RHBZ #218435
158- Resolves: RHBZ #193808, RHBZ #219423, RHBZ #171626, RHBZ #173050
159- Resolves: RHBZ #218433, RHBZ #218043, RHBZ #118696, RHBZ #178633
160- Resolves: RHBZ #191275, RHBZ #209856, RHBZ #200621, RHBZ #180293
161- Resolves: RHBZ #198179, RHBZ #198182, RHBZ #187847
162
163* Mon Nov 20 2006 Jakub Jelinek <jakub@redhat.com> - 4.5.14-4
164- Fix ia64 syscall decoding (#206768)
165- Fix build with glibc-2.4.90-33 and up on all arches but ia64
166- Fix build against 2.6.18+ headers
167
168* Tue Aug 22 2006 Roland McGrath <roland@redhat.com> - 4.5.14-3
169- Fix bogus decoding of syscalls >= 300 (#201462, #202620).
170
171* Fri Jul 14 2006 Jesse Keating <jkeating@redhat.com> - 4.5.14-2
172- rebuild
173
174* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 4.5.14-1.2
175- bump again for long double bug on ppc{,64}
176
177* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 4.5.14-1.1
178- rebuilt for new gcc4.1 snapshot and glibc changes
179
180* Mon Jan 16 2006 Roland McGrath <roland@redhat.com> - 4.5.14-1
181- Fix biarch decoding of socket syscalls (#174354).
182- Fix biarch -e support (#173986).
183- Accept numeric syscalls in -e (#174798).
184- Fix ipc syscall decoding (#164755).
185- Improve msgrcv printing (#164757).
186- Man page updates (#165375).
187- Improve mount syscall printing (#165377).
188- Correct printing of restarting syscalls (#165469).
189
190* Wed Aug 3 2005 Roland McGrath <roland@redhat.com> - 4.5.13-1
191- Fix setsockopt decoding on 64-bit (#162449).
192- Fix typos in socket option name strings (#161578).
193- Display more IPV6 socket options by name (#162450).
194- Don't display inappropriate syscalls for -e trace=file (#159340).
195- New selector type -e trace=desc for file-descriptor using calls (#159400).
196- Fix 32-bit old_mmap syscall decoding on x86-64 (#162467, #164215).
197- Fix errors detaching from multithreaded process on interrupt (#161919).
198- Note 4.5.12 fix for crash handling bad signal numbers (#162739).
199
The Android Open Source Project34d6eab2009-03-03 19:30:45 -0800200* Wed Jun 8 2005 Roland McGrath <roland@redhat.com> - 4.5.12-1
201- Fix known syscall recognition for IA32 processes on x86-64 (#158934).
202- Fix bad output for ptrace on x86-64 (#159787).
203- Fix potential buffer overruns (#151570, #159196).
204- Make some diagnostics more consistent (#159308).
205- Update PowerPC system calls.
206- Better printing for Linux aio system calls.
207- Don't truncate statfs64 fields to 32 bits in output (#158243).
208- Cosmetic code cleanups (#159688).
209
210* Tue Mar 22 2005 Roland McGrath <roland@redhat.com> - 4.5.11-1
211- Build tweaks.
212- Note 4.5.10 select fix (#151570).
213
214* Mon Mar 14 2005 Roland McGrath <roland@redhat.com> - 4.5.10-1
215- Fix select handling on nonstandard fd_set sizes.
216- Don't print errors for null file name pointers.
217- Fix initial execve output with -i (#143365).
218
219* Fri Feb 4 2005 Roland McGrath <roland@redhat.com> - 4.5.9-2
220- update ia64 syscall list (#146245)
221- fix x86_64 syscall argument extraction for 32-bit processes (#146093)
222- fix -e signal=NAME parsing (#143362)
223- fix x86_64 exit_group syscall handling
224- improve socket ioctl printing (#138223)
225- code cleanups (#143369, #143370)
226- improve mount flags printing (#141932)
227- support symbolic printing of x86_64 arch_prctl parameters (#142667)
228- fix potential crash in getxattr printing
229
230* Tue Oct 19 2004 Roland McGrath <roland@redhat.com> - 4.5.8-1
231- fix multithreaded exit handling (#132150, #135254)
232- fix ioctl name matching (#129808)
233- print RTC_* ioctl structure contents (#58606)
234- grok epoll_* syscalls (#134463)
235- grok new RLIMIT_* values (#133594)
236- print struct cmsghdr contents for sendmsg (#131689)
237- fix clock_* and timer_* argument output (#131420)
238
239* Tue Aug 31 2004 Roland McGrath <roland@redhat.com> - 4.5.7-2
240- new upstream version, misc fixes and updates (#128091, #129166, #128391, #129378, #130965, #131177)
241
242* Mon Jul 12 2004 Roland McGrath <roland@redhat.com> 4.5.6-1
243- new upstream version, updates ioctl lists (#127398), fixes quotactl (#127393), more ioctl decoding (#126917)
244
245* Sun Jun 27 2004 Roland McGrath <roland@redhat.com> 4.5.5-1
246- new upstream version, fixes x86-64 biarch support (#126547)
247
248* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com> 4.5.4-2
249- rebuilt
250
251* Thu Jun 3 2004 Roland McGrath <roland@redhat.com> 4.5.4-0.FC1
252- rebuilt for FC1 update
253
254* Thu Jun 3 2004 Roland McGrath <roland@redhat.com> 4.5.4-1
255- new upstream version, more ioctls (#122257), minor fixes
256
257* Fri Apr 16 2004 Roland McGrath <roland@redhat.com> 4.5.3-1
258- new upstream version, mq_* calls (#120701), -p vs NPTL (#120462), more fixes (#118694, #120541, #118685)
259
260* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com> 4.5.2-1.1
261- rebuilt
262
263* Mon Mar 1 2004 Roland McGrath <roland@redhat.com> 4.5.2-1
264- new upstream version, sched_* calls (#116990), show core flag (#112117)
265
266* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
267- rebuilt
268
269* Thu Nov 13 2003 Roland McGrath <roland@redhat.com> 4.5.1-1
270- new upstream version, more fixes (#108012, #105366, #105359, #105358)
271
272* Tue Sep 30 2003 Roland McGrath <roland@redhat.com> 4.5-3
273- revert bogus s390 fix
274
275* Thu Sep 25 2003 Roland McGrath <roland@redhat.com> 4.5-1.2.1AS
276- rebuilt for 2.1AS erratum
277
278* Wed Sep 24 2003 Roland McGrath <roland@redhat.com> 4.5-2
279- rebuilt
280
281* Wed Sep 24 2003 Roland McGrath <roland@redhat.com> 4.5-1
282- new upstream version, more fixes (#101499, #104365)
283
284* Thu Jul 17 2003 Roland McGrath <roland@redhat.com> 4.4.99-2
285- rebuilt
286
287* Thu Jul 17 2003 Roland McGrath <roland@redhat.com> 4.4.99-1
288- new upstream version, groks more new system calls, PF_INET6 sockets
289
290* Mon Jun 10 2003 Roland McGrath <roland@redhat.com> 4.4.98-1
291- new upstream version, more fixes (#90754, #91085)
292
293* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
294- rebuilt
295
296* Sun Mar 30 2003 Roland McGrath <roland@redhat.com> 4.4.96-1
297- new upstream version, handles yet more 2.5 syscalls, x86_64 & ia64 fixes
298
299* Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com> 4.4.95-2
300- rebuilt
301
302* Mon Feb 24 2003 Roland McGrath <roland@redhat.com> 4.4.95-1
303- new upstream version, fixed getresuid/getresgid (#84959)
304
305* Wed Feb 19 2003 Roland McGrath <roland@redhat.com> 4.4.94-1
306- new upstream version, new option -E to set environment variables (#82392)
307
308* Wed Jan 22 2003 Tim Powers <timp@redhat.com> 4.4.93-2
309- rebuilt
310
311* Tue Jan 21 2003 Roland McGrath <roland@redhat.com> 4.4.93-1
312- new upstream version, fixes ppc and s390 bugs, adds missing ptrace requests
313
314* Fri Jan 10 2003 Roland McGrath <roland@redhat.com> 4.4.91-1
315- new upstream version, fixes -f on x86-64
316
317* Fri Jan 10 2003 Roland McGrath <roland@redhat.com> 4.4.90-1
318- new upstream version, fixes all known bugs modulo ia64 and s390 issues
319
320* Fri Jan 03 2003 Florian La Roche <Florian.LaRoche@redhat.de> 4.4-11
321- add further s390 patch from IBM
322
323* Wed Nov 27 2002 Tim Powers <timp@redhat.com> 4.4-10
324- remove unpackaged files from the buildroot
325
326* Mon Oct 07 2002 Phil Knirsch <pknirsch@redhat.com> 4.4-9.1
327- Added latest s390(x) patch.
328
329* Fri Sep 06 2002 Karsten Hopp <karsten@redhat.de> 4.4-9
330- preliminary x86_64 support with an ugly patch to help
331 debugging. Needs cleanup!
332
333* Mon Sep 2 2002 Jakub Jelinek <jakub@redhat.com> 4.4-8
334- newer version of the clone fixing patch (Roland McGrath)
335- aio syscalls for i386/ia64/ppc (Ben LaHaise)
336
337* Wed Aug 28 2002 Jakub Jelinek <jakub@redhat.com> 4.4-7
338- fix strace -f (Roland McGrath, #68994)
339- handle ?et_thread_area, SA_RESTORER (Ulrich Drepper)
340
341* Fri Jun 21 2002 Jakub Jelinek <jakub@redhat.com> 4.4-6
342- handle futexes, *xattr, sendfile64, etc. (Ulrich Drepper)
343- handle modify_ldt (#66894)
344
345* Thu May 23 2002 Tim Powers <timp@redhat.com>
346- automated rebuild
347
348* Tue Apr 16 2002 Jakub Jelinek <jakub@redhat.com> 4.4-4
349- fix for the last patch by Jeff Law (#62591)
350
351* Mon Mar 4 2002 Preston Brown <pbrown@redhat.com> 4.4-3
352- integrate patch from Jeff Law to eliminate hang tracing threads
353
354* Sat Feb 23 2002 Florian La Roche <Florian.LaRoche@redhat.de>
355- minor update from debian tar-ball
356
357* Wed Jan 02 2002 Florian La Roche <Florian.LaRoche@redhat.de>
358- update to 4.4
359
360* Sun Jul 22 2001 Florian La Roche <Florian.LaRoche@redhat.de>
361- disable s390 patches, they are already included
362
363* Wed Jul 18 2001 Preston Brown <pbrown@redhat.com> 4.3-1
364- new upstream version. Seems to have integrated most new syscalls
365- tracing threaded programs is now functional.
366
367* Mon Jun 11 2001 Than Ngo <than@redhat.com>
368- port s390 patches from IBM
369
370* Wed May 16 2001 Nalin Dahyabhai <nalin@redhat.com>
371- modify new syscall patch to allocate enough heap space in setgroups32()
372
373* Wed Feb 14 2001 Jakub Jelinek <jakub@redhat.com>
374- #include <time.h> in addition to <sys/time.h>
375
376* Fri Jan 26 2001 Karsten Hopp <karsten@redhat.com>
377- clean up conflicting patches. This happened only
378 when building on S390
379
380* Fri Jan 19 2001 Bill Nottingham <notting@redhat.com>
381- update to CVS, reintegrate ia64 support
382
383* Sat Dec 8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
384- Get S/390 support into the normal package
385
386* Sat Nov 18 2000 Florian La Roche <Florian.LaRoche@redhat.de>
387- added S/390 patch from IBM, adapting it to not conflict with
388 IA64 patch
389
390* Sat Aug 19 2000 Jakub Jelinek <jakub@redhat.com>
391- doh, actually apply the 2.4 syscalls patch
392- make it compile with 2.4.0-test7-pre4+ headers, add
393 getdents64 and fcntl64
394
395* Thu Aug 3 2000 Jakub Jelinek <jakub@redhat.com>
396- add a bunch of new 2.4 syscalls (#14036)
397
398* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
399- automatic rebuild
400- excludearch ia64
401
402* Fri Jun 2 2000 Matt Wilson <msw@redhat.com>
403- use buildinstall for FHS
404
405* Wed May 24 2000 Jakub Jelinek <jakub@redhat.com>
406- make things compile on sparc
407- fix sigreturn on sparc
408
409* Fri Mar 31 2000 Bill Nottingham <notting@redhat.com>
410- fix stat64 misdef (#10485)
411
412* Tue Mar 21 2000 Michael K. Johnson <johnsonm@redhat.com>
413- added ia64 patch
414
415* Thu Feb 03 2000 Cristian Gafton <gafton@redhat.com>
416- man pages are compressed
417- version 4.2 (why are we keeping all these patches around?)
418
419* Sat Nov 27 1999 Jeff Johnson <jbj@redhat.com>
420- update to 4.1 (with sparc socketcall patch).
421
422* Fri Nov 12 1999 Jakub Jelinek <jakub@redhat.com>
423- fix socketcall on sparc.
424
425* Thu Sep 02 1999 Cristian Gafton <gafton@redhat.com>
426- fix KERN_SECURELVL compile problem
427
428* Tue Aug 31 1999 Cristian Gafton <gafton@redhat.com>
429- added alpha patch from HJLu to fix the osf_sigprocmask interpretation
430
431* Sat Jun 12 1999 Jeff Johnson <jbj@redhat.com>
432- update to 3.99.1.
433
434* Wed Jun 2 1999 Jeff Johnson <jbj@redhat.com>
435- add (the other :-) jj's sparc patch.
436
437* Wed May 26 1999 Jeff Johnson <jbj@redhat.com>
438- upgrade to 3.99 in order to
439- add new 2.2.x open flags (#2955).
440- add new 2.2.x syscalls (#2866).
441- strace 3.1 patches carried along for now.
442
443* Sun May 16 1999 Jeff Johnson <jbj@redhat.com>
Jeff Brownf76f96e2012-03-02 16:23:23 -0800444- don't rely on (broken!) rpm %%patch (#2735)
The Android Open Source Project34d6eab2009-03-03 19:30:45 -0800445
446* Tue Apr 06 1999 Preston Brown <pbrown@redhat.com>
447- strip binary
448
449* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
450- auto rebuild in the new build environment (release 16)
451
452* Tue Feb 9 1999 Jeff Johnson <jbj@redhat.com>
453- vfork est arrive!
454
455* Tue Feb 9 1999 Christopher Blizzard <blizzard@redhat.com>
456- Add patch to follow clone() syscalls, too.
457
458* Sun Jan 17 1999 Jeff Johnson <jbj@redhat.com>
459- patch to build alpha/sparc with glibc 2.1.
460
461* Thu Dec 03 1998 Cristian Gafton <gafton@redhat.com>
462- patch to build on ARM
463
464* Wed Sep 30 1998 Jeff Johnson <jbj@redhat.com>
465- fix typo (printf, not tprintf).
466
467* Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
468- fix compile problem on sparc.
469
470* Tue Aug 18 1998 Cristian Gafton <gafton@redhat.com>
471- buildroot
472
473* Mon Jul 20 1998 Cristian Gafton <gafton@redhat.com>
474- added the umoven patch from James Youngman <jay@gnu.org>
475- fixed build problems on newer glibc releases
476
477* Mon Jun 08 1998 Prospector System <bugs@redhat.com>
478- translations modified for de, fr, tr