Roland McGrath | 00a1875 | 2007-02-18 22:55:21 +0000 | [diff] [blame] | 1 | Summary: Tracks and displays system calls associated with a running process |
Roland McGrath | 037124f | 2003-01-10 10:44:57 +0000 | [diff] [blame] | 2 | Name: strace |
Dmitry V. Levin | fbfed22 | 2009-09-14 16:34:34 +0000 | [diff] [blame] | 3 | Version: 4.5.19 |
Roland McGrath | cdec469 | 2007-01-11 22:22:47 +0000 | [diff] [blame] | 4 | Release: 1%{?dist} |
Roland McGrath | 037124f | 2003-01-10 10:44:57 +0000 | [diff] [blame] | 5 | License: BSD |
| 6 | Group: Development/Debuggers |
| 7 | URL: http://sourceforge.net/projects/strace/ |
Roland McGrath | 4aa1556 | 2006-04-25 07:22:02 +0000 | [diff] [blame] | 8 | Source0: http://dl.sourceforge.net/strace/%{name}-%{version}.tar.bz2 |
Roland McGrath | 00a1875 | 2007-02-18 22:55:21 +0000 | [diff] [blame] | 9 | BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) |
Roland McGrath | 037124f | 2003-01-10 10:44:57 +0000 | [diff] [blame] | 10 | |
Roland McGrath | 4c99f56 | 2007-11-19 22:14:56 +0000 | [diff] [blame] | 11 | BuildRequires: libaio-devel, libacl-devel |
| 12 | |
Roland McGrath | 7c2ec57 | 2008-03-26 19:15:41 +0000 | [diff] [blame] | 13 | %define strace64_arches ppc64 sparc64 |
Roland McGrath | a943d00 | 2003-09-24 22:22:42 +0000 | [diff] [blame] | 14 | |
Roland McGrath | 037124f | 2003-01-10 10:44:57 +0000 | [diff] [blame] | 15 | %description |
| 16 | The strace program intercepts and records the system calls called and |
| 17 | received by a running process. Strace can print a record of each |
| 18 | system call, its arguments and its return value. Strace is useful for |
| 19 | diagnosing problems and debugging, as well as for instructional |
| 20 | purposes. |
| 21 | |
| 22 | Install strace if you need a tool to track the system calls made and |
| 23 | received by a process. |
| 24 | |
Roland McGrath | a943d00 | 2003-09-24 22:22:42 +0000 | [diff] [blame] | 25 | %ifarch %{strace64_arches} |
| 26 | %package -n strace64 |
| 27 | Summary: Tracks and displays system calls associated with a running process. |
| 28 | Group: Development/Debuggers |
| 29 | |
| 30 | %description -n strace64 |
| 31 | The strace program intercepts and records the system calls called and |
| 32 | received by a running process. Strace can print a record of each |
| 33 | system call, its arguments and its return value. Strace is useful for |
| 34 | diagnosing problems and debugging, as well as for instructional |
| 35 | purposes. |
| 36 | |
| 37 | Install strace if you need a tool to track the system calls made and |
| 38 | received by a process. |
| 39 | |
| 40 | This package provides the `strace64' program to trace 64-bit processes. |
| 41 | The `strace' program in the `strace' package is for 32-bit processes. |
| 42 | %endif |
| 43 | |
Roland McGrath | 037124f | 2003-01-10 10:44:57 +0000 | [diff] [blame] | 44 | %prep |
| 45 | %setup -q |
| 46 | |
| 47 | %build |
| 48 | %configure |
Roland McGrath | cddc21f | 2007-02-18 22:56:37 +0000 | [diff] [blame] | 49 | make %{?_smp_mflags} |
Roland McGrath | 037124f | 2003-01-10 10:44:57 +0000 | [diff] [blame] | 50 | |
| 51 | %install |
| 52 | rm -rf %{buildroot} |
Roland McGrath | 00a1875 | 2007-02-18 22:55:21 +0000 | [diff] [blame] | 53 | make DESTDIR=%{buildroot} install |
Roland McGrath | 037124f | 2003-01-10 10:44:57 +0000 | [diff] [blame] | 54 | |
| 55 | # remove unpackaged files from the buildroot |
| 56 | rm -f %{buildroot}%{_bindir}/strace-graph |
| 57 | |
Roland McGrath | 3f0dbe2 | 2008-08-28 23:26:21 +0000 | [diff] [blame] | 58 | %define copy64 ln |
| 59 | %if 0%{?rhel} |
| 60 | %if 0%{?rhel} < 6 |
| 61 | %endif |
| 62 | %define copy64 cp -p |
| 63 | %endif |
| 64 | |
Roland McGrath | a943d00 | 2003-09-24 22:22:42 +0000 | [diff] [blame] | 65 | %ifarch %{strace64_arches} |
Roland McGrath | 3f0dbe2 | 2008-08-28 23:26:21 +0000 | [diff] [blame] | 66 | %{copy64} %{buildroot}%{_bindir}/strace %{buildroot}%{_bindir}/strace64 |
Roland McGrath | a943d00 | 2003-09-24 22:22:42 +0000 | [diff] [blame] | 67 | %endif |
| 68 | |
Roland McGrath | 037124f | 2003-01-10 10:44:57 +0000 | [diff] [blame] | 69 | %clean |
| 70 | rm -rf %{buildroot} |
| 71 | |
| 72 | %files |
| 73 | %defattr(-,root,root) |
Roland McGrath | d087571 | 2009-10-06 18:03:25 -0700 | [diff] [blame] | 74 | %doc CREDITS ChangeLog ChangeLog-CVS COPYRIGHT NEWS PORTING README |
Roland McGrath | 037124f | 2003-01-10 10:44:57 +0000 | [diff] [blame] | 75 | %{_bindir}/strace |
| 76 | %{_mandir}/man1/* |
| 77 | |
Roland McGrath | a943d00 | 2003-09-24 22:22:42 +0000 | [diff] [blame] | 78 | %ifarch %{strace64_arches} |
| 79 | %files -n strace64 |
| 80 | %defattr(-,root,root) |
| 81 | %{_bindir}/strace64 |
| 82 | %endif |
| 83 | |
Roland McGrath | 037124f | 2003-01-10 10:44:57 +0000 | [diff] [blame] | 84 | %changelog |
Roland McGrath | 7d9247e | 2009-10-21 10:36:13 -0700 | [diff] [blame] | 85 | * Wed Oct 21 2009 Roland McGrath <roland@redhat.com> - 4.5.19-1 |
| 86 | - New upstream release, work mostly by Dmitry V. Levin <ldv@altlinux.org> |
Dmitry V. Levin | fbfed22 | 2009-09-14 16:34:34 +0000 | [diff] [blame] | 87 | + exit/kill strace with traced process exitcode/signal (#105371); |
| 88 | + fixed build on ARM EABI (#507576); |
| 89 | + fixed display of 32-bit argv array on 64-bit architectures (#519480); |
| 90 | + fixed display of 32-bit fcntl(F_SETLK) on 64-bit architectures (#471169); |
| 91 | + fixed several bugs in strings decoder, including potential heap |
| 92 | memory corruption (#470529, #478324, #511035). |
| 93 | |
Roland McGrath | 09db705 | 2008-08-28 22:00:46 +0000 | [diff] [blame] | 94 | * Thu Aug 28 2008 Roland McGrath <roland@redhat.com> - 4.5.18-1 |
| 95 | - build fix for newer kernel headers (#457291) |
| 96 | - fix CLONE_VFORK handling (#455078) |
| 97 | - Support new Linux/PPC system call subpage_prot and PROT_SAO flag. |
| 98 | - In sigaction system call, display sa_flags value along with SIG_DFL/SIG_IGN. |
| 99 | |
Roland McGrath | 6a1311d | 2008-07-22 00:43:09 +0000 | [diff] [blame] | 100 | * Mon Jul 21 2008 Roland McGrath <roland@redhat.com> - 4.5.17-1 |
Roland McGrath | 55dd278 | 2008-07-18 02:21:11 +0000 | [diff] [blame] | 101 | - handle O_CLOEXEC, MSG_CMSG_CLOEXEC (#365781) |
| 102 | - fix biarch stat64 decoding (#222275) |
| 103 | - fix spurious "..." in printing of environment strings (#358241) |
| 104 | - improve prctl decoding (#364401) |
| 105 | - fix hang wait on exited child with exited child (#354261) |
| 106 | - fix biarch fork/vfork (-f) tracing (#447475) |
| 107 | - fix biarch printing of negative argument kill (#430585) |
| 108 | - fix biarch decoding of error return values (#447587) |
| 109 | - fix -f tracing of CLONE_VFORK (#455078) |
| 110 | - fix ia64 register clobberation in -f tracing (#453438) |
| 111 | - print SO_NODEFER, SA_RESETHAND instead of SA_NOMASK, SA_ONESHOT (#455821) |
| 112 | - fix futex argument decoding (#448628, #448629) |
| 113 | |
Roland McGrath | 47d3223 | 2007-08-03 10:28:55 +0000 | [diff] [blame] | 114 | * Fri Aug 3 2007 Roland McGrath <roland@redhat.com> - 4.5.16-1 |
| 115 | - fix multithread issues (#240962, #240961, #247907) |
| 116 | - fix spurious SIGSTOP on early interrupt (#240986) |
| 117 | - fix utime for biarch (#247185) |
| 118 | - fix -u error message (#247170) |
| 119 | - better futex syscall printing (##241467) |
| 120 | - fix argv/envp printing with small -s settings, and for biarch |
| 121 | - new syscalls: getcpu, eventfd, timerfd, signalfd, epoll_pwait, |
| 122 | move_pages, utimensat |
| 123 | |
Roland McGrath | 0a45fae | 2007-01-16 23:25:34 +0000 | [diff] [blame] | 124 | * Tue Jan 16 2007 Roland McGrath <roland@redhat.com> - 4.5.15-1 |
Roland McGrath | cdec469 | 2007-01-11 22:22:47 +0000 | [diff] [blame] | 125 | - biarch fixes (#179740, #192193, #171626, #173050, #218433, #218043) |
| 126 | - fix -ff -o behavior (#204950, #218435, #193808, #219423) |
| 127 | - better quotactl printing (#118696) |
| 128 | - *at, inotify*, pselect6, ppoll and unshare syscalls (#178633, #191275) |
| 129 | - glibc-2.5 build fixes (#209856) |
| 130 | - memory corruption fixes (#200621 |
| 131 | - fix race in child setup under -f (#180293) |
| 132 | - show ipc key values in hex (#198179, #192182) |
| 133 | - disallow -c with -ff (#187847) |
| 134 | - Resolves: RHBZ #179740, RHBZ #192193, RHBZ #204950, RHBZ #218435 |
| 135 | - Resolves: RHBZ #193808, RHBZ #219423, RHBZ #171626, RHBZ #173050 |
| 136 | - Resolves: RHBZ #218433, RHBZ #218043, RHBZ #118696, RHBZ #178633 |
| 137 | - Resolves: RHBZ #191275, RHBZ #209856, RHBZ #200621, RHBZ #180293 |
| 138 | - Resolves: RHBZ #198179, RHBZ #198182, RHBZ #187847 |
| 139 | |
| 140 | * Mon Nov 20 2006 Jakub Jelinek <jakub@redhat.com> - 4.5.14-4 |
| 141 | - Fix ia64 syscall decoding (#206768) |
| 142 | - Fix build with glibc-2.4.90-33 and up on all arches but ia64 |
| 143 | - Fix build against 2.6.18+ headers |
| 144 | |
| 145 | * Tue Aug 22 2006 Roland McGrath <roland@redhat.com> - 4.5.14-3 |
| 146 | - Fix bogus decoding of syscalls >= 300 (#201462, #202620). |
| 147 | |
| 148 | * Fri Jul 14 2006 Jesse Keating <jkeating@redhat.com> - 4.5.14-2 |
| 149 | - rebuild |
| 150 | |
| 151 | * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 4.5.14-1.2 |
| 152 | - bump again for long double bug on ppc{,64} |
| 153 | |
| 154 | * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 4.5.14-1.1 |
| 155 | - rebuilt for new gcc4.1 snapshot and glibc changes |
| 156 | |
Roland McGrath | f4d9b49 | 2006-01-17 06:22:57 +0000 | [diff] [blame] | 157 | * Mon Jan 16 2006 Roland McGrath <roland@redhat.com> - 4.5.14-1 |
| 158 | - Fix biarch decoding of socket syscalls (#174354). |
| 159 | - Fix biarch -e support (#173986). |
| 160 | - Accept numeric syscalls in -e (#174798). |
| 161 | - Fix ipc syscall decoding (#164755). |
| 162 | - Improve msgrcv printing (#164757). |
| 163 | - Man page updates (#165375). |
| 164 | - Improve mount syscall printing (#165377). |
| 165 | - Correct printing of restarting syscalls (#165469). |
| 166 | |
Roland McGrath | cab4380 | 2005-08-03 11:42:35 +0000 | [diff] [blame] | 167 | * Wed Aug 3 2005 Roland McGrath <roland@redhat.com> - 4.5.13-1 |
| 168 | - Fix setsockopt decoding on 64-bit (#162449). |
| 169 | - Fix typos in socket option name strings (#161578). |
| 170 | - Display more IPV6 socket options by name (#162450). |
| 171 | - Don't display inappropriate syscalls for -e trace=file (#159340). |
| 172 | - New selector type -e trace=desc for file-descriptor using calls (#159400). |
| 173 | - Fix 32-bit old_mmap syscall decoding on x86-64 (#162467, #164215). |
| 174 | - Fix errors detaching from multithreaded process on interrupt (#161919). |
| 175 | - Note 4.5.12 fix for crash handling bad signal numbers (#162739). |
| 176 | |
Roland McGrath | 182cbf4 | 2005-06-10 03:56:16 +0000 | [diff] [blame] | 177 | * Wed Jun 8 2005 Roland McGrath <roland@redhat.com> - 4.5.12-1 |
| 178 | - Fix known syscall recognition for IA32 processes on x86-64 (#158934). |
| 179 | - Fix bad output for ptrace on x86-64 (#159787). |
| 180 | - Fix potential buffer overruns (#151570, #159196). |
| 181 | - Make some diagnostics more consistent (#159308). |
| 182 | - Update PowerPC system calls. |
| 183 | - Better printing for Linux aio system calls. |
| 184 | - Don't truncate statfs64 fields to 32 bits in output (#158243). |
| 185 | - Cosmetic code cleanups (#159688). |
| 186 | |
Roland McGrath | 7147a3d | 2005-03-22 23:12:39 +0000 | [diff] [blame] | 187 | * Tue Mar 22 2005 Roland McGrath <roland@redhat.com> - 4.5.11-1 |
| 188 | - Build tweaks. |
| 189 | - Note 4.5.10 select fix (#151570). |
| 190 | |
Roland McGrath | d818403 | 2005-03-15 02:40:12 +0000 | [diff] [blame] | 191 | * Mon Mar 14 2005 Roland McGrath <roland@redhat.com> - 4.5.10-1 |
| 192 | - Fix select handling on nonstandard fd_set sizes. |
| 193 | - Don't print errors for null file name pointers. |
| 194 | - Fix initial execve output with -i (#143365). |
| 195 | |
Roland McGrath | 6df9d64 | 2005-02-04 10:13:15 +0000 | [diff] [blame] | 196 | * Fri Feb 4 2005 Roland McGrath <roland@redhat.com> - 4.5.9-2 |
Roland McGrath | d63311a | 2005-02-04 09:29:04 +0000 | [diff] [blame] | 197 | - update ia64 syscall list (#146245) |
| 198 | - fix x86_64 syscall argument extraction for 32-bit processes (#146093) |
| 199 | - fix -e signal=NAME parsing (#143362) |
| 200 | - fix x86_64 exit_group syscall handling |
| 201 | - improve socket ioctl printing (#138223) |
| 202 | - code cleanups (#143369, #143370) |
| 203 | - improve mount flags printing (#141932) |
| 204 | - support symbolic printing of x86_64 arch_prctl parameters (#142667) |
| 205 | - fix potential crash in getxattr printing |
| 206 | |
Roland McGrath | f041d47 | 2004-10-20 02:17:52 +0000 | [diff] [blame] | 207 | * Tue Oct 19 2004 Roland McGrath <roland@redhat.com> - 4.5.8-1 |
| 208 | - fix multithreaded exit handling (#132150, #135254) |
| 209 | - fix ioctl name matching (#129808) |
| 210 | - print RTC_* ioctl structure contents (#58606) |
| 211 | - grok epoll_* syscalls (#134463) |
| 212 | - grok new RLIMIT_* values (#133594) |
| 213 | - print struct cmsghdr contents for sendmsg (#131689) |
| 214 | - fix clock_* and timer_* argument output (#131420) |
| 215 | |
Roland McGrath | 61d6487 | 2004-08-31 08:58:10 +0000 | [diff] [blame] | 216 | * Tue Aug 31 2004 Roland McGrath <roland@redhat.com> - 4.5.7-2 |
Roland McGrath | b93f918 | 2004-08-31 08:17:20 +0000 | [diff] [blame] | 217 | - new upstream version, misc fixes and updates (#128091, #129166, #128391, #129378, #130965, #131177) |
| 218 | |
Roland McGrath | 785a026 | 2004-07-12 07:55:48 +0000 | [diff] [blame] | 219 | * Mon Jul 12 2004 Roland McGrath <roland@redhat.com> 4.5.6-1 |
| 220 | - new upstream version, updates ioctl lists (#127398), fixes quotactl (#127393), more ioctl decoding (#126917) |
| 221 | |
Roland McGrath | b7e2ca1 | 2004-06-28 05:24:29 +0000 | [diff] [blame] | 222 | * Sun Jun 27 2004 Roland McGrath <roland@redhat.com> 4.5.5-1 |
| 223 | - new upstream version, fixes x86-64 biarch support (#126547) |
| 224 | |
| 225 | * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com> 4.5.4-2 |
| 226 | - rebuilt |
| 227 | |
| 228 | * Thu Jun 3 2004 Roland McGrath <roland@redhat.com> 4.5.4-0.FC1 |
| 229 | - rebuilt for FC1 update |
| 230 | |
Roland McGrath | ed8e77e | 2004-06-04 02:35:58 +0000 | [diff] [blame] | 231 | * Thu Jun 3 2004 Roland McGrath <roland@redhat.com> 4.5.4-1 |
| 232 | - new upstream version, more ioctls (#122257), minor fixes |
| 233 | |
Roland McGrath | a8c555f | 2004-04-16 22:28:41 +0000 | [diff] [blame] | 234 | * Fri Apr 16 2004 Roland McGrath <roland@redhat.com> 4.5.3-1 |
| 235 | - new upstream version, mq_* calls (#120701), -p vs NPTL (#120462), more fixes (#118694, #120541, #118685) |
| 236 | |
| 237 | * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com> 4.5.2-1.1 |
| 238 | - rebuilt |
| 239 | |
Roland McGrath | b66e936 | 2004-03-02 06:38:35 +0000 | [diff] [blame] | 240 | * Mon Mar 1 2004 Roland McGrath <roland@redhat.com> 4.5.2-1 |
| 241 | - new upstream version, sched_* calls (#116990), show core flag (#112117) |
| 242 | |
| 243 | * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com> |
| 244 | - rebuilt |
| 245 | |
Roland McGrath | 00eb84e | 2003-11-14 02:57:22 +0000 | [diff] [blame] | 246 | * Thu Nov 13 2003 Roland McGrath <roland@redhat.com> 4.5.1-1 |
| 247 | - new upstream version, more fixes (#108012, #105366, #105359, #105358) |
| 248 | |
| 249 | * Tue Sep 30 2003 Roland McGrath <roland@redhat.com> 4.5-3 |
| 250 | - revert bogus s390 fix |
| 251 | |
| 252 | * Thu Sep 25 2003 Roland McGrath <roland@redhat.com> 4.5-1.2.1AS |
| 253 | - rebuilt for 2.1AS erratum |
| 254 | |
| 255 | * Wed Sep 24 2003 Roland McGrath <roland@redhat.com> 4.5-2 |
| 256 | - rebuilt |
| 257 | |
Roland McGrath | 739868f | 2003-09-24 23:05:09 +0000 | [diff] [blame] | 258 | * Wed Sep 24 2003 Roland McGrath <roland@redhat.com> 4.5-1 |
| 259 | - new upstream version, more fixes (#101499, #104365) |
| 260 | |
Roland McGrath | a943d00 | 2003-09-24 22:22:42 +0000 | [diff] [blame] | 261 | * Thu Jul 17 2003 Roland McGrath <roland@redhat.com> 4.4.99-2 |
| 262 | - rebuilt |
| 263 | |
Roland McGrath | cb61214 | 2003-07-17 09:23:56 +0000 | [diff] [blame] | 264 | * Thu Jul 17 2003 Roland McGrath <roland@redhat.com> 4.4.99-1 |
| 265 | - new upstream version, groks more new system calls, PF_INET6 sockets |
| 266 | |
Roland McGrath | f02c3c3 | 2003-06-11 05:47:07 +0000 | [diff] [blame] | 267 | * Mon Jun 10 2003 Roland McGrath <roland@redhat.com> 4.4.98-1 |
Roland McGrath | 64ffba5 | 2003-06-02 19:37:48 +0000 | [diff] [blame] | 268 | - new upstream version, more fixes (#90754, #91085) |
| 269 | |
Roland McGrath | acd3cd7 | 2003-06-11 05:37:56 +0000 | [diff] [blame] | 270 | * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com> |
| 271 | - rebuilt |
| 272 | |
Roland McGrath | 1b86e2d | 2003-03-31 01:21:36 +0000 | [diff] [blame] | 273 | * Sun Mar 30 2003 Roland McGrath <roland@redhat.com> 4.4.96-1 |
| 274 | - new upstream version, handles yet more 2.5 syscalls, x86_64 & ia64 fixes |
| 275 | |
Roland McGrath | 215da2a | 2003-03-31 01:46:47 +0000 | [diff] [blame] | 276 | * Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com> 4.4.95-2 |
| 277 | - rebuilt |
| 278 | |
Roland McGrath | 1893d05 | 2003-02-24 10:53:44 +0000 | [diff] [blame] | 279 | * Mon Feb 24 2003 Roland McGrath <roland@redhat.com> 4.4.95-1 |
| 280 | - new upstream version, fixed getresuid/getresgid (#84959) |
| 281 | |
Roland McGrath | 6c2fe9d | 2003-02-20 03:26:47 +0000 | [diff] [blame] | 282 | * Wed Feb 19 2003 Roland McGrath <roland@redhat.com> 4.4.94-1 |
| 283 | - new upstream version, new option -E to set environment variables (#82392) |
| 284 | |
| 285 | * Wed Jan 22 2003 Tim Powers <timp@redhat.com> 4.4.93-2 |
| 286 | - rebuilt |
| 287 | |
Roland McGrath | ee06172 | 2003-01-22 02:27:51 +0000 | [diff] [blame] | 288 | * Tue Jan 21 2003 Roland McGrath <roland@redhat.com> 4.4.93-1 |
| 289 | - new upstream version, fixes ppc and s390 bugs, adds missing ptrace requests |
| 290 | |
Roland McGrath | 1d847cf | 2003-01-10 21:43:24 +0000 | [diff] [blame] | 291 | * Fri Jan 10 2003 Roland McGrath <roland@redhat.com> 4.4.91-1 |
| 292 | - new upstream version, fixes -f on x86-64 |
| 293 | |
Roland McGrath | 037124f | 2003-01-10 10:44:57 +0000 | [diff] [blame] | 294 | * Fri Jan 10 2003 Roland McGrath <roland@redhat.com> 4.4.90-1 |
| 295 | - new upstream version, fixes all known bugs modulo ia64 and s390 issues |
| 296 | |
| 297 | * Fri Jan 03 2003 Florian La Roche <Florian.LaRoche@redhat.de> 4.4-11 |
| 298 | - add further s390 patch from IBM |
| 299 | |
| 300 | * Wed Nov 27 2002 Tim Powers <timp@redhat.com> 4.4-10 |
| 301 | - remove unpackaged files from the buildroot |
| 302 | |
| 303 | * Mon Oct 07 2002 Phil Knirsch <pknirsch@redhat.com> 4.4-9.1 |
| 304 | - Added latest s390(x) patch. |
| 305 | |
| 306 | * Fri Sep 06 2002 Karsten Hopp <karsten@redhat.de> 4.4-9 |
| 307 | - preliminary x86_64 support with an ugly patch to help |
| 308 | debugging. Needs cleanup! |
| 309 | |
| 310 | * Mon Sep 2 2002 Jakub Jelinek <jakub@redhat.com> 4.4-8 |
| 311 | - newer version of the clone fixing patch (Roland McGrath) |
| 312 | - aio syscalls for i386/ia64/ppc (Ben LaHaise) |
| 313 | |
| 314 | * Wed Aug 28 2002 Jakub Jelinek <jakub@redhat.com> 4.4-7 |
| 315 | - fix strace -f (Roland McGrath, #68994) |
| 316 | - handle ?et_thread_area, SA_RESTORER (Ulrich Drepper) |
| 317 | |
| 318 | * Fri Jun 21 2002 Jakub Jelinek <jakub@redhat.com> 4.4-6 |
| 319 | - handle futexes, *xattr, sendfile64, etc. (Ulrich Drepper) |
| 320 | - handle modify_ldt (#66894) |
| 321 | |
| 322 | * Thu May 23 2002 Tim Powers <timp@redhat.com> |
| 323 | - automated rebuild |
| 324 | |
| 325 | * Tue Apr 16 2002 Jakub Jelinek <jakub@redhat.com> 4.4-4 |
| 326 | - fix for the last patch by Jeff Law (#62591) |
| 327 | |
| 328 | * Mon Mar 4 2002 Preston Brown <pbrown@redhat.com> 4.4-3 |
| 329 | - integrate patch from Jeff Law to eliminate hang tracing threads |
| 330 | |
| 331 | * Sat Feb 23 2002 Florian La Roche <Florian.LaRoche@redhat.de> |
| 332 | - minor update from debian tar-ball |
| 333 | |
| 334 | * Wed Jan 02 2002 Florian La Roche <Florian.LaRoche@redhat.de> |
| 335 | - update to 4.4 |
| 336 | |
| 337 | * Sun Jul 22 2001 Florian La Roche <Florian.LaRoche@redhat.de> |
| 338 | - disable s390 patches, they are already included |
| 339 | |
| 340 | * Wed Jul 18 2001 Preston Brown <pbrown@redhat.com> 4.3-1 |
| 341 | - new upstream version. Seems to have integrated most new syscalls |
| 342 | - tracing threaded programs is now functional. |
| 343 | |
| 344 | * Mon Jun 11 2001 Than Ngo <than@redhat.com> |
| 345 | - port s390 patches from IBM |
| 346 | |
| 347 | * Wed May 16 2001 Nalin Dahyabhai <nalin@redhat.com> |
| 348 | - modify new syscall patch to allocate enough heap space in setgroups32() |
| 349 | |
| 350 | * Wed Feb 14 2001 Jakub Jelinek <jakub@redhat.com> |
| 351 | - #include <time.h> in addition to <sys/time.h> |
| 352 | |
| 353 | * Fri Jan 26 2001 Karsten Hopp <karsten@redhat.com> |
| 354 | - clean up conflicting patches. This happened only |
| 355 | when building on S390 |
| 356 | |
| 357 | * Fri Jan 19 2001 Bill Nottingham <notting@redhat.com> |
| 358 | - update to CVS, reintegrate ia64 support |
| 359 | |
| 360 | * Sat Dec 8 2000 Bernhard Rosenkraenzer <bero@redhat.com> |
| 361 | - Get S/390 support into the normal package |
| 362 | |
| 363 | * Sat Nov 18 2000 Florian La Roche <Florian.LaRoche@redhat.de> |
| 364 | - added S/390 patch from IBM, adapting it to not conflict with |
| 365 | IA64 patch |
| 366 | |
| 367 | * Sat Aug 19 2000 Jakub Jelinek <jakub@redhat.com> |
| 368 | - doh, actually apply the 2.4 syscalls patch |
| 369 | - make it compile with 2.4.0-test7-pre4+ headers, add |
| 370 | getdents64 and fcntl64 |
| 371 | |
| 372 | * Thu Aug 3 2000 Jakub Jelinek <jakub@redhat.com> |
| 373 | - add a bunch of new 2.4 syscalls (#14036) |
| 374 | |
| 375 | * Wed Jul 12 2000 Prospector <bugzilla@redhat.com> |
| 376 | - automatic rebuild |
| 377 | - excludearch ia64 |
| 378 | |
| 379 | * Fri Jun 2 2000 Matt Wilson <msw@redhat.com> |
| 380 | - use buildinstall for FHS |
| 381 | |
| 382 | * Wed May 24 2000 Jakub Jelinek <jakub@redhat.com> |
| 383 | - make things compile on sparc |
| 384 | - fix sigreturn on sparc |
| 385 | |
| 386 | * Fri Mar 31 2000 Bill Nottingham <notting@redhat.com> |
| 387 | - fix stat64 misdef (#10485) |
| 388 | |
| 389 | * Tue Mar 21 2000 Michael K. Johnson <johnsonm@redhat.com> |
| 390 | - added ia64 patch |
| 391 | |
| 392 | * Thu Feb 03 2000 Cristian Gafton <gafton@redhat.com> |
| 393 | - man pages are compressed |
| 394 | - version 4.2 (why are we keeping all these patches around?) |
| 395 | |
| 396 | * Sat Nov 27 1999 Jeff Johnson <jbj@redhat.com> |
| 397 | - update to 4.1 (with sparc socketcall patch). |
| 398 | |
| 399 | * Fri Nov 12 1999 Jakub Jelinek <jakub@redhat.com> |
| 400 | - fix socketcall on sparc. |
| 401 | |
| 402 | * Thu Sep 02 1999 Cristian Gafton <gafton@redhat.com> |
| 403 | - fix KERN_SECURELVL compile problem |
| 404 | |
| 405 | * Tue Aug 31 1999 Cristian Gafton <gafton@redhat.com> |
| 406 | - added alpha patch from HJLu to fix the osf_sigprocmask interpretation |
| 407 | |
| 408 | * Sat Jun 12 1999 Jeff Johnson <jbj@redhat.com> |
| 409 | - update to 3.99.1. |
| 410 | |
| 411 | * Wed Jun 2 1999 Jeff Johnson <jbj@redhat.com> |
| 412 | - add (the other :-) jj's sparc patch. |
| 413 | |
| 414 | * Wed May 26 1999 Jeff Johnson <jbj@redhat.com> |
| 415 | - upgrade to 3.99 in order to |
| 416 | - add new 2.2.x open flags (#2955). |
| 417 | - add new 2.2.x syscalls (#2866). |
| 418 | - strace 3.1 patches carried along for now. |
| 419 | |
| 420 | * Sun May 16 1999 Jeff Johnson <jbj@redhat.com> |
Roland McGrath | 00a1875 | 2007-02-18 22:55:21 +0000 | [diff] [blame] | 421 | - don't rely on (broken!) rpm %%patch (#2735) |
Roland McGrath | 037124f | 2003-01-10 10:44:57 +0000 | [diff] [blame] | 422 | |
| 423 | * Tue Apr 06 1999 Preston Brown <pbrown@redhat.com> |
| 424 | - strip binary |
| 425 | |
| 426 | * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com> |
| 427 | - auto rebuild in the new build environment (release 16) |
| 428 | |
| 429 | * Tue Feb 9 1999 Jeff Johnson <jbj@redhat.com> |
| 430 | - vfork est arrive! |
| 431 | |
| 432 | * Tue Feb 9 1999 Christopher Blizzard <blizzard@redhat.com> |
| 433 | - Add patch to follow clone() syscalls, too. |
| 434 | |
| 435 | * Sun Jan 17 1999 Jeff Johnson <jbj@redhat.com> |
| 436 | - patch to build alpha/sparc with glibc 2.1. |
| 437 | |
| 438 | * Thu Dec 03 1998 Cristian Gafton <gafton@redhat.com> |
| 439 | - patch to build on ARM |
| 440 | |
| 441 | * Wed Sep 30 1998 Jeff Johnson <jbj@redhat.com> |
| 442 | - fix typo (printf, not tprintf). |
| 443 | |
| 444 | * Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com> |
| 445 | - fix compile problem on sparc. |
| 446 | |
| 447 | * Tue Aug 18 1998 Cristian Gafton <gafton@redhat.com> |
| 448 | - buildroot |
| 449 | |
| 450 | * Mon Jul 20 1998 Cristian Gafton <gafton@redhat.com> |
| 451 | - added the umoven patch from James Youngman <jay@gnu.org> |
| 452 | - fixed build problems on newer glibc releases |
| 453 | |
| 454 | * Mon Jun 08 1998 Prospector System <bugs@redhat.com> |
| 455 | - translations modified for de, fr, tr |