blob: 4fad2ae841e4e084f1694225495644584352b270 [file] [log] [blame]
Roland McGrath00a18752007-02-18 22:55:21 +00001Summary: Tracks and displays system calls associated with a running process
Roland McGrath037124f2003-01-10 10:44:57 +00002Name: strace
Dmitry V. Levin50e69cb2011-02-21 22:58:59 +00003Version: 4.6
Dmitry V. Levin48e95c72012-04-20 17:31:48 +00004Release: 2%{?dist}
Roland McGrath037124f2003-01-10 10:44:57 +00005License: BSD
6Group: Development/Debuggers
7URL: http://sourceforge.net/projects/strace/
Dmitry V. Levin525a39a2011-02-27 14:05:58 +00008Source: http://downloads.sourceforge.net/strace/%{name}-%{version}.tar.xz
Roland McGrath00a18752007-02-18 22:55:21 +00009BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Roland McGrath037124f2003-01-10 10:44:57 +000010
Dmitry V. Levin983e8752011-02-27 10:16:41 +000011BuildRequires: libacl-devel, libaio-devel, time
Roland McGrath4c99f562007-11-19 22:14:56 +000012
Roland McGrath7c2ec572008-03-26 19:15:41 +000013%define strace64_arches ppc64 sparc64
Roland McGratha943d002003-09-24 22:22:42 +000014
Roland McGrath037124f2003-01-10 10:44:57 +000015%description
16The strace program intercepts and records the system calls called and
17received by a running process. Strace can print a record of each
18system call, its arguments and its return value. Strace is useful for
19diagnosing problems and debugging, as well as for instructional
20purposes.
21
22Install strace if you need a tool to track the system calls made and
23received by a process.
24
Roland McGratha943d002003-09-24 22:22:42 +000025%ifarch %{strace64_arches}
26%package -n strace64
27Summary: Tracks and displays system calls associated with a running process.
28Group: Development/Debuggers
29
30%description -n strace64
31The strace program intercepts and records the system calls called and
32received by a running process. Strace can print a record of each
33system call, its arguments and its return value. Strace is useful for
34diagnosing problems and debugging, as well as for instructional
35purposes.
36
37Install strace if you need a tool to track the system calls made and
38received by a process.
39
40This package provides the `strace64' program to trace 64-bit processes.
41The `strace' program in the `strace' package is for 32-bit processes.
42%endif
43
Roland McGrath037124f2003-01-10 10:44:57 +000044%prep
45%setup -q
46
47%build
48%configure
Roland McGrathcddc21f2007-02-18 22:56:37 +000049make %{?_smp_mflags}
Roland McGrath037124f2003-01-10 10:44:57 +000050
51%install
52rm -rf %{buildroot}
Roland McGrath00a18752007-02-18 22:55:21 +000053make DESTDIR=%{buildroot} install
Roland McGrath037124f2003-01-10 10:44:57 +000054
55# remove unpackaged files from the buildroot
56rm -f %{buildroot}%{_bindir}/strace-graph
57
Roland McGrath3f0dbe22008-08-28 23:26:21 +000058%define copy64 ln
59%if 0%{?rhel}
60%if 0%{?rhel} < 6
61%endif
62%define copy64 cp -p
63%endif
64
Roland McGratha943d002003-09-24 22:22:42 +000065%ifarch %{strace64_arches}
Roland McGrath3f0dbe22008-08-28 23:26:21 +000066%{copy64} %{buildroot}%{_bindir}/strace %{buildroot}%{_bindir}/strace64
Roland McGratha943d002003-09-24 22:22:42 +000067%endif
68
Dmitry V. Levin983e8752011-02-27 10:16:41 +000069%check
70make check
71
Roland McGrath037124f2003-01-10 10:44:57 +000072%clean
73rm -rf %{buildroot}
74
75%files
76%defattr(-,root,root)
Dmitry V. Levindd762c32012-02-25 15:29:21 +010077%doc CREDITS ChangeLog ChangeLog-CVS COPYRIGHT NEWS README
Roland McGrath037124f2003-01-10 10:44:57 +000078%{_bindir}/strace
79%{_mandir}/man1/*
80
Roland McGratha943d002003-09-24 22:22:42 +000081%ifarch %{strace64_arches}
82%files -n strace64
83%defattr(-,root,root)
84%{_bindir}/strace64
85%endif
86
Roland McGrath037124f2003-01-10 10:44:57 +000087%changelog
Dmitry V. Levin48e95c72012-04-20 17:31:48 +000088* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.6-2
89- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
90
Dmitry V. Levin50e69cb2011-02-21 22:58:59 +000091* Mon Mar 14 2011 Dmitry V. Levin <ldv@altlinux.org> - 4.6-1
92- New upstream release.
93 + fixed a corner case in waitpid handling (#663547).
94
Dmitry V. Levinc36c3032011-02-21 23:22:34 +000095* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.5.20-2
96- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
97
Dmitry V. Levinacbe5182010-04-06 23:46:43 +000098* Tue Apr 13 2010 Roland McGrath <roland@redhat.com> - 4.5.20-1
99- New upstream release, work mostly by Andreas Schwab and Dmitry V. Levin.
100 + fixed potential stack buffer overflow in select decoder (#556678);
101 + fixed FTBFS (#539044).
102
Roland McGrath7d9247e2009-10-21 10:36:13 -0700103* Wed Oct 21 2009 Roland McGrath <roland@redhat.com> - 4.5.19-1
104- New upstream release, work mostly by Dmitry V. Levin <ldv@altlinux.org>
Dmitry V. Levinfbfed222009-09-14 16:34:34 +0000105 + exit/kill strace with traced process exitcode/signal (#105371);
106 + fixed build on ARM EABI (#507576);
107 + fixed display of 32-bit argv array on 64-bit architectures (#519480);
108 + fixed display of 32-bit fcntl(F_SETLK) on 64-bit architectures (#471169);
109 + fixed several bugs in strings decoder, including potential heap
110 memory corruption (#470529, #478324, #511035).
111
Roland McGrath09db7052008-08-28 22:00:46 +0000112* Thu Aug 28 2008 Roland McGrath <roland@redhat.com> - 4.5.18-1
113- build fix for newer kernel headers (#457291)
114- fix CLONE_VFORK handling (#455078)
115- Support new Linux/PPC system call subpage_prot and PROT_SAO flag.
116- In sigaction system call, display sa_flags value along with SIG_DFL/SIG_IGN.
117
Roland McGrath6a1311d2008-07-22 00:43:09 +0000118* Mon Jul 21 2008 Roland McGrath <roland@redhat.com> - 4.5.17-1
Roland McGrath55dd2782008-07-18 02:21:11 +0000119- handle O_CLOEXEC, MSG_CMSG_CLOEXEC (#365781)
120- fix biarch stat64 decoding (#222275)
121- fix spurious "..." in printing of environment strings (#358241)
122- improve prctl decoding (#364401)
123- fix hang wait on exited child with exited child (#354261)
124- fix biarch fork/vfork (-f) tracing (#447475)
125- fix biarch printing of negative argument kill (#430585)
126- fix biarch decoding of error return values (#447587)
127- fix -f tracing of CLONE_VFORK (#455078)
128- fix ia64 register clobberation in -f tracing (#453438)
129- print SO_NODEFER, SA_RESETHAND instead of SA_NOMASK, SA_ONESHOT (#455821)
130- fix futex argument decoding (#448628, #448629)
131
Roland McGrath47d32232007-08-03 10:28:55 +0000132* Fri Aug 3 2007 Roland McGrath <roland@redhat.com> - 4.5.16-1
133- fix multithread issues (#240962, #240961, #247907)
134- fix spurious SIGSTOP on early interrupt (#240986)
135- fix utime for biarch (#247185)
136- fix -u error message (#247170)
137- better futex syscall printing (##241467)
138- fix argv/envp printing with small -s settings, and for biarch
139- new syscalls: getcpu, eventfd, timerfd, signalfd, epoll_pwait,
140 move_pages, utimensat
141
Roland McGrath0a45fae2007-01-16 23:25:34 +0000142* Tue Jan 16 2007 Roland McGrath <roland@redhat.com> - 4.5.15-1
Roland McGrathcdec4692007-01-11 22:22:47 +0000143- biarch fixes (#179740, #192193, #171626, #173050, #218433, #218043)
144- fix -ff -o behavior (#204950, #218435, #193808, #219423)
145- better quotactl printing (#118696)
146- *at, inotify*, pselect6, ppoll and unshare syscalls (#178633, #191275)
147- glibc-2.5 build fixes (#209856)
148- memory corruption fixes (#200621
149- fix race in child setup under -f (#180293)
150- show ipc key values in hex (#198179, #192182)
151- disallow -c with -ff (#187847)
152- Resolves: RHBZ #179740, RHBZ #192193, RHBZ #204950, RHBZ #218435
153- Resolves: RHBZ #193808, RHBZ #219423, RHBZ #171626, RHBZ #173050
154- Resolves: RHBZ #218433, RHBZ #218043, RHBZ #118696, RHBZ #178633
155- Resolves: RHBZ #191275, RHBZ #209856, RHBZ #200621, RHBZ #180293
156- Resolves: RHBZ #198179, RHBZ #198182, RHBZ #187847
157
158* Mon Nov 20 2006 Jakub Jelinek <jakub@redhat.com> - 4.5.14-4
159- Fix ia64 syscall decoding (#206768)
160- Fix build with glibc-2.4.90-33 and up on all arches but ia64
161- Fix build against 2.6.18+ headers
162
163* Tue Aug 22 2006 Roland McGrath <roland@redhat.com> - 4.5.14-3
164- Fix bogus decoding of syscalls >= 300 (#201462, #202620).
165
166* Fri Jul 14 2006 Jesse Keating <jkeating@redhat.com> - 4.5.14-2
167- rebuild
168
169* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 4.5.14-1.2
170- bump again for long double bug on ppc{,64}
171
172* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 4.5.14-1.1
173- rebuilt for new gcc4.1 snapshot and glibc changes
174
Roland McGrathf4d9b492006-01-17 06:22:57 +0000175* Mon Jan 16 2006 Roland McGrath <roland@redhat.com> - 4.5.14-1
176- Fix biarch decoding of socket syscalls (#174354).
177- Fix biarch -e support (#173986).
178- Accept numeric syscalls in -e (#174798).
179- Fix ipc syscall decoding (#164755).
180- Improve msgrcv printing (#164757).
181- Man page updates (#165375).
182- Improve mount syscall printing (#165377).
183- Correct printing of restarting syscalls (#165469).
184
Roland McGrathcab43802005-08-03 11:42:35 +0000185* Wed Aug 3 2005 Roland McGrath <roland@redhat.com> - 4.5.13-1
186- Fix setsockopt decoding on 64-bit (#162449).
187- Fix typos in socket option name strings (#161578).
188- Display more IPV6 socket options by name (#162450).
189- Don't display inappropriate syscalls for -e trace=file (#159340).
190- New selector type -e trace=desc for file-descriptor using calls (#159400).
191- Fix 32-bit old_mmap syscall decoding on x86-64 (#162467, #164215).
192- Fix errors detaching from multithreaded process on interrupt (#161919).
193- Note 4.5.12 fix for crash handling bad signal numbers (#162739).
194
Roland McGrath182cbf42005-06-10 03:56:16 +0000195* Wed Jun 8 2005 Roland McGrath <roland@redhat.com> - 4.5.12-1
196- Fix known syscall recognition for IA32 processes on x86-64 (#158934).
197- Fix bad output for ptrace on x86-64 (#159787).
198- Fix potential buffer overruns (#151570, #159196).
199- Make some diagnostics more consistent (#159308).
200- Update PowerPC system calls.
201- Better printing for Linux aio system calls.
202- Don't truncate statfs64 fields to 32 bits in output (#158243).
203- Cosmetic code cleanups (#159688).
204
Roland McGrath7147a3d2005-03-22 23:12:39 +0000205* Tue Mar 22 2005 Roland McGrath <roland@redhat.com> - 4.5.11-1
206- Build tweaks.
207- Note 4.5.10 select fix (#151570).
208
Roland McGrathd8184032005-03-15 02:40:12 +0000209* Mon Mar 14 2005 Roland McGrath <roland@redhat.com> - 4.5.10-1
210- Fix select handling on nonstandard fd_set sizes.
211- Don't print errors for null file name pointers.
212- Fix initial execve output with -i (#143365).
213
Roland McGrath6df9d642005-02-04 10:13:15 +0000214* Fri Feb 4 2005 Roland McGrath <roland@redhat.com> - 4.5.9-2
Roland McGrathd63311a2005-02-04 09:29:04 +0000215- update ia64 syscall list (#146245)
216- fix x86_64 syscall argument extraction for 32-bit processes (#146093)
217- fix -e signal=NAME parsing (#143362)
218- fix x86_64 exit_group syscall handling
219- improve socket ioctl printing (#138223)
220- code cleanups (#143369, #143370)
221- improve mount flags printing (#141932)
222- support symbolic printing of x86_64 arch_prctl parameters (#142667)
223- fix potential crash in getxattr printing
224
Roland McGrathf041d472004-10-20 02:17:52 +0000225* Tue Oct 19 2004 Roland McGrath <roland@redhat.com> - 4.5.8-1
226- fix multithreaded exit handling (#132150, #135254)
227- fix ioctl name matching (#129808)
228- print RTC_* ioctl structure contents (#58606)
229- grok epoll_* syscalls (#134463)
230- grok new RLIMIT_* values (#133594)
231- print struct cmsghdr contents for sendmsg (#131689)
232- fix clock_* and timer_* argument output (#131420)
233
Roland McGrath61d64872004-08-31 08:58:10 +0000234* Tue Aug 31 2004 Roland McGrath <roland@redhat.com> - 4.5.7-2
Roland McGrathb93f9182004-08-31 08:17:20 +0000235- new upstream version, misc fixes and updates (#128091, #129166, #128391, #129378, #130965, #131177)
236
Roland McGrath785a0262004-07-12 07:55:48 +0000237* Mon Jul 12 2004 Roland McGrath <roland@redhat.com> 4.5.6-1
238- new upstream version, updates ioctl lists (#127398), fixes quotactl (#127393), more ioctl decoding (#126917)
239
Roland McGrathb7e2ca12004-06-28 05:24:29 +0000240* Sun Jun 27 2004 Roland McGrath <roland@redhat.com> 4.5.5-1
241- new upstream version, fixes x86-64 biarch support (#126547)
242
243* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com> 4.5.4-2
244- rebuilt
245
246* Thu Jun 3 2004 Roland McGrath <roland@redhat.com> 4.5.4-0.FC1
247- rebuilt for FC1 update
248
Roland McGrathed8e77e2004-06-04 02:35:58 +0000249* Thu Jun 3 2004 Roland McGrath <roland@redhat.com> 4.5.4-1
250- new upstream version, more ioctls (#122257), minor fixes
251
Roland McGratha8c555f2004-04-16 22:28:41 +0000252* Fri Apr 16 2004 Roland McGrath <roland@redhat.com> 4.5.3-1
253- new upstream version, mq_* calls (#120701), -p vs NPTL (#120462), more fixes (#118694, #120541, #118685)
254
255* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com> 4.5.2-1.1
256- rebuilt
257
Roland McGrathb66e9362004-03-02 06:38:35 +0000258* Mon Mar 1 2004 Roland McGrath <roland@redhat.com> 4.5.2-1
259- new upstream version, sched_* calls (#116990), show core flag (#112117)
260
261* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
262- rebuilt
263
Roland McGrath00eb84e2003-11-14 02:57:22 +0000264* Thu Nov 13 2003 Roland McGrath <roland@redhat.com> 4.5.1-1
265- new upstream version, more fixes (#108012, #105366, #105359, #105358)
266
267* Tue Sep 30 2003 Roland McGrath <roland@redhat.com> 4.5-3
268- revert bogus s390 fix
269
270* Thu Sep 25 2003 Roland McGrath <roland@redhat.com> 4.5-1.2.1AS
271- rebuilt for 2.1AS erratum
272
273* Wed Sep 24 2003 Roland McGrath <roland@redhat.com> 4.5-2
274- rebuilt
275
Roland McGrath739868f2003-09-24 23:05:09 +0000276* Wed Sep 24 2003 Roland McGrath <roland@redhat.com> 4.5-1
277- new upstream version, more fixes (#101499, #104365)
278
Roland McGratha943d002003-09-24 22:22:42 +0000279* Thu Jul 17 2003 Roland McGrath <roland@redhat.com> 4.4.99-2
280- rebuilt
281
Roland McGrathcb612142003-07-17 09:23:56 +0000282* Thu Jul 17 2003 Roland McGrath <roland@redhat.com> 4.4.99-1
283- new upstream version, groks more new system calls, PF_INET6 sockets
284
Roland McGrathf02c3c32003-06-11 05:47:07 +0000285* Mon Jun 10 2003 Roland McGrath <roland@redhat.com> 4.4.98-1
Roland McGrath64ffba52003-06-02 19:37:48 +0000286- new upstream version, more fixes (#90754, #91085)
287
Roland McGrathacd3cd72003-06-11 05:37:56 +0000288* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
289- rebuilt
290
Roland McGrath1b86e2d2003-03-31 01:21:36 +0000291* Sun Mar 30 2003 Roland McGrath <roland@redhat.com> 4.4.96-1
292- new upstream version, handles yet more 2.5 syscalls, x86_64 & ia64 fixes
293
Roland McGrath215da2a2003-03-31 01:46:47 +0000294* Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com> 4.4.95-2
295- rebuilt
296
Roland McGrath1893d052003-02-24 10:53:44 +0000297* Mon Feb 24 2003 Roland McGrath <roland@redhat.com> 4.4.95-1
298- new upstream version, fixed getresuid/getresgid (#84959)
299
Roland McGrath6c2fe9d2003-02-20 03:26:47 +0000300* Wed Feb 19 2003 Roland McGrath <roland@redhat.com> 4.4.94-1
301- new upstream version, new option -E to set environment variables (#82392)
302
303* Wed Jan 22 2003 Tim Powers <timp@redhat.com> 4.4.93-2
304- rebuilt
305
Roland McGrathee061722003-01-22 02:27:51 +0000306* Tue Jan 21 2003 Roland McGrath <roland@redhat.com> 4.4.93-1
307- new upstream version, fixes ppc and s390 bugs, adds missing ptrace requests
308
Roland McGrath1d847cf2003-01-10 21:43:24 +0000309* Fri Jan 10 2003 Roland McGrath <roland@redhat.com> 4.4.91-1
310- new upstream version, fixes -f on x86-64
311
Roland McGrath037124f2003-01-10 10:44:57 +0000312* Fri Jan 10 2003 Roland McGrath <roland@redhat.com> 4.4.90-1
313- new upstream version, fixes all known bugs modulo ia64 and s390 issues
314
315* Fri Jan 03 2003 Florian La Roche <Florian.LaRoche@redhat.de> 4.4-11
316- add further s390 patch from IBM
317
318* Wed Nov 27 2002 Tim Powers <timp@redhat.com> 4.4-10
319- remove unpackaged files from the buildroot
320
321* Mon Oct 07 2002 Phil Knirsch <pknirsch@redhat.com> 4.4-9.1
322- Added latest s390(x) patch.
323
324* Fri Sep 06 2002 Karsten Hopp <karsten@redhat.de> 4.4-9
325- preliminary x86_64 support with an ugly patch to help
326 debugging. Needs cleanup!
327
328* Mon Sep 2 2002 Jakub Jelinek <jakub@redhat.com> 4.4-8
329- newer version of the clone fixing patch (Roland McGrath)
330- aio syscalls for i386/ia64/ppc (Ben LaHaise)
331
332* Wed Aug 28 2002 Jakub Jelinek <jakub@redhat.com> 4.4-7
333- fix strace -f (Roland McGrath, #68994)
334- handle ?et_thread_area, SA_RESTORER (Ulrich Drepper)
335
336* Fri Jun 21 2002 Jakub Jelinek <jakub@redhat.com> 4.4-6
337- handle futexes, *xattr, sendfile64, etc. (Ulrich Drepper)
338- handle modify_ldt (#66894)
339
340* Thu May 23 2002 Tim Powers <timp@redhat.com>
341- automated rebuild
342
343* Tue Apr 16 2002 Jakub Jelinek <jakub@redhat.com> 4.4-4
344- fix for the last patch by Jeff Law (#62591)
345
346* Mon Mar 4 2002 Preston Brown <pbrown@redhat.com> 4.4-3
347- integrate patch from Jeff Law to eliminate hang tracing threads
348
349* Sat Feb 23 2002 Florian La Roche <Florian.LaRoche@redhat.de>
350- minor update from debian tar-ball
351
352* Wed Jan 02 2002 Florian La Roche <Florian.LaRoche@redhat.de>
353- update to 4.4
354
355* Sun Jul 22 2001 Florian La Roche <Florian.LaRoche@redhat.de>
356- disable s390 patches, they are already included
357
358* Wed Jul 18 2001 Preston Brown <pbrown@redhat.com> 4.3-1
359- new upstream version. Seems to have integrated most new syscalls
360- tracing threaded programs is now functional.
361
362* Mon Jun 11 2001 Than Ngo <than@redhat.com>
363- port s390 patches from IBM
364
365* Wed May 16 2001 Nalin Dahyabhai <nalin@redhat.com>
366- modify new syscall patch to allocate enough heap space in setgroups32()
367
368* Wed Feb 14 2001 Jakub Jelinek <jakub@redhat.com>
369- #include <time.h> in addition to <sys/time.h>
370
371* Fri Jan 26 2001 Karsten Hopp <karsten@redhat.com>
372- clean up conflicting patches. This happened only
373 when building on S390
374
375* Fri Jan 19 2001 Bill Nottingham <notting@redhat.com>
376- update to CVS, reintegrate ia64 support
377
378* Sat Dec 8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
379- Get S/390 support into the normal package
380
381* Sat Nov 18 2000 Florian La Roche <Florian.LaRoche@redhat.de>
382- added S/390 patch from IBM, adapting it to not conflict with
383 IA64 patch
384
385* Sat Aug 19 2000 Jakub Jelinek <jakub@redhat.com>
386- doh, actually apply the 2.4 syscalls patch
387- make it compile with 2.4.0-test7-pre4+ headers, add
388 getdents64 and fcntl64
389
390* Thu Aug 3 2000 Jakub Jelinek <jakub@redhat.com>
391- add a bunch of new 2.4 syscalls (#14036)
392
393* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
394- automatic rebuild
395- excludearch ia64
396
397* Fri Jun 2 2000 Matt Wilson <msw@redhat.com>
398- use buildinstall for FHS
399
400* Wed May 24 2000 Jakub Jelinek <jakub@redhat.com>
401- make things compile on sparc
402- fix sigreturn on sparc
403
404* Fri Mar 31 2000 Bill Nottingham <notting@redhat.com>
405- fix stat64 misdef (#10485)
406
407* Tue Mar 21 2000 Michael K. Johnson <johnsonm@redhat.com>
408- added ia64 patch
409
410* Thu Feb 03 2000 Cristian Gafton <gafton@redhat.com>
411- man pages are compressed
412- version 4.2 (why are we keeping all these patches around?)
413
414* Sat Nov 27 1999 Jeff Johnson <jbj@redhat.com>
415- update to 4.1 (with sparc socketcall patch).
416
417* Fri Nov 12 1999 Jakub Jelinek <jakub@redhat.com>
418- fix socketcall on sparc.
419
420* Thu Sep 02 1999 Cristian Gafton <gafton@redhat.com>
421- fix KERN_SECURELVL compile problem
422
423* Tue Aug 31 1999 Cristian Gafton <gafton@redhat.com>
424- added alpha patch from HJLu to fix the osf_sigprocmask interpretation
425
426* Sat Jun 12 1999 Jeff Johnson <jbj@redhat.com>
427- update to 3.99.1.
428
429* Wed Jun 2 1999 Jeff Johnson <jbj@redhat.com>
430- add (the other :-) jj's sparc patch.
431
432* Wed May 26 1999 Jeff Johnson <jbj@redhat.com>
433- upgrade to 3.99 in order to
434- add new 2.2.x open flags (#2955).
435- add new 2.2.x syscalls (#2866).
436- strace 3.1 patches carried along for now.
437
438* Sun May 16 1999 Jeff Johnson <jbj@redhat.com>
Roland McGrath00a18752007-02-18 22:55:21 +0000439- don't rely on (broken!) rpm %%patch (#2735)
Roland McGrath037124f2003-01-10 10:44:57 +0000440
441* Tue Apr 06 1999 Preston Brown <pbrown@redhat.com>
442- strip binary
443
444* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
445- auto rebuild in the new build environment (release 16)
446
447* Tue Feb 9 1999 Jeff Johnson <jbj@redhat.com>
448- vfork est arrive!
449
450* Tue Feb 9 1999 Christopher Blizzard <blizzard@redhat.com>
451- Add patch to follow clone() syscalls, too.
452
453* Sun Jan 17 1999 Jeff Johnson <jbj@redhat.com>
454- patch to build alpha/sparc with glibc 2.1.
455
456* Thu Dec 03 1998 Cristian Gafton <gafton@redhat.com>
457- patch to build on ARM
458
459* Wed Sep 30 1998 Jeff Johnson <jbj@redhat.com>
460- fix typo (printf, not tprintf).
461
462* Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
463- fix compile problem on sparc.
464
465* Tue Aug 18 1998 Cristian Gafton <gafton@redhat.com>
466- buildroot
467
468* Mon Jul 20 1998 Cristian Gafton <gafton@redhat.com>
469- added the umoven patch from James Youngman <jay@gnu.org>
470- fixed build problems on newer glibc releases
471
472* Mon Jun 08 1998 Prospector System <bugs@redhat.com>
473- translations modified for de, fr, tr