blob: 18e987c1fb14d5586ef02138eaa06d048fd3dfa3 [file] [log] [blame]
Roland McGrath00a18752007-02-18 22:55:21 +00001Summary: Tracks and displays system calls associated with a running process
Roland McGrath037124f2003-01-10 10:44:57 +00002Name: strace
Roland McGrath47d32232007-08-03 10:28:55 +00003Version: 4.5.16
Roland McGrathcdec4692007-01-11 22:22:47 +00004Release: 1%{?dist}
Roland McGrath037124f2003-01-10 10:44:57 +00005License: BSD
6Group: Development/Debuggers
7URL: http://sourceforge.net/projects/strace/
Roland McGrath4aa15562006-04-25 07:22:02 +00008Source0: http://dl.sourceforge.net/strace/%{name}-%{version}.tar.bz2
Roland McGrath00a18752007-02-18 22:55:21 +00009BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Roland McGrath037124f2003-01-10 10:44:57 +000010
Roland McGratha943d002003-09-24 22:22:42 +000011%define strace64_arches ppc64
12
Roland McGrath037124f2003-01-10 10:44:57 +000013%description
14The strace program intercepts and records the system calls called and
15received by a running process. Strace can print a record of each
16system call, its arguments and its return value. Strace is useful for
17diagnosing problems and debugging, as well as for instructional
18purposes.
19
20Install strace if you need a tool to track the system calls made and
21received by a process.
22
Roland McGratha943d002003-09-24 22:22:42 +000023%ifarch %{strace64_arches}
24%package -n strace64
25Summary: Tracks and displays system calls associated with a running process.
26Group: Development/Debuggers
27
28%description -n strace64
29The strace program intercepts and records the system calls called and
30received by a running process. Strace can print a record of each
31system call, its arguments and its return value. Strace is useful for
32diagnosing problems and debugging, as well as for instructional
33purposes.
34
35Install strace if you need a tool to track the system calls made and
36received by a process.
37
38This package provides the `strace64' program to trace 64-bit processes.
39The `strace' program in the `strace' package is for 32-bit processes.
40%endif
41
Roland McGrath037124f2003-01-10 10:44:57 +000042%prep
43%setup -q
44
45%build
46%configure
Roland McGrathcddc21f2007-02-18 22:56:37 +000047make %{?_smp_mflags}
Roland McGrath037124f2003-01-10 10:44:57 +000048
49%install
50rm -rf %{buildroot}
Roland McGrath00a18752007-02-18 22:55:21 +000051make DESTDIR=%{buildroot} install
Roland McGrath037124f2003-01-10 10:44:57 +000052
53# remove unpackaged files from the buildroot
54rm -f %{buildroot}%{_bindir}/strace-graph
55
Roland McGratha943d002003-09-24 22:22:42 +000056%ifarch %{strace64_arches}
57ln %{buildroot}%{_bindir}/strace %{buildroot}%{_bindir}/strace64
58%endif
59
Roland McGrath037124f2003-01-10 10:44:57 +000060%clean
61rm -rf %{buildroot}
62
63%files
64%defattr(-,root,root)
Roland McGrath00a18752007-02-18 22:55:21 +000065%doc CREDITS ChangeLog COPYRIGHT NEWS PORTING README
Roland McGrath037124f2003-01-10 10:44:57 +000066%{_bindir}/strace
67%{_mandir}/man1/*
68
Roland McGratha943d002003-09-24 22:22:42 +000069%ifarch %{strace64_arches}
70%files -n strace64
71%defattr(-,root,root)
72%{_bindir}/strace64
73%endif
74
75
Roland McGrath037124f2003-01-10 10:44:57 +000076%changelog
Roland McGrath47d32232007-08-03 10:28:55 +000077* Fri Aug 3 2007 Roland McGrath <roland@redhat.com> - 4.5.16-1
78- fix multithread issues (#240962, #240961, #247907)
79- fix spurious SIGSTOP on early interrupt (#240986)
80- fix utime for biarch (#247185)
81- fix -u error message (#247170)
82- better futex syscall printing (##241467)
83- fix argv/envp printing with small -s settings, and for biarch
84- new syscalls: getcpu, eventfd, timerfd, signalfd, epoll_pwait,
85 move_pages, utimensat
86
Roland McGrath0a45fae2007-01-16 23:25:34 +000087* Tue Jan 16 2007 Roland McGrath <roland@redhat.com> - 4.5.15-1
Roland McGrathcdec4692007-01-11 22:22:47 +000088- biarch fixes (#179740, #192193, #171626, #173050, #218433, #218043)
89- fix -ff -o behavior (#204950, #218435, #193808, #219423)
90- better quotactl printing (#118696)
91- *at, inotify*, pselect6, ppoll and unshare syscalls (#178633, #191275)
92- glibc-2.5 build fixes (#209856)
93- memory corruption fixes (#200621
94- fix race in child setup under -f (#180293)
95- show ipc key values in hex (#198179, #192182)
96- disallow -c with -ff (#187847)
97- Resolves: RHBZ #179740, RHBZ #192193, RHBZ #204950, RHBZ #218435
98- Resolves: RHBZ #193808, RHBZ #219423, RHBZ #171626, RHBZ #173050
99- Resolves: RHBZ #218433, RHBZ #218043, RHBZ #118696, RHBZ #178633
100- Resolves: RHBZ #191275, RHBZ #209856, RHBZ #200621, RHBZ #180293
101- Resolves: RHBZ #198179, RHBZ #198182, RHBZ #187847
102
103* Mon Nov 20 2006 Jakub Jelinek <jakub@redhat.com> - 4.5.14-4
104- Fix ia64 syscall decoding (#206768)
105- Fix build with glibc-2.4.90-33 and up on all arches but ia64
106- Fix build against 2.6.18+ headers
107
108* Tue Aug 22 2006 Roland McGrath <roland@redhat.com> - 4.5.14-3
109- Fix bogus decoding of syscalls >= 300 (#201462, #202620).
110
111* Fri Jul 14 2006 Jesse Keating <jkeating@redhat.com> - 4.5.14-2
112- rebuild
113
114* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 4.5.14-1.2
115- bump again for long double bug on ppc{,64}
116
117* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 4.5.14-1.1
118- rebuilt for new gcc4.1 snapshot and glibc changes
119
Roland McGrathf4d9b492006-01-17 06:22:57 +0000120* Mon Jan 16 2006 Roland McGrath <roland@redhat.com> - 4.5.14-1
121- Fix biarch decoding of socket syscalls (#174354).
122- Fix biarch -e support (#173986).
123- Accept numeric syscalls in -e (#174798).
124- Fix ipc syscall decoding (#164755).
125- Improve msgrcv printing (#164757).
126- Man page updates (#165375).
127- Improve mount syscall printing (#165377).
128- Correct printing of restarting syscalls (#165469).
129
Roland McGrathcab43802005-08-03 11:42:35 +0000130* Wed Aug 3 2005 Roland McGrath <roland@redhat.com> - 4.5.13-1
131- Fix setsockopt decoding on 64-bit (#162449).
132- Fix typos in socket option name strings (#161578).
133- Display more IPV6 socket options by name (#162450).
134- Don't display inappropriate syscalls for -e trace=file (#159340).
135- New selector type -e trace=desc for file-descriptor using calls (#159400).
136- Fix 32-bit old_mmap syscall decoding on x86-64 (#162467, #164215).
137- Fix errors detaching from multithreaded process on interrupt (#161919).
138- Note 4.5.12 fix for crash handling bad signal numbers (#162739).
139
Roland McGrath182cbf42005-06-10 03:56:16 +0000140* Wed Jun 8 2005 Roland McGrath <roland@redhat.com> - 4.5.12-1
141- Fix known syscall recognition for IA32 processes on x86-64 (#158934).
142- Fix bad output for ptrace on x86-64 (#159787).
143- Fix potential buffer overruns (#151570, #159196).
144- Make some diagnostics more consistent (#159308).
145- Update PowerPC system calls.
146- Better printing for Linux aio system calls.
147- Don't truncate statfs64 fields to 32 bits in output (#158243).
148- Cosmetic code cleanups (#159688).
149
Roland McGrath7147a3d2005-03-22 23:12:39 +0000150* Tue Mar 22 2005 Roland McGrath <roland@redhat.com> - 4.5.11-1
151- Build tweaks.
152- Note 4.5.10 select fix (#151570).
153
Roland McGrathd8184032005-03-15 02:40:12 +0000154* Mon Mar 14 2005 Roland McGrath <roland@redhat.com> - 4.5.10-1
155- Fix select handling on nonstandard fd_set sizes.
156- Don't print errors for null file name pointers.
157- Fix initial execve output with -i (#143365).
158
Roland McGrath6df9d642005-02-04 10:13:15 +0000159* Fri Feb 4 2005 Roland McGrath <roland@redhat.com> - 4.5.9-2
Roland McGrathd63311a2005-02-04 09:29:04 +0000160- update ia64 syscall list (#146245)
161- fix x86_64 syscall argument extraction for 32-bit processes (#146093)
162- fix -e signal=NAME parsing (#143362)
163- fix x86_64 exit_group syscall handling
164- improve socket ioctl printing (#138223)
165- code cleanups (#143369, #143370)
166- improve mount flags printing (#141932)
167- support symbolic printing of x86_64 arch_prctl parameters (#142667)
168- fix potential crash in getxattr printing
169
Roland McGrathf041d472004-10-20 02:17:52 +0000170* Tue Oct 19 2004 Roland McGrath <roland@redhat.com> - 4.5.8-1
171- fix multithreaded exit handling (#132150, #135254)
172- fix ioctl name matching (#129808)
173- print RTC_* ioctl structure contents (#58606)
174- grok epoll_* syscalls (#134463)
175- grok new RLIMIT_* values (#133594)
176- print struct cmsghdr contents for sendmsg (#131689)
177- fix clock_* and timer_* argument output (#131420)
178
Roland McGrath61d64872004-08-31 08:58:10 +0000179* Tue Aug 31 2004 Roland McGrath <roland@redhat.com> - 4.5.7-2
Roland McGrathb93f9182004-08-31 08:17:20 +0000180- new upstream version, misc fixes and updates (#128091, #129166, #128391, #129378, #130965, #131177)
181
Roland McGrath785a0262004-07-12 07:55:48 +0000182* Mon Jul 12 2004 Roland McGrath <roland@redhat.com> 4.5.6-1
183- new upstream version, updates ioctl lists (#127398), fixes quotactl (#127393), more ioctl decoding (#126917)
184
Roland McGrathb7e2ca12004-06-28 05:24:29 +0000185* Sun Jun 27 2004 Roland McGrath <roland@redhat.com> 4.5.5-1
186- new upstream version, fixes x86-64 biarch support (#126547)
187
188* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com> 4.5.4-2
189- rebuilt
190
191* Thu Jun 3 2004 Roland McGrath <roland@redhat.com> 4.5.4-0.FC1
192- rebuilt for FC1 update
193
Roland McGrathed8e77e2004-06-04 02:35:58 +0000194* Thu Jun 3 2004 Roland McGrath <roland@redhat.com> 4.5.4-1
195- new upstream version, more ioctls (#122257), minor fixes
196
Roland McGratha8c555f2004-04-16 22:28:41 +0000197* Fri Apr 16 2004 Roland McGrath <roland@redhat.com> 4.5.3-1
198- new upstream version, mq_* calls (#120701), -p vs NPTL (#120462), more fixes (#118694, #120541, #118685)
199
200* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com> 4.5.2-1.1
201- rebuilt
202
Roland McGrathb66e9362004-03-02 06:38:35 +0000203* Mon Mar 1 2004 Roland McGrath <roland@redhat.com> 4.5.2-1
204- new upstream version, sched_* calls (#116990), show core flag (#112117)
205
206* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
207- rebuilt
208
Roland McGrath00eb84e2003-11-14 02:57:22 +0000209* Thu Nov 13 2003 Roland McGrath <roland@redhat.com> 4.5.1-1
210- new upstream version, more fixes (#108012, #105366, #105359, #105358)
211
212* Tue Sep 30 2003 Roland McGrath <roland@redhat.com> 4.5-3
213- revert bogus s390 fix
214
215* Thu Sep 25 2003 Roland McGrath <roland@redhat.com> 4.5-1.2.1AS
216- rebuilt for 2.1AS erratum
217
218* Wed Sep 24 2003 Roland McGrath <roland@redhat.com> 4.5-2
219- rebuilt
220
Roland McGrath739868f2003-09-24 23:05:09 +0000221* Wed Sep 24 2003 Roland McGrath <roland@redhat.com> 4.5-1
222- new upstream version, more fixes (#101499, #104365)
223
Roland McGratha943d002003-09-24 22:22:42 +0000224* Thu Jul 17 2003 Roland McGrath <roland@redhat.com> 4.4.99-2
225- rebuilt
226
Roland McGrathcb612142003-07-17 09:23:56 +0000227* Thu Jul 17 2003 Roland McGrath <roland@redhat.com> 4.4.99-1
228- new upstream version, groks more new system calls, PF_INET6 sockets
229
Roland McGrathf02c3c32003-06-11 05:47:07 +0000230* Mon Jun 10 2003 Roland McGrath <roland@redhat.com> 4.4.98-1
Roland McGrath64ffba52003-06-02 19:37:48 +0000231- new upstream version, more fixes (#90754, #91085)
232
Roland McGrathacd3cd72003-06-11 05:37:56 +0000233* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
234- rebuilt
235
Roland McGrath1b86e2d2003-03-31 01:21:36 +0000236* Sun Mar 30 2003 Roland McGrath <roland@redhat.com> 4.4.96-1
237- new upstream version, handles yet more 2.5 syscalls, x86_64 & ia64 fixes
238
Roland McGrath215da2a2003-03-31 01:46:47 +0000239* Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com> 4.4.95-2
240- rebuilt
241
Roland McGrath1893d052003-02-24 10:53:44 +0000242* Mon Feb 24 2003 Roland McGrath <roland@redhat.com> 4.4.95-1
243- new upstream version, fixed getresuid/getresgid (#84959)
244
Roland McGrath6c2fe9d2003-02-20 03:26:47 +0000245* Wed Feb 19 2003 Roland McGrath <roland@redhat.com> 4.4.94-1
246- new upstream version, new option -E to set environment variables (#82392)
247
248* Wed Jan 22 2003 Tim Powers <timp@redhat.com> 4.4.93-2
249- rebuilt
250
Roland McGrathee061722003-01-22 02:27:51 +0000251* Tue Jan 21 2003 Roland McGrath <roland@redhat.com> 4.4.93-1
252- new upstream version, fixes ppc and s390 bugs, adds missing ptrace requests
253
Roland McGrath1d847cf2003-01-10 21:43:24 +0000254* Fri Jan 10 2003 Roland McGrath <roland@redhat.com> 4.4.91-1
255- new upstream version, fixes -f on x86-64
256
Roland McGrath037124f2003-01-10 10:44:57 +0000257* Fri Jan 10 2003 Roland McGrath <roland@redhat.com> 4.4.90-1
258- new upstream version, fixes all known bugs modulo ia64 and s390 issues
259
260* Fri Jan 03 2003 Florian La Roche <Florian.LaRoche@redhat.de> 4.4-11
261- add further s390 patch from IBM
262
263* Wed Nov 27 2002 Tim Powers <timp@redhat.com> 4.4-10
264- remove unpackaged files from the buildroot
265
266* Mon Oct 07 2002 Phil Knirsch <pknirsch@redhat.com> 4.4-9.1
267- Added latest s390(x) patch.
268
269* Fri Sep 06 2002 Karsten Hopp <karsten@redhat.de> 4.4-9
270- preliminary x86_64 support with an ugly patch to help
271 debugging. Needs cleanup!
272
273* Mon Sep 2 2002 Jakub Jelinek <jakub@redhat.com> 4.4-8
274- newer version of the clone fixing patch (Roland McGrath)
275- aio syscalls for i386/ia64/ppc (Ben LaHaise)
276
277* Wed Aug 28 2002 Jakub Jelinek <jakub@redhat.com> 4.4-7
278- fix strace -f (Roland McGrath, #68994)
279- handle ?et_thread_area, SA_RESTORER (Ulrich Drepper)
280
281* Fri Jun 21 2002 Jakub Jelinek <jakub@redhat.com> 4.4-6
282- handle futexes, *xattr, sendfile64, etc. (Ulrich Drepper)
283- handle modify_ldt (#66894)
284
285* Thu May 23 2002 Tim Powers <timp@redhat.com>
286- automated rebuild
287
288* Tue Apr 16 2002 Jakub Jelinek <jakub@redhat.com> 4.4-4
289- fix for the last patch by Jeff Law (#62591)
290
291* Mon Mar 4 2002 Preston Brown <pbrown@redhat.com> 4.4-3
292- integrate patch from Jeff Law to eliminate hang tracing threads
293
294* Sat Feb 23 2002 Florian La Roche <Florian.LaRoche@redhat.de>
295- minor update from debian tar-ball
296
297* Wed Jan 02 2002 Florian La Roche <Florian.LaRoche@redhat.de>
298- update to 4.4
299
300* Sun Jul 22 2001 Florian La Roche <Florian.LaRoche@redhat.de>
301- disable s390 patches, they are already included
302
303* Wed Jul 18 2001 Preston Brown <pbrown@redhat.com> 4.3-1
304- new upstream version. Seems to have integrated most new syscalls
305- tracing threaded programs is now functional.
306
307* Mon Jun 11 2001 Than Ngo <than@redhat.com>
308- port s390 patches from IBM
309
310* Wed May 16 2001 Nalin Dahyabhai <nalin@redhat.com>
311- modify new syscall patch to allocate enough heap space in setgroups32()
312
313* Wed Feb 14 2001 Jakub Jelinek <jakub@redhat.com>
314- #include <time.h> in addition to <sys/time.h>
315
316* Fri Jan 26 2001 Karsten Hopp <karsten@redhat.com>
317- clean up conflicting patches. This happened only
318 when building on S390
319
320* Fri Jan 19 2001 Bill Nottingham <notting@redhat.com>
321- update to CVS, reintegrate ia64 support
322
323* Sat Dec 8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
324- Get S/390 support into the normal package
325
326* Sat Nov 18 2000 Florian La Roche <Florian.LaRoche@redhat.de>
327- added S/390 patch from IBM, adapting it to not conflict with
328 IA64 patch
329
330* Sat Aug 19 2000 Jakub Jelinek <jakub@redhat.com>
331- doh, actually apply the 2.4 syscalls patch
332- make it compile with 2.4.0-test7-pre4+ headers, add
333 getdents64 and fcntl64
334
335* Thu Aug 3 2000 Jakub Jelinek <jakub@redhat.com>
336- add a bunch of new 2.4 syscalls (#14036)
337
338* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
339- automatic rebuild
340- excludearch ia64
341
342* Fri Jun 2 2000 Matt Wilson <msw@redhat.com>
343- use buildinstall for FHS
344
345* Wed May 24 2000 Jakub Jelinek <jakub@redhat.com>
346- make things compile on sparc
347- fix sigreturn on sparc
348
349* Fri Mar 31 2000 Bill Nottingham <notting@redhat.com>
350- fix stat64 misdef (#10485)
351
352* Tue Mar 21 2000 Michael K. Johnson <johnsonm@redhat.com>
353- added ia64 patch
354
355* Thu Feb 03 2000 Cristian Gafton <gafton@redhat.com>
356- man pages are compressed
357- version 4.2 (why are we keeping all these patches around?)
358
359* Sat Nov 27 1999 Jeff Johnson <jbj@redhat.com>
360- update to 4.1 (with sparc socketcall patch).
361
362* Fri Nov 12 1999 Jakub Jelinek <jakub@redhat.com>
363- fix socketcall on sparc.
364
365* Thu Sep 02 1999 Cristian Gafton <gafton@redhat.com>
366- fix KERN_SECURELVL compile problem
367
368* Tue Aug 31 1999 Cristian Gafton <gafton@redhat.com>
369- added alpha patch from HJLu to fix the osf_sigprocmask interpretation
370
371* Sat Jun 12 1999 Jeff Johnson <jbj@redhat.com>
372- update to 3.99.1.
373
374* Wed Jun 2 1999 Jeff Johnson <jbj@redhat.com>
375- add (the other :-) jj's sparc patch.
376
377* Wed May 26 1999 Jeff Johnson <jbj@redhat.com>
378- upgrade to 3.99 in order to
379- add new 2.2.x open flags (#2955).
380- add new 2.2.x syscalls (#2866).
381- strace 3.1 patches carried along for now.
382
383* Sun May 16 1999 Jeff Johnson <jbj@redhat.com>
Roland McGrath00a18752007-02-18 22:55:21 +0000384- don't rely on (broken!) rpm %%patch (#2735)
Roland McGrath037124f2003-01-10 10:44:57 +0000385
386* Tue Apr 06 1999 Preston Brown <pbrown@redhat.com>
387- strip binary
388
389* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
390- auto rebuild in the new build environment (release 16)
391
392* Tue Feb 9 1999 Jeff Johnson <jbj@redhat.com>
393- vfork est arrive!
394
395* Tue Feb 9 1999 Christopher Blizzard <blizzard@redhat.com>
396- Add patch to follow clone() syscalls, too.
397
398* Sun Jan 17 1999 Jeff Johnson <jbj@redhat.com>
399- patch to build alpha/sparc with glibc 2.1.
400
401* Thu Dec 03 1998 Cristian Gafton <gafton@redhat.com>
402- patch to build on ARM
403
404* Wed Sep 30 1998 Jeff Johnson <jbj@redhat.com>
405- fix typo (printf, not tprintf).
406
407* Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
408- fix compile problem on sparc.
409
410* Tue Aug 18 1998 Cristian Gafton <gafton@redhat.com>
411- buildroot
412
413* Mon Jul 20 1998 Cristian Gafton <gafton@redhat.com>
414- added the umoven patch from James Youngman <jay@gnu.org>
415- fixed build problems on newer glibc releases
416
417* Mon Jun 08 1998 Prospector System <bugs@redhat.com>
418- translations modified for de, fr, tr