blob: 004f307970b0a250d50e2d318fe6db10a4ac1ac8 [file] [log] [blame]
Roland McGrath00a18752007-02-18 22:55:21 +00001Summary: Tracks and displays system calls associated with a running process
Roland McGrath037124f2003-01-10 10:44:57 +00002Name: strace
Roland McGrath47d32232007-08-03 10:28:55 +00003Version: 4.5.16
Roland McGrathcdec4692007-01-11 22:22:47 +00004Release: 1%{?dist}
Roland McGrath037124f2003-01-10 10:44:57 +00005License: BSD
6Group: Development/Debuggers
7URL: http://sourceforge.net/projects/strace/
Roland McGrath4aa15562006-04-25 07:22:02 +00008Source0: http://dl.sourceforge.net/strace/%{name}-%{version}.tar.bz2
Roland McGrath00a18752007-02-18 22:55:21 +00009BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Roland McGrath037124f2003-01-10 10:44:57 +000010
Roland McGrath4c99f562007-11-19 22:14:56 +000011BuildRequires: libaio-devel, libacl-devel
12
Roland McGratha943d002003-09-24 22:22:42 +000013%define strace64_arches ppc64
14
Roland McGrath037124f2003-01-10 10:44:57 +000015%description
16The strace program intercepts and records the system calls called and
17received by a running process. Strace can print a record of each
18system call, its arguments and its return value. Strace is useful for
19diagnosing problems and debugging, as well as for instructional
20purposes.
21
22Install strace if you need a tool to track the system calls made and
23received by a process.
24
Roland McGratha943d002003-09-24 22:22:42 +000025%ifarch %{strace64_arches}
26%package -n strace64
27Summary: Tracks and displays system calls associated with a running process.
28Group: Development/Debuggers
29
30%description -n strace64
31The strace program intercepts and records the system calls called and
32received by a running process. Strace can print a record of each
33system call, its arguments and its return value. Strace is useful for
34diagnosing problems and debugging, as well as for instructional
35purposes.
36
37Install strace if you need a tool to track the system calls made and
38received by a process.
39
40This package provides the `strace64' program to trace 64-bit processes.
41The `strace' program in the `strace' package is for 32-bit processes.
42%endif
43
Roland McGrath037124f2003-01-10 10:44:57 +000044%prep
45%setup -q
46
47%build
48%configure
Roland McGrathcddc21f2007-02-18 22:56:37 +000049make %{?_smp_mflags}
Roland McGrath037124f2003-01-10 10:44:57 +000050
51%install
52rm -rf %{buildroot}
Roland McGrath00a18752007-02-18 22:55:21 +000053make DESTDIR=%{buildroot} install
Roland McGrath037124f2003-01-10 10:44:57 +000054
55# remove unpackaged files from the buildroot
56rm -f %{buildroot}%{_bindir}/strace-graph
57
Roland McGratha943d002003-09-24 22:22:42 +000058%ifarch %{strace64_arches}
59ln %{buildroot}%{_bindir}/strace %{buildroot}%{_bindir}/strace64
60%endif
61
Roland McGrath037124f2003-01-10 10:44:57 +000062%clean
63rm -rf %{buildroot}
64
65%files
66%defattr(-,root,root)
Roland McGrath00a18752007-02-18 22:55:21 +000067%doc CREDITS ChangeLog COPYRIGHT NEWS PORTING README
Roland McGrath037124f2003-01-10 10:44:57 +000068%{_bindir}/strace
69%{_mandir}/man1/*
70
Roland McGratha943d002003-09-24 22:22:42 +000071%ifarch %{strace64_arches}
72%files -n strace64
73%defattr(-,root,root)
74%{_bindir}/strace64
75%endif
76
77
Roland McGrath037124f2003-01-10 10:44:57 +000078%changelog
Roland McGrath47d32232007-08-03 10:28:55 +000079* Fri Aug 3 2007 Roland McGrath <roland@redhat.com> - 4.5.16-1
80- fix multithread issues (#240962, #240961, #247907)
81- fix spurious SIGSTOP on early interrupt (#240986)
82- fix utime for biarch (#247185)
83- fix -u error message (#247170)
84- better futex syscall printing (##241467)
85- fix argv/envp printing with small -s settings, and for biarch
86- new syscalls: getcpu, eventfd, timerfd, signalfd, epoll_pwait,
87 move_pages, utimensat
88
Roland McGrath0a45fae2007-01-16 23:25:34 +000089* Tue Jan 16 2007 Roland McGrath <roland@redhat.com> - 4.5.15-1
Roland McGrathcdec4692007-01-11 22:22:47 +000090- biarch fixes (#179740, #192193, #171626, #173050, #218433, #218043)
91- fix -ff -o behavior (#204950, #218435, #193808, #219423)
92- better quotactl printing (#118696)
93- *at, inotify*, pselect6, ppoll and unshare syscalls (#178633, #191275)
94- glibc-2.5 build fixes (#209856)
95- memory corruption fixes (#200621
96- fix race in child setup under -f (#180293)
97- show ipc key values in hex (#198179, #192182)
98- disallow -c with -ff (#187847)
99- Resolves: RHBZ #179740, RHBZ #192193, RHBZ #204950, RHBZ #218435
100- Resolves: RHBZ #193808, RHBZ #219423, RHBZ #171626, RHBZ #173050
101- Resolves: RHBZ #218433, RHBZ #218043, RHBZ #118696, RHBZ #178633
102- Resolves: RHBZ #191275, RHBZ #209856, RHBZ #200621, RHBZ #180293
103- Resolves: RHBZ #198179, RHBZ #198182, RHBZ #187847
104
105* Mon Nov 20 2006 Jakub Jelinek <jakub@redhat.com> - 4.5.14-4
106- Fix ia64 syscall decoding (#206768)
107- Fix build with glibc-2.4.90-33 and up on all arches but ia64
108- Fix build against 2.6.18+ headers
109
110* Tue Aug 22 2006 Roland McGrath <roland@redhat.com> - 4.5.14-3
111- Fix bogus decoding of syscalls >= 300 (#201462, #202620).
112
113* Fri Jul 14 2006 Jesse Keating <jkeating@redhat.com> - 4.5.14-2
114- rebuild
115
116* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 4.5.14-1.2
117- bump again for long double bug on ppc{,64}
118
119* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 4.5.14-1.1
120- rebuilt for new gcc4.1 snapshot and glibc changes
121
Roland McGrathf4d9b492006-01-17 06:22:57 +0000122* Mon Jan 16 2006 Roland McGrath <roland@redhat.com> - 4.5.14-1
123- Fix biarch decoding of socket syscalls (#174354).
124- Fix biarch -e support (#173986).
125- Accept numeric syscalls in -e (#174798).
126- Fix ipc syscall decoding (#164755).
127- Improve msgrcv printing (#164757).
128- Man page updates (#165375).
129- Improve mount syscall printing (#165377).
130- Correct printing of restarting syscalls (#165469).
131
Roland McGrathcab43802005-08-03 11:42:35 +0000132* Wed Aug 3 2005 Roland McGrath <roland@redhat.com> - 4.5.13-1
133- Fix setsockopt decoding on 64-bit (#162449).
134- Fix typos in socket option name strings (#161578).
135- Display more IPV6 socket options by name (#162450).
136- Don't display inappropriate syscalls for -e trace=file (#159340).
137- New selector type -e trace=desc for file-descriptor using calls (#159400).
138- Fix 32-bit old_mmap syscall decoding on x86-64 (#162467, #164215).
139- Fix errors detaching from multithreaded process on interrupt (#161919).
140- Note 4.5.12 fix for crash handling bad signal numbers (#162739).
141
Roland McGrath182cbf42005-06-10 03:56:16 +0000142* Wed Jun 8 2005 Roland McGrath <roland@redhat.com> - 4.5.12-1
143- Fix known syscall recognition for IA32 processes on x86-64 (#158934).
144- Fix bad output for ptrace on x86-64 (#159787).
145- Fix potential buffer overruns (#151570, #159196).
146- Make some diagnostics more consistent (#159308).
147- Update PowerPC system calls.
148- Better printing for Linux aio system calls.
149- Don't truncate statfs64 fields to 32 bits in output (#158243).
150- Cosmetic code cleanups (#159688).
151
Roland McGrath7147a3d2005-03-22 23:12:39 +0000152* Tue Mar 22 2005 Roland McGrath <roland@redhat.com> - 4.5.11-1
153- Build tweaks.
154- Note 4.5.10 select fix (#151570).
155
Roland McGrathd8184032005-03-15 02:40:12 +0000156* Mon Mar 14 2005 Roland McGrath <roland@redhat.com> - 4.5.10-1
157- Fix select handling on nonstandard fd_set sizes.
158- Don't print errors for null file name pointers.
159- Fix initial execve output with -i (#143365).
160
Roland McGrath6df9d642005-02-04 10:13:15 +0000161* Fri Feb 4 2005 Roland McGrath <roland@redhat.com> - 4.5.9-2
Roland McGrathd63311a2005-02-04 09:29:04 +0000162- update ia64 syscall list (#146245)
163- fix x86_64 syscall argument extraction for 32-bit processes (#146093)
164- fix -e signal=NAME parsing (#143362)
165- fix x86_64 exit_group syscall handling
166- improve socket ioctl printing (#138223)
167- code cleanups (#143369, #143370)
168- improve mount flags printing (#141932)
169- support symbolic printing of x86_64 arch_prctl parameters (#142667)
170- fix potential crash in getxattr printing
171
Roland McGrathf041d472004-10-20 02:17:52 +0000172* Tue Oct 19 2004 Roland McGrath <roland@redhat.com> - 4.5.8-1
173- fix multithreaded exit handling (#132150, #135254)
174- fix ioctl name matching (#129808)
175- print RTC_* ioctl structure contents (#58606)
176- grok epoll_* syscalls (#134463)
177- grok new RLIMIT_* values (#133594)
178- print struct cmsghdr contents for sendmsg (#131689)
179- fix clock_* and timer_* argument output (#131420)
180
Roland McGrath61d64872004-08-31 08:58:10 +0000181* Tue Aug 31 2004 Roland McGrath <roland@redhat.com> - 4.5.7-2
Roland McGrathb93f9182004-08-31 08:17:20 +0000182- new upstream version, misc fixes and updates (#128091, #129166, #128391, #129378, #130965, #131177)
183
Roland McGrath785a0262004-07-12 07:55:48 +0000184* Mon Jul 12 2004 Roland McGrath <roland@redhat.com> 4.5.6-1
185- new upstream version, updates ioctl lists (#127398), fixes quotactl (#127393), more ioctl decoding (#126917)
186
Roland McGrathb7e2ca12004-06-28 05:24:29 +0000187* Sun Jun 27 2004 Roland McGrath <roland@redhat.com> 4.5.5-1
188- new upstream version, fixes x86-64 biarch support (#126547)
189
190* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com> 4.5.4-2
191- rebuilt
192
193* Thu Jun 3 2004 Roland McGrath <roland@redhat.com> 4.5.4-0.FC1
194- rebuilt for FC1 update
195
Roland McGrathed8e77e2004-06-04 02:35:58 +0000196* Thu Jun 3 2004 Roland McGrath <roland@redhat.com> 4.5.4-1
197- new upstream version, more ioctls (#122257), minor fixes
198
Roland McGratha8c555f2004-04-16 22:28:41 +0000199* Fri Apr 16 2004 Roland McGrath <roland@redhat.com> 4.5.3-1
200- new upstream version, mq_* calls (#120701), -p vs NPTL (#120462), more fixes (#118694, #120541, #118685)
201
202* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com> 4.5.2-1.1
203- rebuilt
204
Roland McGrathb66e9362004-03-02 06:38:35 +0000205* Mon Mar 1 2004 Roland McGrath <roland@redhat.com> 4.5.2-1
206- new upstream version, sched_* calls (#116990), show core flag (#112117)
207
208* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
209- rebuilt
210
Roland McGrath00eb84e2003-11-14 02:57:22 +0000211* Thu Nov 13 2003 Roland McGrath <roland@redhat.com> 4.5.1-1
212- new upstream version, more fixes (#108012, #105366, #105359, #105358)
213
214* Tue Sep 30 2003 Roland McGrath <roland@redhat.com> 4.5-3
215- revert bogus s390 fix
216
217* Thu Sep 25 2003 Roland McGrath <roland@redhat.com> 4.5-1.2.1AS
218- rebuilt for 2.1AS erratum
219
220* Wed Sep 24 2003 Roland McGrath <roland@redhat.com> 4.5-2
221- rebuilt
222
Roland McGrath739868f2003-09-24 23:05:09 +0000223* Wed Sep 24 2003 Roland McGrath <roland@redhat.com> 4.5-1
224- new upstream version, more fixes (#101499, #104365)
225
Roland McGratha943d002003-09-24 22:22:42 +0000226* Thu Jul 17 2003 Roland McGrath <roland@redhat.com> 4.4.99-2
227- rebuilt
228
Roland McGrathcb612142003-07-17 09:23:56 +0000229* Thu Jul 17 2003 Roland McGrath <roland@redhat.com> 4.4.99-1
230- new upstream version, groks more new system calls, PF_INET6 sockets
231
Roland McGrathf02c3c32003-06-11 05:47:07 +0000232* Mon Jun 10 2003 Roland McGrath <roland@redhat.com> 4.4.98-1
Roland McGrath64ffba52003-06-02 19:37:48 +0000233- new upstream version, more fixes (#90754, #91085)
234
Roland McGrathacd3cd72003-06-11 05:37:56 +0000235* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
236- rebuilt
237
Roland McGrath1b86e2d2003-03-31 01:21:36 +0000238* Sun Mar 30 2003 Roland McGrath <roland@redhat.com> 4.4.96-1
239- new upstream version, handles yet more 2.5 syscalls, x86_64 & ia64 fixes
240
Roland McGrath215da2a2003-03-31 01:46:47 +0000241* Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com> 4.4.95-2
242- rebuilt
243
Roland McGrath1893d052003-02-24 10:53:44 +0000244* Mon Feb 24 2003 Roland McGrath <roland@redhat.com> 4.4.95-1
245- new upstream version, fixed getresuid/getresgid (#84959)
246
Roland McGrath6c2fe9d2003-02-20 03:26:47 +0000247* Wed Feb 19 2003 Roland McGrath <roland@redhat.com> 4.4.94-1
248- new upstream version, new option -E to set environment variables (#82392)
249
250* Wed Jan 22 2003 Tim Powers <timp@redhat.com> 4.4.93-2
251- rebuilt
252
Roland McGrathee061722003-01-22 02:27:51 +0000253* Tue Jan 21 2003 Roland McGrath <roland@redhat.com> 4.4.93-1
254- new upstream version, fixes ppc and s390 bugs, adds missing ptrace requests
255
Roland McGrath1d847cf2003-01-10 21:43:24 +0000256* Fri Jan 10 2003 Roland McGrath <roland@redhat.com> 4.4.91-1
257- new upstream version, fixes -f on x86-64
258
Roland McGrath037124f2003-01-10 10:44:57 +0000259* Fri Jan 10 2003 Roland McGrath <roland@redhat.com> 4.4.90-1
260- new upstream version, fixes all known bugs modulo ia64 and s390 issues
261
262* Fri Jan 03 2003 Florian La Roche <Florian.LaRoche@redhat.de> 4.4-11
263- add further s390 patch from IBM
264
265* Wed Nov 27 2002 Tim Powers <timp@redhat.com> 4.4-10
266- remove unpackaged files from the buildroot
267
268* Mon Oct 07 2002 Phil Knirsch <pknirsch@redhat.com> 4.4-9.1
269- Added latest s390(x) patch.
270
271* Fri Sep 06 2002 Karsten Hopp <karsten@redhat.de> 4.4-9
272- preliminary x86_64 support with an ugly patch to help
273 debugging. Needs cleanup!
274
275* Mon Sep 2 2002 Jakub Jelinek <jakub@redhat.com> 4.4-8
276- newer version of the clone fixing patch (Roland McGrath)
277- aio syscalls for i386/ia64/ppc (Ben LaHaise)
278
279* Wed Aug 28 2002 Jakub Jelinek <jakub@redhat.com> 4.4-7
280- fix strace -f (Roland McGrath, #68994)
281- handle ?et_thread_area, SA_RESTORER (Ulrich Drepper)
282
283* Fri Jun 21 2002 Jakub Jelinek <jakub@redhat.com> 4.4-6
284- handle futexes, *xattr, sendfile64, etc. (Ulrich Drepper)
285- handle modify_ldt (#66894)
286
287* Thu May 23 2002 Tim Powers <timp@redhat.com>
288- automated rebuild
289
290* Tue Apr 16 2002 Jakub Jelinek <jakub@redhat.com> 4.4-4
291- fix for the last patch by Jeff Law (#62591)
292
293* Mon Mar 4 2002 Preston Brown <pbrown@redhat.com> 4.4-3
294- integrate patch from Jeff Law to eliminate hang tracing threads
295
296* Sat Feb 23 2002 Florian La Roche <Florian.LaRoche@redhat.de>
297- minor update from debian tar-ball
298
299* Wed Jan 02 2002 Florian La Roche <Florian.LaRoche@redhat.de>
300- update to 4.4
301
302* Sun Jul 22 2001 Florian La Roche <Florian.LaRoche@redhat.de>
303- disable s390 patches, they are already included
304
305* Wed Jul 18 2001 Preston Brown <pbrown@redhat.com> 4.3-1
306- new upstream version. Seems to have integrated most new syscalls
307- tracing threaded programs is now functional.
308
309* Mon Jun 11 2001 Than Ngo <than@redhat.com>
310- port s390 patches from IBM
311
312* Wed May 16 2001 Nalin Dahyabhai <nalin@redhat.com>
313- modify new syscall patch to allocate enough heap space in setgroups32()
314
315* Wed Feb 14 2001 Jakub Jelinek <jakub@redhat.com>
316- #include <time.h> in addition to <sys/time.h>
317
318* Fri Jan 26 2001 Karsten Hopp <karsten@redhat.com>
319- clean up conflicting patches. This happened only
320 when building on S390
321
322* Fri Jan 19 2001 Bill Nottingham <notting@redhat.com>
323- update to CVS, reintegrate ia64 support
324
325* Sat Dec 8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
326- Get S/390 support into the normal package
327
328* Sat Nov 18 2000 Florian La Roche <Florian.LaRoche@redhat.de>
329- added S/390 patch from IBM, adapting it to not conflict with
330 IA64 patch
331
332* Sat Aug 19 2000 Jakub Jelinek <jakub@redhat.com>
333- doh, actually apply the 2.4 syscalls patch
334- make it compile with 2.4.0-test7-pre4+ headers, add
335 getdents64 and fcntl64
336
337* Thu Aug 3 2000 Jakub Jelinek <jakub@redhat.com>
338- add a bunch of new 2.4 syscalls (#14036)
339
340* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
341- automatic rebuild
342- excludearch ia64
343
344* Fri Jun 2 2000 Matt Wilson <msw@redhat.com>
345- use buildinstall for FHS
346
347* Wed May 24 2000 Jakub Jelinek <jakub@redhat.com>
348- make things compile on sparc
349- fix sigreturn on sparc
350
351* Fri Mar 31 2000 Bill Nottingham <notting@redhat.com>
352- fix stat64 misdef (#10485)
353
354* Tue Mar 21 2000 Michael K. Johnson <johnsonm@redhat.com>
355- added ia64 patch
356
357* Thu Feb 03 2000 Cristian Gafton <gafton@redhat.com>
358- man pages are compressed
359- version 4.2 (why are we keeping all these patches around?)
360
361* Sat Nov 27 1999 Jeff Johnson <jbj@redhat.com>
362- update to 4.1 (with sparc socketcall patch).
363
364* Fri Nov 12 1999 Jakub Jelinek <jakub@redhat.com>
365- fix socketcall on sparc.
366
367* Thu Sep 02 1999 Cristian Gafton <gafton@redhat.com>
368- fix KERN_SECURELVL compile problem
369
370* Tue Aug 31 1999 Cristian Gafton <gafton@redhat.com>
371- added alpha patch from HJLu to fix the osf_sigprocmask interpretation
372
373* Sat Jun 12 1999 Jeff Johnson <jbj@redhat.com>
374- update to 3.99.1.
375
376* Wed Jun 2 1999 Jeff Johnson <jbj@redhat.com>
377- add (the other :-) jj's sparc patch.
378
379* Wed May 26 1999 Jeff Johnson <jbj@redhat.com>
380- upgrade to 3.99 in order to
381- add new 2.2.x open flags (#2955).
382- add new 2.2.x syscalls (#2866).
383- strace 3.1 patches carried along for now.
384
385* Sun May 16 1999 Jeff Johnson <jbj@redhat.com>
Roland McGrath00a18752007-02-18 22:55:21 +0000386- don't rely on (broken!) rpm %%patch (#2735)
Roland McGrath037124f2003-01-10 10:44:57 +0000387
388* Tue Apr 06 1999 Preston Brown <pbrown@redhat.com>
389- strip binary
390
391* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
392- auto rebuild in the new build environment (release 16)
393
394* Tue Feb 9 1999 Jeff Johnson <jbj@redhat.com>
395- vfork est arrive!
396
397* Tue Feb 9 1999 Christopher Blizzard <blizzard@redhat.com>
398- Add patch to follow clone() syscalls, too.
399
400* Sun Jan 17 1999 Jeff Johnson <jbj@redhat.com>
401- patch to build alpha/sparc with glibc 2.1.
402
403* Thu Dec 03 1998 Cristian Gafton <gafton@redhat.com>
404- patch to build on ARM
405
406* Wed Sep 30 1998 Jeff Johnson <jbj@redhat.com>
407- fix typo (printf, not tprintf).
408
409* Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
410- fix compile problem on sparc.
411
412* Tue Aug 18 1998 Cristian Gafton <gafton@redhat.com>
413- buildroot
414
415* Mon Jul 20 1998 Cristian Gafton <gafton@redhat.com>
416- added the umoven patch from James Youngman <jay@gnu.org>
417- fixed build problems on newer glibc releases
418
419* Mon Jun 08 1998 Prospector System <bugs@redhat.com>
420- translations modified for de, fr, tr