blob: 3dd8f0f43654ead47916066853c7e819e2a85243 [file] [log] [blame]
Roland McGrath00a18752007-02-18 22:55:21 +00001Summary: Tracks and displays system calls associated with a running process
Roland McGrath037124f2003-01-10 10:44:57 +00002Name: strace
Roland McGrath09db7052008-08-28 22:00:46 +00003Version: 4.5.18
Roland McGrathcdec4692007-01-11 22:22:47 +00004Release: 1%{?dist}
Roland McGrath037124f2003-01-10 10:44:57 +00005License: BSD
6Group: Development/Debuggers
7URL: http://sourceforge.net/projects/strace/
Roland McGrath4aa15562006-04-25 07:22:02 +00008Source0: http://dl.sourceforge.net/strace/%{name}-%{version}.tar.bz2
Roland McGrath00a18752007-02-18 22:55:21 +00009BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Roland McGrath037124f2003-01-10 10:44:57 +000010
Roland McGrath4c99f562007-11-19 22:14:56 +000011BuildRequires: libaio-devel, libacl-devel
12
Roland McGrath7c2ec572008-03-26 19:15:41 +000013%define strace64_arches ppc64 sparc64
Roland McGratha943d002003-09-24 22:22:42 +000014
Roland McGrath037124f2003-01-10 10:44:57 +000015%description
16The strace program intercepts and records the system calls called and
17received by a running process. Strace can print a record of each
18system call, its arguments and its return value. Strace is useful for
19diagnosing problems and debugging, as well as for instructional
20purposes.
21
22Install strace if you need a tool to track the system calls made and
23received by a process.
24
Roland McGratha943d002003-09-24 22:22:42 +000025%ifarch %{strace64_arches}
26%package -n strace64
27Summary: Tracks and displays system calls associated with a running process.
28Group: Development/Debuggers
29
30%description -n strace64
31The strace program intercepts and records the system calls called and
32received by a running process. Strace can print a record of each
33system call, its arguments and its return value. Strace is useful for
34diagnosing problems and debugging, as well as for instructional
35purposes.
36
37Install strace if you need a tool to track the system calls made and
38received by a process.
39
40This package provides the `strace64' program to trace 64-bit processes.
41The `strace' program in the `strace' package is for 32-bit processes.
42%endif
43
Roland McGrath037124f2003-01-10 10:44:57 +000044%prep
45%setup -q
46
47%build
48%configure
Roland McGrathcddc21f2007-02-18 22:56:37 +000049make %{?_smp_mflags}
Roland McGrath037124f2003-01-10 10:44:57 +000050
51%install
52rm -rf %{buildroot}
Roland McGrath00a18752007-02-18 22:55:21 +000053make DESTDIR=%{buildroot} install
Roland McGrath037124f2003-01-10 10:44:57 +000054
55# remove unpackaged files from the buildroot
56rm -f %{buildroot}%{_bindir}/strace-graph
57
Roland McGrath3f0dbe22008-08-28 23:26:21 +000058%define copy64 ln
59%if 0%{?rhel}
60%if 0%{?rhel} < 6
61%endif
62%define copy64 cp -p
63%endif
64
Roland McGratha943d002003-09-24 22:22:42 +000065%ifarch %{strace64_arches}
Roland McGrath3f0dbe22008-08-28 23:26:21 +000066%{copy64} %{buildroot}%{_bindir}/strace %{buildroot}%{_bindir}/strace64
Roland McGratha943d002003-09-24 22:22:42 +000067%endif
68
Roland McGrath037124f2003-01-10 10:44:57 +000069%clean
70rm -rf %{buildroot}
71
72%files
73%defattr(-,root,root)
Roland McGrath00a18752007-02-18 22:55:21 +000074%doc CREDITS ChangeLog COPYRIGHT NEWS PORTING README
Roland McGrath037124f2003-01-10 10:44:57 +000075%{_bindir}/strace
76%{_mandir}/man1/*
77
Roland McGratha943d002003-09-24 22:22:42 +000078%ifarch %{strace64_arches}
79%files -n strace64
80%defattr(-,root,root)
81%{_bindir}/strace64
82%endif
83
84
Roland McGrath037124f2003-01-10 10:44:57 +000085%changelog
Roland McGrath09db7052008-08-28 22:00:46 +000086* Thu Aug 28 2008 Roland McGrath <roland@redhat.com> - 4.5.18-1
87- build fix for newer kernel headers (#457291)
88- fix CLONE_VFORK handling (#455078)
89- Support new Linux/PPC system call subpage_prot and PROT_SAO flag.
90- In sigaction system call, display sa_flags value along with SIG_DFL/SIG_IGN.
91
Roland McGrath6a1311d2008-07-22 00:43:09 +000092* Mon Jul 21 2008 Roland McGrath <roland@redhat.com> - 4.5.17-1
Roland McGrath55dd2782008-07-18 02:21:11 +000093- handle O_CLOEXEC, MSG_CMSG_CLOEXEC (#365781)
94- fix biarch stat64 decoding (#222275)
95- fix spurious "..." in printing of environment strings (#358241)
96- improve prctl decoding (#364401)
97- fix hang wait on exited child with exited child (#354261)
98- fix biarch fork/vfork (-f) tracing (#447475)
99- fix biarch printing of negative argument kill (#430585)
100- fix biarch decoding of error return values (#447587)
101- fix -f tracing of CLONE_VFORK (#455078)
102- fix ia64 register clobberation in -f tracing (#453438)
103- print SO_NODEFER, SA_RESETHAND instead of SA_NOMASK, SA_ONESHOT (#455821)
104- fix futex argument decoding (#448628, #448629)
105
Roland McGrath47d32232007-08-03 10:28:55 +0000106* Fri Aug 3 2007 Roland McGrath <roland@redhat.com> - 4.5.16-1
107- fix multithread issues (#240962, #240961, #247907)
108- fix spurious SIGSTOP on early interrupt (#240986)
109- fix utime for biarch (#247185)
110- fix -u error message (#247170)
111- better futex syscall printing (##241467)
112- fix argv/envp printing with small -s settings, and for biarch
113- new syscalls: getcpu, eventfd, timerfd, signalfd, epoll_pwait,
114 move_pages, utimensat
115
Roland McGrath0a45fae2007-01-16 23:25:34 +0000116* Tue Jan 16 2007 Roland McGrath <roland@redhat.com> - 4.5.15-1
Roland McGrathcdec4692007-01-11 22:22:47 +0000117- biarch fixes (#179740, #192193, #171626, #173050, #218433, #218043)
118- fix -ff -o behavior (#204950, #218435, #193808, #219423)
119- better quotactl printing (#118696)
120- *at, inotify*, pselect6, ppoll and unshare syscalls (#178633, #191275)
121- glibc-2.5 build fixes (#209856)
122- memory corruption fixes (#200621
123- fix race in child setup under -f (#180293)
124- show ipc key values in hex (#198179, #192182)
125- disallow -c with -ff (#187847)
126- Resolves: RHBZ #179740, RHBZ #192193, RHBZ #204950, RHBZ #218435
127- Resolves: RHBZ #193808, RHBZ #219423, RHBZ #171626, RHBZ #173050
128- Resolves: RHBZ #218433, RHBZ #218043, RHBZ #118696, RHBZ #178633
129- Resolves: RHBZ #191275, RHBZ #209856, RHBZ #200621, RHBZ #180293
130- Resolves: RHBZ #198179, RHBZ #198182, RHBZ #187847
131
132* Mon Nov 20 2006 Jakub Jelinek <jakub@redhat.com> - 4.5.14-4
133- Fix ia64 syscall decoding (#206768)
134- Fix build with glibc-2.4.90-33 and up on all arches but ia64
135- Fix build against 2.6.18+ headers
136
137* Tue Aug 22 2006 Roland McGrath <roland@redhat.com> - 4.5.14-3
138- Fix bogus decoding of syscalls >= 300 (#201462, #202620).
139
140* Fri Jul 14 2006 Jesse Keating <jkeating@redhat.com> - 4.5.14-2
141- rebuild
142
143* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 4.5.14-1.2
144- bump again for long double bug on ppc{,64}
145
146* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 4.5.14-1.1
147- rebuilt for new gcc4.1 snapshot and glibc changes
148
Roland McGrathf4d9b492006-01-17 06:22:57 +0000149* Mon Jan 16 2006 Roland McGrath <roland@redhat.com> - 4.5.14-1
150- Fix biarch decoding of socket syscalls (#174354).
151- Fix biarch -e support (#173986).
152- Accept numeric syscalls in -e (#174798).
153- Fix ipc syscall decoding (#164755).
154- Improve msgrcv printing (#164757).
155- Man page updates (#165375).
156- Improve mount syscall printing (#165377).
157- Correct printing of restarting syscalls (#165469).
158
Roland McGrathcab43802005-08-03 11:42:35 +0000159* Wed Aug 3 2005 Roland McGrath <roland@redhat.com> - 4.5.13-1
160- Fix setsockopt decoding on 64-bit (#162449).
161- Fix typos in socket option name strings (#161578).
162- Display more IPV6 socket options by name (#162450).
163- Don't display inappropriate syscalls for -e trace=file (#159340).
164- New selector type -e trace=desc for file-descriptor using calls (#159400).
165- Fix 32-bit old_mmap syscall decoding on x86-64 (#162467, #164215).
166- Fix errors detaching from multithreaded process on interrupt (#161919).
167- Note 4.5.12 fix for crash handling bad signal numbers (#162739).
168
Roland McGrath182cbf42005-06-10 03:56:16 +0000169* Wed Jun 8 2005 Roland McGrath <roland@redhat.com> - 4.5.12-1
170- Fix known syscall recognition for IA32 processes on x86-64 (#158934).
171- Fix bad output for ptrace on x86-64 (#159787).
172- Fix potential buffer overruns (#151570, #159196).
173- Make some diagnostics more consistent (#159308).
174- Update PowerPC system calls.
175- Better printing for Linux aio system calls.
176- Don't truncate statfs64 fields to 32 bits in output (#158243).
177- Cosmetic code cleanups (#159688).
178
Roland McGrath7147a3d2005-03-22 23:12:39 +0000179* Tue Mar 22 2005 Roland McGrath <roland@redhat.com> - 4.5.11-1
180- Build tweaks.
181- Note 4.5.10 select fix (#151570).
182
Roland McGrathd8184032005-03-15 02:40:12 +0000183* Mon Mar 14 2005 Roland McGrath <roland@redhat.com> - 4.5.10-1
184- Fix select handling on nonstandard fd_set sizes.
185- Don't print errors for null file name pointers.
186- Fix initial execve output with -i (#143365).
187
Roland McGrath6df9d642005-02-04 10:13:15 +0000188* Fri Feb 4 2005 Roland McGrath <roland@redhat.com> - 4.5.9-2
Roland McGrathd63311a2005-02-04 09:29:04 +0000189- update ia64 syscall list (#146245)
190- fix x86_64 syscall argument extraction for 32-bit processes (#146093)
191- fix -e signal=NAME parsing (#143362)
192- fix x86_64 exit_group syscall handling
193- improve socket ioctl printing (#138223)
194- code cleanups (#143369, #143370)
195- improve mount flags printing (#141932)
196- support symbolic printing of x86_64 arch_prctl parameters (#142667)
197- fix potential crash in getxattr printing
198
Roland McGrathf041d472004-10-20 02:17:52 +0000199* Tue Oct 19 2004 Roland McGrath <roland@redhat.com> - 4.5.8-1
200- fix multithreaded exit handling (#132150, #135254)
201- fix ioctl name matching (#129808)
202- print RTC_* ioctl structure contents (#58606)
203- grok epoll_* syscalls (#134463)
204- grok new RLIMIT_* values (#133594)
205- print struct cmsghdr contents for sendmsg (#131689)
206- fix clock_* and timer_* argument output (#131420)
207
Roland McGrath61d64872004-08-31 08:58:10 +0000208* Tue Aug 31 2004 Roland McGrath <roland@redhat.com> - 4.5.7-2
Roland McGrathb93f9182004-08-31 08:17:20 +0000209- new upstream version, misc fixes and updates (#128091, #129166, #128391, #129378, #130965, #131177)
210
Roland McGrath785a0262004-07-12 07:55:48 +0000211* Mon Jul 12 2004 Roland McGrath <roland@redhat.com> 4.5.6-1
212- new upstream version, updates ioctl lists (#127398), fixes quotactl (#127393), more ioctl decoding (#126917)
213
Roland McGrathb7e2ca12004-06-28 05:24:29 +0000214* Sun Jun 27 2004 Roland McGrath <roland@redhat.com> 4.5.5-1
215- new upstream version, fixes x86-64 biarch support (#126547)
216
217* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com> 4.5.4-2
218- rebuilt
219
220* Thu Jun 3 2004 Roland McGrath <roland@redhat.com> 4.5.4-0.FC1
221- rebuilt for FC1 update
222
Roland McGrathed8e77e2004-06-04 02:35:58 +0000223* Thu Jun 3 2004 Roland McGrath <roland@redhat.com> 4.5.4-1
224- new upstream version, more ioctls (#122257), minor fixes
225
Roland McGratha8c555f2004-04-16 22:28:41 +0000226* Fri Apr 16 2004 Roland McGrath <roland@redhat.com> 4.5.3-1
227- new upstream version, mq_* calls (#120701), -p vs NPTL (#120462), more fixes (#118694, #120541, #118685)
228
229* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com> 4.5.2-1.1
230- rebuilt
231
Roland McGrathb66e9362004-03-02 06:38:35 +0000232* Mon Mar 1 2004 Roland McGrath <roland@redhat.com> 4.5.2-1
233- new upstream version, sched_* calls (#116990), show core flag (#112117)
234
235* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
236- rebuilt
237
Roland McGrath00eb84e2003-11-14 02:57:22 +0000238* Thu Nov 13 2003 Roland McGrath <roland@redhat.com> 4.5.1-1
239- new upstream version, more fixes (#108012, #105366, #105359, #105358)
240
241* Tue Sep 30 2003 Roland McGrath <roland@redhat.com> 4.5-3
242- revert bogus s390 fix
243
244* Thu Sep 25 2003 Roland McGrath <roland@redhat.com> 4.5-1.2.1AS
245- rebuilt for 2.1AS erratum
246
247* Wed Sep 24 2003 Roland McGrath <roland@redhat.com> 4.5-2
248- rebuilt
249
Roland McGrath739868f2003-09-24 23:05:09 +0000250* Wed Sep 24 2003 Roland McGrath <roland@redhat.com> 4.5-1
251- new upstream version, more fixes (#101499, #104365)
252
Roland McGratha943d002003-09-24 22:22:42 +0000253* Thu Jul 17 2003 Roland McGrath <roland@redhat.com> 4.4.99-2
254- rebuilt
255
Roland McGrathcb612142003-07-17 09:23:56 +0000256* Thu Jul 17 2003 Roland McGrath <roland@redhat.com> 4.4.99-1
257- new upstream version, groks more new system calls, PF_INET6 sockets
258
Roland McGrathf02c3c32003-06-11 05:47:07 +0000259* Mon Jun 10 2003 Roland McGrath <roland@redhat.com> 4.4.98-1
Roland McGrath64ffba52003-06-02 19:37:48 +0000260- new upstream version, more fixes (#90754, #91085)
261
Roland McGrathacd3cd72003-06-11 05:37:56 +0000262* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
263- rebuilt
264
Roland McGrath1b86e2d2003-03-31 01:21:36 +0000265* Sun Mar 30 2003 Roland McGrath <roland@redhat.com> 4.4.96-1
266- new upstream version, handles yet more 2.5 syscalls, x86_64 & ia64 fixes
267
Roland McGrath215da2a2003-03-31 01:46:47 +0000268* Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com> 4.4.95-2
269- rebuilt
270
Roland McGrath1893d052003-02-24 10:53:44 +0000271* Mon Feb 24 2003 Roland McGrath <roland@redhat.com> 4.4.95-1
272- new upstream version, fixed getresuid/getresgid (#84959)
273
Roland McGrath6c2fe9d2003-02-20 03:26:47 +0000274* Wed Feb 19 2003 Roland McGrath <roland@redhat.com> 4.4.94-1
275- new upstream version, new option -E to set environment variables (#82392)
276
277* Wed Jan 22 2003 Tim Powers <timp@redhat.com> 4.4.93-2
278- rebuilt
279
Roland McGrathee061722003-01-22 02:27:51 +0000280* Tue Jan 21 2003 Roland McGrath <roland@redhat.com> 4.4.93-1
281- new upstream version, fixes ppc and s390 bugs, adds missing ptrace requests
282
Roland McGrath1d847cf2003-01-10 21:43:24 +0000283* Fri Jan 10 2003 Roland McGrath <roland@redhat.com> 4.4.91-1
284- new upstream version, fixes -f on x86-64
285
Roland McGrath037124f2003-01-10 10:44:57 +0000286* Fri Jan 10 2003 Roland McGrath <roland@redhat.com> 4.4.90-1
287- new upstream version, fixes all known bugs modulo ia64 and s390 issues
288
289* Fri Jan 03 2003 Florian La Roche <Florian.LaRoche@redhat.de> 4.4-11
290- add further s390 patch from IBM
291
292* Wed Nov 27 2002 Tim Powers <timp@redhat.com> 4.4-10
293- remove unpackaged files from the buildroot
294
295* Mon Oct 07 2002 Phil Knirsch <pknirsch@redhat.com> 4.4-9.1
296- Added latest s390(x) patch.
297
298* Fri Sep 06 2002 Karsten Hopp <karsten@redhat.de> 4.4-9
299- preliminary x86_64 support with an ugly patch to help
300 debugging. Needs cleanup!
301
302* Mon Sep 2 2002 Jakub Jelinek <jakub@redhat.com> 4.4-8
303- newer version of the clone fixing patch (Roland McGrath)
304- aio syscalls for i386/ia64/ppc (Ben LaHaise)
305
306* Wed Aug 28 2002 Jakub Jelinek <jakub@redhat.com> 4.4-7
307- fix strace -f (Roland McGrath, #68994)
308- handle ?et_thread_area, SA_RESTORER (Ulrich Drepper)
309
310* Fri Jun 21 2002 Jakub Jelinek <jakub@redhat.com> 4.4-6
311- handle futexes, *xattr, sendfile64, etc. (Ulrich Drepper)
312- handle modify_ldt (#66894)
313
314* Thu May 23 2002 Tim Powers <timp@redhat.com>
315- automated rebuild
316
317* Tue Apr 16 2002 Jakub Jelinek <jakub@redhat.com> 4.4-4
318- fix for the last patch by Jeff Law (#62591)
319
320* Mon Mar 4 2002 Preston Brown <pbrown@redhat.com> 4.4-3
321- integrate patch from Jeff Law to eliminate hang tracing threads
322
323* Sat Feb 23 2002 Florian La Roche <Florian.LaRoche@redhat.de>
324- minor update from debian tar-ball
325
326* Wed Jan 02 2002 Florian La Roche <Florian.LaRoche@redhat.de>
327- update to 4.4
328
329* Sun Jul 22 2001 Florian La Roche <Florian.LaRoche@redhat.de>
330- disable s390 patches, they are already included
331
332* Wed Jul 18 2001 Preston Brown <pbrown@redhat.com> 4.3-1
333- new upstream version. Seems to have integrated most new syscalls
334- tracing threaded programs is now functional.
335
336* Mon Jun 11 2001 Than Ngo <than@redhat.com>
337- port s390 patches from IBM
338
339* Wed May 16 2001 Nalin Dahyabhai <nalin@redhat.com>
340- modify new syscall patch to allocate enough heap space in setgroups32()
341
342* Wed Feb 14 2001 Jakub Jelinek <jakub@redhat.com>
343- #include <time.h> in addition to <sys/time.h>
344
345* Fri Jan 26 2001 Karsten Hopp <karsten@redhat.com>
346- clean up conflicting patches. This happened only
347 when building on S390
348
349* Fri Jan 19 2001 Bill Nottingham <notting@redhat.com>
350- update to CVS, reintegrate ia64 support
351
352* Sat Dec 8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
353- Get S/390 support into the normal package
354
355* Sat Nov 18 2000 Florian La Roche <Florian.LaRoche@redhat.de>
356- added S/390 patch from IBM, adapting it to not conflict with
357 IA64 patch
358
359* Sat Aug 19 2000 Jakub Jelinek <jakub@redhat.com>
360- doh, actually apply the 2.4 syscalls patch
361- make it compile with 2.4.0-test7-pre4+ headers, add
362 getdents64 and fcntl64
363
364* Thu Aug 3 2000 Jakub Jelinek <jakub@redhat.com>
365- add a bunch of new 2.4 syscalls (#14036)
366
367* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
368- automatic rebuild
369- excludearch ia64
370
371* Fri Jun 2 2000 Matt Wilson <msw@redhat.com>
372- use buildinstall for FHS
373
374* Wed May 24 2000 Jakub Jelinek <jakub@redhat.com>
375- make things compile on sparc
376- fix sigreturn on sparc
377
378* Fri Mar 31 2000 Bill Nottingham <notting@redhat.com>
379- fix stat64 misdef (#10485)
380
381* Tue Mar 21 2000 Michael K. Johnson <johnsonm@redhat.com>
382- added ia64 patch
383
384* Thu Feb 03 2000 Cristian Gafton <gafton@redhat.com>
385- man pages are compressed
386- version 4.2 (why are we keeping all these patches around?)
387
388* Sat Nov 27 1999 Jeff Johnson <jbj@redhat.com>
389- update to 4.1 (with sparc socketcall patch).
390
391* Fri Nov 12 1999 Jakub Jelinek <jakub@redhat.com>
392- fix socketcall on sparc.
393
394* Thu Sep 02 1999 Cristian Gafton <gafton@redhat.com>
395- fix KERN_SECURELVL compile problem
396
397* Tue Aug 31 1999 Cristian Gafton <gafton@redhat.com>
398- added alpha patch from HJLu to fix the osf_sigprocmask interpretation
399
400* Sat Jun 12 1999 Jeff Johnson <jbj@redhat.com>
401- update to 3.99.1.
402
403* Wed Jun 2 1999 Jeff Johnson <jbj@redhat.com>
404- add (the other :-) jj's sparc patch.
405
406* Wed May 26 1999 Jeff Johnson <jbj@redhat.com>
407- upgrade to 3.99 in order to
408- add new 2.2.x open flags (#2955).
409- add new 2.2.x syscalls (#2866).
410- strace 3.1 patches carried along for now.
411
412* Sun May 16 1999 Jeff Johnson <jbj@redhat.com>
Roland McGrath00a18752007-02-18 22:55:21 +0000413- don't rely on (broken!) rpm %%patch (#2735)
Roland McGrath037124f2003-01-10 10:44:57 +0000414
415* Tue Apr 06 1999 Preston Brown <pbrown@redhat.com>
416- strip binary
417
418* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
419- auto rebuild in the new build environment (release 16)
420
421* Tue Feb 9 1999 Jeff Johnson <jbj@redhat.com>
422- vfork est arrive!
423
424* Tue Feb 9 1999 Christopher Blizzard <blizzard@redhat.com>
425- Add patch to follow clone() syscalls, too.
426
427* Sun Jan 17 1999 Jeff Johnson <jbj@redhat.com>
428- patch to build alpha/sparc with glibc 2.1.
429
430* Thu Dec 03 1998 Cristian Gafton <gafton@redhat.com>
431- patch to build on ARM
432
433* Wed Sep 30 1998 Jeff Johnson <jbj@redhat.com>
434- fix typo (printf, not tprintf).
435
436* Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
437- fix compile problem on sparc.
438
439* Tue Aug 18 1998 Cristian Gafton <gafton@redhat.com>
440- buildroot
441
442* Mon Jul 20 1998 Cristian Gafton <gafton@redhat.com>
443- added the umoven patch from James Youngman <jay@gnu.org>
444- fixed build problems on newer glibc releases
445
446* Mon Jun 08 1998 Prospector System <bugs@redhat.com>
447- translations modified for de, fr, tr