blob: ad9562c34f3e3876d33e4eb60e196cbee07488d1 [file] [log] [blame]
Roland McGrath00a18752007-02-18 22:55:21 +00001Summary: Tracks and displays system calls associated with a running process
Roland McGrath037124f2003-01-10 10:44:57 +00002Name: strace
Dmitry V. Levinacbe5182010-04-06 23:46:43 +00003Version: 4.5.20
Roland McGrathcdec4692007-01-11 22:22:47 +00004Release: 1%{?dist}
Roland McGrath037124f2003-01-10 10:44:57 +00005License: BSD
6Group: Development/Debuggers
7URL: http://sourceforge.net/projects/strace/
Roland McGrath4aa15562006-04-25 07:22:02 +00008Source0: http://dl.sourceforge.net/strace/%{name}-%{version}.tar.bz2
Roland McGrath00a18752007-02-18 22:55:21 +00009BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Roland McGrath037124f2003-01-10 10:44:57 +000010
Roland McGrath4c99f562007-11-19 22:14:56 +000011BuildRequires: libaio-devel, libacl-devel
12
Roland McGrath7c2ec572008-03-26 19:15:41 +000013%define strace64_arches ppc64 sparc64
Roland McGratha943d002003-09-24 22:22:42 +000014
Roland McGrath037124f2003-01-10 10:44:57 +000015%description
16The strace program intercepts and records the system calls called and
17received by a running process. Strace can print a record of each
18system call, its arguments and its return value. Strace is useful for
19diagnosing problems and debugging, as well as for instructional
20purposes.
21
22Install strace if you need a tool to track the system calls made and
23received by a process.
24
Roland McGratha943d002003-09-24 22:22:42 +000025%ifarch %{strace64_arches}
26%package -n strace64
27Summary: Tracks and displays system calls associated with a running process.
28Group: Development/Debuggers
29
30%description -n strace64
31The strace program intercepts and records the system calls called and
32received by a running process. Strace can print a record of each
33system call, its arguments and its return value. Strace is useful for
34diagnosing problems and debugging, as well as for instructional
35purposes.
36
37Install strace if you need a tool to track the system calls made and
38received by a process.
39
40This package provides the `strace64' program to trace 64-bit processes.
41The `strace' program in the `strace' package is for 32-bit processes.
42%endif
43
Roland McGrath037124f2003-01-10 10:44:57 +000044%prep
45%setup -q
46
47%build
48%configure
Roland McGrathcddc21f2007-02-18 22:56:37 +000049make %{?_smp_mflags}
Roland McGrath037124f2003-01-10 10:44:57 +000050
51%install
52rm -rf %{buildroot}
Roland McGrath00a18752007-02-18 22:55:21 +000053make DESTDIR=%{buildroot} install
Roland McGrath037124f2003-01-10 10:44:57 +000054
55# remove unpackaged files from the buildroot
56rm -f %{buildroot}%{_bindir}/strace-graph
57
Roland McGrath3f0dbe22008-08-28 23:26:21 +000058%define copy64 ln
59%if 0%{?rhel}
60%if 0%{?rhel} < 6
61%endif
62%define copy64 cp -p
63%endif
64
Roland McGratha943d002003-09-24 22:22:42 +000065%ifarch %{strace64_arches}
Roland McGrath3f0dbe22008-08-28 23:26:21 +000066%{copy64} %{buildroot}%{_bindir}/strace %{buildroot}%{_bindir}/strace64
Roland McGratha943d002003-09-24 22:22:42 +000067%endif
68
Roland McGrath037124f2003-01-10 10:44:57 +000069%clean
70rm -rf %{buildroot}
71
72%files
73%defattr(-,root,root)
Roland McGrathd0875712009-10-06 18:03:25 -070074%doc CREDITS ChangeLog ChangeLog-CVS COPYRIGHT NEWS PORTING README
Roland McGrath037124f2003-01-10 10:44:57 +000075%{_bindir}/strace
76%{_mandir}/man1/*
77
Roland McGratha943d002003-09-24 22:22:42 +000078%ifarch %{strace64_arches}
79%files -n strace64
80%defattr(-,root,root)
81%{_bindir}/strace64
82%endif
83
Roland McGrath037124f2003-01-10 10:44:57 +000084%changelog
Dmitry V. Levinacbe5182010-04-06 23:46:43 +000085* Tue Apr 13 2010 Roland McGrath <roland@redhat.com> - 4.5.20-1
86- New upstream release, work mostly by Andreas Schwab and Dmitry V. Levin.
87 + fixed potential stack buffer overflow in select decoder (#556678);
88 + fixed FTBFS (#539044).
89
Roland McGrath7d9247e2009-10-21 10:36:13 -070090* Wed Oct 21 2009 Roland McGrath <roland@redhat.com> - 4.5.19-1
91- New upstream release, work mostly by Dmitry V. Levin <ldv@altlinux.org>
Dmitry V. Levinfbfed222009-09-14 16:34:34 +000092 + exit/kill strace with traced process exitcode/signal (#105371);
93 + fixed build on ARM EABI (#507576);
94 + fixed display of 32-bit argv array on 64-bit architectures (#519480);
95 + fixed display of 32-bit fcntl(F_SETLK) on 64-bit architectures (#471169);
96 + fixed several bugs in strings decoder, including potential heap
97 memory corruption (#470529, #478324, #511035).
98
Roland McGrath09db7052008-08-28 22:00:46 +000099* Thu Aug 28 2008 Roland McGrath <roland@redhat.com> - 4.5.18-1
100- build fix for newer kernel headers (#457291)
101- fix CLONE_VFORK handling (#455078)
102- Support new Linux/PPC system call subpage_prot and PROT_SAO flag.
103- In sigaction system call, display sa_flags value along with SIG_DFL/SIG_IGN.
104
Roland McGrath6a1311d2008-07-22 00:43:09 +0000105* Mon Jul 21 2008 Roland McGrath <roland@redhat.com> - 4.5.17-1
Roland McGrath55dd2782008-07-18 02:21:11 +0000106- handle O_CLOEXEC, MSG_CMSG_CLOEXEC (#365781)
107- fix biarch stat64 decoding (#222275)
108- fix spurious "..." in printing of environment strings (#358241)
109- improve prctl decoding (#364401)
110- fix hang wait on exited child with exited child (#354261)
111- fix biarch fork/vfork (-f) tracing (#447475)
112- fix biarch printing of negative argument kill (#430585)
113- fix biarch decoding of error return values (#447587)
114- fix -f tracing of CLONE_VFORK (#455078)
115- fix ia64 register clobberation in -f tracing (#453438)
116- print SO_NODEFER, SA_RESETHAND instead of SA_NOMASK, SA_ONESHOT (#455821)
117- fix futex argument decoding (#448628, #448629)
118
Roland McGrath47d32232007-08-03 10:28:55 +0000119* Fri Aug 3 2007 Roland McGrath <roland@redhat.com> - 4.5.16-1
120- fix multithread issues (#240962, #240961, #247907)
121- fix spurious SIGSTOP on early interrupt (#240986)
122- fix utime for biarch (#247185)
123- fix -u error message (#247170)
124- better futex syscall printing (##241467)
125- fix argv/envp printing with small -s settings, and for biarch
126- new syscalls: getcpu, eventfd, timerfd, signalfd, epoll_pwait,
127 move_pages, utimensat
128
Roland McGrath0a45fae2007-01-16 23:25:34 +0000129* Tue Jan 16 2007 Roland McGrath <roland@redhat.com> - 4.5.15-1
Roland McGrathcdec4692007-01-11 22:22:47 +0000130- biarch fixes (#179740, #192193, #171626, #173050, #218433, #218043)
131- fix -ff -o behavior (#204950, #218435, #193808, #219423)
132- better quotactl printing (#118696)
133- *at, inotify*, pselect6, ppoll and unshare syscalls (#178633, #191275)
134- glibc-2.5 build fixes (#209856)
135- memory corruption fixes (#200621
136- fix race in child setup under -f (#180293)
137- show ipc key values in hex (#198179, #192182)
138- disallow -c with -ff (#187847)
139- Resolves: RHBZ #179740, RHBZ #192193, RHBZ #204950, RHBZ #218435
140- Resolves: RHBZ #193808, RHBZ #219423, RHBZ #171626, RHBZ #173050
141- Resolves: RHBZ #218433, RHBZ #218043, RHBZ #118696, RHBZ #178633
142- Resolves: RHBZ #191275, RHBZ #209856, RHBZ #200621, RHBZ #180293
143- Resolves: RHBZ #198179, RHBZ #198182, RHBZ #187847
144
145* Mon Nov 20 2006 Jakub Jelinek <jakub@redhat.com> - 4.5.14-4
146- Fix ia64 syscall decoding (#206768)
147- Fix build with glibc-2.4.90-33 and up on all arches but ia64
148- Fix build against 2.6.18+ headers
149
150* Tue Aug 22 2006 Roland McGrath <roland@redhat.com> - 4.5.14-3
151- Fix bogus decoding of syscalls >= 300 (#201462, #202620).
152
153* Fri Jul 14 2006 Jesse Keating <jkeating@redhat.com> - 4.5.14-2
154- rebuild
155
156* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 4.5.14-1.2
157- bump again for long double bug on ppc{,64}
158
159* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 4.5.14-1.1
160- rebuilt for new gcc4.1 snapshot and glibc changes
161
Roland McGrathf4d9b492006-01-17 06:22:57 +0000162* Mon Jan 16 2006 Roland McGrath <roland@redhat.com> - 4.5.14-1
163- Fix biarch decoding of socket syscalls (#174354).
164- Fix biarch -e support (#173986).
165- Accept numeric syscalls in -e (#174798).
166- Fix ipc syscall decoding (#164755).
167- Improve msgrcv printing (#164757).
168- Man page updates (#165375).
169- Improve mount syscall printing (#165377).
170- Correct printing of restarting syscalls (#165469).
171
Roland McGrathcab43802005-08-03 11:42:35 +0000172* Wed Aug 3 2005 Roland McGrath <roland@redhat.com> - 4.5.13-1
173- Fix setsockopt decoding on 64-bit (#162449).
174- Fix typos in socket option name strings (#161578).
175- Display more IPV6 socket options by name (#162450).
176- Don't display inappropriate syscalls for -e trace=file (#159340).
177- New selector type -e trace=desc for file-descriptor using calls (#159400).
178- Fix 32-bit old_mmap syscall decoding on x86-64 (#162467, #164215).
179- Fix errors detaching from multithreaded process on interrupt (#161919).
180- Note 4.5.12 fix for crash handling bad signal numbers (#162739).
181
Roland McGrath182cbf42005-06-10 03:56:16 +0000182* Wed Jun 8 2005 Roland McGrath <roland@redhat.com> - 4.5.12-1
183- Fix known syscall recognition for IA32 processes on x86-64 (#158934).
184- Fix bad output for ptrace on x86-64 (#159787).
185- Fix potential buffer overruns (#151570, #159196).
186- Make some diagnostics more consistent (#159308).
187- Update PowerPC system calls.
188- Better printing for Linux aio system calls.
189- Don't truncate statfs64 fields to 32 bits in output (#158243).
190- Cosmetic code cleanups (#159688).
191
Roland McGrath7147a3d2005-03-22 23:12:39 +0000192* Tue Mar 22 2005 Roland McGrath <roland@redhat.com> - 4.5.11-1
193- Build tweaks.
194- Note 4.5.10 select fix (#151570).
195
Roland McGrathd8184032005-03-15 02:40:12 +0000196* Mon Mar 14 2005 Roland McGrath <roland@redhat.com> - 4.5.10-1
197- Fix select handling on nonstandard fd_set sizes.
198- Don't print errors for null file name pointers.
199- Fix initial execve output with -i (#143365).
200
Roland McGrath6df9d642005-02-04 10:13:15 +0000201* Fri Feb 4 2005 Roland McGrath <roland@redhat.com> - 4.5.9-2
Roland McGrathd63311a2005-02-04 09:29:04 +0000202- update ia64 syscall list (#146245)
203- fix x86_64 syscall argument extraction for 32-bit processes (#146093)
204- fix -e signal=NAME parsing (#143362)
205- fix x86_64 exit_group syscall handling
206- improve socket ioctl printing (#138223)
207- code cleanups (#143369, #143370)
208- improve mount flags printing (#141932)
209- support symbolic printing of x86_64 arch_prctl parameters (#142667)
210- fix potential crash in getxattr printing
211
Roland McGrathf041d472004-10-20 02:17:52 +0000212* Tue Oct 19 2004 Roland McGrath <roland@redhat.com> - 4.5.8-1
213- fix multithreaded exit handling (#132150, #135254)
214- fix ioctl name matching (#129808)
215- print RTC_* ioctl structure contents (#58606)
216- grok epoll_* syscalls (#134463)
217- grok new RLIMIT_* values (#133594)
218- print struct cmsghdr contents for sendmsg (#131689)
219- fix clock_* and timer_* argument output (#131420)
220
Roland McGrath61d64872004-08-31 08:58:10 +0000221* Tue Aug 31 2004 Roland McGrath <roland@redhat.com> - 4.5.7-2
Roland McGrathb93f9182004-08-31 08:17:20 +0000222- new upstream version, misc fixes and updates (#128091, #129166, #128391, #129378, #130965, #131177)
223
Roland McGrath785a0262004-07-12 07:55:48 +0000224* Mon Jul 12 2004 Roland McGrath <roland@redhat.com> 4.5.6-1
225- new upstream version, updates ioctl lists (#127398), fixes quotactl (#127393), more ioctl decoding (#126917)
226
Roland McGrathb7e2ca12004-06-28 05:24:29 +0000227* Sun Jun 27 2004 Roland McGrath <roland@redhat.com> 4.5.5-1
228- new upstream version, fixes x86-64 biarch support (#126547)
229
230* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com> 4.5.4-2
231- rebuilt
232
233* Thu Jun 3 2004 Roland McGrath <roland@redhat.com> 4.5.4-0.FC1
234- rebuilt for FC1 update
235
Roland McGrathed8e77e2004-06-04 02:35:58 +0000236* Thu Jun 3 2004 Roland McGrath <roland@redhat.com> 4.5.4-1
237- new upstream version, more ioctls (#122257), minor fixes
238
Roland McGratha8c555f2004-04-16 22:28:41 +0000239* Fri Apr 16 2004 Roland McGrath <roland@redhat.com> 4.5.3-1
240- new upstream version, mq_* calls (#120701), -p vs NPTL (#120462), more fixes (#118694, #120541, #118685)
241
242* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com> 4.5.2-1.1
243- rebuilt
244
Roland McGrathb66e9362004-03-02 06:38:35 +0000245* Mon Mar 1 2004 Roland McGrath <roland@redhat.com> 4.5.2-1
246- new upstream version, sched_* calls (#116990), show core flag (#112117)
247
248* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
249- rebuilt
250
Roland McGrath00eb84e2003-11-14 02:57:22 +0000251* Thu Nov 13 2003 Roland McGrath <roland@redhat.com> 4.5.1-1
252- new upstream version, more fixes (#108012, #105366, #105359, #105358)
253
254* Tue Sep 30 2003 Roland McGrath <roland@redhat.com> 4.5-3
255- revert bogus s390 fix
256
257* Thu Sep 25 2003 Roland McGrath <roland@redhat.com> 4.5-1.2.1AS
258- rebuilt for 2.1AS erratum
259
260* Wed Sep 24 2003 Roland McGrath <roland@redhat.com> 4.5-2
261- rebuilt
262
Roland McGrath739868f2003-09-24 23:05:09 +0000263* Wed Sep 24 2003 Roland McGrath <roland@redhat.com> 4.5-1
264- new upstream version, more fixes (#101499, #104365)
265
Roland McGratha943d002003-09-24 22:22:42 +0000266* Thu Jul 17 2003 Roland McGrath <roland@redhat.com> 4.4.99-2
267- rebuilt
268
Roland McGrathcb612142003-07-17 09:23:56 +0000269* Thu Jul 17 2003 Roland McGrath <roland@redhat.com> 4.4.99-1
270- new upstream version, groks more new system calls, PF_INET6 sockets
271
Roland McGrathf02c3c32003-06-11 05:47:07 +0000272* Mon Jun 10 2003 Roland McGrath <roland@redhat.com> 4.4.98-1
Roland McGrath64ffba52003-06-02 19:37:48 +0000273- new upstream version, more fixes (#90754, #91085)
274
Roland McGrathacd3cd72003-06-11 05:37:56 +0000275* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
276- rebuilt
277
Roland McGrath1b86e2d2003-03-31 01:21:36 +0000278* Sun Mar 30 2003 Roland McGrath <roland@redhat.com> 4.4.96-1
279- new upstream version, handles yet more 2.5 syscalls, x86_64 & ia64 fixes
280
Roland McGrath215da2a2003-03-31 01:46:47 +0000281* Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com> 4.4.95-2
282- rebuilt
283
Roland McGrath1893d052003-02-24 10:53:44 +0000284* Mon Feb 24 2003 Roland McGrath <roland@redhat.com> 4.4.95-1
285- new upstream version, fixed getresuid/getresgid (#84959)
286
Roland McGrath6c2fe9d2003-02-20 03:26:47 +0000287* Wed Feb 19 2003 Roland McGrath <roland@redhat.com> 4.4.94-1
288- new upstream version, new option -E to set environment variables (#82392)
289
290* Wed Jan 22 2003 Tim Powers <timp@redhat.com> 4.4.93-2
291- rebuilt
292
Roland McGrathee061722003-01-22 02:27:51 +0000293* Tue Jan 21 2003 Roland McGrath <roland@redhat.com> 4.4.93-1
294- new upstream version, fixes ppc and s390 bugs, adds missing ptrace requests
295
Roland McGrath1d847cf2003-01-10 21:43:24 +0000296* Fri Jan 10 2003 Roland McGrath <roland@redhat.com> 4.4.91-1
297- new upstream version, fixes -f on x86-64
298
Roland McGrath037124f2003-01-10 10:44:57 +0000299* Fri Jan 10 2003 Roland McGrath <roland@redhat.com> 4.4.90-1
300- new upstream version, fixes all known bugs modulo ia64 and s390 issues
301
302* Fri Jan 03 2003 Florian La Roche <Florian.LaRoche@redhat.de> 4.4-11
303- add further s390 patch from IBM
304
305* Wed Nov 27 2002 Tim Powers <timp@redhat.com> 4.4-10
306- remove unpackaged files from the buildroot
307
308* Mon Oct 07 2002 Phil Knirsch <pknirsch@redhat.com> 4.4-9.1
309- Added latest s390(x) patch.
310
311* Fri Sep 06 2002 Karsten Hopp <karsten@redhat.de> 4.4-9
312- preliminary x86_64 support with an ugly patch to help
313 debugging. Needs cleanup!
314
315* Mon Sep 2 2002 Jakub Jelinek <jakub@redhat.com> 4.4-8
316- newer version of the clone fixing patch (Roland McGrath)
317- aio syscalls for i386/ia64/ppc (Ben LaHaise)
318
319* Wed Aug 28 2002 Jakub Jelinek <jakub@redhat.com> 4.4-7
320- fix strace -f (Roland McGrath, #68994)
321- handle ?et_thread_area, SA_RESTORER (Ulrich Drepper)
322
323* Fri Jun 21 2002 Jakub Jelinek <jakub@redhat.com> 4.4-6
324- handle futexes, *xattr, sendfile64, etc. (Ulrich Drepper)
325- handle modify_ldt (#66894)
326
327* Thu May 23 2002 Tim Powers <timp@redhat.com>
328- automated rebuild
329
330* Tue Apr 16 2002 Jakub Jelinek <jakub@redhat.com> 4.4-4
331- fix for the last patch by Jeff Law (#62591)
332
333* Mon Mar 4 2002 Preston Brown <pbrown@redhat.com> 4.4-3
334- integrate patch from Jeff Law to eliminate hang tracing threads
335
336* Sat Feb 23 2002 Florian La Roche <Florian.LaRoche@redhat.de>
337- minor update from debian tar-ball
338
339* Wed Jan 02 2002 Florian La Roche <Florian.LaRoche@redhat.de>
340- update to 4.4
341
342* Sun Jul 22 2001 Florian La Roche <Florian.LaRoche@redhat.de>
343- disable s390 patches, they are already included
344
345* Wed Jul 18 2001 Preston Brown <pbrown@redhat.com> 4.3-1
346- new upstream version. Seems to have integrated most new syscalls
347- tracing threaded programs is now functional.
348
349* Mon Jun 11 2001 Than Ngo <than@redhat.com>
350- port s390 patches from IBM
351
352* Wed May 16 2001 Nalin Dahyabhai <nalin@redhat.com>
353- modify new syscall patch to allocate enough heap space in setgroups32()
354
355* Wed Feb 14 2001 Jakub Jelinek <jakub@redhat.com>
356- #include <time.h> in addition to <sys/time.h>
357
358* Fri Jan 26 2001 Karsten Hopp <karsten@redhat.com>
359- clean up conflicting patches. This happened only
360 when building on S390
361
362* Fri Jan 19 2001 Bill Nottingham <notting@redhat.com>
363- update to CVS, reintegrate ia64 support
364
365* Sat Dec 8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
366- Get S/390 support into the normal package
367
368* Sat Nov 18 2000 Florian La Roche <Florian.LaRoche@redhat.de>
369- added S/390 patch from IBM, adapting it to not conflict with
370 IA64 patch
371
372* Sat Aug 19 2000 Jakub Jelinek <jakub@redhat.com>
373- doh, actually apply the 2.4 syscalls patch
374- make it compile with 2.4.0-test7-pre4+ headers, add
375 getdents64 and fcntl64
376
377* Thu Aug 3 2000 Jakub Jelinek <jakub@redhat.com>
378- add a bunch of new 2.4 syscalls (#14036)
379
380* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
381- automatic rebuild
382- excludearch ia64
383
384* Fri Jun 2 2000 Matt Wilson <msw@redhat.com>
385- use buildinstall for FHS
386
387* Wed May 24 2000 Jakub Jelinek <jakub@redhat.com>
388- make things compile on sparc
389- fix sigreturn on sparc
390
391* Fri Mar 31 2000 Bill Nottingham <notting@redhat.com>
392- fix stat64 misdef (#10485)
393
394* Tue Mar 21 2000 Michael K. Johnson <johnsonm@redhat.com>
395- added ia64 patch
396
397* Thu Feb 03 2000 Cristian Gafton <gafton@redhat.com>
398- man pages are compressed
399- version 4.2 (why are we keeping all these patches around?)
400
401* Sat Nov 27 1999 Jeff Johnson <jbj@redhat.com>
402- update to 4.1 (with sparc socketcall patch).
403
404* Fri Nov 12 1999 Jakub Jelinek <jakub@redhat.com>
405- fix socketcall on sparc.
406
407* Thu Sep 02 1999 Cristian Gafton <gafton@redhat.com>
408- fix KERN_SECURELVL compile problem
409
410* Tue Aug 31 1999 Cristian Gafton <gafton@redhat.com>
411- added alpha patch from HJLu to fix the osf_sigprocmask interpretation
412
413* Sat Jun 12 1999 Jeff Johnson <jbj@redhat.com>
414- update to 3.99.1.
415
416* Wed Jun 2 1999 Jeff Johnson <jbj@redhat.com>
417- add (the other :-) jj's sparc patch.
418
419* Wed May 26 1999 Jeff Johnson <jbj@redhat.com>
420- upgrade to 3.99 in order to
421- add new 2.2.x open flags (#2955).
422- add new 2.2.x syscalls (#2866).
423- strace 3.1 patches carried along for now.
424
425* Sun May 16 1999 Jeff Johnson <jbj@redhat.com>
Roland McGrath00a18752007-02-18 22:55:21 +0000426- don't rely on (broken!) rpm %%patch (#2735)
Roland McGrath037124f2003-01-10 10:44:57 +0000427
428* Tue Apr 06 1999 Preston Brown <pbrown@redhat.com>
429- strip binary
430
431* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
432- auto rebuild in the new build environment (release 16)
433
434* Tue Feb 9 1999 Jeff Johnson <jbj@redhat.com>
435- vfork est arrive!
436
437* Tue Feb 9 1999 Christopher Blizzard <blizzard@redhat.com>
438- Add patch to follow clone() syscalls, too.
439
440* Sun Jan 17 1999 Jeff Johnson <jbj@redhat.com>
441- patch to build alpha/sparc with glibc 2.1.
442
443* Thu Dec 03 1998 Cristian Gafton <gafton@redhat.com>
444- patch to build on ARM
445
446* Wed Sep 30 1998 Jeff Johnson <jbj@redhat.com>
447- fix typo (printf, not tprintf).
448
449* Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
450- fix compile problem on sparc.
451
452* Tue Aug 18 1998 Cristian Gafton <gafton@redhat.com>
453- buildroot
454
455* Mon Jul 20 1998 Cristian Gafton <gafton@redhat.com>
456- added the umoven patch from James Youngman <jay@gnu.org>
457- fixed build problems on newer glibc releases
458
459* Mon Jun 08 1998 Prospector System <bugs@redhat.com>
460- translations modified for de, fr, tr