blob: b357b33c5ecb1f19b8b3ae5d965bb4736a1176a0 [file] [log] [blame]
Jean-Luc Brouilletc5184e22015-03-13 13:51:24 -07001#
2# Copyright (C) 2015 The Android Open Source Project
3#
4# Licensed under the Apache License, Version 2.0 (the "License");
5# you may not use this file except in compliance with the License.
6# You may obtain a copy of the License at
7#
8# http://www.apache.org/licenses/LICENSE-2.0
9#
10# Unless required by applicable law or agreed to in writing, software
11# distributed under the License is distributed on an "AS IS" BASIS,
12# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13# See the License for the specific language governing permissions and
14# limitations under the License.
15#
16
17header:
18summary: Utility debugging routines
19description:
20 Routines intended to be used during application developement. These should
21 not be used in shipping applications. All print a string and value pair to
22 the standard log.
23include:
24 #define RS_DEBUG(a) rsDebug(#a, a)
25 #define RS_DEBUG_MARKER rsDebug(__FILE__, __LINE__)
26end:
27
28function: rsDebug
29t: i32, u32, i64, u64, f64
30ret: void
31arg: const char* message
32arg: #1 a
33summary:
34description:
35 Debug function. Prints a string and value to the log.
36test: none
37end:
38
39function: rsDebug
40version: 17
41w: 2, 3, 4
42# TODO We're not doing it for f64?
43t: i32, u32, i64, u64
44ret: void
45arg: const char* message
46arg: #2#1 a
47test: none
48end:
49
50function: rsDebug
51w: 1, 2, 3, 4
52ret: void
53arg: const char* message
54arg: float#1 a
55test: none
56end:
57
58function: rsDebug
59version: 17
60w: 1, 2, 3, 4
61t: i8, u8, i16, u16
62ret: void
63arg: const char* message
64arg: #2#1 a
65test: none
66end:
67
68function: rsDebug
69ret: void
70arg: const char* message
71arg: float a
72arg: float b
73test: none
74end:
75
76function: rsDebug
77ret: void
78arg: const char* message
79arg: float a
80arg: float b
81arg: float c
82test: none
83end:
84
85function: rsDebug
86ret: void
87arg: const char* message
88arg: float a
89arg: float b
90arg: float c
91arg: float d
92test: none
93end:
94
95function: rsDebug
96ret: void
97arg: const char* message
98arg: long long a
99test: none
100end:
101
102function: rsDebug
103ret: void
104arg: const char* message
105arg: unsigned long long a
106test: none
107end:
108
109function: rsDebug
110ret: void
111arg: const char* message
112arg: const void* a
113test: none
114end:
115
116function: rsDebug
117ret: void
118arg: const char* message
119arg: const rs_matrix4x4* a
120test: none
121end:
122
123function: rsDebug
124ret: void
125arg: const char* message
126arg: const rs_matrix3x3* a
127test: none
128end:
129
130function: rsDebug
131ret: void
132arg: const char* message
133arg: const rs_matrix2x2* a
134test: none
135end:
136
137#define RS_DEBUG(a) rsDebug(#a, a)
138#define RS_DEBUG_MARKER rsDebug(__FILE__, __LINE__)