1. cc8cea7 Fix the bug for AllocationRead() that cannot handle 3d Allocation by Miao Wang · 9 years ago
  2. 05c2cd0 Merge "Implement arrays and allocation adapters" by Jason Sams · 9 years ago
  3. bc9dc27 Implement arrays and allocation adapters by Jason Sams · 9 years ago
  4. eb9aa67 Runtime support for invocables in ScriptGroups by Yang Ni · 9 years ago
  5. da0f069 Runtime support for compiler kernel fusion. by Yang Ni · 10 years ago
  6. 6000c26 Merge "Array type and allocation support" by Jason Sams · 10 years ago
  7. c7968a0 Array type and allocation support by Jason Sams · 10 years ago
  8. 1ffd86b New Script Group API: runtime and cpu driver support. by Yang Ni · 10 years ago
  9. 4b3c34e Adds support for multi-input kernels to Frameworks/RS. by Chris Wailes · 10 years ago
  10. ac8d146 Switch the dimensions array to use uint32_t instead of size_t. by Stephen Hines · 10 years ago
  11. b8a94e2 Add getPointer for USAGE_SHARED allocations. by Jason Sams · 10 years ago
  12. 397b0b1 Make object destruction asynchronous. by Tim Murray · 11 years ago
  13. 8f615d6 Replace "mips" with "mipmaps" since the MIPS gcc compiler defines mips to 1. by Stephen Hines · 11 years ago
  14. 4a92d12 Move to dynamic dispatch. Add support for IoAllocation* in rs.spec. by Tim Murray · 11 years ago
  15. 8c1da3f Removed unused methods from rs.spec. by Tim Murray · 11 years ago
  16. 9c64239 Add support for synchronous get(). by Tim Murray · 11 years ago
  17. 3bbc0fd Add 3D allocation copies. by Jason Sams · 11 years ago
  18. 099bc26 Start making RS 64-bit clean. by Tim Murray · 11 years ago
  19. 2487bb7 Split rs.spec into generic and native-specific functions. by Tim Murray · 11 years ago
  20. 29226ae Split graphics rs.spec into its own file. by Tim Murray · 11 years ago
  21. 733396b Implement usage IO INPUT by Jason Sams · 11 years ago
  22. d4ecb17 Add API entry points for clipped kernels and fix Z-dimension clipping. by Tim Murray · 11 years ago
  23. 7026520 Implement rs.sendMessage() by Jason Sams · 11 years ago
  24. a572aca Add support for YUV allocations. by Jason Sams · 12 years ago
  25. 358747a Add support for 2D strided copies to/from an allocation with the C++ API. by Tim Murray · 12 years ago
  26. 7b3e309 Add support for 2D copies to arbitrary data pointers. by Tim Murray · 12 years ago
  27. 509ea5c Add copy1DRangeToUnchecked. by Tim Murray · 12 years ago
  28. dbe66d6 Add backed for script groups. by Jason Sams · 12 years ago
  29. 8eaba4f Intrinisics by Jason Sams · 12 years ago
  30. 2980f07 Support additional element/dim information for FieldPacker. by Stephen Hines · 12 years ago
  31. 3522f40 Implement USAGE_IO_INPUT by Jason Sams · 12 years ago
  32. 38c04ad Merge "Piping texture names through shader builder. Fixing uint size_t mismatch." by Alex Sakhartchouk · 12 years ago
  33. 748eb07 Piping texture names through shader builder. Fixing uint size_t mismatch. by Alex Sakhartchouk · 12 years ago
  34. 7ac2a4d Beging IO stream out from allocation to surface texture. by Jason Sams · 12 years ago
  35. d3e4b74 Merge commit 'bdeec118' into manualmerge by Jason Sams · 12 years ago
  36. 5f27d6f Implement RS VSync on new vsync infrastructure. by Jason Sams · 12 years ago
  37. d104703 am 855eadf9: Merge "Fix potential bug with reordered size/offset arguments." by Stephen Hines · 12 years ago
  38. 6ae039b Fix potential bug with reordered size/offset arguments. by Stephen Hines · 13 years ago
  39. 41e373d Start implementing SurfaceTexture streaming into RS allocations. by Jason Sams · 13 years ago
  40. 179e9a4 Private API to support MFF transition. by Jason Sams · 13 years ago
  41. 9e0afb5 Path rendering by Jason Sams · 13 years ago
  42. 5b9f3e2 Remove unused fields in ProgramRaster by Jason Sams · 13 years ago
  43. c700e64 Fixing asynchronous performance issues. by Alex Sakhartchouk · 13 years ago
  44. c33e690 First cut at RSTextureView. by Jason Sams · 13 years ago
  45. 74a8279 Allocation copy functions. by Alex Sakhartchouk · 13 years ago
  46. 789ca83 Move context and device creation out of the spec file. by Jason Sams · 13 years ago
  47. 7257c7e Preparing libRS for for compilation on host. by Alex Sakhartchouk · 13 years ago
  48. 1a4efa3 Core to client fifo on sockets. by Jason Sams · 13 years ago
  49. 9003e56 Cleanup mesh creation. by Alex Sakhartchouk · 13 years ago
  50. 2008747 Add code for generating fifo command packing. by Jason Sams · 13 years ago
  51. c2c02a8 Code Cleanup and better Sampler creation method by Alex Sakhartchouk · 13 years ago
  52. c975cf4 Pipe rsa function though the RS api table. by Jason Sams · 13 years ago
  53. 5fb1aeb Start implementing control side forEach. by Jason Sams · 13 years ago
  54. 186e591 Cleanup rs.spec file and code generator. by Jason Sams · 13 years ago
  55. 70b83c1 Modifying libRS internal communication to handle network rendering. by Alex Sakhartchouk · 13 years ago
  56. 721acc4 Seperate ProgramRaster. Cleanup ProgramRaster and ProgramStore creation. by Jason Sams · 13 years ago
  57. bad8074 Start seperating out RS compute implementation. Create hal by Jason Sams · 13 years ago
  58. a237151 Cleanup bitmap uploads Implement standalone mipmap generation. by Jason Sams · 14 years ago
  59. 5224a27 Additional loading methods for fonts and a3d files. Cleaned up error messages. by Alex Sakhartchouk · 14 years ago
  60. 4b45b89 Move adapter2D to a derived class from Allocation. by Jason Sams · 14 years ago
  61. 741aac9 Fix teardown bug found in books. by Jason Sams · 14 years ago
  62. ce8a079 Stale cache management to address a P1 bug # 3296131. by Shih-wei Liao · 14 years ago
  63. c17ace2 API reaview cleanup by Alex Sakhartchouk · 14 years ago
  64. 15849d9 1. Add Context to a RenderScript or RenderScriptGL instance. by Shih-wei Liao · 14 years ago
  65. ebc5019 More API updates. by Jason Sams · 14 years ago
  66. 837e388 Remove CreateFromBitmapRef and add CopyTo(bitmap) replacement. by Jason Sams · 14 years ago
  67. 1dcefab Fix a severe cleanup bug where teardown of the GL by Jason Sams · 14 years ago
  68. 366c9c8 Allocation API update. by Jason Sams · 14 years ago
  69. 87319de More error checks by Jason Sams · 14 years ago
  70. 9503b66 Add caching support of BCC binaries. by Shih-wei Liao · 14 years ago
  71. a5eb6e1 Fix ref counting for globals when set from java code. by Jason Sams · 14 years ago
  72. 54929cc Moving attrib creation to Mesh. Adding arrays as shader inputs. by Alex Sakhartchouk · 14 years ago
  73. dc763f3 Adding nvidia extension for limited npot support. by Alex Sakhartchouk · 14 years ago
  74. f0c1df4 Begin adding async allocation creation. by Jason Sams · 14 years ago
  75. 2353ae3 Async type creation. by Jason Sams · 14 years ago
  76. 39f2ef6 Update allocation from bitmap. GL attribute cleanup in type. by Alex Sakhartchouk · 14 years ago
  77. 0977c94 Fix support for 64-bit integers. by Stephen Hines · 14 years ago
  78. d7e5481 Cleanup error message for null binding address. by Jason Sams · 14 years ago
  79. 96abf81 Implement allocation resizing. by Jason Sams · 14 years ago
  80. 1103d8e Adding anisotropic filtering and related samples. by Alex Sakhartchouk · 14 years ago
  81. 383e5b1 Adding support for all allowed textures. by Alex Sakhartchouk · 14 years ago
  82. b9077f4 Better debugging for scripts. by Jason Sams · 14 years ago
  83. 6d0a074 Add support for Float64 (double) to RenderScript. by Stephen Hines · 14 years ago
  84. 46e4554 Add arrays to elements. by Jason Sams · 14 years ago
  85. 5f0c84c SubElementData data upload functions. by Jason Sams · 14 years ago
  86. 46bafb3 Make java entry points for native fifo synchronized. by Jason Sams · 14 years ago
  87. 9fc9f03 Added ability to set font color. by Alex Sakhartchouk · 14 years ago
  88. 417e6a4 Populate java objects with native data from a3d file. by Alex Sakhartchouk · 14 years ago
  89. d18c744 Work on synchronizing a3d created files and java layer. by Alex Sakhartchouk · 14 years ago
  90. 479e292 Remove points from fixed function. Add basic GL performance test. by Jason Sams · 14 years ago
  91. 17d72e8 Cleanup pass on the mesh api change. by Alex Sakhartchouk · 14 years ago
  92. 4e9a7a8 Start of mesh API cleanup. by Alex Sakhartchouk · 14 years ago
  93. 4ab16b5 am 177c405a: am c6e1d880: Merge "Introduce official public NativeWindow type." into gingerbread by Dianne Hackborn · 14 years ago
  94. 1c769c3 Introduce official public NativeWindow type. by Dianne Hackborn · 14 years ago
  95. d3e0ad4 Adding freetype font rendering to renderscript. by Alex Sakhartchouk · 14 years ago
  96. 8c88090 Remove InvokeData and add ContextFinish to generate a sync point. by Jason Sams · 14 years ago
  97. b825f67 Creating the jni and java layer to integrate a3d by Alex Sakhartchouk · 14 years ago
  98. 22fa371 Begin naming cleanup for renderscript runtime. by Jason Sams · 14 years ago
  99. ce92d4b Remove more pieces of setRoot. Add pointer to allocation lookup for scripts. by Jason Sams · 14 years ago
  100. 639e6e9 Delete legacy setDefine API. by Jason Sams · 14 years ago