1. 9c64239 Add support for synchronous get(). by Tim Murray · 11 years ago
  2. 3bbc0fd Add 3D allocation copies. by Jason Sams · 11 years ago
  3. 099bc26 Start making RS 64-bit clean. by Tim Murray · 11 years ago
  4. 2487bb7 Split rs.spec into generic and native-specific functions. by Tim Murray · 11 years ago
  5. 29226ae Split graphics rs.spec into its own file. by Tim Murray · 11 years ago
  6. 733396b Implement usage IO INPUT by Jason Sams · 11 years ago
  7. d4ecb17 Add API entry points for clipped kernels and fix Z-dimension clipping. by Tim Murray · 11 years ago
  8. 7026520 Implement rs.sendMessage() by Jason Sams · 11 years ago
  9. a572aca Add support for YUV allocations. by Jason Sams · 12 years ago
  10. 358747a Add support for 2D strided copies to/from an allocation with the C++ API. by Tim Murray · 12 years ago
  11. 7b3e309 Add support for 2D copies to arbitrary data pointers. by Tim Murray · 12 years ago
  12. 509ea5c Add copy1DRangeToUnchecked. by Tim Murray · 12 years ago
  13. dbe66d6 Add backed for script groups. by Jason Sams · 12 years ago
  14. 8eaba4f Intrinisics by Jason Sams · 12 years ago
  15. 2980f07 Support additional element/dim information for FieldPacker. by Stephen Hines · 12 years ago
  16. 3522f40 Implement USAGE_IO_INPUT by Jason Sams · 12 years ago
  17. 38c04ad Merge "Piping texture names through shader builder. Fixing uint size_t mismatch." by Alex Sakhartchouk · 12 years ago
  18. 748eb07 Piping texture names through shader builder. Fixing uint size_t mismatch. by Alex Sakhartchouk · 12 years ago
  19. 7ac2a4d Beging IO stream out from allocation to surface texture. by Jason Sams · 12 years ago
  20. d3e4b74 Merge commit 'bdeec118' into manualmerge by Jason Sams · 12 years ago
  21. 5f27d6f Implement RS VSync on new vsync infrastructure. by Jason Sams · 12 years ago
  22. d104703 am 855eadf9: Merge "Fix potential bug with reordered size/offset arguments." by Stephen Hines · 12 years ago
  23. 6ae039b Fix potential bug with reordered size/offset arguments. by Stephen Hines · 13 years ago
  24. 41e373d Start implementing SurfaceTexture streaming into RS allocations. by Jason Sams · 13 years ago
  25. 179e9a4 Private API to support MFF transition. by Jason Sams · 13 years ago
  26. 9e0afb5 Path rendering by Jason Sams · 13 years ago
  27. 5b9f3e2 Remove unused fields in ProgramRaster by Jason Sams · 13 years ago
  28. c700e64 Fixing asynchronous performance issues. by Alex Sakhartchouk · 13 years ago
  29. c33e690 First cut at RSTextureView. by Jason Sams · 13 years ago
  30. 74a8279 Allocation copy functions. by Alex Sakhartchouk · 13 years ago
  31. 789ca83 Move context and device creation out of the spec file. by Jason Sams · 13 years ago
  32. 7257c7e Preparing libRS for for compilation on host. by Alex Sakhartchouk · 13 years ago
  33. 1a4efa3 Core to client fifo on sockets. by Jason Sams · 13 years ago
  34. 9003e56 Cleanup mesh creation. by Alex Sakhartchouk · 13 years ago
  35. 2008747 Add code for generating fifo command packing. by Jason Sams · 13 years ago
  36. c2c02a8 Code Cleanup and better Sampler creation method by Alex Sakhartchouk · 13 years ago
  37. c975cf4 Pipe rsa function though the RS api table. by Jason Sams · 13 years ago
  38. 5fb1aeb Start implementing control side forEach. by Jason Sams · 13 years ago
  39. 186e591 Cleanup rs.spec file and code generator. by Jason Sams · 13 years ago
  40. 70b83c1 Modifying libRS internal communication to handle network rendering. by Alex Sakhartchouk · 13 years ago
  41. 721acc4 Seperate ProgramRaster. Cleanup ProgramRaster and ProgramStore creation. by Jason Sams · 13 years ago
  42. bad8074 Start seperating out RS compute implementation. Create hal by Jason Sams · 13 years ago
  43. a237151 Cleanup bitmap uploads Implement standalone mipmap generation. by Jason Sams · 14 years ago
  44. 5224a27 Additional loading methods for fonts and a3d files. Cleaned up error messages. by Alex Sakhartchouk · 14 years ago
  45. 4b45b89 Move adapter2D to a derived class from Allocation. by Jason Sams · 14 years ago
  46. 741aac9 Fix teardown bug found in books. by Jason Sams · 14 years ago
  47. ce8a079 Stale cache management to address a P1 bug # 3296131. by Shih-wei Liao · 14 years ago
  48. c17ace2 API reaview cleanup by Alex Sakhartchouk · 14 years ago
  49. 15849d9 1. Add Context to a RenderScript or RenderScriptGL instance. by Shih-wei Liao · 14 years ago
  50. ebc5019 More API updates. by Jason Sams · 14 years ago
  51. 837e388 Remove CreateFromBitmapRef and add CopyTo(bitmap) replacement. by Jason Sams · 14 years ago
  52. 1dcefab Fix a severe cleanup bug where teardown of the GL by Jason Sams · 14 years ago
  53. 366c9c8 Allocation API update. by Jason Sams · 14 years ago
  54. 87319de More error checks by Jason Sams · 14 years ago
  55. 9503b66 Add caching support of BCC binaries. by Shih-wei Liao · 14 years ago
  56. a5eb6e1 Fix ref counting for globals when set from java code. by Jason Sams · 14 years ago
  57. 54929cc Moving attrib creation to Mesh. Adding arrays as shader inputs. by Alex Sakhartchouk · 14 years ago
  58. dc763f3 Adding nvidia extension for limited npot support. by Alex Sakhartchouk · 14 years ago
  59. f0c1df4 Begin adding async allocation creation. by Jason Sams · 14 years ago
  60. 2353ae3 Async type creation. by Jason Sams · 14 years ago
  61. 39f2ef6 Update allocation from bitmap. GL attribute cleanup in type. by Alex Sakhartchouk · 14 years ago
  62. 0977c94 Fix support for 64-bit integers. by Stephen Hines · 14 years ago
  63. d7e5481 Cleanup error message for null binding address. by Jason Sams · 14 years ago
  64. 96abf81 Implement allocation resizing. by Jason Sams · 14 years ago
  65. 1103d8e Adding anisotropic filtering and related samples. by Alex Sakhartchouk · 14 years ago
  66. 383e5b1 Adding support for all allowed textures. by Alex Sakhartchouk · 14 years ago
  67. b9077f4 Better debugging for scripts. by Jason Sams · 14 years ago
  68. 6d0a074 Add support for Float64 (double) to RenderScript. by Stephen Hines · 14 years ago
  69. 46e4554 Add arrays to elements. by Jason Sams · 14 years ago
  70. 5f0c84c SubElementData data upload functions. by Jason Sams · 14 years ago
  71. 46bafb3 Make java entry points for native fifo synchronized. by Jason Sams · 14 years ago
  72. 9fc9f03 Added ability to set font color. by Alex Sakhartchouk · 14 years ago
  73. 417e6a4 Populate java objects with native data from a3d file. by Alex Sakhartchouk · 14 years ago
  74. d18c744 Work on synchronizing a3d created files and java layer. by Alex Sakhartchouk · 14 years ago
  75. 479e292 Remove points from fixed function. Add basic GL performance test. by Jason Sams · 14 years ago
  76. 17d72e8 Cleanup pass on the mesh api change. by Alex Sakhartchouk · 14 years ago
  77. 4e9a7a8 Start of mesh API cleanup. by Alex Sakhartchouk · 14 years ago
  78. 4ab16b5 am 177c405a: am c6e1d880: Merge "Introduce official public NativeWindow type." into gingerbread by Dianne Hackborn · 14 years ago
  79. 1c769c3 Introduce official public NativeWindow type. by Dianne Hackborn · 14 years ago
  80. d3e0ad4 Adding freetype font rendering to renderscript. by Alex Sakhartchouk · 14 years ago
  81. 8c88090 Remove InvokeData and add ContextFinish to generate a sync point. by Jason Sams · 14 years ago
  82. b825f67 Creating the jni and java layer to integrate a3d by Alex Sakhartchouk · 14 years ago
  83. 22fa371 Begin naming cleanup for renderscript runtime. by Jason Sams · 14 years ago
  84. ce92d4b Remove more pieces of setRoot. Add pointer to allocation lookup for scripts. by Jason Sams · 14 years ago
  85. 639e6e9 Delete legacy setDefine API. by Jason Sams · 14 years ago
  86. ccc010b Rename ProgramFragmentStore to ProgramStore. by Jason Sams · 14 years ago
  87. be36bf3 Convert renderscript from using ACC to LLVM for its compiler. by Jason Sams · 14 years ago
  88. c1ed589 checkpoint animations by Jason Sams · 14 years ago
  89. a2cf755 Improve RS error handling. On errors RS will now store the error and a message that can be read from the app. RS will then not continue rendering frames while an unchecked error is present until new state is received. by Jason Sams · 14 years ago
  90. fa84da2 Add support for linking to a skia bitmap rather than always copying the data from the bitmap. by Jason Sams · 14 years ago
  91. 7fabe1a Support defered generation of mipmaps. With this change we support mipmap generation when the texture is uploaded to GL without requiring RS to retain the full chain. by Jason Sams · 14 years ago
  92. fa40286 real fix for [2440014] launcher2 crashing in loop during boot by Mathias Agopian · 14 years ago
  93. b4d3568 Add RS support for generic attribs as input to vertex programs. by Jason Sams · 15 years ago
  94. d01d970 Element restructuring. Add support for new basic Element types including the RS objects and vectors(2-4). In theory this paves the way for maintaining type info for RS objects, passing elements for GLSL uiforms/attribs/varyings, and supporting nested structures. by Jason Sams · 15 years ago
  95. 7dad9c3 Move texture bindings to base program object. Change ProgramFragment creation to require a texture format in 1.0 mode. by Jason Sams · 15 years ago
  96. f2e4fa2 Continue es2 shader dev by Jason Sams · 15 years ago
  97. 4815c0d Continue development of es2.0 user shader support for renderscript. This change cleans up ProgramVertex creation and adds support for passing input, output, and constant type info. by Jason Sams · 15 years ago
  98. f2a5d73 Beging GL2 user shaders. Switch master to using GL2 by default. by Jason Sams · 15 years ago
  99. c21cf40 Add support for dumping RS objects to aid in debugging of white blocks bug. by Jason Sams · 15 years ago
  100. 1583244 Add setPriority to allow wallpapers to run at lower cpu priority than default. by Jason Sams · 15 years ago