blob: f5e83eaac6182cb01cd10492e98cbd034a9f5674 [file] [log] [blame]
John McCall018591f2011-03-02 02:04:40 +00001// RUN: %clang_cc1 -fcxx-exceptions -fexceptions -verify %s
Douglas Gregorc05babe2010-07-01 14:21:35 +00002struct A { };
3struct B { };
Douglas Gregorb87786f2010-07-01 17:48:08 +00004struct C { };
Douglas Gregorc05babe2010-07-01 14:21:35 +00005
Douglas Gregorb87786f2010-07-01 17:48:08 +00006// Destructor
Douglas Gregorc05babe2010-07-01 14:21:35 +00007struct X0 {
8 virtual ~X0() throw(A); // expected-note{{overridden virtual function is here}}
9};
10struct X1 {
11 virtual ~X1() throw(B); // expected-note{{overridden virtual function is here}}
12};
13struct X2 : public X0, public X1 { }; // expected-error 2{{exception specification of overriding function is more lax than base version}}
14
Douglas Gregorb87786f2010-07-01 17:48:08 +000015// Copy-assignment operator.
16struct CA0 {
17 CA0 &operator=(const CA0&) throw(A);
18};
19struct CA1 {
20 CA1 &operator=(const CA1&) throw(B);
21};
22struct CA2 : CA0, CA1 { };
23
24void test_CA() {
25 CA2 &(CA2::*captr1)(const CA2&) throw(A, B) = &CA2::operator=;
26 CA2 &(CA2::*captr2)(const CA2&) throw(A, B, C) = &CA2::operator=;
27 CA2 &(CA2::*captr3)(const CA2&) throw(A) = &CA2::operator=; // expected-error{{target exception specification is not superset of source}}
28 CA2 &(CA2::*captr4)(const CA2&) throw(B) = &CA2::operator=; // expected-error{{target exception specification is not superset of source}}
29}