Don't build e2fsck statically by default anymore

Also removed the --enable-dynamic-static configure option.

Unfortunately the usefulness of building e2fsck statically is gone on
all modern distributions, since everything else on the system is built
dynamically these days.  In fact on some distributions it is almost
impossible to build programs statically any more.

Signed-off-by: "Theodore Ts'o" <tytso@mit.edu>
diff --git a/debian/rules b/debian/rules
index b5c00e7..6e74c2f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -97,8 +97,7 @@
 BF_CCOPTS = -Os -fomit-frame-pointer
 
 COMMON_CONF_FLAGS =  \
-                --enable-elf-shlibs --enable-dynamic-e2fsck \
-                --infodir=/usr/share/info --enable-fsck
+                --enable-elf-shlibs --infodir=/usr/share/info --enable-fsck
 
 STD_CONF_FLAGS = --with-ccopts="${CCOPTS}" --enable-compression \
 		${DEVMAPPER}
@@ -199,6 +198,7 @@
 ${BUILDSTDSTAMP}: ${CFGSTDSTAMP}
 	dh_testdir
 	$(MAKE) -C ${stdbuilddir} all
+	$(MAKE) -C ${stdbuilddir}/e2fsck e2fsck.static
 
 	( cd ${stdbuilddir}/doc && \
 	  texi2html -split_chapter ${topdir}/doc/libext2fs.texinfo )
@@ -231,7 +231,7 @@
 ${BUILDSTATICSTAMP}: ${CFGSTATICSTAMP}
 	dh_testdir
 	$(MAKE) -C ${staticbuilddir} libs
-	$(MAKE) -C ${staticbuilddir}/e2fsck all
+	$(MAKE) -C ${staticbuilddir}/e2fsck all e2fsck.static
 	touch ${BUILDSTATICSTAMP}
 
 clean: