blob: 2548d5593f125e9a38ebb757c95ab2c96f3067ad [file] [log] [blame]
Roland McGrath00a18752007-02-18 22:55:21 +00001Summary: Tracks and displays system calls associated with a running process
Roland McGrath037124f2003-01-10 10:44:57 +00002Name: strace
Dmitry V. Levined1f2062016-05-31 11:12:13 +00003Version: 4.12
4Release: 1%{?dist}
5%define srcname %name-%version
Roland McGrath037124f2003-01-10 10:44:57 +00006License: BSD
7Group: Development/Debuggers
8URL: http://sourceforge.net/projects/strace/
Dmitry V. Levin3ce8e9f2016-05-31 10:47:53 +00009Source: http://downloads.sourceforge.net/strace/%{srcname}.tar.xz
Dmitry V. Levin24fb8ef2015-12-24 00:02:36 +000010BuildRequires: time
Dmitry V. Levin796fbe02015-12-23 04:23:13 +000011%ifarch x86_64
12# for experimental -k option
13BuildRequires: libunwind-devel
14%endif
Roland McGrath7c2ec572008-03-26 19:15:41 +000015%define strace64_arches ppc64 sparc64
Roland McGratha943d002003-09-24 22:22:42 +000016
Roland McGrath037124f2003-01-10 10:44:57 +000017%description
18The strace program intercepts and records the system calls called and
19received by a running process. Strace can print a record of each
20system call, its arguments and its return value. Strace is useful for
21diagnosing problems and debugging, as well as for instructional
22purposes.
23
24Install strace if you need a tool to track the system calls made and
25received by a process.
26
Roland McGratha943d002003-09-24 22:22:42 +000027%ifarch %{strace64_arches}
28%package -n strace64
29Summary: Tracks and displays system calls associated with a running process.
30Group: Development/Debuggers
31
32%description -n strace64
33The strace program intercepts and records the system calls called and
34received by a running process. Strace can print a record of each
35system call, its arguments and its return value. Strace is useful for
36diagnosing problems and debugging, as well as for instructional
37purposes.
38
39Install strace if you need a tool to track the system calls made and
40received by a process.
41
42This package provides the `strace64' program to trace 64-bit processes.
43The `strace' program in the `strace' package is for 32-bit processes.
44%endif
45
Roland McGrath037124f2003-01-10 10:44:57 +000046%prep
Dmitry V. Levin3ce8e9f2016-05-31 10:47:53 +000047%setup -q -n %{srcname}
Roland McGrath037124f2003-01-10 10:44:57 +000048
49%build
Dmitry V. Levined1f2062016-05-31 11:12:13 +000050echo 'BEGIN OF BUILD ENVIRONMENT INFORMATION'
51uname -a |head -1
52libc="$(ldd /bin/sh |sed -n 's|^[^/]*\(/[^ ]*/libc\.so[^ ]*\).*|\1|p' |head -1)"
53$libc |head -1
54file -L /bin/sh
55gcc --version |head -1
56kver="$(echo -e '#include <linux/version.h>\nLINUX_VERSION_CODE' | gcc -E -P -)"
57printf 'kernel-headers %%s.%%s.%%s\n' $(($kver/65536)) $(($kver/256%%256)) $(($kver%%256))
58echo 'END OF BUILD ENVIRONMENT INFORMATION'
59
Roland McGrath037124f2003-01-10 10:44:57 +000060%configure
Roland McGrathcddc21f2007-02-18 22:56:37 +000061make %{?_smp_mflags}
Roland McGrath037124f2003-01-10 10:44:57 +000062
63%install
Roland McGrath00a18752007-02-18 22:55:21 +000064make DESTDIR=%{buildroot} install
Roland McGrath037124f2003-01-10 10:44:57 +000065
66# remove unpackaged files from the buildroot
67rm -f %{buildroot}%{_bindir}/strace-graph
68
Roland McGrath3f0dbe22008-08-28 23:26:21 +000069%define copy64 ln
70%if 0%{?rhel}
71%if 0%{?rhel} < 6
72%endif
73%define copy64 cp -p
74%endif
75
Roland McGratha943d002003-09-24 22:22:42 +000076%ifarch %{strace64_arches}
Roland McGrath3f0dbe22008-08-28 23:26:21 +000077%{copy64} %{buildroot}%{_bindir}/strace %{buildroot}%{_bindir}/strace64
Roland McGratha943d002003-09-24 22:22:42 +000078%endif
79
Dmitry V. Levin983e8752011-02-27 10:16:41 +000080%check
Dmitry V. Levin3ce8e9f2016-05-31 10:47:53 +000081make %{?_smp_mflags} -k check VERBOSE=1
Dmitry V. Levined1f2062016-05-31 11:12:13 +000082echo 'BEGIN OF TEST SUITE INFORMATION'
83tail -n 99999 -- tests*/test-suite.log tests*/ksysent.log
84echo 'END OF TEST SUITE INFORMATION'
Dmitry V. Levin983e8752011-02-27 10:16:41 +000085
Roland McGrath037124f2003-01-10 10:44:57 +000086%files
Mike Frysinger6c191362013-05-15 16:33:09 -040087%doc CREDITS ChangeLog ChangeLog-CVS COPYING NEWS README
Roland McGrath037124f2003-01-10 10:44:57 +000088%{_bindir}/strace
Dmitry V. Levin54432562012-04-27 23:38:44 +000089%{_bindir}/strace-log-merge
Roland McGrath037124f2003-01-10 10:44:57 +000090%{_mandir}/man1/*
91
Roland McGratha943d002003-09-24 22:22:42 +000092%ifarch %{strace64_arches}
93%files -n strace64
Roland McGratha943d002003-09-24 22:22:42 +000094%{_bindir}/strace64
95%endif
96
Roland McGrath037124f2003-01-10 10:44:57 +000097%changelog
Dmitry V. Levined1f2062016-05-31 11:12:13 +000098* Tue May 31 2016 Dmitry V. Levin <ldv@altlinux.org> - 4.12-1
99- 4.11.0.163.9720 -> 4.12.
100
Dmitry V. Levin3ce8e9f2016-05-31 10:47:53 +0000101* Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 4.11.0.163.9720-2
102- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
103
104* Fri Jan 15 2016 Dmitry V. Levin <ldv@altlinux.org> - 4.11.0.163.9720-1
105- New upstream snapshot v4.11-163-g972018f:
106 + fixed decoding of syscalls unknown to the kernel on s390/s390x (#1298294).
107
Dmitry V. Levin796fbe02015-12-23 04:23:13 +0000108* Wed Dec 23 2015 Dmitry V. Levin <ldv@altlinux.org> - 4.11-2
109- Enabled experimental -k option on x86_64 (#1170296).
110
Dmitry V. Levin2acb0652015-12-21 20:21:22 +0000111* Mon Dec 21 2015 Dmitry V. Levin <ldv@altlinux.org> - 4.11-1
112- New upstream release:
113 + print nanoseconds along with seconds in stat family syscalls (#1251176).
114
Dmitry V. Levin4fa80732015-12-20 00:51:51 +0000115* Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.10-3
116- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
117
118* Mon May 11 2015 Marcin Juszkiewicz <mjuszkiewicz@redhat.com> - 4.10-2
119- Backport set of upstream patches to get it buildable on AArch64
120
Dmitry V. Levindfabccf2015-03-06 13:14:15 +0000121* Fri Mar 06 2015 Dmitry V. Levin <ldv@altlinux.org> - 4.10-1
122- New upstream release:
123 + enhanced ioctl decoding (#902788).
124
125* Mon Nov 03 2014 Lubomir Rintel <lkundrak@v3.sk> - 4.9-3
126- Regenerate ioctl entries with proper kernel headers
127
128* Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.9-2
129- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
130
Dmitry V. Levine4db4c42014-08-15 13:14:15 +0000131* Fri Aug 15 2014 Dmitry V. Levin <ldv@altlinux.org> - 4.9-1
132- New upstream release:
133 + fixed build when <sys/ptrace.h> and <linux/ptrace.h> conflict (#993384);
134 + updated CLOCK_* constants (#1088455);
135 + enabled ppc64le support (#1122323);
136 + fixed attach to a process on ppc64le (#1129569).
137
Dmitry V. Levina283ae02014-08-15 13:14:15 +0000138* Fri Jul 25 2014 Dan Horák <dan[at]danny.cz> - 4.8-5
139- update for ppc64
140
141* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.8-4
142- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
143
144* Fri Dec 6 2013 Peter Robinson <pbrobinson@fedoraproject.org> 4.8-3
145- Fix FTBFS
146
147* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.8-2
148- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
149
Dmitry V. Levind8454112013-06-03 12:34:56 +0000150* Mon Jun 03 2013 Dmitry V. Levin <ldv@altlinux.org> - 4.8-1
151- New upstream release:
152 + fixed ERESTARTNOINTR leaking to userspace on ancient kernels (#659382);
153 + fixed decoding of *xattr syscalls (#885233);
154 + fixed handling of files with 64-bit inode numbers by 32-bit strace (#912790);
155 + added aarch64 support (#969858).
156
Dmitry V. Levin0eb71652013-05-17 23:16:39 +0000157* Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.7-3
158- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
159
160* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.7-2
161- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
162
Dmitry V. Levin417eb882012-05-02 12:34:56 +0000163* Wed May 02 2012 Dmitry V. Levin <ldv@altlinux.org> 4.7-1
164- New upstream release.
165 + implemented proper handling of real SIGTRAPs (#162774).
166
Dmitry V. Levin48e95c72012-04-20 17:31:48 +0000167* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.6-2
168- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
169
Dmitry V. Levin50e69cb2011-02-21 22:58:59 +0000170* Mon Mar 14 2011 Dmitry V. Levin <ldv@altlinux.org> - 4.6-1
171- New upstream release.
172 + fixed a corner case in waitpid handling (#663547).
173
Dmitry V. Levinc36c3032011-02-21 23:22:34 +0000174* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.5.20-2
175- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
176
Dmitry V. Levinacbe5182010-04-06 23:46:43 +0000177* Tue Apr 13 2010 Roland McGrath <roland@redhat.com> - 4.5.20-1
178- New upstream release, work mostly by Andreas Schwab and Dmitry V. Levin.
179 + fixed potential stack buffer overflow in select decoder (#556678);
180 + fixed FTBFS (#539044).
181
Roland McGrath7d9247e2009-10-21 10:36:13 -0700182* Wed Oct 21 2009 Roland McGrath <roland@redhat.com> - 4.5.19-1
183- New upstream release, work mostly by Dmitry V. Levin <ldv@altlinux.org>
Dmitry V. Levinfbfed222009-09-14 16:34:34 +0000184 + exit/kill strace with traced process exitcode/signal (#105371);
185 + fixed build on ARM EABI (#507576);
186 + fixed display of 32-bit argv array on 64-bit architectures (#519480);
187 + fixed display of 32-bit fcntl(F_SETLK) on 64-bit architectures (#471169);
188 + fixed several bugs in strings decoder, including potential heap
189 memory corruption (#470529, #478324, #511035).
190
Roland McGrath09db7052008-08-28 22:00:46 +0000191* Thu Aug 28 2008 Roland McGrath <roland@redhat.com> - 4.5.18-1
192- build fix for newer kernel headers (#457291)
193- fix CLONE_VFORK handling (#455078)
194- Support new Linux/PPC system call subpage_prot and PROT_SAO flag.
195- In sigaction system call, display sa_flags value along with SIG_DFL/SIG_IGN.
196
Roland McGrath6a1311d2008-07-22 00:43:09 +0000197* Mon Jul 21 2008 Roland McGrath <roland@redhat.com> - 4.5.17-1
Roland McGrath55dd2782008-07-18 02:21:11 +0000198- handle O_CLOEXEC, MSG_CMSG_CLOEXEC (#365781)
199- fix biarch stat64 decoding (#222275)
200- fix spurious "..." in printing of environment strings (#358241)
201- improve prctl decoding (#364401)
202- fix hang wait on exited child with exited child (#354261)
203- fix biarch fork/vfork (-f) tracing (#447475)
204- fix biarch printing of negative argument kill (#430585)
205- fix biarch decoding of error return values (#447587)
206- fix -f tracing of CLONE_VFORK (#455078)
207- fix ia64 register clobberation in -f tracing (#453438)
208- print SO_NODEFER, SA_RESETHAND instead of SA_NOMASK, SA_ONESHOT (#455821)
209- fix futex argument decoding (#448628, #448629)
210
Roland McGrath47d32232007-08-03 10:28:55 +0000211* Fri Aug 3 2007 Roland McGrath <roland@redhat.com> - 4.5.16-1
212- fix multithread issues (#240962, #240961, #247907)
213- fix spurious SIGSTOP on early interrupt (#240986)
214- fix utime for biarch (#247185)
215- fix -u error message (#247170)
216- better futex syscall printing (##241467)
217- fix argv/envp printing with small -s settings, and for biarch
218- new syscalls: getcpu, eventfd, timerfd, signalfd, epoll_pwait,
219 move_pages, utimensat
220
Roland McGrath0a45fae2007-01-16 23:25:34 +0000221* Tue Jan 16 2007 Roland McGrath <roland@redhat.com> - 4.5.15-1
Roland McGrathcdec4692007-01-11 22:22:47 +0000222- biarch fixes (#179740, #192193, #171626, #173050, #218433, #218043)
223- fix -ff -o behavior (#204950, #218435, #193808, #219423)
224- better quotactl printing (#118696)
225- *at, inotify*, pselect6, ppoll and unshare syscalls (#178633, #191275)
226- glibc-2.5 build fixes (#209856)
227- memory corruption fixes (#200621
228- fix race in child setup under -f (#180293)
229- show ipc key values in hex (#198179, #192182)
230- disallow -c with -ff (#187847)
231- Resolves: RHBZ #179740, RHBZ #192193, RHBZ #204950, RHBZ #218435
232- Resolves: RHBZ #193808, RHBZ #219423, RHBZ #171626, RHBZ #173050
233- Resolves: RHBZ #218433, RHBZ #218043, RHBZ #118696, RHBZ #178633
234- Resolves: RHBZ #191275, RHBZ #209856, RHBZ #200621, RHBZ #180293
235- Resolves: RHBZ #198179, RHBZ #198182, RHBZ #187847
236
237* Mon Nov 20 2006 Jakub Jelinek <jakub@redhat.com> - 4.5.14-4
238- Fix ia64 syscall decoding (#206768)
239- Fix build with glibc-2.4.90-33 and up on all arches but ia64
240- Fix build against 2.6.18+ headers
241
242* Tue Aug 22 2006 Roland McGrath <roland@redhat.com> - 4.5.14-3
243- Fix bogus decoding of syscalls >= 300 (#201462, #202620).
244
245* Fri Jul 14 2006 Jesse Keating <jkeating@redhat.com> - 4.5.14-2
246- rebuild
247
248* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 4.5.14-1.2
249- bump again for long double bug on ppc{,64}
250
251* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 4.5.14-1.1
252- rebuilt for new gcc4.1 snapshot and glibc changes
253
Roland McGrathf4d9b492006-01-17 06:22:57 +0000254* Mon Jan 16 2006 Roland McGrath <roland@redhat.com> - 4.5.14-1
255- Fix biarch decoding of socket syscalls (#174354).
256- Fix biarch -e support (#173986).
257- Accept numeric syscalls in -e (#174798).
258- Fix ipc syscall decoding (#164755).
259- Improve msgrcv printing (#164757).
260- Man page updates (#165375).
261- Improve mount syscall printing (#165377).
262- Correct printing of restarting syscalls (#165469).
263
Roland McGrathcab43802005-08-03 11:42:35 +0000264* Wed Aug 3 2005 Roland McGrath <roland@redhat.com> - 4.5.13-1
265- Fix setsockopt decoding on 64-bit (#162449).
266- Fix typos in socket option name strings (#161578).
267- Display more IPV6 socket options by name (#162450).
268- Don't display inappropriate syscalls for -e trace=file (#159340).
269- New selector type -e trace=desc for file-descriptor using calls (#159400).
270- Fix 32-bit old_mmap syscall decoding on x86-64 (#162467, #164215).
271- Fix errors detaching from multithreaded process on interrupt (#161919).
272- Note 4.5.12 fix for crash handling bad signal numbers (#162739).
273
Roland McGrath182cbf42005-06-10 03:56:16 +0000274* Wed Jun 8 2005 Roland McGrath <roland@redhat.com> - 4.5.12-1
275- Fix known syscall recognition for IA32 processes on x86-64 (#158934).
276- Fix bad output for ptrace on x86-64 (#159787).
277- Fix potential buffer overruns (#151570, #159196).
278- Make some diagnostics more consistent (#159308).
279- Update PowerPC system calls.
280- Better printing for Linux aio system calls.
281- Don't truncate statfs64 fields to 32 bits in output (#158243).
282- Cosmetic code cleanups (#159688).
283
Roland McGrath7147a3d2005-03-22 23:12:39 +0000284* Tue Mar 22 2005 Roland McGrath <roland@redhat.com> - 4.5.11-1
285- Build tweaks.
286- Note 4.5.10 select fix (#151570).
287
Roland McGrathd8184032005-03-15 02:40:12 +0000288* Mon Mar 14 2005 Roland McGrath <roland@redhat.com> - 4.5.10-1
289- Fix select handling on nonstandard fd_set sizes.
290- Don't print errors for null file name pointers.
291- Fix initial execve output with -i (#143365).
292
Roland McGrath6df9d642005-02-04 10:13:15 +0000293* Fri Feb 4 2005 Roland McGrath <roland@redhat.com> - 4.5.9-2
Roland McGrathd63311a2005-02-04 09:29:04 +0000294- update ia64 syscall list (#146245)
295- fix x86_64 syscall argument extraction for 32-bit processes (#146093)
296- fix -e signal=NAME parsing (#143362)
297- fix x86_64 exit_group syscall handling
298- improve socket ioctl printing (#138223)
299- code cleanups (#143369, #143370)
300- improve mount flags printing (#141932)
301- support symbolic printing of x86_64 arch_prctl parameters (#142667)
302- fix potential crash in getxattr printing
303
Roland McGrathf041d472004-10-20 02:17:52 +0000304* Tue Oct 19 2004 Roland McGrath <roland@redhat.com> - 4.5.8-1
305- fix multithreaded exit handling (#132150, #135254)
306- fix ioctl name matching (#129808)
307- print RTC_* ioctl structure contents (#58606)
308- grok epoll_* syscalls (#134463)
309- grok new RLIMIT_* values (#133594)
310- print struct cmsghdr contents for sendmsg (#131689)
311- fix clock_* and timer_* argument output (#131420)
312
Roland McGrath61d64872004-08-31 08:58:10 +0000313* Tue Aug 31 2004 Roland McGrath <roland@redhat.com> - 4.5.7-2
Roland McGrathb93f9182004-08-31 08:17:20 +0000314- new upstream version, misc fixes and updates (#128091, #129166, #128391, #129378, #130965, #131177)
315
Roland McGrath785a0262004-07-12 07:55:48 +0000316* Mon Jul 12 2004 Roland McGrath <roland@redhat.com> 4.5.6-1
317- new upstream version, updates ioctl lists (#127398), fixes quotactl (#127393), more ioctl decoding (#126917)
318
Roland McGrathb7e2ca12004-06-28 05:24:29 +0000319* Sun Jun 27 2004 Roland McGrath <roland@redhat.com> 4.5.5-1
320- new upstream version, fixes x86-64 biarch support (#126547)
321
322* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com> 4.5.4-2
323- rebuilt
324
325* Thu Jun 3 2004 Roland McGrath <roland@redhat.com> 4.5.4-0.FC1
326- rebuilt for FC1 update
327
Roland McGrathed8e77e2004-06-04 02:35:58 +0000328* Thu Jun 3 2004 Roland McGrath <roland@redhat.com> 4.5.4-1
329- new upstream version, more ioctls (#122257), minor fixes
330
Roland McGratha8c555f2004-04-16 22:28:41 +0000331* Fri Apr 16 2004 Roland McGrath <roland@redhat.com> 4.5.3-1
332- new upstream version, mq_* calls (#120701), -p vs NPTL (#120462), more fixes (#118694, #120541, #118685)
333
334* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com> 4.5.2-1.1
335- rebuilt
336
Roland McGrathb66e9362004-03-02 06:38:35 +0000337* Mon Mar 1 2004 Roland McGrath <roland@redhat.com> 4.5.2-1
338- new upstream version, sched_* calls (#116990), show core flag (#112117)
339
340* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
341- rebuilt
342
Roland McGrath00eb84e2003-11-14 02:57:22 +0000343* Thu Nov 13 2003 Roland McGrath <roland@redhat.com> 4.5.1-1
344- new upstream version, more fixes (#108012, #105366, #105359, #105358)
345
346* Tue Sep 30 2003 Roland McGrath <roland@redhat.com> 4.5-3
347- revert bogus s390 fix
348
349* Thu Sep 25 2003 Roland McGrath <roland@redhat.com> 4.5-1.2.1AS
350- rebuilt for 2.1AS erratum
351
352* Wed Sep 24 2003 Roland McGrath <roland@redhat.com> 4.5-2
353- rebuilt
354
Roland McGrath739868f2003-09-24 23:05:09 +0000355* Wed Sep 24 2003 Roland McGrath <roland@redhat.com> 4.5-1
356- new upstream version, more fixes (#101499, #104365)
357
Roland McGratha943d002003-09-24 22:22:42 +0000358* Thu Jul 17 2003 Roland McGrath <roland@redhat.com> 4.4.99-2
359- rebuilt
360
Roland McGrathcb612142003-07-17 09:23:56 +0000361* Thu Jul 17 2003 Roland McGrath <roland@redhat.com> 4.4.99-1
362- new upstream version, groks more new system calls, PF_INET6 sockets
363
Dmitry V. Levine4db4c42014-08-15 13:14:15 +0000364* Tue Jun 10 2003 Roland McGrath <roland@redhat.com> 4.4.98-1
Roland McGrath64ffba52003-06-02 19:37:48 +0000365- new upstream version, more fixes (#90754, #91085)
366
Roland McGrathacd3cd72003-06-11 05:37:56 +0000367* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
368- rebuilt
369
Roland McGrath1b86e2d2003-03-31 01:21:36 +0000370* Sun Mar 30 2003 Roland McGrath <roland@redhat.com> 4.4.96-1
371- new upstream version, handles yet more 2.5 syscalls, x86_64 & ia64 fixes
372
Roland McGrath215da2a2003-03-31 01:46:47 +0000373* Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com> 4.4.95-2
374- rebuilt
375
Roland McGrath1893d052003-02-24 10:53:44 +0000376* Mon Feb 24 2003 Roland McGrath <roland@redhat.com> 4.4.95-1
377- new upstream version, fixed getresuid/getresgid (#84959)
378
Roland McGrath6c2fe9d2003-02-20 03:26:47 +0000379* Wed Feb 19 2003 Roland McGrath <roland@redhat.com> 4.4.94-1
380- new upstream version, new option -E to set environment variables (#82392)
381
382* Wed Jan 22 2003 Tim Powers <timp@redhat.com> 4.4.93-2
383- rebuilt
384
Roland McGrathee061722003-01-22 02:27:51 +0000385* Tue Jan 21 2003 Roland McGrath <roland@redhat.com> 4.4.93-1
386- new upstream version, fixes ppc and s390 bugs, adds missing ptrace requests
387
Roland McGrath1d847cf2003-01-10 21:43:24 +0000388* Fri Jan 10 2003 Roland McGrath <roland@redhat.com> 4.4.91-1
389- new upstream version, fixes -f on x86-64
390
Roland McGrath037124f2003-01-10 10:44:57 +0000391* Fri Jan 10 2003 Roland McGrath <roland@redhat.com> 4.4.90-1
392- new upstream version, fixes all known bugs modulo ia64 and s390 issues
393
394* Fri Jan 03 2003 Florian La Roche <Florian.LaRoche@redhat.de> 4.4-11
395- add further s390 patch from IBM
396
397* Wed Nov 27 2002 Tim Powers <timp@redhat.com> 4.4-10
398- remove unpackaged files from the buildroot
399
400* Mon Oct 07 2002 Phil Knirsch <pknirsch@redhat.com> 4.4-9.1
401- Added latest s390(x) patch.
402
403* Fri Sep 06 2002 Karsten Hopp <karsten@redhat.de> 4.4-9
404- preliminary x86_64 support with an ugly patch to help
405 debugging. Needs cleanup!
406
407* Mon Sep 2 2002 Jakub Jelinek <jakub@redhat.com> 4.4-8
408- newer version of the clone fixing patch (Roland McGrath)
409- aio syscalls for i386/ia64/ppc (Ben LaHaise)
410
411* Wed Aug 28 2002 Jakub Jelinek <jakub@redhat.com> 4.4-7
412- fix strace -f (Roland McGrath, #68994)
413- handle ?et_thread_area, SA_RESTORER (Ulrich Drepper)
414
415* Fri Jun 21 2002 Jakub Jelinek <jakub@redhat.com> 4.4-6
416- handle futexes, *xattr, sendfile64, etc. (Ulrich Drepper)
417- handle modify_ldt (#66894)
418
419* Thu May 23 2002 Tim Powers <timp@redhat.com>
420- automated rebuild
421
422* Tue Apr 16 2002 Jakub Jelinek <jakub@redhat.com> 4.4-4
423- fix for the last patch by Jeff Law (#62591)
424
425* Mon Mar 4 2002 Preston Brown <pbrown@redhat.com> 4.4-3
426- integrate patch from Jeff Law to eliminate hang tracing threads
427
428* Sat Feb 23 2002 Florian La Roche <Florian.LaRoche@redhat.de>
429- minor update from debian tar-ball
430
431* Wed Jan 02 2002 Florian La Roche <Florian.LaRoche@redhat.de>
432- update to 4.4
433
434* Sun Jul 22 2001 Florian La Roche <Florian.LaRoche@redhat.de>
435- disable s390 patches, they are already included
436
437* Wed Jul 18 2001 Preston Brown <pbrown@redhat.com> 4.3-1
438- new upstream version. Seems to have integrated most new syscalls
439- tracing threaded programs is now functional.
440
441* Mon Jun 11 2001 Than Ngo <than@redhat.com>
442- port s390 patches from IBM
443
444* Wed May 16 2001 Nalin Dahyabhai <nalin@redhat.com>
445- modify new syscall patch to allocate enough heap space in setgroups32()
446
447* Wed Feb 14 2001 Jakub Jelinek <jakub@redhat.com>
448- #include <time.h> in addition to <sys/time.h>
449
450* Fri Jan 26 2001 Karsten Hopp <karsten@redhat.com>
451- clean up conflicting patches. This happened only
452 when building on S390
453
454* Fri Jan 19 2001 Bill Nottingham <notting@redhat.com>
455- update to CVS, reintegrate ia64 support
456
Dmitry V. Levine4db4c42014-08-15 13:14:15 +0000457* Fri Dec 8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
Roland McGrath037124f2003-01-10 10:44:57 +0000458- Get S/390 support into the normal package
459
460* Sat Nov 18 2000 Florian La Roche <Florian.LaRoche@redhat.de>
461- added S/390 patch from IBM, adapting it to not conflict with
462 IA64 patch
463
464* Sat Aug 19 2000 Jakub Jelinek <jakub@redhat.com>
465- doh, actually apply the 2.4 syscalls patch
466- make it compile with 2.4.0-test7-pre4+ headers, add
467 getdents64 and fcntl64
468
469* Thu Aug 3 2000 Jakub Jelinek <jakub@redhat.com>
470- add a bunch of new 2.4 syscalls (#14036)
471
472* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
473- automatic rebuild
474- excludearch ia64
475
476* Fri Jun 2 2000 Matt Wilson <msw@redhat.com>
477- use buildinstall for FHS
478
479* Wed May 24 2000 Jakub Jelinek <jakub@redhat.com>
480- make things compile on sparc
481- fix sigreturn on sparc
482
483* Fri Mar 31 2000 Bill Nottingham <notting@redhat.com>
484- fix stat64 misdef (#10485)
485
486* Tue Mar 21 2000 Michael K. Johnson <johnsonm@redhat.com>
487- added ia64 patch
488
489* Thu Feb 03 2000 Cristian Gafton <gafton@redhat.com>
490- man pages are compressed
491- version 4.2 (why are we keeping all these patches around?)
492
493* Sat Nov 27 1999 Jeff Johnson <jbj@redhat.com>
494- update to 4.1 (with sparc socketcall patch).
495
496* Fri Nov 12 1999 Jakub Jelinek <jakub@redhat.com>
497- fix socketcall on sparc.
498
499* Thu Sep 02 1999 Cristian Gafton <gafton@redhat.com>
500- fix KERN_SECURELVL compile problem
501
502* Tue Aug 31 1999 Cristian Gafton <gafton@redhat.com>
503- added alpha patch from HJLu to fix the osf_sigprocmask interpretation
504
505* Sat Jun 12 1999 Jeff Johnson <jbj@redhat.com>
506- update to 3.99.1.
507
508* Wed Jun 2 1999 Jeff Johnson <jbj@redhat.com>
509- add (the other :-) jj's sparc patch.
510
511* Wed May 26 1999 Jeff Johnson <jbj@redhat.com>
512- upgrade to 3.99 in order to
513- add new 2.2.x open flags (#2955).
514- add new 2.2.x syscalls (#2866).
515- strace 3.1 patches carried along for now.
516
517* Sun May 16 1999 Jeff Johnson <jbj@redhat.com>
Roland McGrath00a18752007-02-18 22:55:21 +0000518- don't rely on (broken!) rpm %%patch (#2735)
Roland McGrath037124f2003-01-10 10:44:57 +0000519
520* Tue Apr 06 1999 Preston Brown <pbrown@redhat.com>
521- strip binary
522
523* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
524- auto rebuild in the new build environment (release 16)
525
526* Tue Feb 9 1999 Jeff Johnson <jbj@redhat.com>
527- vfork est arrive!
528
529* Tue Feb 9 1999 Christopher Blizzard <blizzard@redhat.com>
530- Add patch to follow clone() syscalls, too.
531
532* Sun Jan 17 1999 Jeff Johnson <jbj@redhat.com>
533- patch to build alpha/sparc with glibc 2.1.
534
535* Thu Dec 03 1998 Cristian Gafton <gafton@redhat.com>
536- patch to build on ARM
537
538* Wed Sep 30 1998 Jeff Johnson <jbj@redhat.com>
539- fix typo (printf, not tprintf).
540
541* Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
542- fix compile problem on sparc.
543
544* Tue Aug 18 1998 Cristian Gafton <gafton@redhat.com>
545- buildroot
546
547* Mon Jul 20 1998 Cristian Gafton <gafton@redhat.com>
548- added the umoven patch from James Youngman <jay@gnu.org>
549- fixed build problems on newer glibc releases
550
551* Mon Jun 08 1998 Prospector System <bugs@redhat.com>
552- translations modified for de, fr, tr