Roland McGrath | 037124f | 2003-01-10 10:44:57 +0000 | [diff] [blame] | 1 | Summary: Tracks and displays system calls associated with a running process. |
| 2 | Name: strace |
Roland McGrath | ed8e77e | 2004-06-04 02:35:58 +0000 | [diff] [blame^] | 3 | Version: 4.5.4 |
Roland McGrath | 037124f | 2003-01-10 10:44:57 +0000 | [diff] [blame] | 4 | Release: 1 |
| 5 | License: BSD |
| 6 | Group: Development/Debuggers |
| 7 | URL: http://sourceforge.net/projects/strace/ |
Roland McGrath | ee06172 | 2003-01-22 02:27:51 +0000 | [diff] [blame] | 8 | Source0: %{name}-%{version}.tar.bz2 |
Roland McGrath | 037124f | 2003-01-10 10:44:57 +0000 | [diff] [blame] | 9 | BuildRoot: %{_tmppath}/%{name}-root |
| 10 | |
Roland McGrath | a943d00 | 2003-09-24 22:22:42 +0000 | [diff] [blame] | 11 | %define strace64_arches ppc64 |
| 12 | |
Roland McGrath | 037124f | 2003-01-10 10:44:57 +0000 | [diff] [blame] | 13 | %description |
| 14 | The strace program intercepts and records the system calls called and |
| 15 | received by a running process. Strace can print a record of each |
| 16 | system call, its arguments and its return value. Strace is useful for |
| 17 | diagnosing problems and debugging, as well as for instructional |
| 18 | purposes. |
| 19 | |
| 20 | Install strace if you need a tool to track the system calls made and |
| 21 | received by a process. |
| 22 | |
Roland McGrath | a943d00 | 2003-09-24 22:22:42 +0000 | [diff] [blame] | 23 | %ifarch %{strace64_arches} |
| 24 | %package -n strace64 |
| 25 | Summary: Tracks and displays system calls associated with a running process. |
| 26 | Group: Development/Debuggers |
| 27 | |
| 28 | %description -n strace64 |
| 29 | The strace program intercepts and records the system calls called and |
| 30 | received by a running process. Strace can print a record of each |
| 31 | system call, its arguments and its return value. Strace is useful for |
| 32 | diagnosing problems and debugging, as well as for instructional |
| 33 | purposes. |
| 34 | |
| 35 | Install strace if you need a tool to track the system calls made and |
| 36 | received by a process. |
| 37 | |
| 38 | This package provides the `strace64' program to trace 64-bit processes. |
| 39 | The `strace' program in the `strace' package is for 32-bit processes. |
| 40 | %endif |
| 41 | |
Roland McGrath | 037124f | 2003-01-10 10:44:57 +0000 | [diff] [blame] | 42 | %prep |
| 43 | %setup -q |
| 44 | |
| 45 | %build |
| 46 | %configure |
| 47 | make |
| 48 | |
| 49 | %install |
| 50 | rm -rf %{buildroot} |
| 51 | mkdir -p %{buildroot}%{_mandir}/man1 |
| 52 | mkdir -p %{buildroot}%{_bindir} |
| 53 | %makeinstall man1dir=%{buildroot}%{_mandir}/man1 |
| 54 | |
| 55 | # remove unpackaged files from the buildroot |
| 56 | rm -f %{buildroot}%{_bindir}/strace-graph |
| 57 | |
Roland McGrath | a943d00 | 2003-09-24 22:22:42 +0000 | [diff] [blame] | 58 | %ifarch %{strace64_arches} |
| 59 | ln %{buildroot}%{_bindir}/strace %{buildroot}%{_bindir}/strace64 |
| 60 | %endif |
| 61 | |
Roland McGrath | 037124f | 2003-01-10 10:44:57 +0000 | [diff] [blame] | 62 | %clean |
| 63 | rm -rf %{buildroot} |
| 64 | |
| 65 | %files |
| 66 | %defattr(-,root,root) |
| 67 | %{_bindir}/strace |
| 68 | %{_mandir}/man1/* |
| 69 | |
Roland McGrath | a943d00 | 2003-09-24 22:22:42 +0000 | [diff] [blame] | 70 | %ifarch %{strace64_arches} |
| 71 | %files -n strace64 |
| 72 | %defattr(-,root,root) |
| 73 | %{_bindir}/strace64 |
| 74 | %endif |
| 75 | |
| 76 | |
Roland McGrath | 037124f | 2003-01-10 10:44:57 +0000 | [diff] [blame] | 77 | %changelog |
Roland McGrath | ed8e77e | 2004-06-04 02:35:58 +0000 | [diff] [blame^] | 78 | * Thu Jun 3 2004 Roland McGrath <roland@redhat.com> 4.5.4-1 |
| 79 | - new upstream version, more ioctls (#122257), minor fixes |
| 80 | |
Roland McGrath | a8c555f | 2004-04-16 22:28:41 +0000 | [diff] [blame] | 81 | * Fri Apr 16 2004 Roland McGrath <roland@redhat.com> 4.5.3-1 |
| 82 | - new upstream version, mq_* calls (#120701), -p vs NPTL (#120462), more fixes (#118694, #120541, #118685) |
| 83 | |
| 84 | * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com> 4.5.2-1.1 |
| 85 | - rebuilt |
| 86 | |
Roland McGrath | b66e936 | 2004-03-02 06:38:35 +0000 | [diff] [blame] | 87 | * Mon Mar 1 2004 Roland McGrath <roland@redhat.com> 4.5.2-1 |
| 88 | - new upstream version, sched_* calls (#116990), show core flag (#112117) |
| 89 | |
| 90 | * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com> |
| 91 | - rebuilt |
| 92 | |
Roland McGrath | 00eb84e | 2003-11-14 02:57:22 +0000 | [diff] [blame] | 93 | * Thu Nov 13 2003 Roland McGrath <roland@redhat.com> 4.5.1-1 |
| 94 | - new upstream version, more fixes (#108012, #105366, #105359, #105358) |
| 95 | |
| 96 | * Tue Sep 30 2003 Roland McGrath <roland@redhat.com> 4.5-3 |
| 97 | - revert bogus s390 fix |
| 98 | |
| 99 | * Thu Sep 25 2003 Roland McGrath <roland@redhat.com> 4.5-1.2.1AS |
| 100 | - rebuilt for 2.1AS erratum |
| 101 | |
| 102 | * Wed Sep 24 2003 Roland McGrath <roland@redhat.com> 4.5-2 |
| 103 | - rebuilt |
| 104 | |
Roland McGrath | 739868f | 2003-09-24 23:05:09 +0000 | [diff] [blame] | 105 | * Wed Sep 24 2003 Roland McGrath <roland@redhat.com> 4.5-1 |
| 106 | - new upstream version, more fixes (#101499, #104365) |
| 107 | |
Roland McGrath | a943d00 | 2003-09-24 22:22:42 +0000 | [diff] [blame] | 108 | * Thu Jul 17 2003 Roland McGrath <roland@redhat.com> 4.4.99-2 |
| 109 | - rebuilt |
| 110 | |
Roland McGrath | cb61214 | 2003-07-17 09:23:56 +0000 | [diff] [blame] | 111 | * Thu Jul 17 2003 Roland McGrath <roland@redhat.com> 4.4.99-1 |
| 112 | - new upstream version, groks more new system calls, PF_INET6 sockets |
| 113 | |
Roland McGrath | f02c3c3 | 2003-06-11 05:47:07 +0000 | [diff] [blame] | 114 | * Mon Jun 10 2003 Roland McGrath <roland@redhat.com> 4.4.98-1 |
Roland McGrath | 64ffba5 | 2003-06-02 19:37:48 +0000 | [diff] [blame] | 115 | - new upstream version, more fixes (#90754, #91085) |
| 116 | |
Roland McGrath | acd3cd7 | 2003-06-11 05:37:56 +0000 | [diff] [blame] | 117 | * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com> |
| 118 | - rebuilt |
| 119 | |
Roland McGrath | 1b86e2d | 2003-03-31 01:21:36 +0000 | [diff] [blame] | 120 | * Sun Mar 30 2003 Roland McGrath <roland@redhat.com> 4.4.96-1 |
| 121 | - new upstream version, handles yet more 2.5 syscalls, x86_64 & ia64 fixes |
| 122 | |
Roland McGrath | 215da2a | 2003-03-31 01:46:47 +0000 | [diff] [blame] | 123 | * Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com> 4.4.95-2 |
| 124 | - rebuilt |
| 125 | |
Roland McGrath | 1893d05 | 2003-02-24 10:53:44 +0000 | [diff] [blame] | 126 | * Mon Feb 24 2003 Roland McGrath <roland@redhat.com> 4.4.95-1 |
| 127 | - new upstream version, fixed getresuid/getresgid (#84959) |
| 128 | |
Roland McGrath | 6c2fe9d | 2003-02-20 03:26:47 +0000 | [diff] [blame] | 129 | * Wed Feb 19 2003 Roland McGrath <roland@redhat.com> 4.4.94-1 |
| 130 | - new upstream version, new option -E to set environment variables (#82392) |
| 131 | |
| 132 | * Wed Jan 22 2003 Tim Powers <timp@redhat.com> 4.4.93-2 |
| 133 | - rebuilt |
| 134 | |
Roland McGrath | ee06172 | 2003-01-22 02:27:51 +0000 | [diff] [blame] | 135 | * Tue Jan 21 2003 Roland McGrath <roland@redhat.com> 4.4.93-1 |
| 136 | - new upstream version, fixes ppc and s390 bugs, adds missing ptrace requests |
| 137 | |
Roland McGrath | 1d847cf | 2003-01-10 21:43:24 +0000 | [diff] [blame] | 138 | * Fri Jan 10 2003 Roland McGrath <roland@redhat.com> 4.4.91-1 |
| 139 | - new upstream version, fixes -f on x86-64 |
| 140 | |
Roland McGrath | 037124f | 2003-01-10 10:44:57 +0000 | [diff] [blame] | 141 | * Fri Jan 10 2003 Roland McGrath <roland@redhat.com> 4.4.90-1 |
| 142 | - new upstream version, fixes all known bugs modulo ia64 and s390 issues |
| 143 | |
| 144 | * Fri Jan 03 2003 Florian La Roche <Florian.LaRoche@redhat.de> 4.4-11 |
| 145 | - add further s390 patch from IBM |
| 146 | |
| 147 | * Wed Nov 27 2002 Tim Powers <timp@redhat.com> 4.4-10 |
| 148 | - remove unpackaged files from the buildroot |
| 149 | |
| 150 | * Mon Oct 07 2002 Phil Knirsch <pknirsch@redhat.com> 4.4-9.1 |
| 151 | - Added latest s390(x) patch. |
| 152 | |
| 153 | * Fri Sep 06 2002 Karsten Hopp <karsten@redhat.de> 4.4-9 |
| 154 | - preliminary x86_64 support with an ugly patch to help |
| 155 | debugging. Needs cleanup! |
| 156 | |
| 157 | * Mon Sep 2 2002 Jakub Jelinek <jakub@redhat.com> 4.4-8 |
| 158 | - newer version of the clone fixing patch (Roland McGrath) |
| 159 | - aio syscalls for i386/ia64/ppc (Ben LaHaise) |
| 160 | |
| 161 | * Wed Aug 28 2002 Jakub Jelinek <jakub@redhat.com> 4.4-7 |
| 162 | - fix strace -f (Roland McGrath, #68994) |
| 163 | - handle ?et_thread_area, SA_RESTORER (Ulrich Drepper) |
| 164 | |
| 165 | * Fri Jun 21 2002 Jakub Jelinek <jakub@redhat.com> 4.4-6 |
| 166 | - handle futexes, *xattr, sendfile64, etc. (Ulrich Drepper) |
| 167 | - handle modify_ldt (#66894) |
| 168 | |
| 169 | * Thu May 23 2002 Tim Powers <timp@redhat.com> |
| 170 | - automated rebuild |
| 171 | |
| 172 | * Tue Apr 16 2002 Jakub Jelinek <jakub@redhat.com> 4.4-4 |
| 173 | - fix for the last patch by Jeff Law (#62591) |
| 174 | |
| 175 | * Mon Mar 4 2002 Preston Brown <pbrown@redhat.com> 4.4-3 |
| 176 | - integrate patch from Jeff Law to eliminate hang tracing threads |
| 177 | |
| 178 | * Sat Feb 23 2002 Florian La Roche <Florian.LaRoche@redhat.de> |
| 179 | - minor update from debian tar-ball |
| 180 | |
| 181 | * Wed Jan 02 2002 Florian La Roche <Florian.LaRoche@redhat.de> |
| 182 | - update to 4.4 |
| 183 | |
| 184 | * Sun Jul 22 2001 Florian La Roche <Florian.LaRoche@redhat.de> |
| 185 | - disable s390 patches, they are already included |
| 186 | |
| 187 | * Wed Jul 18 2001 Preston Brown <pbrown@redhat.com> 4.3-1 |
| 188 | - new upstream version. Seems to have integrated most new syscalls |
| 189 | - tracing threaded programs is now functional. |
| 190 | |
| 191 | * Mon Jun 11 2001 Than Ngo <than@redhat.com> |
| 192 | - port s390 patches from IBM |
| 193 | |
| 194 | * Wed May 16 2001 Nalin Dahyabhai <nalin@redhat.com> |
| 195 | - modify new syscall patch to allocate enough heap space in setgroups32() |
| 196 | |
| 197 | * Wed Feb 14 2001 Jakub Jelinek <jakub@redhat.com> |
| 198 | - #include <time.h> in addition to <sys/time.h> |
| 199 | |
| 200 | * Fri Jan 26 2001 Karsten Hopp <karsten@redhat.com> |
| 201 | - clean up conflicting patches. This happened only |
| 202 | when building on S390 |
| 203 | |
| 204 | * Fri Jan 19 2001 Bill Nottingham <notting@redhat.com> |
| 205 | - update to CVS, reintegrate ia64 support |
| 206 | |
| 207 | * Sat Dec 8 2000 Bernhard Rosenkraenzer <bero@redhat.com> |
| 208 | - Get S/390 support into the normal package |
| 209 | |
| 210 | * Sat Nov 18 2000 Florian La Roche <Florian.LaRoche@redhat.de> |
| 211 | - added S/390 patch from IBM, adapting it to not conflict with |
| 212 | IA64 patch |
| 213 | |
| 214 | * Sat Aug 19 2000 Jakub Jelinek <jakub@redhat.com> |
| 215 | - doh, actually apply the 2.4 syscalls patch |
| 216 | - make it compile with 2.4.0-test7-pre4+ headers, add |
| 217 | getdents64 and fcntl64 |
| 218 | |
| 219 | * Thu Aug 3 2000 Jakub Jelinek <jakub@redhat.com> |
| 220 | - add a bunch of new 2.4 syscalls (#14036) |
| 221 | |
| 222 | * Wed Jul 12 2000 Prospector <bugzilla@redhat.com> |
| 223 | - automatic rebuild |
| 224 | - excludearch ia64 |
| 225 | |
| 226 | * Fri Jun 2 2000 Matt Wilson <msw@redhat.com> |
| 227 | - use buildinstall for FHS |
| 228 | |
| 229 | * Wed May 24 2000 Jakub Jelinek <jakub@redhat.com> |
| 230 | - make things compile on sparc |
| 231 | - fix sigreturn on sparc |
| 232 | |
| 233 | * Fri Mar 31 2000 Bill Nottingham <notting@redhat.com> |
| 234 | - fix stat64 misdef (#10485) |
| 235 | |
| 236 | * Tue Mar 21 2000 Michael K. Johnson <johnsonm@redhat.com> |
| 237 | - added ia64 patch |
| 238 | |
| 239 | * Thu Feb 03 2000 Cristian Gafton <gafton@redhat.com> |
| 240 | - man pages are compressed |
| 241 | - version 4.2 (why are we keeping all these patches around?) |
| 242 | |
| 243 | * Sat Nov 27 1999 Jeff Johnson <jbj@redhat.com> |
| 244 | - update to 4.1 (with sparc socketcall patch). |
| 245 | |
| 246 | * Fri Nov 12 1999 Jakub Jelinek <jakub@redhat.com> |
| 247 | - fix socketcall on sparc. |
| 248 | |
| 249 | * Thu Sep 02 1999 Cristian Gafton <gafton@redhat.com> |
| 250 | - fix KERN_SECURELVL compile problem |
| 251 | |
| 252 | * Tue Aug 31 1999 Cristian Gafton <gafton@redhat.com> |
| 253 | - added alpha patch from HJLu to fix the osf_sigprocmask interpretation |
| 254 | |
| 255 | * Sat Jun 12 1999 Jeff Johnson <jbj@redhat.com> |
| 256 | - update to 3.99.1. |
| 257 | |
| 258 | * Wed Jun 2 1999 Jeff Johnson <jbj@redhat.com> |
| 259 | - add (the other :-) jj's sparc patch. |
| 260 | |
| 261 | * Wed May 26 1999 Jeff Johnson <jbj@redhat.com> |
| 262 | - upgrade to 3.99 in order to |
| 263 | - add new 2.2.x open flags (#2955). |
| 264 | - add new 2.2.x syscalls (#2866). |
| 265 | - strace 3.1 patches carried along for now. |
| 266 | |
| 267 | * Sun May 16 1999 Jeff Johnson <jbj@redhat.com> |
| 268 | - don't rely on (broken!) rpm %patch (#2735) |
| 269 | |
| 270 | * Tue Apr 06 1999 Preston Brown <pbrown@redhat.com> |
| 271 | - strip binary |
| 272 | |
| 273 | * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com> |
| 274 | - auto rebuild in the new build environment (release 16) |
| 275 | |
| 276 | * Tue Feb 9 1999 Jeff Johnson <jbj@redhat.com> |
| 277 | - vfork est arrive! |
| 278 | |
| 279 | * Tue Feb 9 1999 Christopher Blizzard <blizzard@redhat.com> |
| 280 | - Add patch to follow clone() syscalls, too. |
| 281 | |
| 282 | * Sun Jan 17 1999 Jeff Johnson <jbj@redhat.com> |
| 283 | - patch to build alpha/sparc with glibc 2.1. |
| 284 | |
| 285 | * Thu Dec 03 1998 Cristian Gafton <gafton@redhat.com> |
| 286 | - patch to build on ARM |
| 287 | |
| 288 | * Wed Sep 30 1998 Jeff Johnson <jbj@redhat.com> |
| 289 | - fix typo (printf, not tprintf). |
| 290 | |
| 291 | * Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com> |
| 292 | - fix compile problem on sparc. |
| 293 | |
| 294 | * Tue Aug 18 1998 Cristian Gafton <gafton@redhat.com> |
| 295 | - buildroot |
| 296 | |
| 297 | * Mon Jul 20 1998 Cristian Gafton <gafton@redhat.com> |
| 298 | - added the umoven patch from James Youngman <jay@gnu.org> |
| 299 | - fixed build problems on newer glibc releases |
| 300 | |
| 301 | * Mon Jun 08 1998 Prospector System <bugs@redhat.com> |
| 302 | - translations modified for de, fr, tr |