Roland McGrath | 00a1875 | 2007-02-18 22:55:21 +0000 | [diff] [blame] | 1 | Summary: Tracks and displays system calls associated with a running process |
Roland McGrath | 037124f | 2003-01-10 10:44:57 +0000 | [diff] [blame] | 2 | Name: strace |
Dmitry V. Levin | dfabccf | 2015-03-06 13:14:15 +0000 | [diff] [blame] | 3 | Version: 4.10 |
Dmitry V. Levin | e4db4c4 | 2014-08-15 13:14:15 +0000 | [diff] [blame] | 4 | Release: 1%{?dist} |
Roland McGrath | 037124f | 2003-01-10 10:44:57 +0000 | [diff] [blame] | 5 | License: BSD |
| 6 | Group: Development/Debuggers |
| 7 | URL: http://sourceforge.net/projects/strace/ |
Dmitry V. Levin | 525a39a | 2011-02-27 14:05:58 +0000 | [diff] [blame] | 8 | Source: http://downloads.sourceforge.net/strace/%{name}-%{version}.tar.xz |
Roland McGrath | 037124f | 2003-01-10 10:44:57 +0000 | [diff] [blame] | 9 | |
Dmitry V. Levin | 983e875 | 2011-02-27 10:16:41 +0000 | [diff] [blame] | 10 | BuildRequires: libacl-devel, libaio-devel, time |
Roland McGrath | 4c99f56 | 2007-11-19 22:14:56 +0000 | [diff] [blame] | 11 | |
Roland McGrath | 7c2ec57 | 2008-03-26 19:15:41 +0000 | [diff] [blame] | 12 | %define strace64_arches ppc64 sparc64 |
Roland McGrath | a943d00 | 2003-09-24 22:22:42 +0000 | [diff] [blame] | 13 | |
Roland McGrath | 037124f | 2003-01-10 10:44:57 +0000 | [diff] [blame] | 14 | %description |
| 15 | The strace program intercepts and records the system calls called and |
| 16 | received by a running process. Strace can print a record of each |
| 17 | system call, its arguments and its return value. Strace is useful for |
| 18 | diagnosing problems and debugging, as well as for instructional |
| 19 | purposes. |
| 20 | |
| 21 | Install strace if you need a tool to track the system calls made and |
| 22 | received by a process. |
| 23 | |
Roland McGrath | a943d00 | 2003-09-24 22:22:42 +0000 | [diff] [blame] | 24 | %ifarch %{strace64_arches} |
| 25 | %package -n strace64 |
| 26 | Summary: Tracks and displays system calls associated with a running process. |
| 27 | Group: Development/Debuggers |
| 28 | |
| 29 | %description -n strace64 |
| 30 | The strace program intercepts and records the system calls called and |
| 31 | received by a running process. Strace can print a record of each |
| 32 | system call, its arguments and its return value. Strace is useful for |
| 33 | diagnosing problems and debugging, as well as for instructional |
| 34 | purposes. |
| 35 | |
| 36 | Install strace if you need a tool to track the system calls made and |
| 37 | received by a process. |
| 38 | |
| 39 | This package provides the `strace64' program to trace 64-bit processes. |
| 40 | The `strace' program in the `strace' package is for 32-bit processes. |
| 41 | %endif |
| 42 | |
Roland McGrath | 037124f | 2003-01-10 10:44:57 +0000 | [diff] [blame] | 43 | %prep |
| 44 | %setup -q |
| 45 | |
| 46 | %build |
| 47 | %configure |
Roland McGrath | cddc21f | 2007-02-18 22:56:37 +0000 | [diff] [blame] | 48 | make %{?_smp_mflags} |
Roland McGrath | 037124f | 2003-01-10 10:44:57 +0000 | [diff] [blame] | 49 | |
| 50 | %install |
Roland McGrath | 00a1875 | 2007-02-18 22:55:21 +0000 | [diff] [blame] | 51 | make DESTDIR=%{buildroot} install |
Roland McGrath | 037124f | 2003-01-10 10:44:57 +0000 | [diff] [blame] | 52 | |
| 53 | # remove unpackaged files from the buildroot |
| 54 | rm -f %{buildroot}%{_bindir}/strace-graph |
| 55 | |
Roland McGrath | 3f0dbe2 | 2008-08-28 23:26:21 +0000 | [diff] [blame] | 56 | %define copy64 ln |
| 57 | %if 0%{?rhel} |
| 58 | %if 0%{?rhel} < 6 |
| 59 | %endif |
| 60 | %define copy64 cp -p |
| 61 | %endif |
| 62 | |
Roland McGrath | a943d00 | 2003-09-24 22:22:42 +0000 | [diff] [blame] | 63 | %ifarch %{strace64_arches} |
Roland McGrath | 3f0dbe2 | 2008-08-28 23:26:21 +0000 | [diff] [blame] | 64 | %{copy64} %{buildroot}%{_bindir}/strace %{buildroot}%{_bindir}/strace64 |
Roland McGrath | a943d00 | 2003-09-24 22:22:42 +0000 | [diff] [blame] | 65 | %endif |
| 66 | |
Dmitry V. Levin | 983e875 | 2011-02-27 10:16:41 +0000 | [diff] [blame] | 67 | %check |
Dmitry V. Levin | e4db4c4 | 2014-08-15 13:14:15 +0000 | [diff] [blame] | 68 | make -k check VERBOSE=1 |
Dmitry V. Levin | 983e875 | 2011-02-27 10:16:41 +0000 | [diff] [blame] | 69 | |
Roland McGrath | 037124f | 2003-01-10 10:44:57 +0000 | [diff] [blame] | 70 | %files |
Mike Frysinger | 6c19136 | 2013-05-15 16:33:09 -0400 | [diff] [blame] | 71 | %doc CREDITS ChangeLog ChangeLog-CVS COPYING NEWS README |
Roland McGrath | 037124f | 2003-01-10 10:44:57 +0000 | [diff] [blame] | 72 | %{_bindir}/strace |
Dmitry V. Levin | 5443256 | 2012-04-27 23:38:44 +0000 | [diff] [blame] | 73 | %{_bindir}/strace-log-merge |
Roland McGrath | 037124f | 2003-01-10 10:44:57 +0000 | [diff] [blame] | 74 | %{_mandir}/man1/* |
| 75 | |
Roland McGrath | a943d00 | 2003-09-24 22:22:42 +0000 | [diff] [blame] | 76 | %ifarch %{strace64_arches} |
| 77 | %files -n strace64 |
Roland McGrath | a943d00 | 2003-09-24 22:22:42 +0000 | [diff] [blame] | 78 | %{_bindir}/strace64 |
| 79 | %endif |
| 80 | |
Roland McGrath | 037124f | 2003-01-10 10:44:57 +0000 | [diff] [blame] | 81 | %changelog |
Dmitry V. Levin | dfabccf | 2015-03-06 13:14:15 +0000 | [diff] [blame] | 82 | * Fri Mar 06 2015 Dmitry V. Levin <ldv@altlinux.org> - 4.10-1 |
| 83 | - New upstream release: |
| 84 | + enhanced ioctl decoding (#902788). |
| 85 | |
| 86 | * Mon Nov 03 2014 Lubomir Rintel <lkundrak@v3.sk> - 4.9-3 |
| 87 | - Regenerate ioctl entries with proper kernel headers |
| 88 | |
| 89 | * Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.9-2 |
| 90 | - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild |
| 91 | |
Dmitry V. Levin | e4db4c4 | 2014-08-15 13:14:15 +0000 | [diff] [blame] | 92 | * Fri Aug 15 2014 Dmitry V. Levin <ldv@altlinux.org> - 4.9-1 |
| 93 | - New upstream release: |
| 94 | + fixed build when <sys/ptrace.h> and <linux/ptrace.h> conflict (#993384); |
| 95 | + updated CLOCK_* constants (#1088455); |
| 96 | + enabled ppc64le support (#1122323); |
| 97 | + fixed attach to a process on ppc64le (#1129569). |
| 98 | |
Dmitry V. Levin | a283ae0 | 2014-08-15 13:14:15 +0000 | [diff] [blame] | 99 | * Fri Jul 25 2014 Dan HorĂ¡k <dan[at]danny.cz> - 4.8-5 |
| 100 | - update for ppc64 |
| 101 | |
| 102 | * Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.8-4 |
| 103 | - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild |
| 104 | |
| 105 | * Fri Dec 6 2013 Peter Robinson <pbrobinson@fedoraproject.org> 4.8-3 |
| 106 | - Fix FTBFS |
| 107 | |
| 108 | * Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.8-2 |
| 109 | - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild |
| 110 | |
Dmitry V. Levin | d845411 | 2013-06-03 12:34:56 +0000 | [diff] [blame] | 111 | * Mon Jun 03 2013 Dmitry V. Levin <ldv@altlinux.org> - 4.8-1 |
| 112 | - New upstream release: |
| 113 | + fixed ERESTARTNOINTR leaking to userspace on ancient kernels (#659382); |
| 114 | + fixed decoding of *xattr syscalls (#885233); |
| 115 | + fixed handling of files with 64-bit inode numbers by 32-bit strace (#912790); |
| 116 | + added aarch64 support (#969858). |
| 117 | |
Dmitry V. Levin | 0eb7165 | 2013-05-17 23:16:39 +0000 | [diff] [blame] | 118 | * Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.7-3 |
| 119 | - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild |
| 120 | |
| 121 | * Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.7-2 |
| 122 | - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild |
| 123 | |
Dmitry V. Levin | 417eb88 | 2012-05-02 12:34:56 +0000 | [diff] [blame] | 124 | * Wed May 02 2012 Dmitry V. Levin <ldv@altlinux.org> 4.7-1 |
| 125 | - New upstream release. |
| 126 | + implemented proper handling of real SIGTRAPs (#162774). |
| 127 | |
Dmitry V. Levin | 48e95c7 | 2012-04-20 17:31:48 +0000 | [diff] [blame] | 128 | * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.6-2 |
| 129 | - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild |
| 130 | |
Dmitry V. Levin | 50e69cb | 2011-02-21 22:58:59 +0000 | [diff] [blame] | 131 | * Mon Mar 14 2011 Dmitry V. Levin <ldv@altlinux.org> - 4.6-1 |
| 132 | - New upstream release. |
| 133 | + fixed a corner case in waitpid handling (#663547). |
| 134 | |
Dmitry V. Levin | c36c303 | 2011-02-21 23:22:34 +0000 | [diff] [blame] | 135 | * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.5.20-2 |
| 136 | - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild |
| 137 | |
Dmitry V. Levin | acbe518 | 2010-04-06 23:46:43 +0000 | [diff] [blame] | 138 | * Tue Apr 13 2010 Roland McGrath <roland@redhat.com> - 4.5.20-1 |
| 139 | - New upstream release, work mostly by Andreas Schwab and Dmitry V. Levin. |
| 140 | + fixed potential stack buffer overflow in select decoder (#556678); |
| 141 | + fixed FTBFS (#539044). |
| 142 | |
Roland McGrath | 7d9247e | 2009-10-21 10:36:13 -0700 | [diff] [blame] | 143 | * Wed Oct 21 2009 Roland McGrath <roland@redhat.com> - 4.5.19-1 |
| 144 | - New upstream release, work mostly by Dmitry V. Levin <ldv@altlinux.org> |
Dmitry V. Levin | fbfed22 | 2009-09-14 16:34:34 +0000 | [diff] [blame] | 145 | + exit/kill strace with traced process exitcode/signal (#105371); |
| 146 | + fixed build on ARM EABI (#507576); |
| 147 | + fixed display of 32-bit argv array on 64-bit architectures (#519480); |
| 148 | + fixed display of 32-bit fcntl(F_SETLK) on 64-bit architectures (#471169); |
| 149 | + fixed several bugs in strings decoder, including potential heap |
| 150 | memory corruption (#470529, #478324, #511035). |
| 151 | |
Roland McGrath | 09db705 | 2008-08-28 22:00:46 +0000 | [diff] [blame] | 152 | * Thu Aug 28 2008 Roland McGrath <roland@redhat.com> - 4.5.18-1 |
| 153 | - build fix for newer kernel headers (#457291) |
| 154 | - fix CLONE_VFORK handling (#455078) |
| 155 | - Support new Linux/PPC system call subpage_prot and PROT_SAO flag. |
| 156 | - In sigaction system call, display sa_flags value along with SIG_DFL/SIG_IGN. |
| 157 | |
Roland McGrath | 6a1311d | 2008-07-22 00:43:09 +0000 | [diff] [blame] | 158 | * Mon Jul 21 2008 Roland McGrath <roland@redhat.com> - 4.5.17-1 |
Roland McGrath | 55dd278 | 2008-07-18 02:21:11 +0000 | [diff] [blame] | 159 | - handle O_CLOEXEC, MSG_CMSG_CLOEXEC (#365781) |
| 160 | - fix biarch stat64 decoding (#222275) |
| 161 | - fix spurious "..." in printing of environment strings (#358241) |
| 162 | - improve prctl decoding (#364401) |
| 163 | - fix hang wait on exited child with exited child (#354261) |
| 164 | - fix biarch fork/vfork (-f) tracing (#447475) |
| 165 | - fix biarch printing of negative argument kill (#430585) |
| 166 | - fix biarch decoding of error return values (#447587) |
| 167 | - fix -f tracing of CLONE_VFORK (#455078) |
| 168 | - fix ia64 register clobberation in -f tracing (#453438) |
| 169 | - print SO_NODEFER, SA_RESETHAND instead of SA_NOMASK, SA_ONESHOT (#455821) |
| 170 | - fix futex argument decoding (#448628, #448629) |
| 171 | |
Roland McGrath | 47d3223 | 2007-08-03 10:28:55 +0000 | [diff] [blame] | 172 | * Fri Aug 3 2007 Roland McGrath <roland@redhat.com> - 4.5.16-1 |
| 173 | - fix multithread issues (#240962, #240961, #247907) |
| 174 | - fix spurious SIGSTOP on early interrupt (#240986) |
| 175 | - fix utime for biarch (#247185) |
| 176 | - fix -u error message (#247170) |
| 177 | - better futex syscall printing (##241467) |
| 178 | - fix argv/envp printing with small -s settings, and for biarch |
| 179 | - new syscalls: getcpu, eventfd, timerfd, signalfd, epoll_pwait, |
| 180 | move_pages, utimensat |
| 181 | |
Roland McGrath | 0a45fae | 2007-01-16 23:25:34 +0000 | [diff] [blame] | 182 | * Tue Jan 16 2007 Roland McGrath <roland@redhat.com> - 4.5.15-1 |
Roland McGrath | cdec469 | 2007-01-11 22:22:47 +0000 | [diff] [blame] | 183 | - biarch fixes (#179740, #192193, #171626, #173050, #218433, #218043) |
| 184 | - fix -ff -o behavior (#204950, #218435, #193808, #219423) |
| 185 | - better quotactl printing (#118696) |
| 186 | - *at, inotify*, pselect6, ppoll and unshare syscalls (#178633, #191275) |
| 187 | - glibc-2.5 build fixes (#209856) |
| 188 | - memory corruption fixes (#200621 |
| 189 | - fix race in child setup under -f (#180293) |
| 190 | - show ipc key values in hex (#198179, #192182) |
| 191 | - disallow -c with -ff (#187847) |
| 192 | - Resolves: RHBZ #179740, RHBZ #192193, RHBZ #204950, RHBZ #218435 |
| 193 | - Resolves: RHBZ #193808, RHBZ #219423, RHBZ #171626, RHBZ #173050 |
| 194 | - Resolves: RHBZ #218433, RHBZ #218043, RHBZ #118696, RHBZ #178633 |
| 195 | - Resolves: RHBZ #191275, RHBZ #209856, RHBZ #200621, RHBZ #180293 |
| 196 | - Resolves: RHBZ #198179, RHBZ #198182, RHBZ #187847 |
| 197 | |
| 198 | * Mon Nov 20 2006 Jakub Jelinek <jakub@redhat.com> - 4.5.14-4 |
| 199 | - Fix ia64 syscall decoding (#206768) |
| 200 | - Fix build with glibc-2.4.90-33 and up on all arches but ia64 |
| 201 | - Fix build against 2.6.18+ headers |
| 202 | |
| 203 | * Tue Aug 22 2006 Roland McGrath <roland@redhat.com> - 4.5.14-3 |
| 204 | - Fix bogus decoding of syscalls >= 300 (#201462, #202620). |
| 205 | |
| 206 | * Fri Jul 14 2006 Jesse Keating <jkeating@redhat.com> - 4.5.14-2 |
| 207 | - rebuild |
| 208 | |
| 209 | * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 4.5.14-1.2 |
| 210 | - bump again for long double bug on ppc{,64} |
| 211 | |
| 212 | * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 4.5.14-1.1 |
| 213 | - rebuilt for new gcc4.1 snapshot and glibc changes |
| 214 | |
Roland McGrath | f4d9b49 | 2006-01-17 06:22:57 +0000 | [diff] [blame] | 215 | * Mon Jan 16 2006 Roland McGrath <roland@redhat.com> - 4.5.14-1 |
| 216 | - Fix biarch decoding of socket syscalls (#174354). |
| 217 | - Fix biarch -e support (#173986). |
| 218 | - Accept numeric syscalls in -e (#174798). |
| 219 | - Fix ipc syscall decoding (#164755). |
| 220 | - Improve msgrcv printing (#164757). |
| 221 | - Man page updates (#165375). |
| 222 | - Improve mount syscall printing (#165377). |
| 223 | - Correct printing of restarting syscalls (#165469). |
| 224 | |
Roland McGrath | cab4380 | 2005-08-03 11:42:35 +0000 | [diff] [blame] | 225 | * Wed Aug 3 2005 Roland McGrath <roland@redhat.com> - 4.5.13-1 |
| 226 | - Fix setsockopt decoding on 64-bit (#162449). |
| 227 | - Fix typos in socket option name strings (#161578). |
| 228 | - Display more IPV6 socket options by name (#162450). |
| 229 | - Don't display inappropriate syscalls for -e trace=file (#159340). |
| 230 | - New selector type -e trace=desc for file-descriptor using calls (#159400). |
| 231 | - Fix 32-bit old_mmap syscall decoding on x86-64 (#162467, #164215). |
| 232 | - Fix errors detaching from multithreaded process on interrupt (#161919). |
| 233 | - Note 4.5.12 fix for crash handling bad signal numbers (#162739). |
| 234 | |
Roland McGrath | 182cbf4 | 2005-06-10 03:56:16 +0000 | [diff] [blame] | 235 | * Wed Jun 8 2005 Roland McGrath <roland@redhat.com> - 4.5.12-1 |
| 236 | - Fix known syscall recognition for IA32 processes on x86-64 (#158934). |
| 237 | - Fix bad output for ptrace on x86-64 (#159787). |
| 238 | - Fix potential buffer overruns (#151570, #159196). |
| 239 | - Make some diagnostics more consistent (#159308). |
| 240 | - Update PowerPC system calls. |
| 241 | - Better printing for Linux aio system calls. |
| 242 | - Don't truncate statfs64 fields to 32 bits in output (#158243). |
| 243 | - Cosmetic code cleanups (#159688). |
| 244 | |
Roland McGrath | 7147a3d | 2005-03-22 23:12:39 +0000 | [diff] [blame] | 245 | * Tue Mar 22 2005 Roland McGrath <roland@redhat.com> - 4.5.11-1 |
| 246 | - Build tweaks. |
| 247 | - Note 4.5.10 select fix (#151570). |
| 248 | |
Roland McGrath | d818403 | 2005-03-15 02:40:12 +0000 | [diff] [blame] | 249 | * Mon Mar 14 2005 Roland McGrath <roland@redhat.com> - 4.5.10-1 |
| 250 | - Fix select handling on nonstandard fd_set sizes. |
| 251 | - Don't print errors for null file name pointers. |
| 252 | - Fix initial execve output with -i (#143365). |
| 253 | |
Roland McGrath | 6df9d64 | 2005-02-04 10:13:15 +0000 | [diff] [blame] | 254 | * Fri Feb 4 2005 Roland McGrath <roland@redhat.com> - 4.5.9-2 |
Roland McGrath | d63311a | 2005-02-04 09:29:04 +0000 | [diff] [blame] | 255 | - update ia64 syscall list (#146245) |
| 256 | - fix x86_64 syscall argument extraction for 32-bit processes (#146093) |
| 257 | - fix -e signal=NAME parsing (#143362) |
| 258 | - fix x86_64 exit_group syscall handling |
| 259 | - improve socket ioctl printing (#138223) |
| 260 | - code cleanups (#143369, #143370) |
| 261 | - improve mount flags printing (#141932) |
| 262 | - support symbolic printing of x86_64 arch_prctl parameters (#142667) |
| 263 | - fix potential crash in getxattr printing |
| 264 | |
Roland McGrath | f041d47 | 2004-10-20 02:17:52 +0000 | [diff] [blame] | 265 | * Tue Oct 19 2004 Roland McGrath <roland@redhat.com> - 4.5.8-1 |
| 266 | - fix multithreaded exit handling (#132150, #135254) |
| 267 | - fix ioctl name matching (#129808) |
| 268 | - print RTC_* ioctl structure contents (#58606) |
| 269 | - grok epoll_* syscalls (#134463) |
| 270 | - grok new RLIMIT_* values (#133594) |
| 271 | - print struct cmsghdr contents for sendmsg (#131689) |
| 272 | - fix clock_* and timer_* argument output (#131420) |
| 273 | |
Roland McGrath | 61d6487 | 2004-08-31 08:58:10 +0000 | [diff] [blame] | 274 | * Tue Aug 31 2004 Roland McGrath <roland@redhat.com> - 4.5.7-2 |
Roland McGrath | b93f918 | 2004-08-31 08:17:20 +0000 | [diff] [blame] | 275 | - new upstream version, misc fixes and updates (#128091, #129166, #128391, #129378, #130965, #131177) |
| 276 | |
Roland McGrath | 785a026 | 2004-07-12 07:55:48 +0000 | [diff] [blame] | 277 | * Mon Jul 12 2004 Roland McGrath <roland@redhat.com> 4.5.6-1 |
| 278 | - new upstream version, updates ioctl lists (#127398), fixes quotactl (#127393), more ioctl decoding (#126917) |
| 279 | |
Roland McGrath | b7e2ca1 | 2004-06-28 05:24:29 +0000 | [diff] [blame] | 280 | * Sun Jun 27 2004 Roland McGrath <roland@redhat.com> 4.5.5-1 |
| 281 | - new upstream version, fixes x86-64 biarch support (#126547) |
| 282 | |
| 283 | * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com> 4.5.4-2 |
| 284 | - rebuilt |
| 285 | |
| 286 | * Thu Jun 3 2004 Roland McGrath <roland@redhat.com> 4.5.4-0.FC1 |
| 287 | - rebuilt for FC1 update |
| 288 | |
Roland McGrath | ed8e77e | 2004-06-04 02:35:58 +0000 | [diff] [blame] | 289 | * Thu Jun 3 2004 Roland McGrath <roland@redhat.com> 4.5.4-1 |
| 290 | - new upstream version, more ioctls (#122257), minor fixes |
| 291 | |
Roland McGrath | a8c555f | 2004-04-16 22:28:41 +0000 | [diff] [blame] | 292 | * Fri Apr 16 2004 Roland McGrath <roland@redhat.com> 4.5.3-1 |
| 293 | - new upstream version, mq_* calls (#120701), -p vs NPTL (#120462), more fixes (#118694, #120541, #118685) |
| 294 | |
| 295 | * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com> 4.5.2-1.1 |
| 296 | - rebuilt |
| 297 | |
Roland McGrath | b66e936 | 2004-03-02 06:38:35 +0000 | [diff] [blame] | 298 | * Mon Mar 1 2004 Roland McGrath <roland@redhat.com> 4.5.2-1 |
| 299 | - new upstream version, sched_* calls (#116990), show core flag (#112117) |
| 300 | |
| 301 | * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com> |
| 302 | - rebuilt |
| 303 | |
Roland McGrath | 00eb84e | 2003-11-14 02:57:22 +0000 | [diff] [blame] | 304 | * Thu Nov 13 2003 Roland McGrath <roland@redhat.com> 4.5.1-1 |
| 305 | - new upstream version, more fixes (#108012, #105366, #105359, #105358) |
| 306 | |
| 307 | * Tue Sep 30 2003 Roland McGrath <roland@redhat.com> 4.5-3 |
| 308 | - revert bogus s390 fix |
| 309 | |
| 310 | * Thu Sep 25 2003 Roland McGrath <roland@redhat.com> 4.5-1.2.1AS |
| 311 | - rebuilt for 2.1AS erratum |
| 312 | |
| 313 | * Wed Sep 24 2003 Roland McGrath <roland@redhat.com> 4.5-2 |
| 314 | - rebuilt |
| 315 | |
Roland McGrath | 739868f | 2003-09-24 23:05:09 +0000 | [diff] [blame] | 316 | * Wed Sep 24 2003 Roland McGrath <roland@redhat.com> 4.5-1 |
| 317 | - new upstream version, more fixes (#101499, #104365) |
| 318 | |
Roland McGrath | a943d00 | 2003-09-24 22:22:42 +0000 | [diff] [blame] | 319 | * Thu Jul 17 2003 Roland McGrath <roland@redhat.com> 4.4.99-2 |
| 320 | - rebuilt |
| 321 | |
Roland McGrath | cb61214 | 2003-07-17 09:23:56 +0000 | [diff] [blame] | 322 | * Thu Jul 17 2003 Roland McGrath <roland@redhat.com> 4.4.99-1 |
| 323 | - new upstream version, groks more new system calls, PF_INET6 sockets |
| 324 | |
Dmitry V. Levin | e4db4c4 | 2014-08-15 13:14:15 +0000 | [diff] [blame] | 325 | * Tue Jun 10 2003 Roland McGrath <roland@redhat.com> 4.4.98-1 |
Roland McGrath | 64ffba5 | 2003-06-02 19:37:48 +0000 | [diff] [blame] | 326 | - new upstream version, more fixes (#90754, #91085) |
| 327 | |
Roland McGrath | acd3cd7 | 2003-06-11 05:37:56 +0000 | [diff] [blame] | 328 | * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com> |
| 329 | - rebuilt |
| 330 | |
Roland McGrath | 1b86e2d | 2003-03-31 01:21:36 +0000 | [diff] [blame] | 331 | * Sun Mar 30 2003 Roland McGrath <roland@redhat.com> 4.4.96-1 |
| 332 | - new upstream version, handles yet more 2.5 syscalls, x86_64 & ia64 fixes |
| 333 | |
Roland McGrath | 215da2a | 2003-03-31 01:46:47 +0000 | [diff] [blame] | 334 | * Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com> 4.4.95-2 |
| 335 | - rebuilt |
| 336 | |
Roland McGrath | 1893d05 | 2003-02-24 10:53:44 +0000 | [diff] [blame] | 337 | * Mon Feb 24 2003 Roland McGrath <roland@redhat.com> 4.4.95-1 |
| 338 | - new upstream version, fixed getresuid/getresgid (#84959) |
| 339 | |
Roland McGrath | 6c2fe9d | 2003-02-20 03:26:47 +0000 | [diff] [blame] | 340 | * Wed Feb 19 2003 Roland McGrath <roland@redhat.com> 4.4.94-1 |
| 341 | - new upstream version, new option -E to set environment variables (#82392) |
| 342 | |
| 343 | * Wed Jan 22 2003 Tim Powers <timp@redhat.com> 4.4.93-2 |
| 344 | - rebuilt |
| 345 | |
Roland McGrath | ee06172 | 2003-01-22 02:27:51 +0000 | [diff] [blame] | 346 | * Tue Jan 21 2003 Roland McGrath <roland@redhat.com> 4.4.93-1 |
| 347 | - new upstream version, fixes ppc and s390 bugs, adds missing ptrace requests |
| 348 | |
Roland McGrath | 1d847cf | 2003-01-10 21:43:24 +0000 | [diff] [blame] | 349 | * Fri Jan 10 2003 Roland McGrath <roland@redhat.com> 4.4.91-1 |
| 350 | - new upstream version, fixes -f on x86-64 |
| 351 | |
Roland McGrath | 037124f | 2003-01-10 10:44:57 +0000 | [diff] [blame] | 352 | * Fri Jan 10 2003 Roland McGrath <roland@redhat.com> 4.4.90-1 |
| 353 | - new upstream version, fixes all known bugs modulo ia64 and s390 issues |
| 354 | |
| 355 | * Fri Jan 03 2003 Florian La Roche <Florian.LaRoche@redhat.de> 4.4-11 |
| 356 | - add further s390 patch from IBM |
| 357 | |
| 358 | * Wed Nov 27 2002 Tim Powers <timp@redhat.com> 4.4-10 |
| 359 | - remove unpackaged files from the buildroot |
| 360 | |
| 361 | * Mon Oct 07 2002 Phil Knirsch <pknirsch@redhat.com> 4.4-9.1 |
| 362 | - Added latest s390(x) patch. |
| 363 | |
| 364 | * Fri Sep 06 2002 Karsten Hopp <karsten@redhat.de> 4.4-9 |
| 365 | - preliminary x86_64 support with an ugly patch to help |
| 366 | debugging. Needs cleanup! |
| 367 | |
| 368 | * Mon Sep 2 2002 Jakub Jelinek <jakub@redhat.com> 4.4-8 |
| 369 | - newer version of the clone fixing patch (Roland McGrath) |
| 370 | - aio syscalls for i386/ia64/ppc (Ben LaHaise) |
| 371 | |
| 372 | * Wed Aug 28 2002 Jakub Jelinek <jakub@redhat.com> 4.4-7 |
| 373 | - fix strace -f (Roland McGrath, #68994) |
| 374 | - handle ?et_thread_area, SA_RESTORER (Ulrich Drepper) |
| 375 | |
| 376 | * Fri Jun 21 2002 Jakub Jelinek <jakub@redhat.com> 4.4-6 |
| 377 | - handle futexes, *xattr, sendfile64, etc. (Ulrich Drepper) |
| 378 | - handle modify_ldt (#66894) |
| 379 | |
| 380 | * Thu May 23 2002 Tim Powers <timp@redhat.com> |
| 381 | - automated rebuild |
| 382 | |
| 383 | * Tue Apr 16 2002 Jakub Jelinek <jakub@redhat.com> 4.4-4 |
| 384 | - fix for the last patch by Jeff Law (#62591) |
| 385 | |
| 386 | * Mon Mar 4 2002 Preston Brown <pbrown@redhat.com> 4.4-3 |
| 387 | - integrate patch from Jeff Law to eliminate hang tracing threads |
| 388 | |
| 389 | * Sat Feb 23 2002 Florian La Roche <Florian.LaRoche@redhat.de> |
| 390 | - minor update from debian tar-ball |
| 391 | |
| 392 | * Wed Jan 02 2002 Florian La Roche <Florian.LaRoche@redhat.de> |
| 393 | - update to 4.4 |
| 394 | |
| 395 | * Sun Jul 22 2001 Florian La Roche <Florian.LaRoche@redhat.de> |
| 396 | - disable s390 patches, they are already included |
| 397 | |
| 398 | * Wed Jul 18 2001 Preston Brown <pbrown@redhat.com> 4.3-1 |
| 399 | - new upstream version. Seems to have integrated most new syscalls |
| 400 | - tracing threaded programs is now functional. |
| 401 | |
| 402 | * Mon Jun 11 2001 Than Ngo <than@redhat.com> |
| 403 | - port s390 patches from IBM |
| 404 | |
| 405 | * Wed May 16 2001 Nalin Dahyabhai <nalin@redhat.com> |
| 406 | - modify new syscall patch to allocate enough heap space in setgroups32() |
| 407 | |
| 408 | * Wed Feb 14 2001 Jakub Jelinek <jakub@redhat.com> |
| 409 | - #include <time.h> in addition to <sys/time.h> |
| 410 | |
| 411 | * Fri Jan 26 2001 Karsten Hopp <karsten@redhat.com> |
| 412 | - clean up conflicting patches. This happened only |
| 413 | when building on S390 |
| 414 | |
| 415 | * Fri Jan 19 2001 Bill Nottingham <notting@redhat.com> |
| 416 | - update to CVS, reintegrate ia64 support |
| 417 | |
Dmitry V. Levin | e4db4c4 | 2014-08-15 13:14:15 +0000 | [diff] [blame] | 418 | * Fri Dec 8 2000 Bernhard Rosenkraenzer <bero@redhat.com> |
Roland McGrath | 037124f | 2003-01-10 10:44:57 +0000 | [diff] [blame] | 419 | - Get S/390 support into the normal package |
| 420 | |
| 421 | * Sat Nov 18 2000 Florian La Roche <Florian.LaRoche@redhat.de> |
| 422 | - added S/390 patch from IBM, adapting it to not conflict with |
| 423 | IA64 patch |
| 424 | |
| 425 | * Sat Aug 19 2000 Jakub Jelinek <jakub@redhat.com> |
| 426 | - doh, actually apply the 2.4 syscalls patch |
| 427 | - make it compile with 2.4.0-test7-pre4+ headers, add |
| 428 | getdents64 and fcntl64 |
| 429 | |
| 430 | * Thu Aug 3 2000 Jakub Jelinek <jakub@redhat.com> |
| 431 | - add a bunch of new 2.4 syscalls (#14036) |
| 432 | |
| 433 | * Wed Jul 12 2000 Prospector <bugzilla@redhat.com> |
| 434 | - automatic rebuild |
| 435 | - excludearch ia64 |
| 436 | |
| 437 | * Fri Jun 2 2000 Matt Wilson <msw@redhat.com> |
| 438 | - use buildinstall for FHS |
| 439 | |
| 440 | * Wed May 24 2000 Jakub Jelinek <jakub@redhat.com> |
| 441 | - make things compile on sparc |
| 442 | - fix sigreturn on sparc |
| 443 | |
| 444 | * Fri Mar 31 2000 Bill Nottingham <notting@redhat.com> |
| 445 | - fix stat64 misdef (#10485) |
| 446 | |
| 447 | * Tue Mar 21 2000 Michael K. Johnson <johnsonm@redhat.com> |
| 448 | - added ia64 patch |
| 449 | |
| 450 | * Thu Feb 03 2000 Cristian Gafton <gafton@redhat.com> |
| 451 | - man pages are compressed |
| 452 | - version 4.2 (why are we keeping all these patches around?) |
| 453 | |
| 454 | * Sat Nov 27 1999 Jeff Johnson <jbj@redhat.com> |
| 455 | - update to 4.1 (with sparc socketcall patch). |
| 456 | |
| 457 | * Fri Nov 12 1999 Jakub Jelinek <jakub@redhat.com> |
| 458 | - fix socketcall on sparc. |
| 459 | |
| 460 | * Thu Sep 02 1999 Cristian Gafton <gafton@redhat.com> |
| 461 | - fix KERN_SECURELVL compile problem |
| 462 | |
| 463 | * Tue Aug 31 1999 Cristian Gafton <gafton@redhat.com> |
| 464 | - added alpha patch from HJLu to fix the osf_sigprocmask interpretation |
| 465 | |
| 466 | * Sat Jun 12 1999 Jeff Johnson <jbj@redhat.com> |
| 467 | - update to 3.99.1. |
| 468 | |
| 469 | * Wed Jun 2 1999 Jeff Johnson <jbj@redhat.com> |
| 470 | - add (the other :-) jj's sparc patch. |
| 471 | |
| 472 | * Wed May 26 1999 Jeff Johnson <jbj@redhat.com> |
| 473 | - upgrade to 3.99 in order to |
| 474 | - add new 2.2.x open flags (#2955). |
| 475 | - add new 2.2.x syscalls (#2866). |
| 476 | - strace 3.1 patches carried along for now. |
| 477 | |
| 478 | * Sun May 16 1999 Jeff Johnson <jbj@redhat.com> |
Roland McGrath | 00a1875 | 2007-02-18 22:55:21 +0000 | [diff] [blame] | 479 | - don't rely on (broken!) rpm %%patch (#2735) |
Roland McGrath | 037124f | 2003-01-10 10:44:57 +0000 | [diff] [blame] | 480 | |
| 481 | * Tue Apr 06 1999 Preston Brown <pbrown@redhat.com> |
| 482 | - strip binary |
| 483 | |
| 484 | * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com> |
| 485 | - auto rebuild in the new build environment (release 16) |
| 486 | |
| 487 | * Tue Feb 9 1999 Jeff Johnson <jbj@redhat.com> |
| 488 | - vfork est arrive! |
| 489 | |
| 490 | * Tue Feb 9 1999 Christopher Blizzard <blizzard@redhat.com> |
| 491 | - Add patch to follow clone() syscalls, too. |
| 492 | |
| 493 | * Sun Jan 17 1999 Jeff Johnson <jbj@redhat.com> |
| 494 | - patch to build alpha/sparc with glibc 2.1. |
| 495 | |
| 496 | * Thu Dec 03 1998 Cristian Gafton <gafton@redhat.com> |
| 497 | - patch to build on ARM |
| 498 | |
| 499 | * Wed Sep 30 1998 Jeff Johnson <jbj@redhat.com> |
| 500 | - fix typo (printf, not tprintf). |
| 501 | |
| 502 | * Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com> |
| 503 | - fix compile problem on sparc. |
| 504 | |
| 505 | * Tue Aug 18 1998 Cristian Gafton <gafton@redhat.com> |
| 506 | - buildroot |
| 507 | |
| 508 | * Mon Jul 20 1998 Cristian Gafton <gafton@redhat.com> |
| 509 | - added the umoven patch from James Youngman <jay@gnu.org> |
| 510 | - fixed build problems on newer glibc releases |
| 511 | |
| 512 | * Mon Jun 08 1998 Prospector System <bugs@redhat.com> |
| 513 | - translations modified for de, fr, tr |