Support defered generation of mipmaps.  With this change we support mipmap generation when the texture is uploaded to GL without requiring RS to retain the full chain.
diff --git a/libs/rs/rs.spec b/libs/rs/rs.spec
index 10e5285..89d9d5e 100644
--- a/libs/rs/rs.spec
+++ b/libs/rs/rs.spec
@@ -113,6 +113,7 @@
 
 AllocationUploadToTexture {
 	param RsAllocation alloc
+	param bool genMipMaps
 	param uint32_t baseMipLevel
 	}