Implement first pass bitmap to allocation support. The Java bindings can create a 2D allocation by passing in a Bitmap object.
diff --git a/libs/rs/rs.spec b/libs/rs/rs.spec
index 6168bd7..65a4a82 100644
--- a/libs/rs/rs.spec
+++ b/libs/rs/rs.spec
@@ -83,12 +83,23 @@
ret RsAllocation
}
-AllocationCreateFromBitmap {
+AllocationCreateFromFile {
param const char *file
param bool genMips
ret RsAllocation
}
+AllocationCreateFromBitmap {
+ param uint32_t width
+ param uint32_t height
+ param RsElementPredefined dstFmt
+ param RsElementPredefined srcFmt
+ param bool genMips
+ param const void * data
+ ret RsAllocation
+ }
+
+
AllocationUploadToTexture {
param RsAllocation alloc
param uint32_t baseMipLevel