1. 40a29e8 Implement basic allocation readback. Add Get height, width to ScriptC_Lib. by Jason Sams · 15 years ago
  2. d7b3774 Let java put #defines into renderscript by Joe Onorato · 15 years ago
  3. 1bada8c Begin implementing SimpleMesh and fix some bugs with refcounting and java object destruction tracking. by Jason Sams · 15 years ago
  4. 9bee51c Remove useless slot from ProgramVertex. Optimize GL state setup. by Jason Sams · 15 years ago
  5. 2253417 Split ProgramFragment and ProgramStore from RenderScript.java. Update Element and Type to new cached builder for easier app developement. by Jason Sams · 15 years ago
  6. 584a375 First pass at implementing the Grass live wallpaper in RenderScript. by Romain Guy · 15 years ago
  7. b0ec1b4 Add "boxed" bitmap uploads which simply place a non-pow2 bitmap into the smallest larger pow texture. The added space is filled black. by Jason Sams · 15 years ago
  8. ee41112 Enable light sources and update film test app. by Jason Sams · 15 years ago
  9. 64676f3 1st cut of a3d file loader. by Jason Sams · 15 years ago
  10. bba134c All light source objects. by Jason Sams · 15 years ago
  11. b37c0a5 Switch fountain to use ProgramVertex rather than hard coded camers in scripts. Remove camera code from scripts. by Jason Sams · 15 years ago
  12. 0826a6f Bug fixes. TriangleMesh now ref-counts, implement missing element formats, add missing modes for program vertex. Add matrix support classes. Add test app rollo by Jason Sams · 15 years ago
  13. d5680f9 Fix bug with bad conversion of java strings to C strings for object names. Update test app to test object defines. by Jason Sams · 15 years ago
  14. 3eaa338 Add named objects and implement support for ProgramFragmentStore and ProgramFragment to be used by name in scripts. by Jason Sams · 15 years ago
  15. 39ddc950 Move call to compiler from jni to core library code. by Jason Sams · 15 years ago
  16. 02fb2cb Add sampler support by Jason Sams · 15 years ago
  17. ec5a20b Delete the acc script when deleting the Renderscript rsScriptC object. by Jack Palevich · 15 years ago
  18. fe08d99 Implement first pass bitmap to allocation support. The Java bindings can create a 2D allocation by passing in a Bitmap object. by Jason Sams · 15 years ago
  19. d19f10d Add the Renderscript library. (Not in the build by default yet.) by Jason Sams · 15 years ago