Gitiles
Code Review
Sign In
gerrit-public.fairphone.software
/
platform
/
frameworks
/
base
/
7eecbf2085bcfe475daf68090a1a4f47fbb6ec72
/
libs
/
rs
/
rs.spec
128ce4b
real fix for [2440014] launcher2 crashing in loop during boot
by Mathias Agopian
· 15 years ago
e17964e
Add RS support for generic attribs as input to vertex programs.
by Jason Sams
· 15 years ago
718cd1f
Element restructuring. Add support for new basic Element types including the RS objects and vectors(2-4). In theory this paves the way for maintaining type info for RS objects, passing elements for GLSL uiforms/attribs/varyings, and supporting nested structures.
by Jason Sams
· 15 years ago
68afd01
Move texture bindings to base program object. Change ProgramFragment creation to require a texture format in 1.0 mode.
by Jason Sams
· 15 years ago
7e5ab3b
Continue es2 shader dev
by Jason Sams
· 15 years ago
0011bcf
Continue development of es2.0 user shader support for renderscript. This change cleans up ProgramVertex creation and adds support for passing input, output, and constant type info.
by Jason Sams
· 15 years ago
54c0ec1
Beging GL2 user shaders. Switch master to using GL2 by default.
by Jason Sams
· 15 years ago
715333b
Add support for dumping RS objects to aid in debugging of white blocks bug.
by Jason Sams
· 15 years ago
7d787b4
Add setPriority to allow wallpapers to run at lower cpu priority than default.
by Jason Sams
· 15 years ago
3bc47d4
Defer EGL init until the surface changed call comes in. Pass w,h along with surface for verification of driver state.
by Jason Sams
· 15 years ago
efd9b6fb
Support applications changing the surface attached to the RS.
by Jason Sams
· 15 years ago
65e7aa5
Implement pause/resume for the RS thread.
by Jason Sams
· 15 years ago
b6f2b13
Removed last bits of predefined element types from native code. Predefined types are now constructed at the java layer from standard building blocks.
by Jason Sams
· 15 years ago
6b9dec0
Remove depricated triangleMesh.
by Jason Sams
· 15 years ago
ebfb436
Add raster object to control point and line params. Add flag to force SW rendering.
by Jason Sams
· 15 years ago
be2e841
Implement renderscript Invokables.
by Jason Sams
· 15 years ago
ea84a7c
Remove "predefined" elements from Java layer. Static elements continue to exist but are no longer treated as a special version of element.
by Jason Sams
· 15 years ago
07ae406
Implement async data/subData. Implement TriangleMeshBuilder in SimpleMesh which replaces TriangleMesh. Update Film to use new builder.
by Jason Sams
· 15 years ago
25ffcdc
Point Sprites
by Jason Sams
· 15 years ago
7ce033d
Cleanup of object destruction. No need to have a per-class destruction function. This was a legacy of the distant past when the classes did not have a common base.
by Jason Sams
· 15 years ago
334ea0c
Update fountain and add writable flag to script slots.
by Jason Sams
· 15 years ago
fbf0b9e
Implement named slots and convert script.addType to script.setType to remove ordering restrictions.
by Jason Sams
· 15 years ago
43ee0685
Implement reflecting Java objects into the ACC enviroment.
by Jason Sams
· 15 years ago
40a29e8
Implement basic allocation readback. Add Get height, width to ScriptC_Lib.
by Jason Sams
· 15 years ago
d7b3774
Let java put #defines into renderscript
by Joe Onorato
· 15 years ago
1bada8c
Begin implementing SimpleMesh and fix some bugs with refcounting and java object destruction tracking.
by Jason Sams
· 15 years ago
9bee51c
Remove useless slot from ProgramVertex. Optimize GL state setup.
by Jason Sams
· 15 years ago
2253417
Split ProgramFragment and ProgramStore from RenderScript.java. Update Element and Type to new cached builder for easier app developement.
by Jason Sams
· 15 years ago
584a375
First pass at implementing the Grass live wallpaper in RenderScript.
by Romain Guy
· 15 years ago
b0ec1b4
Add "boxed" bitmap uploads which simply place a non-pow2 bitmap into the smallest larger pow texture. The added space is filled black.
by Jason Sams
· 15 years ago
ee41112
Enable light sources and update film test app.
by Jason Sams
· 15 years ago
64676f3
1st cut of a3d file loader.
by Jason Sams
· 15 years ago
bba134c
All light source objects.
by Jason Sams
· 15 years ago
b37c0a5
Switch fountain to use ProgramVertex rather than hard coded camers in scripts. Remove camera code from scripts.
by Jason Sams
· 15 years ago
0826a6f
Bug fixes. TriangleMesh now ref-counts, implement missing element formats, add missing modes for program vertex. Add matrix support classes. Add test app rollo
by Jason Sams
· 15 years ago
d5680f9
Fix bug with bad conversion of java strings to C strings for object names. Update test app to test object defines.
by Jason Sams
· 15 years ago
3eaa338
Add named objects and implement support for ProgramFragmentStore and ProgramFragment to be used by name in scripts.
by Jason Sams
· 15 years ago
39ddc950
Move call to compiler from jni to core library code.
by Jason Sams
· 15 years ago
02fb2cb
Add sampler support
by Jason Sams
· 15 years ago
ec5a20b
Delete the acc script when deleting the Renderscript rsScriptC object.
by Jack Palevich
· 15 years ago
fe08d99
Implement first pass bitmap to allocation support. The Java bindings can create a 2D allocation by passing in a Bitmap object.
by Jason Sams
· 15 years ago
d19f10d
Add the Renderscript library. (Not in the build by default yet.)
by Jason Sams
· 15 years ago