Implement named slots and convert script.addType to script.setType to remove ordering restrictions.
diff --git a/rs.spec b/rs.spec
index d4fbf6b..105142b 100644
--- a/rs.spec
+++ b/rs.spec
@@ -312,14 +312,18 @@
 	param uint32_t stencil
 	}
 
-ScriptCAddType {
+ScriptSetType {
 	param RsType type
+	param uint32_t slot
+	param const char * name
 	}
 
-ScriptCSetRoot {
+ScriptSetRoot {
 	param bool isRoot
 	}
 
+
+
 ScriptCSetScript {
 	param void * codePtr
 	}