1. a237151 Cleanup bitmap uploads Implement standalone mipmap generation. by Jason Sams · 13 years ago
  2. 5224a27 Additional loading methods for fonts and a3d files. Cleaned up error messages. by Alex Sakhartchouk · 14 years ago
  3. 4b45b89 Move adapter2D to a derived class from Allocation. by Jason Sams · 14 years ago
  4. 741aac9 Fix teardown bug found in books. by Jason Sams · 14 years ago
  5. ce8a079 Stale cache management to address a P1 bug # 3296131. by Shih-wei Liao · 14 years ago
  6. c17ace2 API reaview cleanup by Alex Sakhartchouk · 14 years ago
  7. 15849d9 1. Add Context to a RenderScript or RenderScriptGL instance. by Shih-wei Liao · 14 years ago
  8. ebc5019 More API updates. by Jason Sams · 14 years ago
  9. 837e388 Remove CreateFromBitmapRef and add CopyTo(bitmap) replacement. by Jason Sams · 14 years ago
  10. 1dcefab Fix a severe cleanup bug where teardown of the GL by Jason Sams · 14 years ago
  11. 366c9c8 Allocation API update. by Jason Sams · 14 years ago
  12. 87319de More error checks by Jason Sams · 14 years ago
  13. 9503b66 Add caching support of BCC binaries. by Shih-wei Liao · 14 years ago
  14. a5eb6e1 Fix ref counting for globals when set from java code. by Jason Sams · 14 years ago
  15. 54929cc Moving attrib creation to Mesh. Adding arrays as shader inputs. by Alex Sakhartchouk · 14 years ago
  16. dc763f3 Adding nvidia extension for limited npot support. by Alex Sakhartchouk · 14 years ago
  17. f0c1df4 Begin adding async allocation creation. by Jason Sams · 14 years ago
  18. 2353ae3 Async type creation. by Jason Sams · 14 years ago
  19. 39f2ef6 Update allocation from bitmap. GL attribute cleanup in type. by Alex Sakhartchouk · 14 years ago
  20. 0977c94 Fix support for 64-bit integers. by Stephen Hines · 14 years ago
  21. d7e5481 Cleanup error message for null binding address. by Jason Sams · 14 years ago
  22. 96abf81 Implement allocation resizing. by Jason Sams · 14 years ago
  23. 1103d8e Adding anisotropic filtering and related samples. by Alex Sakhartchouk · 14 years ago
  24. 383e5b1 Adding support for all allowed textures. by Alex Sakhartchouk · 14 years ago
  25. b9077f4 Better debugging for scripts. by Jason Sams · 14 years ago
  26. 6d0a074 Add support for Float64 (double) to RenderScript. by Stephen Hines · 14 years ago
  27. 46e4554 Add arrays to elements. by Jason Sams · 14 years ago
  28. 5f0c84c SubElementData data upload functions. by Jason Sams · 14 years ago
  29. 46bafb3 Make java entry points for native fifo synchronized. by Jason Sams · 14 years ago
  30. 9fc9f03 Added ability to set font color. by Alex Sakhartchouk · 14 years ago
  31. 417e6a4 Populate java objects with native data from a3d file. by Alex Sakhartchouk · 14 years ago
  32. d18c744 Work on synchronizing a3d created files and java layer. by Alex Sakhartchouk · 14 years ago
  33. 479e292 Remove points from fixed function. Add basic GL performance test. by Jason Sams · 14 years ago
  34. 17d72e8 Cleanup pass on the mesh api change. by Alex Sakhartchouk · 14 years ago
  35. 4e9a7a8 Start of mesh API cleanup. by Alex Sakhartchouk · 14 years ago
  36. 4ab16b5 am 177c405a: am c6e1d880: Merge "Introduce official public NativeWindow type." into gingerbread by Dianne Hackborn · 14 years ago
  37. 1c769c3 Introduce official public NativeWindow type. by Dianne Hackborn · 14 years ago
  38. d3e0ad4 Adding freetype font rendering to renderscript. by Alex Sakhartchouk · 14 years ago
  39. 8c88090 Remove InvokeData and add ContextFinish to generate a sync point. by Jason Sams · 14 years ago
  40. b825f67 Creating the jni and java layer to integrate a3d by Alex Sakhartchouk · 14 years ago
  41. 22fa371 Begin naming cleanup for renderscript runtime. by Jason Sams · 14 years ago
  42. ce92d4b Remove more pieces of setRoot. Add pointer to allocation lookup for scripts. by Jason Sams · 14 years ago
  43. 639e6e9 Delete legacy setDefine API. by Jason Sams · 14 years ago
  44. ccc010b Rename ProgramFragmentStore to ProgramStore. by Jason Sams · 14 years ago
  45. be36bf3 Convert renderscript from using ACC to LLVM for its compiler. by Jason Sams · 14 years ago
  46. c1ed589 checkpoint animations by Jason Sams · 14 years ago
  47. a2cf755 Improve RS error handling. On errors RS will now store the error and a message that can be read from the app. RS will then not continue rendering frames while an unchecked error is present until new state is received. by Jason Sams · 14 years ago
  48. fa84da2 Add support for linking to a skia bitmap rather than always copying the data from the bitmap. by Jason Sams · 14 years ago
  49. 7fabe1a Support defered generation of mipmaps. With this change we support mipmap generation when the texture is uploaded to GL without requiring RS to retain the full chain. by Jason Sams · 14 years ago
  50. fa40286 real fix for [2440014] launcher2 crashing in loop during boot by Mathias Agopian · 14 years ago
  51. b4d3568 Add RS support for generic attribs as input to vertex programs. by Jason Sams · 15 years ago
  52. d01d970 Element restructuring. Add support for new basic Element types including the RS objects and vectors(2-4). In theory this paves the way for maintaining type info for RS objects, passing elements for GLSL uiforms/attribs/varyings, and supporting nested structures. by Jason Sams · 15 years ago
  53. 7dad9c3 Move texture bindings to base program object. Change ProgramFragment creation to require a texture format in 1.0 mode. by Jason Sams · 15 years ago
  54. f2e4fa2 Continue es2 shader dev by Jason Sams · 15 years ago
  55. 4815c0d Continue development of es2.0 user shader support for renderscript. This change cleans up ProgramVertex creation and adds support for passing input, output, and constant type info. by Jason Sams · 15 years ago
  56. f2a5d73 Beging GL2 user shaders. Switch master to using GL2 by default. by Jason Sams · 15 years ago
  57. c21cf40 Add support for dumping RS objects to aid in debugging of white blocks bug. by Jason Sams · 15 years ago
  58. 1583244 Add setPriority to allow wallpapers to run at lower cpu priority than default. by Jason Sams · 15 years ago
  59. 613cad1 Defer EGL init until the surface changed call comes in. Pass w,h along with surface for verification of driver state. by Jason Sams · 15 years ago
  60. 458f2dc Support applications changing the surface attached to the RS. by Jason Sams · 15 years ago
  61. 86f1b23 Implement pause/resume for the RS thread. by Jason Sams · 15 years ago
  62. 8287c0c Removed last bits of predefined element types from native code. Predefined types are now constructed at the java layer from standard building blocks. by Jason Sams · 15 years ago
  63. a2b54c4 Remove depricated triangleMesh. by Jason Sams · 15 years ago
  64. 5fd09d8 Add raster object to control point and line params. Add flag to force SW rendering. by Jason Sams · 15 years ago
  65. 8c6bc69 Implement renderscript Invokables. by Jason Sams · 15 years ago
  66. a57c0a7 Remove "predefined" elements from Java layer. Static elements continue to exist but are no longer treated as a special version of element. by Jason Sams · 15 years ago
  67. 9397e30 Implement async data/subData. Implement TriangleMeshBuilder in SimpleMesh which replaces TriangleMesh. Update Film to use new builder. by Jason Sams · 15 years ago
  68. e015841 Point Sprites by Jason Sams · 15 years ago
  69. 707aaf3 Cleanup of object destruction. No need to have a per-class destruction function. This was a legacy of the distant past when the classes did not have a common base. by Jason Sams · 15 years ago
  70. 90b36a8 Update fountain and add writable flag to script slots. by Jason Sams · 15 years ago
  71. fa51719 Implement named slots and convert script.addType to script.setType to remove ordering restrictions. by Jason Sams · 15 years ago
  72. 8b2c065 Implement reflecting Java objects into the ACC enviroment. by Jason Sams · 15 years ago
  73. e579df4 Implement basic allocation readback. Add Get height, width to ScriptC_Lib. by Jason Sams · 15 years ago
  74. 57b79ce Let java put #defines into renderscript by Joe Onorato · 15 years ago
  75. e5ffb87 Begin implementing SimpleMesh and fix some bugs with refcounting and java object destruction tracking. by Jason Sams · 15 years ago
  76. cfb1d11 Remove useless slot from ProgramVertex. Optimize GL state setup. by Jason Sams · 15 years ago
  77. d34b725 Split ProgramFragment and ProgramStore from RenderScript.java. Update Element and Type to new cached builder for easier app developement. by Jason Sams · 15 years ago
  78. 98e10fd First pass at implementing the Grass live wallpaper in RenderScript. by Romain Guy · 15 years ago
  79. c9d43db Add "boxed" bitmap uploads which simply place a non-pow2 bitmap into the smallest larger pow texture. The added space is filled black. by Jason Sams · 15 years ago
  80. b5909ce Enable light sources and update film test app. by Jason Sams · 15 years ago
  81. a5597fc 1st cut of a3d file loader. by Jason Sams · 15 years ago
  82. 62bc1db All light source objects. by Jason Sams · 15 years ago
  83. 56bc1af Switch fountain to use ProgramVertex rather than hard coded camers in scripts. Remove camera code from scripts. by Jason Sams · 15 years ago
  84. 2a1cc8f Bug fixes. TriangleMesh now ref-counts, implement missing element formats, add missing modes for program vertex. Add matrix support classes. Add test app rollo by Jason Sams · 15 years ago
  85. a4a54e4 Fix bug with bad conversion of java strings to C strings for object names. Update test app to test object defines. by Jason Sams · 15 years ago
  86. a0a1b6f Add named objects and implement support for ProgramFragmentStore and ProgramFragment to be used by name in scripts. by Jason Sams · 15 years ago
  87. 1f52633 Move call to compiler from jni to core library code. by Jason Sams · 15 years ago
  88. 39c8bc7 Add sampler support by Jason Sams · 15 years ago
  89. 1ef8b80 Delete the acc script when deleting the Renderscript rsScriptC object. by Jack Palevich · 15 years ago
  90. 6678e9b Implement first pass bitmap to allocation support. The Java bindings can create a 2D allocation by passing in a Bitmap object. by Jason Sams · 15 years ago
  91. 326e0dd Add the Renderscript library. (Not in the build by default yet.) by Jason Sams · 15 years ago