1. 8c6bc69 Implement renderscript Invokables. by Jason Sams · 15 years ago
  2. a57c0a7 Remove "predefined" elements from Java layer. Static elements continue to exist but are no longer treated as a special version of element. by Jason Sams · 15 years ago
  3. 9397e30 Implement async data/subData. Implement TriangleMeshBuilder in SimpleMesh which replaces TriangleMesh. Update Film to use new builder. by Jason Sams · 15 years ago
  4. e015841 Point Sprites by Jason Sams · 15 years ago
  5. 707aaf3 Cleanup of object destruction. No need to have a per-class destruction function. This was a legacy of the distant past when the classes did not have a common base. by Jason Sams · 15 years ago
  6. 90b36a8 Update fountain and add writable flag to script slots. by Jason Sams · 15 years ago
  7. fa51719 Implement named slots and convert script.addType to script.setType to remove ordering restrictions. by Jason Sams · 15 years ago
  8. 8b2c065 Implement reflecting Java objects into the ACC enviroment. by Jason Sams · 15 years ago
  9. e579df4 Implement basic allocation readback. Add Get height, width to ScriptC_Lib. by Jason Sams · 15 years ago
  10. 57b79ce Let java put #defines into renderscript by Joe Onorato · 15 years ago
  11. e5ffb87 Begin implementing SimpleMesh and fix some bugs with refcounting and java object destruction tracking. by Jason Sams · 15 years ago
  12. cfb1d11 Remove useless slot from ProgramVertex. Optimize GL state setup. by Jason Sams · 15 years ago
  13. d34b725 Split ProgramFragment and ProgramStore from RenderScript.java. Update Element and Type to new cached builder for easier app developement. by Jason Sams · 15 years ago
  14. 98e10fd First pass at implementing the Grass live wallpaper in RenderScript. by Romain Guy · 15 years ago
  15. c9d43db Add "boxed" bitmap uploads which simply place a non-pow2 bitmap into the smallest larger pow texture. The added space is filled black. by Jason Sams · 15 years ago
  16. b5909ce Enable light sources and update film test app. by Jason Sams · 15 years ago
  17. a5597fc 1st cut of a3d file loader. by Jason Sams · 15 years ago
  18. 62bc1db All light source objects. by Jason Sams · 15 years ago
  19. 56bc1af Switch fountain to use ProgramVertex rather than hard coded camers in scripts. Remove camera code from scripts. by Jason Sams · 15 years ago
  20. 2a1cc8f Bug fixes. TriangleMesh now ref-counts, implement missing element formats, add missing modes for program vertex. Add matrix support classes. Add test app rollo by Jason Sams · 15 years ago
  21. a4a54e4 Fix bug with bad conversion of java strings to C strings for object names. Update test app to test object defines. by Jason Sams · 15 years ago
  22. a0a1b6f Add named objects and implement support for ProgramFragmentStore and ProgramFragment to be used by name in scripts. by Jason Sams · 15 years ago
  23. 1f52633 Move call to compiler from jni to core library code. by Jason Sams · 15 years ago
  24. 39c8bc7 Add sampler support by Jason Sams · 15 years ago
  25. 1ef8b80 Delete the acc script when deleting the Renderscript rsScriptC object. by Jack Palevich · 15 years ago
  26. 6678e9b Implement first pass bitmap to allocation support. The Java bindings can create a 2D allocation by passing in a Bitmap object. by Jason Sams · 15 years ago
  27. 326e0dd Add the Renderscript library. (Not in the build by default yet.) by Jason Sams · 15 years ago