Gitiles
Code Review
Sign In
gerrit-public.fairphone.software
/
platform
/
frameworks
/
rs
/
adc46414b68614c95c3cfbfd0a9de38bfa27c2be
/
rs.spec
ae2ec3f
Delete simple reduction implementation.
by David Gross
· 8 years ago
5e48002
Avoid accessing TLS in rsClearObject()
by Yang Ni
· 9 years ago
02ed79a
ContextDestroy should go through FIFO
by Yang Ni
· 9 years ago
cc1b09f
Revert "Added a flag to APIs for rsObj creation"
by Yang Ni
· 9 years ago
04dcca9
Added a flag to APIs for rsObj creation
by Yang Ni
· 9 years ago
886e5a2
Merge "Add multi-frame support to RenderScript:"
by Miao Wang
· 9 years ago
7547468
Add multi-frame support to RenderScript:
by Miao Wang
· 9 years ago
6c1876b
Support for general reduction kernels.
by David Gross
· 9 years ago
fef0cd4
Various fixes in setting globals in a script group
by Yang Ni
· 9 years ago
39a9d9b
Add a ScriptReduce API entry and a stub function rsi_ScriptReduce().
by Matt Wala
· 9 years ago
21b0461
Handle error case when yylex() failed to parse.
by Logan Chien
· 10 years ago
8b94222
Added a name to ScriptGroup2
by Yang Ni
· 10 years ago
ea6e062
Add cache dir to context object.
by Tim Murray
· 10 years ago
bd0af2d
Clean up ScriptGroup2 implementation
by Yang Ni
· 10 years ago
cc8cea7
Fix the bug for AllocationRead() that cannot handle 3d Allocation
by Miao Wang
· 10 years ago
05c2cd0
Merge "Implement arrays and allocation adapters"
by Jason Sams
· 10 years ago
bc9dc27
Implement arrays and allocation adapters
by Jason Sams
· 10 years ago
eb9aa67
Runtime support for invocables in ScriptGroups
by Yang Ni
· 10 years ago
da0f069
Runtime support for compiler kernel fusion.
by Yang Ni
· 10 years ago
6000c26
Merge "Array type and allocation support"
by Jason Sams
· 10 years ago
c7968a0
Array type and allocation support
by Jason Sams
· 10 years ago
1ffd86b
New Script Group API: runtime and cpu driver support.
by Yang Ni
· 10 years ago
4b3c34e
Adds support for multi-input kernels to Frameworks/RS.
by Chris Wailes
· 10 years ago
ac8d146
Switch the dimensions array to use uint32_t instead of size_t.
by Stephen Hines
· 10 years ago
b8a94e2
Add getPointer for USAGE_SHARED allocations.
by Jason Sams
· 11 years ago
397b0b1
Make object destruction asynchronous.
by Tim Murray
· 11 years ago
8f615d6
Replace "mips" with "mipmaps" since the MIPS gcc compiler defines mips to 1.
by Stephen Hines
· 11 years ago
4a92d12
Move to dynamic dispatch. Add support for IoAllocation* in rs.spec.
by Tim Murray
· 11 years ago
8c1da3f
Removed unused methods from rs.spec.
by Tim Murray
· 11 years ago
9c64239
Add support for synchronous get().
by Tim Murray
· 12 years ago
3bbc0fd
Add 3D allocation copies.
by Jason Sams
· 12 years ago
099bc26
Start making RS 64-bit clean.
by Tim Murray
· 12 years ago
2487bb7
Split rs.spec into generic and native-specific functions.
by Tim Murray
· 12 years ago
29226ae
Split graphics rs.spec into its own file.
by Tim Murray
· 12 years ago
733396b
Implement usage IO INPUT
by Jason Sams
· 12 years ago
d4ecb17
Add API entry points for clipped kernels and fix Z-dimension clipping.
by Tim Murray
· 12 years ago
7026520
Implement rs.sendMessage()
by Jason Sams
· 12 years ago
a572aca
Add support for YUV allocations.
by Jason Sams
· 12 years ago
358747a
Add support for 2D strided copies to/from an allocation with the C++ API.
by Tim Murray
· 12 years ago
7b3e309
Add support for 2D copies to arbitrary data pointers.
by Tim Murray
· 12 years ago
509ea5c
Add copy1DRangeToUnchecked.
by Tim Murray
· 12 years ago
dbe66d6
Add backed for script groups.
by Jason Sams
· 12 years ago
8eaba4f
Intrinisics
by Jason Sams
· 12 years ago
2980f07
Support additional element/dim information for FieldPacker.
by Stephen Hines
· 13 years ago
3522f40
Implement USAGE_IO_INPUT
by Jason Sams
· 13 years ago
38c04ad
Merge "Piping texture names through shader builder. Fixing uint size_t mismatch."
by Alex Sakhartchouk
· 13 years ago
748eb07
Piping texture names through shader builder. Fixing uint size_t mismatch.
by Alex Sakhartchouk
· 13 years ago
7ac2a4d
Beging IO stream out from allocation to surface texture.
by Jason Sams
· 13 years ago
d3e4b74
Merge commit 'bdeec118' into manualmerge
by Jason Sams
· 13 years ago
5f27d6f
Implement RS VSync on new vsync infrastructure.
by Jason Sams
· 13 years ago
d104703
am 855eadf9: Merge "Fix potential bug with reordered size/offset arguments."
by Stephen Hines
· 13 years ago
6ae039b
Fix potential bug with reordered size/offset arguments.
by Stephen Hines
· 13 years ago
41e373d
Start implementing SurfaceTexture streaming into RS allocations.
by Jason Sams
· 13 years ago
179e9a4
Private API to support MFF transition.
by Jason Sams
· 13 years ago
9e0afb5
Path rendering
by Jason Sams
· 13 years ago
5b9f3e2
Remove unused fields in ProgramRaster
by Jason Sams
· 13 years ago
c700e64
Fixing asynchronous performance issues.
by Alex Sakhartchouk
· 13 years ago
c33e690
First cut at RSTextureView.
by Jason Sams
· 13 years ago
74a8279
Allocation copy functions.
by Alex Sakhartchouk
· 13 years ago
789ca83
Move context and device creation out of the spec file.
by Jason Sams
· 14 years ago
7257c7e
Preparing libRS for for compilation on host.
by Alex Sakhartchouk
· 14 years ago
1a4efa3
Core to client fifo on sockets.
by Jason Sams
· 14 years ago
9003e56
Cleanup mesh creation.
by Alex Sakhartchouk
· 14 years ago
2008747
Add code for generating fifo command packing.
by Jason Sams
· 14 years ago
c2c02a8
Code Cleanup and better Sampler creation method
by Alex Sakhartchouk
· 14 years ago
c975cf4
Pipe rsa function though the RS api table.
by Jason Sams
· 14 years ago
5fb1aeb
Start implementing control side forEach.
by Jason Sams
· 14 years ago
186e591
Cleanup rs.spec file and code generator.
by Jason Sams
· 14 years ago
70b83c1
Modifying libRS internal communication to handle network rendering.
by Alex Sakhartchouk
· 14 years ago
721acc4
Seperate ProgramRaster. Cleanup ProgramRaster and ProgramStore creation.
by Jason Sams
· 14 years ago
bad8074
Start seperating out RS compute implementation. Create hal
by Jason Sams
· 14 years ago
a237151
Cleanup bitmap uploads Implement standalone mipmap generation.
by Jason Sams
· 14 years ago
5224a27
Additional loading methods for fonts and a3d files. Cleaned up error messages.
by Alex Sakhartchouk
· 14 years ago
4b45b89
Move adapter2D to a derived class from Allocation.
by Jason Sams
· 14 years ago
741aac9
Fix teardown bug found in books.
by Jason Sams
· 14 years ago
ce8a079
Stale cache management to address a P1 bug # 3296131.
by Shih-wei Liao
· 14 years ago
c17ace2
API reaview cleanup
by Alex Sakhartchouk
· 14 years ago
15849d9
1. Add Context to a RenderScript or RenderScriptGL instance.
by Shih-wei Liao
· 14 years ago
ebc5019
More API updates.
by Jason Sams
· 14 years ago
837e388
Remove CreateFromBitmapRef and add CopyTo(bitmap) replacement.
by Jason Sams
· 14 years ago
1dcefab
Fix a severe cleanup bug where teardown of the GL
by Jason Sams
· 14 years ago
366c9c8
Allocation API update.
by Jason Sams
· 14 years ago
87319de
More error checks
by Jason Sams
· 14 years ago
9503b66
Add caching support of BCC binaries.
by Shih-wei Liao
· 14 years ago
a5eb6e1
Fix ref counting for globals when set from java code.
by Jason Sams
· 14 years ago
54929cc
Moving attrib creation to Mesh. Adding arrays as shader inputs.
by Alex Sakhartchouk
· 14 years ago
dc763f3
Adding nvidia extension for limited npot support.
by Alex Sakhartchouk
· 14 years ago
f0c1df4
Begin adding async allocation creation.
by Jason Sams
· 14 years ago
2353ae3
Async type creation.
by Jason Sams
· 14 years ago
39f2ef6
Update allocation from bitmap. GL attribute cleanup in type.
by Alex Sakhartchouk
· 14 years ago
0977c94
Fix support for 64-bit integers.
by Stephen Hines
· 14 years ago
d7e5481
Cleanup error message for null binding address.
by Jason Sams
· 14 years ago
96abf81
Implement allocation resizing.
by Jason Sams
· 14 years ago
1103d8e
Adding anisotropic filtering and related samples.
by Alex Sakhartchouk
· 14 years ago
383e5b1
Adding support for all allowed textures.
by Alex Sakhartchouk
· 14 years ago
b9077f4
Better debugging for scripts.
by Jason Sams
· 14 years ago
6d0a074
Add support for Float64 (double) to RenderScript.
by Stephen Hines
· 14 years ago
46e4554
Add arrays to elements.
by Jason Sams
· 14 years ago
5f0c84c
SubElementData data upload functions.
by Jason Sams
· 14 years ago
46bafb3
Make java entry points for native fifo synchronized.
by Jason Sams
· 14 years ago
Next »