1. d01d970 Element restructuring. Add support for new basic Element types including the RS objects and vectors(2-4). In theory this paves the way for maintaining type info for RS objects, passing elements for GLSL uiforms/attribs/varyings, and supporting nested structures. by Jason Sams · 15 years ago
  2. 7dad9c3 Move texture bindings to base program object. Change ProgramFragment creation to require a texture format in 1.0 mode. by Jason Sams · 15 years ago
  3. f2e4fa2 Continue es2 shader dev by Jason Sams · 15 years ago
  4. 4815c0d Continue development of es2.0 user shader support for renderscript. This change cleans up ProgramVertex creation and adds support for passing input, output, and constant type info. by Jason Sams · 15 years ago
  5. f2a5d73 Beging GL2 user shaders. Switch master to using GL2 by default. by Jason Sams · 15 years ago
  6. c21cf40 Add support for dumping RS objects to aid in debugging of white blocks bug. by Jason Sams · 15 years ago
  7. 1583244 Add setPriority to allow wallpapers to run at lower cpu priority than default. by Jason Sams · 15 years ago
  8. 613cad1 Defer EGL init until the surface changed call comes in. Pass w,h along with surface for verification of driver state. by Jason Sams · 15 years ago
  9. 458f2dc Support applications changing the surface attached to the RS. by Jason Sams · 15 years ago
  10. 86f1b23 Implement pause/resume for the RS thread. by Jason Sams · 15 years ago
  11. 8287c0c Removed last bits of predefined element types from native code. Predefined types are now constructed at the java layer from standard building blocks. by Jason Sams · 15 years ago
  12. a2b54c4 Remove depricated triangleMesh. by Jason Sams · 15 years ago
  13. 5fd09d8 Add raster object to control point and line params. Add flag to force SW rendering. by Jason Sams · 15 years ago
  14. 8c6bc69 Implement renderscript Invokables. by Jason Sams · 15 years ago
  15. a57c0a7 Remove "predefined" elements from Java layer. Static elements continue to exist but are no longer treated as a special version of element. by Jason Sams · 15 years ago
  16. 9397e30 Implement async data/subData. Implement TriangleMeshBuilder in SimpleMesh which replaces TriangleMesh. Update Film to use new builder. by Jason Sams · 15 years ago
  17. e015841 Point Sprites by Jason Sams · 15 years ago
  18. 707aaf3 Cleanup of object destruction. No need to have a per-class destruction function. This was a legacy of the distant past when the classes did not have a common base. by Jason Sams · 15 years ago
  19. 90b36a8 Update fountain and add writable flag to script slots. by Jason Sams · 15 years ago
  20. fa51719 Implement named slots and convert script.addType to script.setType to remove ordering restrictions. by Jason Sams · 15 years ago
  21. 8b2c065 Implement reflecting Java objects into the ACC enviroment. by Jason Sams · 15 years ago
  22. e579df4 Implement basic allocation readback. Add Get height, width to ScriptC_Lib. by Jason Sams · 15 years ago
  23. 57b79ce Let java put #defines into renderscript by Joe Onorato · 15 years ago
  24. e5ffb87 Begin implementing SimpleMesh and fix some bugs with refcounting and java object destruction tracking. by Jason Sams · 15 years ago
  25. cfb1d11 Remove useless slot from ProgramVertex. Optimize GL state setup. by Jason Sams · 15 years ago
  26. d34b725 Split ProgramFragment and ProgramStore from RenderScript.java. Update Element and Type to new cached builder for easier app developement. by Jason Sams · 15 years ago
  27. 98e10fd First pass at implementing the Grass live wallpaper in RenderScript. by Romain Guy · 15 years ago
  28. c9d43db Add "boxed" bitmap uploads which simply place a non-pow2 bitmap into the smallest larger pow texture. The added space is filled black. by Jason Sams · 15 years ago
  29. b5909ce Enable light sources and update film test app. by Jason Sams · 15 years ago
  30. a5597fc 1st cut of a3d file loader. by Jason Sams · 15 years ago
  31. 62bc1db All light source objects. by Jason Sams · 15 years ago
  32. 56bc1af Switch fountain to use ProgramVertex rather than hard coded camers in scripts. Remove camera code from scripts. by Jason Sams · 15 years ago
  33. 2a1cc8f Bug fixes. TriangleMesh now ref-counts, implement missing element formats, add missing modes for program vertex. Add matrix support classes. Add test app rollo by Jason Sams · 15 years ago
  34. a4a54e4 Fix bug with bad conversion of java strings to C strings for object names. Update test app to test object defines. by Jason Sams · 15 years ago
  35. a0a1b6f Add named objects and implement support for ProgramFragmentStore and ProgramFragment to be used by name in scripts. by Jason Sams · 15 years ago
  36. 1f52633 Move call to compiler from jni to core library code. by Jason Sams · 15 years ago
  37. 39c8bc7 Add sampler support by Jason Sams · 15 years ago
  38. 1ef8b80 Delete the acc script when deleting the Renderscript rsScriptC object. by Jack Palevich · 15 years ago
  39. 6678e9b Implement first pass bitmap to allocation support. The Java bindings can create a 2D allocation by passing in a Bitmap object. by Jason Sams · 15 years ago
  40. 326e0dd Add the Renderscript library. (Not in the build by default yet.) by Jason Sams · 15 years ago