blob: 8db9350d83148867375fba0066bf877f5727d8d9 [file] [log] [blame]
Brian Paul7b2c0f92000-06-09 00:22:02 +00001Name
2
3 MESA_release_buffers
4
5Name Strings
6
7 GLX_MESA_release_buffers
8
9Contact
10
Brian Pauld3b09fe2004-03-25 01:42:41 +000011 Brian Paul (brian.paul 'at' tungstengraphics.com)
Brian Paul7b2c0f92000-06-09 00:22:02 +000012
13Status
14
15 Shipping since Mesa 2.0 in October, 1996.
16
17Version
18
19 Last Modified Date: 8 June 2000
20
21Number
22
Brian Pauldd18a4f2000-06-23 17:34:47 +000023 217
Brian Paul7b2c0f92000-06-09 00:22:02 +000024
25Dependencies
26
27 OpenGL 1.0 or later is required.
28 GLX 1.0 or later is required.
29
30Overview
31
32 Mesa's implementation of GLX is entirely implemented on the client side.
33 Therefore, Mesa cannot immediately detect when an X window or pixmap is
34 destroyed in order to free any ancilliary data associated with the window
35 or pixmap.
36
37 The glxMesaReleaseBuffers() function can be used to explicitly indicate
38 when the back color buffer, depth buffer, stencil buffer, and/or accum-
39 ulation buffer associated with a drawable can be freed.
40
41IP Status
42
43 Open-source; freely implementable.
44
45Issues
46
47 None.
48
49New Procedures and Functions
50
51 Bool glXReleaseBuffersMESA( Display *dpy, GLXDrawable d );
52
53New Tokens
54
55 None.
56
57Additions to Chapter 3 of the GLX 1.3 Specification (Functions and Errors)
58
59 The function
60
Brian Pauldd18a4f2000-06-23 17:34:47 +000061 Bool glXReleaseBuffersMESA( Display *dpy, GLXDrawable d );
Brian Paul7b2c0f92000-06-09 00:22:02 +000062
63 causes all software ancilliary buffers (back buffer, depth, stencil,
64 accum, etc) associated with the named drawable to be immediately
65 deallocated. True is returned if <d> is a valid Mesa GLX drawable,
66 else False is returned. After calling glXReleaseBuffersMESA, the
67 drawable should no longer be used for GL rendering. Results of
68 attempting to do so are undefined.
69
70
71GLX Protocol
72
73 None, since this is a client-side operation.
74
75Errors
76
77 None.
78
79New State
80
81 None.
82
83Revision History
84
85 8 June 2000 - initial specification