blob: bb8b446ab57c087a82a5af648856a61fd5f7d2ae [file] [log] [blame]
Jason Sams41371c72015-03-26 20:46:57 +00001#
2# Copyright (C) 2015 The Android Open Source Project
3#
4# Licensed under the Apache License, Version 2.0 (the "License");
5# you may not use this file except in compliance with the License.
6# You may obtain a copy of the License at
7#
8# http://www.apache.org/licenses/LICENSE-2.0
9#
10# Unless required by applicable law or agreed to in writing, software
11# distributed under the License is distributed on an "AS IS" BASIS,
12# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13# See the License for the specific language governing permissions and
14# limitations under the License.
15#
16
17header:
18summary: Object routines
19description:
20end:
21
22function: rsClearObject
23t: rs_element, rs_type, rs_allocation, rs_sampler, rs_script
24ret: void
25arg: #1* dst
26hidden:
27summary: For internal use.
28description:
29test: none
30end:
31
32function: rsClearObject
33size: 32
34t: rs_mesh, rs_program_fragment, rs_program_vertex, rs_program_raster, rs_program_store, rs_font
35ret: void
36arg: #1* dst
37test: none
38end:
39
40function: rsIsObject
41t: rs_element, rs_type, rs_allocation, rs_sampler, rs_script
42ret: bool
43arg: #1 v
44hidden:
45summary: For internal use.
46description:
47test: none
48end:
49
50function: rsIsObject
51size: 32
52t: rs_mesh, rs_program_fragment, rs_program_vertex, rs_program_raster, rs_program_store, rs_font
53ret: bool
54arg: #1 v
55test: none
56end:
57
58function: rsSetObject
59t: rs_element, rs_type, rs_allocation, rs_sampler, rs_script
60ret: void
61arg: #1* dst
62arg: #1 src
63hidden:
64summary: For internal use.
65description:
66test: none
67end:
68
69function: rsSetObject
70size: 32
71t: rs_mesh, rs_program_fragment, rs_program_vertex, rs_program_raster, rs_program_store, rs_font
72ret: void
73arg: #1* dst
74arg: #1 src
75test: none
76end: