blob: a2c39a9c8e4d5cc114f952b3a64d5b217b5a613e [file] [log] [blame]
Jason Sams41371c72015-03-26 20:46:57 +00001#
2# Copyright (C) 2015 The Android Open Source Project
3#
4# Licensed under the Apache License, Version 2.0 (the "License");
5# you may not use this file except in compliance with the License.
6# You may obtain a copy of the License at
7#
8# http://www.apache.org/licenses/LICENSE-2.0
9#
10# Unless required by applicable law or agreed to in writing, software
11# distributed under the License is distributed on an "AS IS" BASIS,
12# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13# See the License for the specific language governing permissions and
14# limitations under the License.
15#
16
17header:
18summary: Program object routines
19description:
20end:
21
22function: rsgProgramRasterGetCullMode
23version: 16
24ret: rs_cull_mode
25arg: rs_program_raster pr, "program raster to query"
26summary:
27description:
28 Get program raster cull mode
29test: none
30end:
31
32function: rsgProgramRasterIsPointSpriteEnabled
33version: 16
34ret: bool
35arg: rs_program_raster pr, "program raster to query"
36summary:
37description:
38 Get program raster point sprite state
39test: none
40end:
41
42function: rsgProgramStoreGetBlendDstFunc
43version: 16
44ret: rs_blend_dst_func
45arg: rs_program_store ps, "program store to query"
46summary:
47description:
48 Get program store blend destination function
49test: none
50end:
51
52function: rsgProgramStoreGetBlendSrcFunc
53version: 16
54ret: rs_blend_src_func
55arg: rs_program_store ps, "program store to query"
56summary:
57description:
58 Get program store blend source function
59test: none
60end:
61
62function: rsgProgramStoreGetDepthFunc
63version: 16
64ret: rs_depth_func
65arg: rs_program_store ps, "program store to query"
66summary:
67description:
68 Get program store depth function
69test: none
70end:
71
72function: rsgProgramStoreIsColorMaskAlphaEnabled
73version: 16
74ret: bool
75arg: rs_program_store ps, "program store to query"
76summary:
77description:
78 Get program store alpha component color mask
79test: none
80end:
81
82function: rsgProgramStoreIsColorMaskBlueEnabled
83version: 16
84ret: bool
85arg: rs_program_store ps, "program store to query"
86summary:
87description:
88 Get program store blur component color mask
89test: none
90end:
91
92function: rsgProgramStoreIsColorMaskGreenEnabled
93version: 16
94ret: bool
95arg: rs_program_store ps, "program store to query"
96summary:
97description:
98 Get program store green component color mask
99test: none
100end:
101
102function: rsgProgramStoreIsColorMaskRedEnabled
103version: 16
104ret: bool
105arg: rs_program_store ps, "program store to query"
106summary:
107description:
108 Get program store red component color mask
109test: none
110end:
111
112function: rsgProgramStoreIsDepthMaskEnabled
113version: 16
114ret: bool
115arg: rs_program_store ps, "program store to query"
116summary:
117description:
118 Get program store depth mask
119test: none
120end:
121
122function: rsgProgramStoreIsDitherEnabled
123version: 16
124ret: bool
125arg: rs_program_store ps, "program store to query"
126summary:
127description:
128 Get program store dither state
129test: none
130end: