blob: 35ab612bd5834d126a1319028017779a1aa1d522 [file] [log] [blame]
Jason Sams41371c72015-03-26 20:46:57 +00001#
2# Copyright (C) 2015 The Android Open Source Project
3#
4# Licensed under the Apache License, Version 2.0 (the "License");
5# you may not use this file except in compliance with the License.
6# You may obtain a copy of the License at
7#
8# http://www.apache.org/licenses/LICENSE-2.0
9#
10# Unless required by applicable law or agreed to in writing, software
11# distributed under the License is distributed on an "AS IS" BASIS,
12# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13# See the License for the specific language governing permissions and
14# limitations under the License.
15#
16
17header:
18summary: Sampler routines
19description:
20end:
21
22function: rsSamplerGetAnisotropy
23version: 16
24ret: float, "anisotropy"
25arg: rs_sampler s, "sampler to query"
26summary:
27description:
28 Get sampler anisotropy
29test: none
30end:
31
32function: rsSamplerGetMagnification
33version: 16
34ret: rs_sampler_value, "magnification value"
35arg: rs_sampler s, "sampler to query"
36summary:
37description:
38 Get sampler magnification value
39test: none
40end:
41
42function: rsSamplerGetMinification
43version: 16
44ret: rs_sampler_value, "minification value"
45arg: rs_sampler s, "sampler to query"
46summary:
47description:
48 Get sampler minification value
49test: none
50end:
51
52function: rsSamplerGetWrapS
53version: 16
54ret: rs_sampler_value, "wrap S value"
55arg: rs_sampler s, "sampler to query"
56summary:
57description:
58 Get sampler wrap S value
59test: none
60end:
61
62function: rsSamplerGetWrapT
63version: 16
64ret: rs_sampler_value, "wrap T value"
65arg: rs_sampler s, "sampler to query"
66summary:
67description:
68 Get sampler wrap T value
69test: none
70end: