blob: 0eeac5bd8bbd8d84f7258b46da6cac9909754896 [file] [log] [blame]
Jason Sams41371c72015-03-26 20:46:57 +00001#
2# Copyright (C) 2015 The Android Open Source Project
3#
4# Licensed under the Apache License, Version 2.0 (the "License");
5# you may not use this file except in compliance with the License.
6# You may obtain a copy of the License at
7#
8# http://www.apache.org/licenses/LICENSE-2.0
9#
10# Unless required by applicable law or agreed to in writing, software
11# distributed under the License is distributed on an "AS IS" BASIS,
12# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13# See the License for the specific language governing permissions and
14# limitations under the License.
15#
16
17header:
18summary: Standard RenderScript types
19description:
20 Integers:<ul>
21 <li>8 bit: char, int8_t</li>
22 <li>16 bit: short, int16_t</li>
23 <li>32 bit: int, in32_t</li>
24 <li>64 bit: long, long long, int64_t</li></ul>
25
26 Unsigned integers:<ul>
27 <li>8 bit: uchar, uint8_t</li>
28 <li>16 bit: ushort, uint16_t</li>
29 <li>32 bit: uint, uint32_t</li>
30 <li>64 bit: ulong, uint64_t</li></ul>
31
32 Floating point:<ul>
33 <li>32 bit: float</li>
34 <li>64 bit: double</li></ul>
35
36 Vectors of length 2, 3, and 4 are supported for all the types above.
37include:
38 #include "stdbool.h"
39
40 #define RS_PACKED __attribute__((packed, aligned(4)))
41 #define NULL ((void *)0)
42
43 // Opaque handle to a RenderScript object. Do not use this directly.
44 #ifndef __LP64__
45 #define _RS_HANDLE \
46 struct {\
47 const int* const p;\
48 } __attribute__((packed, aligned(4)))
49 #else
50 #define _RS_HANDLE \
51 struct {\
52 const long* const p;\
53 const long* const r;\
54 const long* const v1;\
55 const long* const v2;\
56 }
57 #endif
58end:
59
60constant: M_1_PI
61value: 0.318309886183790671537767526745028724f
62summary: 1 / pi, as a 32 bit float
63description:
64 The inverse of pi, as a 32 bit float.
65end:
66
67constant: M_2_PI
68value: 0.636619772367581343075535053490057448f
69summary: 2 / pi, as a 32 bit float
70description:
71 2 divided by pi, as a 32 bit float.
72end:
73
74constant: M_2_PIl
75value: 0.636619772367581343075535053490057448f
76hidden:
77summary: Deprecated. Use M_2_PI instead.
78description:
79end:
80
81constant: M_2_SQRTPI
82value: 1.128379167095512573896158903121545172f
83summary: 2 / sqrt(pi), as a 32 bit float
84description:
85 2 divided by the square root of pi, as a 32 bit float.
86end:
87
88constant: M_E
89value: 2.718281828459045235360287471352662498f
90summary: e, as a 32 bit float
91description:
92 The number e, the base of the natural logarithm, as a 32 bit float.
93end:
94
95constant: M_LN10
96value: 2.302585092994045684017991454684364208f
97summary: log_e(10), as a 32 bit float
98description:
99 The natural logarithm of 10, as a 32 bit float.
100end:
101
102constant: M_LN2
103value: 0.693147180559945309417232121458176568f
104summary: log_e(2), as a 32 bit float
105description:
106 The natural logarithm of 2, as a 32 bit float.
107end:
108
109constant: M_LOG10E
110value: 0.434294481903251827651128918916605082f
111summary: log_10(e), as a 32 bit float
112description:
113 The logarithm base 10 of e, as a 32 bit float.
114end:
115
116constant: M_LOG2E
117value: 1.442695040888963407359924681001892137f
118summary: log_2(e), as a 32 bit float
119description:
120 The logarithm base 2 of e, as a 32 bit float.
121end:
122
123constant: M_PI
124value: 3.141592653589793238462643383279502884f
125summary: pi, as a 32 bit float
126description:
127 The constant pi, as a 32 bit float.
128end:
129
130constant: M_PI_2
131value: 1.570796326794896619231321691639751442f
132summary: pi / 2, as a 32 bit float
133description:
134 Pi divided by 2, as a 32 bit float.
135end:
136
137constant: M_PI_4
138value: 0.785398163397448309615660845819875721f
139summary: pi / 4, as a 32 bit float
140description:
141 Pi divided by 4, as a 32 bit float.
142end:
143
144constant: M_SQRT1_2
145value: 0.707106781186547524400844362104849039f
146summary: 1 / sqrt(2), as a 32 bit float
147description:
148 The inverse of the square root of 2, as a 32 bit float.
149end:
150
151constant: M_SQRT2
152value: 1.414213562373095048801688724209698079f
153summary: sqrt(2), as a 32 bit float
154description:
155 The square root of 2, as a 32 bit float.
156end:
157
158type: int8_t
159simple: char
160summary: 8 bit signed integer
161description:
162 8 bit integer type
163end:
164
165type: int16_t
166simple: short
167summary: 16 bit signed integer
168description:
169 16 bit integer type
170end:
171
172type: int32_t
173simple: int
174summary: 32 bit signed integer
175description:
176 32 bit integer type
177end:
178
179type: int64_t
180version: 9 20
181simple: long long
182summary: 64 bit signed integer
183description:
184 64 bit integer type
185end:
186
187type: int64_t
188version: 21
189simple: long
190end:
191
192type: uint8_t
193simple: unsigned char
194summary: 8 bit unsigned integer
195description:
196 8 bit unsigned integer type
197end:
198
199type: uint16_t
200simple: unsigned short
201summary: 16 bit unsigned integer
202description:
203 16 bit unsigned integer type
204end:
205
206type: uint32_t
207simple: unsigned int
208summary: 32 bit unsigned integer
209description:
210 32 bit unsigned integer type
211end:
212
213type: uint64_t
214version: 9 20
215simple: unsigned long long
216summary: 64 bit unsigned integer
217description:
218 64 bit unsigned integer type
219end:
220
221type: uint64_t
222version: 21
223simple: unsigned long
224end:
225
226type: uchar
227simple: uint8_t
228summary: 8 bit unsigned integer
229description:
230 8 bit unsigned integer type
231end:
232
233type: ushort
234simple: uint16_t
235summary: 16 bit unsigned integer
236description:
237 16 bit unsigned integer type
238end:
239
240type: uint
241simple: uint32_t
242summary: 32 bit unsigned integer
243description:
244 32 bit unsigned integer type
245end:
246
247type: ulong
248simple: uint64_t
249summary: 64 bit unsigned integer
250description:
251 Typedef for unsigned long (use for 64-bit unsigned integers)
252end:
253
254type: size_t
255size: 64
256simple: uint64_t
257summary: Unsigned size type
258description:
259 Typedef for size_t
260end:
261
262type: size_t
263size: 32
264simple: uint32_t
265end:
266
267type: ssize_t
268size: 64
269simple: int64_t
270summary: Signed size type
271description:
272 Typedef for ssize_t
273end:
274
275type: ssize_t
276size: 32
277simple: int32_t
278end:
279
280type: rs_element
281simple: _RS_HANDLE
282summary: Handle to an element
283description:
284 Opaque handle to a RenderScript element.
285 See: android.renderscript.Element
286end:
287
288type: rs_type
289simple: _RS_HANDLE
290summary: Handle to a Type
291description:
292 Opaque handle to a RenderScript type.
293 See: android.renderscript.Type
294end:
295
296type: rs_allocation
297simple: _RS_HANDLE
298summary: Handle to an allocation
299description:
300 Opaque handle to a RenderScript allocation.
301 See: android.renderscript.Allocation
302end:
303
304type: rs_sampler
305simple: _RS_HANDLE
306summary: Handle to a Sampler
307description:
308 Opaque handle to a RenderScript sampler object.
309 See: android.renderscript.Sampler
310end:
311
312type: rs_script
313simple: _RS_HANDLE
314summary: Handle to a Script
315description:
316 Opaque handle to a RenderScript script object.
317 See: android.renderscript.ScriptC
318end:
319
320
321type: rs_mesh
322size: 32
323simple: _RS_HANDLE
324summary: Handle to a Mesh
325description:
326 Opaque handle to a RenderScript mesh object.
327 See: android.renderscript.Mesh
328end:
329
330type: rs_program_fragment
331size: 32
332simple: _RS_HANDLE
333summary: Handle to a ProgramFragment
334description:
335 Opaque handle to a RenderScript ProgramFragment object.
336 See: android.renderscript.ProgramFragment
337end:
338
339type: rs_program_vertex
340size: 32
341simple: _RS_HANDLE
342summary: Handle to a ProgramVertex
343description:
344 Opaque handle to a RenderScript ProgramVertex object.
345 See: android.renderscript.ProgramVertex
346end:
347
348type: rs_program_raster
349size: 32
350simple: _RS_HANDLE
351summary: Handle to a ProgramRaster
352description:
353 Opaque handle to a RenderScript ProgramRaster object.
354 See: android.renderscript.ProgramRaster
355end:
356
357type: rs_program_store
358size: 32
359simple: _RS_HANDLE
360summary: Handle to a ProgramStore
361description:
362 Opaque handle to a RenderScript ProgramStore object.
363 See: android.renderscript.ProgramStore
364end:
365
366type: rs_font
367size: 32
368simple: _RS_HANDLE
369summary: Handle to a Font
370description:
371 Opaque handle to a RenderScript font object.
372 See: android.renderscript.Font
373end:
374
375type: float2
376simple: float __attribute__((ext_vector_type(2)))
377summary: Two 32 bit floats
378description:
379 Vector version of the basic float type.
380 Provides two float fields packed into a single 64 bit field with 64 bit alignment.
381end:
382
383type: float3
384simple: float __attribute__((ext_vector_type(3)))
385summary: Three 32 bit floats
386description:
387 Vector version of the basic float type.
388 Provides three float fields packed into a single 128 bit field with 128 bit alignment.
389end:
390
391type: float4
392simple: float __attribute__((ext_vector_type(4)))
393summary: Four 32 bit floats
394description:
395 Vector version of the basic float type.
396 Provides four float fields packed into a single 128 bit field with 128 bit alignment.
397end:
398
399
400type: double2
401simple: double __attribute__((ext_vector_type(2)))
402summary: Two 64 bit floats
403description:
404 Vector version of the basic double type. Provides two double fields packed
405 into a single 128 bit field with 128 bit alignment.
406end:
407
408type: double3
409simple: double __attribute__((ext_vector_type(3)))
410summary: Three 64 bit floats
411description:
412 Vector version of the basic double type. Provides three double fields packed
413 into a single 256 bit field with 256 bit alignment.
414end:
415
416type: double4
417simple: double __attribute__((ext_vector_type(4)))
418summary: Four 64 bit floats
419description:
420 Vector version of the basic double type. Provides four double fields packed
421 into a single 256 bit field with 256 bit alignment.
422end:
423
424
425type: uchar2
426simple: uchar __attribute__((ext_vector_type(2)))
427summary: Two 8 bit unsigned integers
428description:
429 Vector version of the basic uchar type. Provides two uchar fields packed
430 into a single 16 bit field with 16 bit alignment.
431end:
432
433type: uchar3
434simple: uchar __attribute__((ext_vector_type(3)))
435summary: Three 8 bit unsigned integers
436description:
437 Vector version of the basic uchar type. Provides three uchar fields packed
438 into a single 32 bit field with 32 bit alignment.
439end:
440
441type: uchar4
442simple: uchar __attribute__((ext_vector_type(4)))
443summary: Four 8 bit unsigned integers
444description:
445 Vector version of the basic uchar type. Provides four uchar fields packed
446 into a single 32 bit field with 32 bit alignment.
447end:
448
449
450type: ushort2
451simple: ushort __attribute__((ext_vector_type(2)))
452summary: Two 16 bit unsigned integers
453description:
454 Vector version of the basic ushort type. Provides two ushort fields packed
455 into a single 32 bit field with 32 bit alignment.
456end:
457
458type: ushort3
459simple: ushort __attribute__((ext_vector_type(3)))
460summary: Three 16 bit unsigned integers
461description:
462 Vector version of the basic ushort type. Provides three ushort fields packed
463 into a single 64 bit field with 64 bit alignment.
464end:
465
466type: ushort4
467simple: ushort __attribute__((ext_vector_type(4)))
468summary: Four 16 bit unsigned integers
469description:
470 Vector version of the basic ushort type. Provides four ushort fields packed
471 into a single 64 bit field with 64 bit alignment.
472end:
473
474
475type: uint2
476simple: uint __attribute__((ext_vector_type(2)))
477summary: Two 32 bit unsigned integers
478description:
479 Vector version of the basic uint type. Provides two uint fields packed into a
480 single 64 bit field with 64 bit alignment.
481end:
482
483type: uint3
484simple: uint __attribute__((ext_vector_type(3)))
485summary: Three 32 bit unsigned integers
486description:
487 Vector version of the basic uint type. Provides three uint fields packed into
488 a single 128 bit field with 128 bit alignment.
489end:
490
491type: uint4
492simple: uint __attribute__((ext_vector_type(4)))
493summary: Four 32 bit unsigned integers
494description:
495 Vector version of the basic uint type. Provides four uint fields packed into
496 a single 128 bit field with 128 bit alignment.
497end:
498
499
500type: ulong2
501simple: ulong __attribute__((ext_vector_type(2)))
502summary: Two 64 bit unsigned integers
503description:
504 Vector version of the basic ulong type. Provides two ulong fields packed into
505 a single 128 bit field with 128 bit alignment.
506end:
507
508type: ulong3
509simple: ulong __attribute__((ext_vector_type(3)))
510summary: Three 64 bit unsigned integers
511description:
512 Vector version of the basic ulong type. Provides three ulong fields packed
513 into a single 256 bit field with 256 bit alignment.
514end:
515
516type: ulong4
517simple: ulong __attribute__((ext_vector_type(4)))
518summary: Four 64 bit unsigned integers
519description:
520 Vector version of the basic ulong type. Provides four ulong fields packed
521 into a single 256 bit field with 256 bit alignment.
522end:
523
524
525type: char2
526simple: char __attribute__((ext_vector_type(2)))
527summary: Two 8 bit signed integers
528description:
529 Vector version of the basic char type. Provides two char fields packed into a
530 single 16 bit field with 16 bit alignment.
531end:
532
533type: char3
534simple: char __attribute__((ext_vector_type(3)))
535summary: Three 8 bit signed integers
536description:
537 Vector version of the basic char type. Provides three char fields packed into
538 a single 32 bit field with 32 bit alignment.
539end:
540
541type: char4
542simple: char __attribute__((ext_vector_type(4)))
543summary: Four 8 bit signed integers
544description:
545 Vector version of the basic char type. Provides four char fields packed into
546 a single 32 bit field with 32 bit alignment.
547end:
548
549type: short2
550simple: short __attribute__((ext_vector_type(2)))
551summary: Two 16 bit signed integers
552description:
553 Vector version of the basic short type. Provides two short fields packed into
554 a single 32 bit field with 32 bit alignment.
555end:
556
557type: short3
558simple: short __attribute__((ext_vector_type(3)))
559summary: Three 16 bit signed integers
560description:
561 Vector version of the basic short type. Provides three short fields packed
562 into a single 64 bit field with 64 bit alignment.
563end:
564
565type: short4
566simple: short __attribute__((ext_vector_type(4)))
567summary: Four 16 bit signed integers
568description:
569 Vector version of the basic short type. Provides four short fields packed
570 into a single 64 bit field with 64 bit alignment.
571end:
572
573
574type: int2
575simple: int __attribute__((ext_vector_type(2)))
576summary: Two 32 bit signed integers
577description:
578 Vector version of the basic int type. Provides two int fields packed into a
579 single 64 bit field with 64 bit alignment.
580end:
581
582type: int3
583simple: int __attribute__((ext_vector_type(3)))
584summary: Three 32 bit signed integers
585description:
586 Vector version of the basic int type. Provides three int fields packed into a
587 single 128 bit field with 128 bit alignment.
588end:
589
590type: int4
591simple: int __attribute__((ext_vector_type(4)))
592summary: Four 32 bit signed integers
593description:
594 Vector version of the basic int type. Provides two four fields packed into a
595 single 128 bit field with 128 bit alignment.
596end:
597
598
599type: long2
600simple: long __attribute__((ext_vector_type(2)))
601summary: Two 64 bit signed integers
602description:
603 Vector version of the basic long type. Provides two long fields packed into a
604 single 128 bit field with 128 bit alignment.
605end:
606
607type: long3
608simple: long __attribute__((ext_vector_type(3)))
609summary: Three 64 bit signed integers
610description:
611 Vector version of the basic long type. Provides three long fields packed into
612 a single 256 bit field with 256 bit alignment.
613end:
614
615type: long4
616simple: long __attribute__((ext_vector_type(4)))
617summary: Four 64 bit signed integers
618description:
619 Vector version of the basic long type. Provides four long fields packed into
620 a single 256 bit field with 256 bit alignment.
621end:
622
623type: rs_matrix4x4
624struct:
625field: float m[16]
626summary: 4x4 matrix of 32 bit floats
627description:
628 Native holder for RS matrix. Elements are stored in the array at the
629 location [row*4 + col]
630end:
631
632type: rs_matrix3x3
633struct:
634field: float m[9]
635summary: 3x3 matrix of 32 bit floats
636description:
637 Native holder for RS matrix. Elements are stored in the array at the
638 location [row*3 + col]
639end:
640
641type: rs_matrix2x2
642struct:
643field: float m[4]
644summary: 2x2 matrix of 32 bit floats
645description:
646 Native holder for RS matrix. Elements are stored in the array at the
647 location [row*2 + col]
648end:
649
650type: rs_quaternion
651simple: float4
652summary: Quarternion
653description:
654 Quaternion type for use with the quaternion functions
655end:
656
657type: rs_allocation_cubemap_face
658version: 14
659enum:
660value: RS_ALLOCATION_CUBEMAP_FACE_POSITIVE_X = 0
661value: RS_ALLOCATION_CUBEMAP_FACE_NEGATIVE_X = 1
662value: RS_ALLOCATION_CUBEMAP_FACE_POSITIVE_Y = 2
663value: RS_ALLOCATION_CUBEMAP_FACE_NEGATIVE_Y = 3
664value: RS_ALLOCATION_CUBEMAP_FACE_POSITIVE_Z = 4
665value: RS_ALLOCATION_CUBEMAP_FACE_NEGATIVE_Z = 5
666summary: Enum for selecting cube map faces
667description:
668end:
669
670type: rs_allocation_usage_type
671version: 14
672enum:
673value: RS_ALLOCATION_USAGE_SCRIPT = 0x0001
674value: RS_ALLOCATION_USAGE_GRAPHICS_TEXTURE = 0x0002, "Deprecated."
675value: RS_ALLOCATION_USAGE_GRAPHICS_VERTEX = 0x0004, "Deprecated."
676value: RS_ALLOCATION_USAGE_GRAPHICS_CONSTANTS = 0x0008, "Deprecated."
677value: RS_ALLOCATION_USAGE_GRAPHICS_RENDER_TARGET = 0x0010, "Deprecated."
678summary: Bitfield to specify the usage types for an allocation
679description:
680 These values are ORed together to specify which usages or memory spaces are
681 relevant to an allocation or an operation on an allocation.
682end:
683
684type: rs_primitive
685version: 16
686size: 32
687enum:
688value: RS_PRIMITIVE_POINT = 0, "Vertex data will be rendered as a series of points"
689value: RS_PRIMITIVE_LINE = 1, "Vertex pairs will be rendered as lines"
690value: RS_PRIMITIVE_LINE_STRIP = 2, "Vertex data will be rendered as a connected line strip"
691value: RS_PRIMITIVE_TRIANGLE = 3, "Vertices will be rendered as individual triangles"
692value: RS_PRIMITIVE_TRIANGLE_STRIP = 4, "Vertices will be rendered as a connected triangle strip defined by the first three vertices with each additional triangle defined by a new vertex"
693value: RS_PRIMITIVE_TRIANGLE_FAN = 5, "Vertices will be rendered as a sequence of triangles that all share first vertex as the origin"
694value: RS_PRIMITIVE_INVALID = 100, "Invalid primitive"
695summary: How to intepret mesh vertex data
696description:
697 Describes the way mesh vertex data is interpreted when rendering
698end:
699
700type: rs_data_type
701version: 16
702enum:
703value: RS_TYPE_NONE = 0
704value: RS_TYPE_FLOAT_32 = 2
705value: RS_TYPE_FLOAT_64 = 3
706value: RS_TYPE_SIGNED_8 = 4
707value: RS_TYPE_SIGNED_16 = 5
708value: RS_TYPE_SIGNED_32 = 6
709value: RS_TYPE_SIGNED_64 = 7
710value: RS_TYPE_UNSIGNED_8 = 8
711value: RS_TYPE_UNSIGNED_16 = 9
712value: RS_TYPE_UNSIGNED_32 = 10
713value: RS_TYPE_UNSIGNED_64 = 11
714value: RS_TYPE_BOOLEAN = 12
715value: RS_TYPE_UNSIGNED_5_6_5 = 13
716value: RS_TYPE_UNSIGNED_5_5_5_1 = 14
717value: RS_TYPE_UNSIGNED_4_4_4_4 = 15
718value: RS_TYPE_MATRIX_4X4 = 16
719value: RS_TYPE_MATRIX_3X3 = 17
720value: RS_TYPE_MATRIX_2X2 = 18
721value: RS_TYPE_ELEMENT = 1000
722value: RS_TYPE_TYPE = 1001
723value: RS_TYPE_ALLOCATION = 1002
724value: RS_TYPE_SAMPLER = 1003
725value: RS_TYPE_SCRIPT = 1004
726value: RS_TYPE_MESH = 1005
727value: RS_TYPE_PROGRAM_FRAGMENT = 1006
728value: RS_TYPE_PROGRAM_VERTEX = 1007
729value: RS_TYPE_PROGRAM_RASTER = 1008
730value: RS_TYPE_PROGRAM_STORE = 1009
731value: RS_TYPE_FONT = 1010
732value: RS_TYPE_INVALID = 10000
733summary: Element data types
734description:
735 DataType represents the basic type information for a basic element. The
736 naming convention follows. For numeric types it is FLOAT,
737 SIGNED, or UNSIGNED followed by the _BITS where BITS is the
738 size of the data. BOOLEAN is a true / false (1,0)
739 represented in an 8 bit container. The UNSIGNED variants
740 with multiple bit definitions are for packed graphical data
741 formats and represent vectors with per vector member sizes
742 which are treated as a single unit for packing and alignment
743 purposes.
744
745 MATRIX the three matrix types contain FLOAT_32 elements and are treated
746 as 32 bits for alignment purposes.
747
748 RS_* objects. 32 bit opaque handles.
749end:
750
751type: rs_data_kind
752version: 16
753enum:
754value: RS_KIND_USER = 0
755value: RS_KIND_PIXEL_L = 7
756value: RS_KIND_PIXEL_A = 8
757value: RS_KIND_PIXEL_LA = 9
758value: RS_KIND_PIXEL_RGB = 10
759value: RS_KIND_PIXEL_RGBA = 11
760value: RS_KIND_PIXEL_DEPTH = 12
761value: RS_KIND_PIXEL_YUV = 13
762value: RS_KIND_INVALID = 100
763summary: Element data kind
764description:
765 The special interpretation of the data if required. This is primarly
766 useful for graphical data. USER indicates no special interpretation is
767 expected. PIXEL is used in conjunction with the standard data types for
768 representing texture formats.
769end:
770
771type: rs_depth_func
772version: 16
773size: 32
774enum:
775value: RS_DEPTH_FUNC_ALWAYS = 0, "Always drawn"
776value: RS_DEPTH_FUNC_LESS = 1, "Drawn if the incoming depth value is less than that in the depth buffer"
777value: RS_DEPTH_FUNC_LEQUAL = 2, "Drawn if the incoming depth value is less or equal to that in the depth buffer"
778value: RS_DEPTH_FUNC_GREATER = 3, "Drawn if the incoming depth value is greater than that in the depth buffer"
779value: RS_DEPTH_FUNC_GEQUAL = 4, "Drawn if the incoming depth value is greater or equal to that in the depth buffer"
780value: RS_DEPTH_FUNC_EQUAL = 5, "Drawn if the incoming depth value is equal to that in the depth buffer"
781value: RS_DEPTH_FUNC_NOTEQUAL = 6, "Drawn if the incoming depth value is not equal to that in the depth buffer"
782value: RS_DEPTH_FUNC_INVALID = 100, "Invalid depth function"
783summary: Depth function
784description:
785 Specifies conditional drawing depending on the comparison of the incoming
786 depth to that found in the depth buffer.
787end:
788
789type: rs_blend_src_func
790version: 16
791size: 32
792enum:
793value: RS_BLEND_SRC_ZERO = 0
794value: RS_BLEND_SRC_ONE = 1
795value: RS_BLEND_SRC_DST_COLOR = 2
796value: RS_BLEND_SRC_ONE_MINUS_DST_COLOR = 3
797value: RS_BLEND_SRC_SRC_ALPHA = 4
798value: RS_BLEND_SRC_ONE_MINUS_SRC_ALPHA = 5
799value: RS_BLEND_SRC_DST_ALPHA = 6
800value: RS_BLEND_SRC_ONE_MINUS_DST_ALPHA = 7
801value: RS_BLEND_SRC_SRC_ALPHA_SATURATE = 8
802value: RS_BLEND_SRC_INVALID = 100
803summary: Blend source function
804description:
805end:
806
807type: rs_blend_dst_func
808version: 16
809size: 32
810enum:
811value: RS_BLEND_DST_ZERO = 0
812value: RS_BLEND_DST_ONE = 1
813value: RS_BLEND_DST_SRC_COLOR = 2
814value: RS_BLEND_DST_ONE_MINUS_SRC_COLOR = 3
815value: RS_BLEND_DST_SRC_ALPHA = 4
816value: RS_BLEND_DST_ONE_MINUS_SRC_ALPHA = 5
817value: RS_BLEND_DST_DST_ALPHA = 6
818value: RS_BLEND_DST_ONE_MINUS_DST_ALPHA = 7
819value: RS_BLEND_DST_INVALID = 100
820summary: Blend destination function
821description:
822end:
823
824type: rs_cull_mode
825version: 16
826size: 32
827enum:
828value: RS_CULL_BACK = 0
829value: RS_CULL_FRONT = 1
830value: RS_CULL_NONE = 2
831value: RS_CULL_INVALID = 100
832summary: Culling mode
833description:
834end:
835
836type: rs_sampler_value
837version: 16
838enum:
839value: RS_SAMPLER_NEAREST = 0
840value: RS_SAMPLER_LINEAR = 1
841value: RS_SAMPLER_LINEAR_MIP_LINEAR = 2
842value: RS_SAMPLER_WRAP = 3
843value: RS_SAMPLER_CLAMP = 4
844value: RS_SAMPLER_LINEAR_MIP_NEAREST = 5
845value: RS_SAMPLER_MIRRORED_REPEAT = 6
846value: RS_SAMPLER_INVALID = 100
847summary: Sampler wrap T value
848description:
849end: