blob: 491474ec2cd0873df8a643ed1d2442be9488fd4d [file] [log] [blame]
Jason Sams326e0dd2009-05-22 14:03:28 -07001
Jason Sams186e5912011-04-26 14:50:00 -07002ContextDestroy {
3 direct
4}
5
6ContextGetMessage {
7 direct
8 param void *data
9 param size_t *receiveLen
Jason Sams1a4efa32011-05-17 15:01:29 -070010 param uint32_t *usrID
Jason Sams186e5912011-04-26 14:50:00 -070011 ret RsMessageToClientType
12}
13
14ContextPeekMessage {
15 direct
16 param size_t *receiveLen
Jason Sams1a4efa32011-05-17 15:01:29 -070017 param uint32_t *usrID
Jason Sams186e5912011-04-26 14:50:00 -070018 ret RsMessageToClientType
19}
20
21ContextInitToClient {
22 direct
23}
24
25ContextDeinitToClient {
26 direct
27}
28
Jason Samsc975cf42011-04-28 18:26:48 -070029TypeCreate {
Jason Sams186e5912011-04-26 14:50:00 -070030 direct
31 param RsElement e
32 param uint32_t dimX
33 param uint32_t dimY
34 param uint32_t dimZ
35 param bool mips
36 param bool faces
37 ret RsType
38}
39
Jason Samsc975cf42011-04-28 18:26:48 -070040AllocationCreateTyped {
Jason Sams186e5912011-04-26 14:50:00 -070041 direct
42 param RsType vtype
43 param RsAllocationMipmapControl mips
44 param uint32_t usages
Jason Sams179e9a42011-11-23 15:02:15 -080045 param uint32_t ptr
Jason Sams186e5912011-04-26 14:50:00 -070046 ret RsAllocation
47}
48
Jason Samsc975cf42011-04-28 18:26:48 -070049AllocationCreateFromBitmap {
Jason Sams186e5912011-04-26 14:50:00 -070050 direct
51 param RsType vtype
52 param RsAllocationMipmapControl mips
53 param const void *data
54 param uint32_t usages
55 ret RsAllocation
56}
57
Jason Samsc975cf42011-04-28 18:26:48 -070058AllocationCubeCreateFromBitmap {
Jason Sams186e5912011-04-26 14:50:00 -070059 direct
60 param RsType vtype
61 param RsAllocationMipmapControl mips
62 param const void *data
63 param uint32_t usages
64 ret RsAllocation
65}
66
Jason Sams41e373d2012-01-13 14:01:20 -080067AllocationGetSurfaceTextureID {
68 param RsAllocation alloc
69 ret int32_t
70}
Jason Sams186e5912011-04-26 14:50:00 -070071
Jason Sams7ac2a4d2012-02-15 12:04:24 -080072AllocationSetSurface {
73 param RsAllocation alloc
74 param RsNativeWindow sur
75 sync
76 }
77
78AllocationIoSend {
79 param RsAllocation alloc
80 }
81
82AllocationIoReceive {
83 param RsAllocation alloc
84 }
85
86
Jason Sams8c880902010-06-15 12:15:57 -070087ContextFinish {
Jason Sams1a4efa32011-05-17 15:01:29 -070088 sync
Jason Sams8c880902010-06-15 12:15:57 -070089 }
Jason Sams326e0dd2009-05-22 14:03:28 -070090
Jason Sams326e0dd2009-05-22 14:03:28 -070091ContextBindRootScript {
92 param RsScript sampler
93 }
94
Jason Samsccc010b2010-05-13 18:30:11 -070095ContextBindProgramStore {
96 param RsProgramStore pgm
Jason Sams326e0dd2009-05-22 14:03:28 -070097 }
98
99ContextBindProgramFragment {
100 param RsProgramFragment pgm
101 }
102
103ContextBindProgramVertex {
104 param RsProgramVertex pgm
105 }
106
Jason Sams5fd09d82009-09-23 13:57:02 -0700107ContextBindProgramRaster {
108 param RsProgramRaster pgm
109 }
110
Alex Sakhartchoukd3e0ad42010-06-24 17:15:34 -0700111ContextBindFont {
112 param RsFont pgm
113 }
114
Jason Sams86f1b232009-09-24 17:38:20 -0700115ContextPause {
116 }
117
118ContextResume {
119 }
120
Jason Sams458f2dc2009-11-03 13:58:36 -0800121ContextSetSurface {
Jason Sams613cad12009-11-12 15:10:25 -0800122 param uint32_t width
123 param uint32_t height
Alex Sakhartchouk7257c7e2011-05-17 12:32:47 -0700124 param RsNativeWindow sur
Jason Samsc33e6902011-06-20 16:58:04 -0700125 sync
Jason Sams458f2dc2009-11-03 13:58:36 -0800126 }
127
Jason Samsc21cf402009-11-17 17:26:46 -0800128ContextDump {
129 param int32_t bits
130}
131
Jason Sams613cad12009-11-12 15:10:25 -0800132ContextSetPriority {
Jason Sams15832442009-11-15 12:14:26 -0800133 param int32_t priority
Jason Sams613cad12009-11-12 15:10:25 -0800134 }
135
Jason Sams741aac92010-12-24 14:38:39 -0800136ContextDestroyWorker {
Jason Sams5f27d6f2012-02-07 15:32:08 -0800137 sync
Jason Sams1dcefab2010-12-09 12:19:46 -0800138}
139
Jason Samsa0a1b6f2009-06-10 15:04:38 -0700140AssignName {
Alex Sakhartchouk70b83c12011-04-06 10:57:51 -0700141 param RsObjectBase obj
Jason Samsa0a1b6f2009-06-10 15:04:38 -0700142 param const char *name
143 }
Jason Sams326e0dd2009-05-22 14:03:28 -0700144
Jason Sams707aaf32009-08-18 14:14:24 -0700145ObjDestroy {
Jason Sams2353ae32010-10-14 17:48:46 -0700146 param RsAsyncVoidPtr objPtr
Jason Sams707aaf32009-08-18 14:14:24 -0700147 }
148
Jason Samsd01d9702009-12-23 14:35:29 -0800149ElementCreate {
Alex Sakhartchoukc700e642011-08-16 13:09:46 -0700150 direct
Jason Samsd01d9702009-12-23 14:35:29 -0800151 param RsDataType mType
152 param RsDataKind mKind
153 param bool mNormalized
154 param uint32_t mVectorSize
155 ret RsElement
Jason Sams326e0dd2009-05-22 14:03:28 -0700156 }
157
Jason Samsd01d9702009-12-23 14:35:29 -0800158ElementCreate2 {
Alex Sakhartchoukc700e642011-08-16 13:09:46 -0700159 direct
Jason Samsd01d9702009-12-23 14:35:29 -0800160 param const RsElement * elements
161 param const char ** names
Jason Sams46e45542010-09-02 17:35:23 -0700162 param const uint32_t * arraySize
Jason Sams326e0dd2009-05-22 14:03:28 -0700163 ret RsElement
164 }
165
Jason Sams837e3882010-12-10 16:03:15 -0800166AllocationCopyToBitmap {
167 param RsAllocation alloc
168 param void * data
Alex Sakhartchouk39f2ef62010-10-11 12:35:15 -0700169 }
170
Jason Sams326e0dd2009-05-22 14:03:28 -0700171
Jason Sams4b45b892010-12-29 14:31:29 -0800172Allocation1DData {
Jason Sams326e0dd2009-05-22 14:03:28 -0700173 param RsAllocation va
174 param uint32_t xoff
Jason Sams4b45b892010-12-29 14:31:29 -0800175 param uint32_t lod
Jason Sams326e0dd2009-05-22 14:03:28 -0700176 param uint32_t count
177 param const void *data
Jason Samsd34b7252009-08-04 16:58:20 -0700178 }
Jason Sams326e0dd2009-05-22 14:03:28 -0700179
Jason Sams4b45b892010-12-29 14:31:29 -0800180Allocation1DElementData {
Jason Sams5f0c84c2010-08-31 13:50:42 -0700181 param RsAllocation va
182 param uint32_t x
Jason Sams4b45b892010-12-29 14:31:29 -0800183 param uint32_t lod
Jason Sams5f0c84c2010-08-31 13:50:42 -0700184 param const void *data
Stephen Hines6ae039b2012-01-18 18:46:27 -0800185 param size_t comp_offset
Jason Sams5f0c84c2010-08-31 13:50:42 -0700186 }
187
Jason Sams4b45b892010-12-29 14:31:29 -0800188Allocation2DData {
Jason Sams326e0dd2009-05-22 14:03:28 -0700189 param RsAllocation va
190 param uint32_t xoff
191 param uint32_t yoff
Jason Sams4b45b892010-12-29 14:31:29 -0800192 param uint32_t lod
193 param RsAllocationCubemapFace face
Jason Sams326e0dd2009-05-22 14:03:28 -0700194 param uint32_t w
195 param uint32_t h
196 param const void *data
197 }
198
Jason Sams4b45b892010-12-29 14:31:29 -0800199Allocation2DElementData {
Jason Sams5f0c84c2010-08-31 13:50:42 -0700200 param RsAllocation va
201 param uint32_t x
202 param uint32_t y
Jason Sams4b45b892010-12-29 14:31:29 -0800203 param uint32_t lod
204 param RsAllocationCubemapFace face
Jason Sams5f0c84c2010-08-31 13:50:42 -0700205 param const void *data
Stephen Hines6ae039b2012-01-18 18:46:27 -0800206 param size_t element_offset
Jason Sams5f0c84c2010-08-31 13:50:42 -0700207 }
208
Jason Samsa2371512011-01-12 13:28:37 -0800209AllocationGenerateMipmaps {
210 param RsAllocation va
211}
212
Jason Samse579df42009-08-10 14:55:26 -0700213AllocationRead {
214 param RsAllocation va
215 param void * data
216 }
Jason Sams326e0dd2009-05-22 14:03:28 -0700217
Jason Sams366c9c82010-12-08 16:14:36 -0800218AllocationSyncAll {
219 param RsAllocation va
220 param RsAllocationUsageType src
221}
222
Jason Sams326e0dd2009-05-22 14:03:28 -0700223
Jason Sams96abf812010-10-05 13:32:49 -0700224AllocationResize1D {
225 param RsAllocation va
226 param uint32_t dimX
227 }
228
229AllocationResize2D {
230 param RsAllocation va
231 param uint32_t dimX
232 param uint32_t dimY
233 }
234
Alex Sakhartchouk74a82792011-06-14 11:13:19 -0700235AllocationCopy2DRange {
236 param RsAllocation dest
237 param uint32_t destXoff
238 param uint32_t destYoff
239 param uint32_t destMip
240 param uint32_t destFace
241 param uint32_t width
242 param uint32_t height
243 param RsAllocation src
244 param uint32_t srcXoff
245 param uint32_t srcYoff
246 param uint32_t srcMip
247 param uint32_t srcFace
248 }
249
Jason Sams326e0dd2009-05-22 14:03:28 -0700250SamplerCreate {
Alex Sakhartchoukc700e642011-08-16 13:09:46 -0700251 direct
Alex Sakhartchoukc2c02a82011-05-04 17:45:36 -0700252 param RsSamplerValue magFilter
253 param RsSamplerValue minFilter
254 param RsSamplerValue wrapS
255 param RsSamplerValue wrapT
256 param RsSamplerValue wrapR
257 param float mAniso
258 ret RsSampler
259}
Jason Sams326e0dd2009-05-22 14:03:28 -0700260
261ScriptBindAllocation {
262 param RsScript vtm
263 param RsAllocation va
264 param uint32_t slot
265 }
266
Jason Samsd34b7252009-08-04 16:58:20 -0700267ScriptSetTimeZone {
268 param RsScript s
Romain Guy98e10fd2009-07-30 18:45:01 -0700269 param const char * timeZone
Romain Guy98e10fd2009-07-30 18:45:01 -0700270 }
271
Jason Sams8c6bc692009-09-16 15:04:38 -0700272ScriptInvoke {
273 param RsScript s
274 param uint32_t slot
275 }
276
Jason Samsbe36bf32010-05-11 14:03:58 -0700277ScriptInvokeV {
278 param RsScript s
279 param uint32_t slot
280 param const void * data
Jason Samsbe36bf32010-05-11 14:03:58 -0700281 }
282
Alex Sakhartchoukc2c02a82011-05-04 17:45:36 -0700283ScriptForEach {
Jason Sams5fb1aeb2011-04-27 15:12:49 -0700284 param RsScript s
285 param uint32_t slot
286 param RsAllocation ain
287 param RsAllocation aout
288 param const void * usr
289}
290
Jason Samsbe36bf32010-05-11 14:03:58 -0700291ScriptSetVarI {
292 param RsScript s
293 param uint32_t slot
294 param int value
295 }
296
Jason Samsa5eb6e12010-11-16 17:37:02 -0800297ScriptSetVarObj {
298 param RsScript s
299 param uint32_t slot
300 param RsObjectBase value
301 }
302
Stephen Hines0977c942010-10-11 10:54:21 -0700303ScriptSetVarJ {
304 param RsScript s
305 param uint32_t slot
306 param int64_t value
307 }
308
Jason Samsbe36bf32010-05-11 14:03:58 -0700309ScriptSetVarF {
310 param RsScript s
311 param uint32_t slot
312 param float value
313 }
314
Stephen Hines6d0a0742010-09-20 17:20:30 -0700315ScriptSetVarD {
316 param RsScript s
317 param uint32_t slot
318 param double value
319 }
320
Jason Samsbe36bf32010-05-11 14:03:58 -0700321ScriptSetVarV {
322 param RsScript s
323 param uint32_t slot
324 param const void * data
Jason Samsbe36bf32010-05-11 14:03:58 -0700325 }
Jason Samsfa517192009-08-13 12:59:04 -0700326
327
Jason Sams326e0dd2009-05-22 14:03:28 -0700328ScriptCCreate {
Shih-wei Liao9503b662010-11-08 01:33:59 -0800329 param const char * resName
Shih-wei Liao15849d92010-12-10 01:03:59 -0800330 param const char * cacheDir
Jason Samsbad80742011-03-16 16:29:28 -0700331 param const char * text
Jason Sams326e0dd2009-05-22 14:03:28 -0700332 ret RsScript
333 }
334
335
Jason Sams721acc42011-04-06 11:23:54 -0700336ProgramStoreCreate {
Alex Sakhartchoukc700e642011-08-16 13:09:46 -0700337 direct
Jason Sams721acc42011-04-06 11:23:54 -0700338 param bool colorMaskR
339 param bool colorMaskG
340 param bool colorMaskB
341 param bool colorMaskA
342 param bool depthMask
343 param bool ditherEnable
Jason Sams326e0dd2009-05-22 14:03:28 -0700344 param RsBlendSrcFunc srcFunc
345 param RsBlendDstFunc destFunc
Jason Sams721acc42011-04-06 11:23:54 -0700346 param RsDepthFunc depthFunc
Jason Samsccc010b2010-05-13 18:30:11 -0700347 ret RsProgramStore
Jason Sams326e0dd2009-05-22 14:03:28 -0700348 }
349
Jason Sams5fd09d82009-09-23 13:57:02 -0700350ProgramRasterCreate {
Alex Sakhartchoukc700e642011-08-16 13:09:46 -0700351 direct
Jason Sams5fd09d82009-09-23 13:57:02 -0700352 param bool pointSprite
Jason Sams721acc42011-04-06 11:23:54 -0700353 param RsCullMode cull
Jason Sams5fd09d82009-09-23 13:57:02 -0700354 ret RsProgramRaster
355}
356
Jason Sams4815c0d2009-12-15 12:58:36 -0800357ProgramBindConstants {
358 param RsProgram vp
359 param uint32_t slot
360 param RsAllocation constants
361 }
362
Jason Sams326e0dd2009-05-22 14:03:28 -0700363
Jason Sams7dad9c32009-12-17 16:55:08 -0800364ProgramBindTexture {
Jason Sams326e0dd2009-05-22 14:03:28 -0700365 param RsProgramFragment pf
366 param uint32_t slot
367 param RsAllocation a
368 }
369
Jason Sams7dad9c32009-12-17 16:55:08 -0800370ProgramBindSampler {
Jason Sams326e0dd2009-05-22 14:03:28 -0700371 param RsProgramFragment pf
372 param uint32_t slot
373 param RsSampler s
374 }
375
Jason Sams326e0dd2009-05-22 14:03:28 -0700376ProgramFragmentCreate {
Alex Sakhartchoukc700e642011-08-16 13:09:46 -0700377 direct
Jason Samsf2e4fa22009-12-15 13:27:04 -0800378 param const char * shaderText
Jason Samsf2e4fa22009-12-15 13:27:04 -0800379 param const uint32_t * params
Jason Samsf2e4fa22009-12-15 13:27:04 -0800380 ret RsProgramFragment
381 }
382
Jason Sams326e0dd2009-05-22 14:03:28 -0700383ProgramVertexCreate {
Alex Sakhartchoukc700e642011-08-16 13:09:46 -0700384 direct
Jason Sams4815c0d2009-12-15 12:58:36 -0800385 param const char * shaderText
Jason Sams4815c0d2009-12-15 12:58:36 -0800386 param const uint32_t * params
Jason Samsf2e4fa22009-12-15 13:27:04 -0800387 ret RsProgramVertex
Jason Samsb5909ce2009-07-21 12:20:54 -0700388 }
389
Alex Sakhartchoukd3e0ad42010-06-24 17:15:34 -0700390FontCreateFromFile {
391 param const char *name
Alex Sakhartchoukc17ace22010-12-17 11:41:08 -0800392 param float fontSize
Alex Sakhartchoukd3e0ad42010-06-24 17:15:34 -0700393 param uint32_t dpi
394 ret RsFont
395 }
396
Alex Sakhartchouk5224a272011-01-07 11:12:08 -0800397FontCreateFromMemory {
398 param const char *name
399 param float fontSize
400 param uint32_t dpi
Alex Sakhartchouk70b83c12011-04-06 10:57:51 -0700401 param const void *data
Alex Sakhartchouk5224a272011-01-07 11:12:08 -0800402 ret RsFont
403 }
404
Alex Sakhartchouk4e9a7a82010-07-01 16:14:06 -0700405MeshCreate {
Alex Sakhartchouk9003e562011-05-12 10:38:03 -0700406 param RsAllocation *vtx
407 param RsAllocation *idx
408 param uint32_t *primType
Alex Sakhartchouk4e9a7a82010-07-01 16:14:06 -0700409 ret RsMesh
Alex Sakhartchouk4e9a7a82010-07-01 16:14:06 -0700410 }
Jason Sams9e0afb52011-10-31 13:23:43 -0700411
412PathCreate {
413 param RsPathPrimitive pp
414 param bool isStatic
415 param RsAllocation vertex
416 param RsAllocation loops
417 param float quality
418 ret RsPath
419 }
420