blob: d60db7e569489953ac971b003f2bd83ed057be09 [file] [log] [blame]
Jason Sams326e0dd2009-05-22 14:03:28 -07001
Jason Sams186e5912011-04-26 14:50:00 -07002ContextDestroy {
3 direct
4}
5
6ContextGetMessage {
7 direct
8 param void *data
9 param size_t *receiveLen
Jason Sams1a4efa32011-05-17 15:01:29 -070010 param uint32_t *usrID
Jason Sams186e5912011-04-26 14:50:00 -070011 ret RsMessageToClientType
12}
13
14ContextPeekMessage {
15 direct
16 param size_t *receiveLen
Jason Sams1a4efa32011-05-17 15:01:29 -070017 param uint32_t *usrID
Jason Sams186e5912011-04-26 14:50:00 -070018 ret RsMessageToClientType
19}
20
21ContextInitToClient {
22 direct
23}
24
25ContextDeinitToClient {
26 direct
27}
28
Jason Samsc975cf42011-04-28 18:26:48 -070029TypeCreate {
Jason Sams186e5912011-04-26 14:50:00 -070030 direct
31 param RsElement e
32 param uint32_t dimX
33 param uint32_t dimY
34 param uint32_t dimZ
35 param bool mips
36 param bool faces
37 ret RsType
38}
39
Jason Samsc975cf42011-04-28 18:26:48 -070040AllocationCreateTyped {
Jason Sams186e5912011-04-26 14:50:00 -070041 direct
42 param RsType vtype
43 param RsAllocationMipmapControl mips
44 param uint32_t usages
Jason Sams179e9a42011-11-23 15:02:15 -080045 param uint32_t ptr
Jason Sams186e5912011-04-26 14:50:00 -070046 ret RsAllocation
47}
48
Jason Samsc975cf42011-04-28 18:26:48 -070049AllocationCreateFromBitmap {
Jason Sams186e5912011-04-26 14:50:00 -070050 direct
51 param RsType vtype
52 param RsAllocationMipmapControl mips
53 param const void *data
54 param uint32_t usages
55 ret RsAllocation
56}
57
Jason Samsc975cf42011-04-28 18:26:48 -070058AllocationCubeCreateFromBitmap {
Jason Sams186e5912011-04-26 14:50:00 -070059 direct
60 param RsType vtype
61 param RsAllocationMipmapControl mips
62 param const void *data
63 param uint32_t usages
64 ret RsAllocation
65}
66
67
68
Jason Sams8c880902010-06-15 12:15:57 -070069ContextFinish {
Jason Sams1a4efa32011-05-17 15:01:29 -070070 sync
Jason Sams8c880902010-06-15 12:15:57 -070071 }
Jason Sams326e0dd2009-05-22 14:03:28 -070072
Jason Sams326e0dd2009-05-22 14:03:28 -070073ContextBindRootScript {
74 param RsScript sampler
75 }
76
Jason Samsccc010b2010-05-13 18:30:11 -070077ContextBindProgramStore {
78 param RsProgramStore pgm
Jason Sams326e0dd2009-05-22 14:03:28 -070079 }
80
81ContextBindProgramFragment {
82 param RsProgramFragment pgm
83 }
84
85ContextBindProgramVertex {
86 param RsProgramVertex pgm
87 }
88
Jason Sams5fd09d82009-09-23 13:57:02 -070089ContextBindProgramRaster {
90 param RsProgramRaster pgm
91 }
92
Alex Sakhartchoukd3e0ad42010-06-24 17:15:34 -070093ContextBindFont {
94 param RsFont pgm
95 }
96
Jason Sams86f1b232009-09-24 17:38:20 -070097ContextPause {
98 }
99
100ContextResume {
101 }
102
Jason Sams458f2dc2009-11-03 13:58:36 -0800103ContextSetSurface {
Jason Sams613cad12009-11-12 15:10:25 -0800104 param uint32_t width
105 param uint32_t height
Alex Sakhartchouk7257c7e2011-05-17 12:32:47 -0700106 param RsNativeWindow sur
Jason Samsc33e6902011-06-20 16:58:04 -0700107 sync
Jason Sams458f2dc2009-11-03 13:58:36 -0800108 }
109
Jason Samsc21cf402009-11-17 17:26:46 -0800110ContextDump {
111 param int32_t bits
112}
113
Jason Sams613cad12009-11-12 15:10:25 -0800114ContextSetPriority {
Jason Sams15832442009-11-15 12:14:26 -0800115 param int32_t priority
Jason Sams613cad12009-11-12 15:10:25 -0800116 }
117
Jason Sams741aac92010-12-24 14:38:39 -0800118ContextDestroyWorker {
Jason Sams1dcefab2010-12-09 12:19:46 -0800119}
120
Jason Samsa0a1b6f2009-06-10 15:04:38 -0700121AssignName {
Alex Sakhartchouk70b83c12011-04-06 10:57:51 -0700122 param RsObjectBase obj
Jason Samsa0a1b6f2009-06-10 15:04:38 -0700123 param const char *name
124 }
Jason Sams326e0dd2009-05-22 14:03:28 -0700125
Jason Sams707aaf32009-08-18 14:14:24 -0700126ObjDestroy {
Jason Sams2353ae32010-10-14 17:48:46 -0700127 param RsAsyncVoidPtr objPtr
Jason Sams707aaf32009-08-18 14:14:24 -0700128 }
129
Jason Samsd01d9702009-12-23 14:35:29 -0800130ElementCreate {
Alex Sakhartchoukc700e642011-08-16 13:09:46 -0700131 direct
Jason Samsd01d9702009-12-23 14:35:29 -0800132 param RsDataType mType
133 param RsDataKind mKind
134 param bool mNormalized
135 param uint32_t mVectorSize
136 ret RsElement
Jason Sams326e0dd2009-05-22 14:03:28 -0700137 }
138
Jason Samsd01d9702009-12-23 14:35:29 -0800139ElementCreate2 {
Alex Sakhartchoukc700e642011-08-16 13:09:46 -0700140 direct
Jason Samsd01d9702009-12-23 14:35:29 -0800141 param const RsElement * elements
142 param const char ** names
Jason Sams46e45542010-09-02 17:35:23 -0700143 param const uint32_t * arraySize
Jason Sams326e0dd2009-05-22 14:03:28 -0700144 ret RsElement
145 }
146
Jason Sams837e3882010-12-10 16:03:15 -0800147AllocationCopyToBitmap {
148 param RsAllocation alloc
149 param void * data
Alex Sakhartchouk39f2ef62010-10-11 12:35:15 -0700150 }
151
Jason Sams326e0dd2009-05-22 14:03:28 -0700152
Jason Sams4b45b892010-12-29 14:31:29 -0800153Allocation1DData {
Jason Sams326e0dd2009-05-22 14:03:28 -0700154 param RsAllocation va
155 param uint32_t xoff
Jason Sams4b45b892010-12-29 14:31:29 -0800156 param uint32_t lod
Jason Sams326e0dd2009-05-22 14:03:28 -0700157 param uint32_t count
158 param const void *data
Jason Samsd34b7252009-08-04 16:58:20 -0700159 }
Jason Sams326e0dd2009-05-22 14:03:28 -0700160
Jason Sams4b45b892010-12-29 14:31:29 -0800161Allocation1DElementData {
Jason Sams5f0c84c2010-08-31 13:50:42 -0700162 param RsAllocation va
163 param uint32_t x
Jason Sams4b45b892010-12-29 14:31:29 -0800164 param uint32_t lod
Jason Sams5f0c84c2010-08-31 13:50:42 -0700165 param const void *data
166 param uint32_t comp_offset
Jason Sams5f0c84c2010-08-31 13:50:42 -0700167 }
168
Jason Sams4b45b892010-12-29 14:31:29 -0800169Allocation2DData {
Jason Sams326e0dd2009-05-22 14:03:28 -0700170 param RsAllocation va
171 param uint32_t xoff
172 param uint32_t yoff
Jason Sams4b45b892010-12-29 14:31:29 -0800173 param uint32_t lod
174 param RsAllocationCubemapFace face
Jason Sams326e0dd2009-05-22 14:03:28 -0700175 param uint32_t w
176 param uint32_t h
177 param const void *data
178 }
179
Jason Sams4b45b892010-12-29 14:31:29 -0800180Allocation2DElementData {
Jason Sams5f0c84c2010-08-31 13:50:42 -0700181 param RsAllocation va
182 param uint32_t x
183 param uint32_t y
Jason Sams4b45b892010-12-29 14:31:29 -0800184 param uint32_t lod
185 param RsAllocationCubemapFace face
Jason Sams5f0c84c2010-08-31 13:50:42 -0700186 param const void *data
187 param uint32_t element_offset
Jason Sams5f0c84c2010-08-31 13:50:42 -0700188 }
189
Jason Samsa2371512011-01-12 13:28:37 -0800190AllocationGenerateMipmaps {
191 param RsAllocation va
192}
193
Jason Samse579df42009-08-10 14:55:26 -0700194AllocationRead {
195 param RsAllocation va
196 param void * data
197 }
Jason Sams326e0dd2009-05-22 14:03:28 -0700198
Jason Sams366c9c82010-12-08 16:14:36 -0800199AllocationSyncAll {
200 param RsAllocation va
201 param RsAllocationUsageType src
202}
203
Jason Sams326e0dd2009-05-22 14:03:28 -0700204
Jason Sams96abf812010-10-05 13:32:49 -0700205AllocationResize1D {
206 param RsAllocation va
207 param uint32_t dimX
208 }
209
210AllocationResize2D {
211 param RsAllocation va
212 param uint32_t dimX
213 param uint32_t dimY
214 }
215
Alex Sakhartchouk74a82792011-06-14 11:13:19 -0700216AllocationCopy2DRange {
217 param RsAllocation dest
218 param uint32_t destXoff
219 param uint32_t destYoff
220 param uint32_t destMip
221 param uint32_t destFace
222 param uint32_t width
223 param uint32_t height
224 param RsAllocation src
225 param uint32_t srcXoff
226 param uint32_t srcYoff
227 param uint32_t srcMip
228 param uint32_t srcFace
229 }
230
Jason Sams326e0dd2009-05-22 14:03:28 -0700231SamplerCreate {
Alex Sakhartchoukc700e642011-08-16 13:09:46 -0700232 direct
Alex Sakhartchoukc2c02a82011-05-04 17:45:36 -0700233 param RsSamplerValue magFilter
234 param RsSamplerValue minFilter
235 param RsSamplerValue wrapS
236 param RsSamplerValue wrapT
237 param RsSamplerValue wrapR
238 param float mAniso
239 ret RsSampler
240}
Jason Sams326e0dd2009-05-22 14:03:28 -0700241
242ScriptBindAllocation {
243 param RsScript vtm
244 param RsAllocation va
245 param uint32_t slot
246 }
247
Jason Samsd34b7252009-08-04 16:58:20 -0700248ScriptSetTimeZone {
249 param RsScript s
Romain Guy98e10fd2009-07-30 18:45:01 -0700250 param const char * timeZone
Romain Guy98e10fd2009-07-30 18:45:01 -0700251 }
252
Jason Sams8c6bc692009-09-16 15:04:38 -0700253ScriptInvoke {
254 param RsScript s
255 param uint32_t slot
256 }
257
Jason Samsbe36bf32010-05-11 14:03:58 -0700258ScriptInvokeV {
259 param RsScript s
260 param uint32_t slot
261 param const void * data
Jason Samsbe36bf32010-05-11 14:03:58 -0700262 }
263
Alex Sakhartchoukc2c02a82011-05-04 17:45:36 -0700264ScriptForEach {
Jason Sams5fb1aeb2011-04-27 15:12:49 -0700265 param RsScript s
266 param uint32_t slot
267 param RsAllocation ain
268 param RsAllocation aout
269 param const void * usr
270}
271
Jason Samsbe36bf32010-05-11 14:03:58 -0700272ScriptSetVarI {
273 param RsScript s
274 param uint32_t slot
275 param int value
276 }
277
Jason Samsa5eb6e12010-11-16 17:37:02 -0800278ScriptSetVarObj {
279 param RsScript s
280 param uint32_t slot
281 param RsObjectBase value
282 }
283
Stephen Hines0977c942010-10-11 10:54:21 -0700284ScriptSetVarJ {
285 param RsScript s
286 param uint32_t slot
287 param int64_t value
288 }
289
Jason Samsbe36bf32010-05-11 14:03:58 -0700290ScriptSetVarF {
291 param RsScript s
292 param uint32_t slot
293 param float value
294 }
295
Stephen Hines6d0a0742010-09-20 17:20:30 -0700296ScriptSetVarD {
297 param RsScript s
298 param uint32_t slot
299 param double value
300 }
301
Jason Samsbe36bf32010-05-11 14:03:58 -0700302ScriptSetVarV {
303 param RsScript s
304 param uint32_t slot
305 param const void * data
Jason Samsbe36bf32010-05-11 14:03:58 -0700306 }
Jason Samsfa517192009-08-13 12:59:04 -0700307
308
Jason Sams326e0dd2009-05-22 14:03:28 -0700309ScriptCCreate {
Shih-wei Liao9503b662010-11-08 01:33:59 -0800310 param const char * resName
Shih-wei Liao15849d92010-12-10 01:03:59 -0800311 param const char * cacheDir
Jason Samsbad80742011-03-16 16:29:28 -0700312 param const char * text
Jason Sams326e0dd2009-05-22 14:03:28 -0700313 ret RsScript
314 }
315
316
Jason Sams721acc42011-04-06 11:23:54 -0700317ProgramStoreCreate {
Alex Sakhartchoukc700e642011-08-16 13:09:46 -0700318 direct
Jason Sams721acc42011-04-06 11:23:54 -0700319 param bool colorMaskR
320 param bool colorMaskG
321 param bool colorMaskB
322 param bool colorMaskA
323 param bool depthMask
324 param bool ditherEnable
Jason Sams326e0dd2009-05-22 14:03:28 -0700325 param RsBlendSrcFunc srcFunc
326 param RsBlendDstFunc destFunc
Jason Sams721acc42011-04-06 11:23:54 -0700327 param RsDepthFunc depthFunc
Jason Samsccc010b2010-05-13 18:30:11 -0700328 ret RsProgramStore
Jason Sams326e0dd2009-05-22 14:03:28 -0700329 }
330
Jason Sams5fd09d82009-09-23 13:57:02 -0700331ProgramRasterCreate {
Alex Sakhartchoukc700e642011-08-16 13:09:46 -0700332 direct
Jason Sams5fd09d82009-09-23 13:57:02 -0700333 param bool pointSprite
Jason Sams721acc42011-04-06 11:23:54 -0700334 param RsCullMode cull
Jason Sams5fd09d82009-09-23 13:57:02 -0700335 ret RsProgramRaster
336}
337
Jason Sams4815c0d2009-12-15 12:58:36 -0800338ProgramBindConstants {
339 param RsProgram vp
340 param uint32_t slot
341 param RsAllocation constants
342 }
343
Jason Sams326e0dd2009-05-22 14:03:28 -0700344
Jason Sams7dad9c32009-12-17 16:55:08 -0800345ProgramBindTexture {
Jason Sams326e0dd2009-05-22 14:03:28 -0700346 param RsProgramFragment pf
347 param uint32_t slot
348 param RsAllocation a
349 }
350
Jason Sams7dad9c32009-12-17 16:55:08 -0800351ProgramBindSampler {
Jason Sams326e0dd2009-05-22 14:03:28 -0700352 param RsProgramFragment pf
353 param uint32_t slot
354 param RsSampler s
355 }
356
Jason Sams326e0dd2009-05-22 14:03:28 -0700357ProgramFragmentCreate {
Alex Sakhartchoukc700e642011-08-16 13:09:46 -0700358 direct
Jason Samsf2e4fa22009-12-15 13:27:04 -0800359 param const char * shaderText
Jason Samsf2e4fa22009-12-15 13:27:04 -0800360 param const uint32_t * params
Jason Samsf2e4fa22009-12-15 13:27:04 -0800361 ret RsProgramFragment
362 }
363
Jason Sams326e0dd2009-05-22 14:03:28 -0700364ProgramVertexCreate {
Alex Sakhartchoukc700e642011-08-16 13:09:46 -0700365 direct
Jason Sams4815c0d2009-12-15 12:58:36 -0800366 param const char * shaderText
Jason Sams4815c0d2009-12-15 12:58:36 -0800367 param const uint32_t * params
Jason Samsf2e4fa22009-12-15 13:27:04 -0800368 ret RsProgramVertex
Jason Samsb5909ce2009-07-21 12:20:54 -0700369 }
370
Alex Sakhartchoukd3e0ad42010-06-24 17:15:34 -0700371FontCreateFromFile {
372 param const char *name
Alex Sakhartchoukc17ace22010-12-17 11:41:08 -0800373 param float fontSize
Alex Sakhartchoukd3e0ad42010-06-24 17:15:34 -0700374 param uint32_t dpi
375 ret RsFont
376 }
377
Alex Sakhartchouk5224a272011-01-07 11:12:08 -0800378FontCreateFromMemory {
379 param const char *name
380 param float fontSize
381 param uint32_t dpi
Alex Sakhartchouk70b83c12011-04-06 10:57:51 -0700382 param const void *data
Alex Sakhartchouk5224a272011-01-07 11:12:08 -0800383 ret RsFont
384 }
385
Alex Sakhartchouk4e9a7a82010-07-01 16:14:06 -0700386MeshCreate {
Alex Sakhartchouk9003e562011-05-12 10:38:03 -0700387 param RsAllocation *vtx
388 param RsAllocation *idx
389 param uint32_t *primType
Alex Sakhartchouk4e9a7a82010-07-01 16:14:06 -0700390 ret RsMesh
Alex Sakhartchouk4e9a7a82010-07-01 16:14:06 -0700391 }
Jason Sams9e0afb52011-10-31 13:23:43 -0700392
393PathCreate {
394 param RsPathPrimitive pp
395 param bool isStatic
396 param RsAllocation vertex
397 param RsAllocation loops
398 param float quality
399 ret RsPath
400 }
401