blob: 0dea97100d353321495b2707dcbbb491d26ea784 [file] [log] [blame]
Jason Sams326e0dd2009-05-22 14:03:28 -07001
Jason Sams186e5912011-04-26 14:50:00 -07002ContextDestroy {
3 direct
4}
5
6ContextGetMessage {
7 direct
8 param void *data
9 param size_t *receiveLen
Jason Sams1a4efa32011-05-17 15:01:29 -070010 param uint32_t *usrID
Jason Sams186e5912011-04-26 14:50:00 -070011 ret RsMessageToClientType
12}
13
14ContextPeekMessage {
15 direct
16 param size_t *receiveLen
Jason Sams1a4efa32011-05-17 15:01:29 -070017 param uint32_t *usrID
Jason Sams186e5912011-04-26 14:50:00 -070018 ret RsMessageToClientType
19}
20
21ContextInitToClient {
22 direct
23}
24
25ContextDeinitToClient {
26 direct
27}
28
Jason Samsc975cf42011-04-28 18:26:48 -070029TypeCreate {
Jason Sams186e5912011-04-26 14:50:00 -070030 direct
31 param RsElement e
32 param uint32_t dimX
33 param uint32_t dimY
34 param uint32_t dimZ
35 param bool mips
36 param bool faces
37 ret RsType
38}
39
Jason Samsc975cf42011-04-28 18:26:48 -070040AllocationCreateTyped {
Jason Sams186e5912011-04-26 14:50:00 -070041 direct
42 param RsType vtype
43 param RsAllocationMipmapControl mips
44 param uint32_t usages
45 ret RsAllocation
46}
47
Jason Samsc975cf42011-04-28 18:26:48 -070048AllocationCreateFromBitmap {
Jason Sams186e5912011-04-26 14:50:00 -070049 direct
50 param RsType vtype
51 param RsAllocationMipmapControl mips
52 param const void *data
53 param uint32_t usages
54 ret RsAllocation
55}
56
Jason Samsc975cf42011-04-28 18:26:48 -070057AllocationCubeCreateFromBitmap {
Jason Sams186e5912011-04-26 14:50:00 -070058 direct
59 param RsType vtype
60 param RsAllocationMipmapControl mips
61 param const void *data
62 param uint32_t usages
63 ret RsAllocation
64}
65
66
67
Jason Sams8c880902010-06-15 12:15:57 -070068ContextFinish {
Jason Sams1a4efa32011-05-17 15:01:29 -070069 sync
Jason Sams8c880902010-06-15 12:15:57 -070070 }
Jason Sams326e0dd2009-05-22 14:03:28 -070071
Jason Sams326e0dd2009-05-22 14:03:28 -070072ContextBindRootScript {
73 param RsScript sampler
74 }
75
Jason Samsccc010b2010-05-13 18:30:11 -070076ContextBindProgramStore {
77 param RsProgramStore pgm
Jason Sams326e0dd2009-05-22 14:03:28 -070078 }
79
80ContextBindProgramFragment {
81 param RsProgramFragment pgm
82 }
83
84ContextBindProgramVertex {
85 param RsProgramVertex pgm
86 }
87
Jason Sams5fd09d82009-09-23 13:57:02 -070088ContextBindProgramRaster {
89 param RsProgramRaster pgm
90 }
91
Alex Sakhartchoukd3e0ad42010-06-24 17:15:34 -070092ContextBindFont {
93 param RsFont pgm
94 }
95
Jason Sams86f1b232009-09-24 17:38:20 -070096ContextPause {
97 }
98
99ContextResume {
100 }
101
Jason Sams458f2dc2009-11-03 13:58:36 -0800102ContextSetSurface {
Jason Sams613cad12009-11-12 15:10:25 -0800103 param uint32_t width
104 param uint32_t height
Alex Sakhartchouk7257c7e2011-05-17 12:32:47 -0700105 param RsNativeWindow sur
Jason Samsc33e6902011-06-20 16:58:04 -0700106 sync
Jason Sams458f2dc2009-11-03 13:58:36 -0800107 }
108
Jason Samsc21cf402009-11-17 17:26:46 -0800109ContextDump {
110 param int32_t bits
111}
112
Jason Sams613cad12009-11-12 15:10:25 -0800113ContextSetPriority {
Jason Sams15832442009-11-15 12:14:26 -0800114 param int32_t priority
Jason Sams613cad12009-11-12 15:10:25 -0800115 }
116
Jason Sams741aac92010-12-24 14:38:39 -0800117ContextDestroyWorker {
Jason Sams1dcefab2010-12-09 12:19:46 -0800118}
119
Jason Samsa0a1b6f2009-06-10 15:04:38 -0700120AssignName {
Alex Sakhartchouk70b83c12011-04-06 10:57:51 -0700121 param RsObjectBase obj
Jason Samsa0a1b6f2009-06-10 15:04:38 -0700122 param const char *name
123 }
Jason Sams326e0dd2009-05-22 14:03:28 -0700124
Jason Sams707aaf32009-08-18 14:14:24 -0700125ObjDestroy {
Jason Sams2353ae32010-10-14 17:48:46 -0700126 param RsAsyncVoidPtr objPtr
Jason Sams707aaf32009-08-18 14:14:24 -0700127 }
128
Jason Samsd01d9702009-12-23 14:35:29 -0800129ElementCreate {
130 param RsDataType mType
131 param RsDataKind mKind
132 param bool mNormalized
133 param uint32_t mVectorSize
134 ret RsElement
Jason Sams326e0dd2009-05-22 14:03:28 -0700135 }
136
Jason Samsd01d9702009-12-23 14:35:29 -0800137ElementCreate2 {
Jason Samsd01d9702009-12-23 14:35:29 -0800138 param const RsElement * elements
139 param const char ** names
Jason Sams46e45542010-09-02 17:35:23 -0700140 param const uint32_t * arraySize
Jason Sams326e0dd2009-05-22 14:03:28 -0700141 ret RsElement
142 }
143
Jason Sams837e3882010-12-10 16:03:15 -0800144AllocationCopyToBitmap {
145 param RsAllocation alloc
146 param void * data
Alex Sakhartchouk39f2ef62010-10-11 12:35:15 -0700147 }
148
Jason Sams326e0dd2009-05-22 14:03:28 -0700149
Jason Sams4b45b892010-12-29 14:31:29 -0800150Allocation1DData {
Jason Sams326e0dd2009-05-22 14:03:28 -0700151 param RsAllocation va
152 param uint32_t xoff
Jason Sams4b45b892010-12-29 14:31:29 -0800153 param uint32_t lod
Jason Sams326e0dd2009-05-22 14:03:28 -0700154 param uint32_t count
155 param const void *data
Jason Samsd34b7252009-08-04 16:58:20 -0700156 }
Jason Sams326e0dd2009-05-22 14:03:28 -0700157
Jason Sams4b45b892010-12-29 14:31:29 -0800158Allocation1DElementData {
Jason Sams5f0c84c2010-08-31 13:50:42 -0700159 param RsAllocation va
160 param uint32_t x
Jason Sams4b45b892010-12-29 14:31:29 -0800161 param uint32_t lod
Jason Sams5f0c84c2010-08-31 13:50:42 -0700162 param const void *data
163 param uint32_t comp_offset
Jason Sams5f0c84c2010-08-31 13:50:42 -0700164 }
165
Jason Sams4b45b892010-12-29 14:31:29 -0800166Allocation2DData {
Jason Sams326e0dd2009-05-22 14:03:28 -0700167 param RsAllocation va
168 param uint32_t xoff
169 param uint32_t yoff
Jason Sams4b45b892010-12-29 14:31:29 -0800170 param uint32_t lod
171 param RsAllocationCubemapFace face
Jason Sams326e0dd2009-05-22 14:03:28 -0700172 param uint32_t w
173 param uint32_t h
174 param const void *data
175 }
176
Jason Sams4b45b892010-12-29 14:31:29 -0800177Allocation2DElementData {
Jason Sams5f0c84c2010-08-31 13:50:42 -0700178 param RsAllocation va
179 param uint32_t x
180 param uint32_t y
Jason Sams4b45b892010-12-29 14:31:29 -0800181 param uint32_t lod
182 param RsAllocationCubemapFace face
Jason Sams5f0c84c2010-08-31 13:50:42 -0700183 param const void *data
184 param uint32_t element_offset
Jason Sams5f0c84c2010-08-31 13:50:42 -0700185 }
186
Jason Samsa2371512011-01-12 13:28:37 -0800187AllocationGenerateMipmaps {
188 param RsAllocation va
189}
190
Jason Samse579df42009-08-10 14:55:26 -0700191AllocationRead {
192 param RsAllocation va
193 param void * data
194 }
Jason Sams326e0dd2009-05-22 14:03:28 -0700195
Jason Sams366c9c82010-12-08 16:14:36 -0800196AllocationSyncAll {
197 param RsAllocation va
198 param RsAllocationUsageType src
199}
200
Jason Sams326e0dd2009-05-22 14:03:28 -0700201
Jason Sams96abf812010-10-05 13:32:49 -0700202AllocationResize1D {
203 param RsAllocation va
204 param uint32_t dimX
205 }
206
207AllocationResize2D {
208 param RsAllocation va
209 param uint32_t dimX
210 param uint32_t dimY
211 }
212
Alex Sakhartchouk74a82792011-06-14 11:13:19 -0700213AllocationCopy2DRange {
214 param RsAllocation dest
215 param uint32_t destXoff
216 param uint32_t destYoff
217 param uint32_t destMip
218 param uint32_t destFace
219 param uint32_t width
220 param uint32_t height
221 param RsAllocation src
222 param uint32_t srcXoff
223 param uint32_t srcYoff
224 param uint32_t srcMip
225 param uint32_t srcFace
226 }
227
Jason Sams326e0dd2009-05-22 14:03:28 -0700228SamplerCreate {
Alex Sakhartchoukc2c02a82011-05-04 17:45:36 -0700229 param RsSamplerValue magFilter
230 param RsSamplerValue minFilter
231 param RsSamplerValue wrapS
232 param RsSamplerValue wrapT
233 param RsSamplerValue wrapR
234 param float mAniso
235 ret RsSampler
236}
Jason Sams326e0dd2009-05-22 14:03:28 -0700237
238ScriptBindAllocation {
239 param RsScript vtm
240 param RsAllocation va
241 param uint32_t slot
242 }
243
Jason Samsd34b7252009-08-04 16:58:20 -0700244ScriptSetTimeZone {
245 param RsScript s
Romain Guy98e10fd2009-07-30 18:45:01 -0700246 param const char * timeZone
Romain Guy98e10fd2009-07-30 18:45:01 -0700247 }
248
Jason Sams8c6bc692009-09-16 15:04:38 -0700249ScriptInvoke {
250 param RsScript s
251 param uint32_t slot
252 }
253
Jason Samsbe36bf32010-05-11 14:03:58 -0700254ScriptInvokeV {
255 param RsScript s
256 param uint32_t slot
257 param const void * data
Jason Samsbe36bf32010-05-11 14:03:58 -0700258 }
259
Alex Sakhartchoukc2c02a82011-05-04 17:45:36 -0700260ScriptForEach {
Jason Sams5fb1aeb2011-04-27 15:12:49 -0700261 param RsScript s
262 param uint32_t slot
263 param RsAllocation ain
264 param RsAllocation aout
265 param const void * usr
266}
267
Jason Samsbe36bf32010-05-11 14:03:58 -0700268ScriptSetVarI {
269 param RsScript s
270 param uint32_t slot
271 param int value
272 }
273
Jason Samsa5eb6e12010-11-16 17:37:02 -0800274ScriptSetVarObj {
275 param RsScript s
276 param uint32_t slot
277 param RsObjectBase value
278 }
279
Stephen Hines0977c942010-10-11 10:54:21 -0700280ScriptSetVarJ {
281 param RsScript s
282 param uint32_t slot
283 param int64_t value
284 }
285
Jason Samsbe36bf32010-05-11 14:03:58 -0700286ScriptSetVarF {
287 param RsScript s
288 param uint32_t slot
289 param float value
290 }
291
Stephen Hines6d0a0742010-09-20 17:20:30 -0700292ScriptSetVarD {
293 param RsScript s
294 param uint32_t slot
295 param double value
296 }
297
Jason Samsbe36bf32010-05-11 14:03:58 -0700298ScriptSetVarV {
299 param RsScript s
300 param uint32_t slot
301 param const void * data
Jason Samsbe36bf32010-05-11 14:03:58 -0700302 }
Jason Samsfa517192009-08-13 12:59:04 -0700303
304
Jason Sams326e0dd2009-05-22 14:03:28 -0700305ScriptCCreate {
Shih-wei Liao9503b662010-11-08 01:33:59 -0800306 param const char * resName
Shih-wei Liao15849d92010-12-10 01:03:59 -0800307 param const char * cacheDir
Jason Samsbad80742011-03-16 16:29:28 -0700308 param const char * text
Jason Sams326e0dd2009-05-22 14:03:28 -0700309 ret RsScript
310 }
311
312
Jason Sams721acc42011-04-06 11:23:54 -0700313ProgramStoreCreate {
314 param bool colorMaskR
315 param bool colorMaskG
316 param bool colorMaskB
317 param bool colorMaskA
318 param bool depthMask
319 param bool ditherEnable
Jason Sams326e0dd2009-05-22 14:03:28 -0700320 param RsBlendSrcFunc srcFunc
321 param RsBlendDstFunc destFunc
Jason Sams721acc42011-04-06 11:23:54 -0700322 param RsDepthFunc depthFunc
Jason Samsccc010b2010-05-13 18:30:11 -0700323 ret RsProgramStore
Jason Sams326e0dd2009-05-22 14:03:28 -0700324 }
325
Jason Sams5fd09d82009-09-23 13:57:02 -0700326ProgramRasterCreate {
Jason Sams5fd09d82009-09-23 13:57:02 -0700327 param bool pointSmooth
328 param bool lineSmooth
329 param bool pointSprite
Jason Sams721acc42011-04-06 11:23:54 -0700330 param float lineWidth
331 param RsCullMode cull
Jason Sams5fd09d82009-09-23 13:57:02 -0700332 ret RsProgramRaster
333}
334
Jason Sams4815c0d2009-12-15 12:58:36 -0800335ProgramBindConstants {
336 param RsProgram vp
337 param uint32_t slot
338 param RsAllocation constants
339 }
340
Jason Sams326e0dd2009-05-22 14:03:28 -0700341
Jason Sams7dad9c32009-12-17 16:55:08 -0800342ProgramBindTexture {
Jason Sams326e0dd2009-05-22 14:03:28 -0700343 param RsProgramFragment pf
344 param uint32_t slot
345 param RsAllocation a
346 }
347
Jason Sams7dad9c32009-12-17 16:55:08 -0800348ProgramBindSampler {
Jason Sams326e0dd2009-05-22 14:03:28 -0700349 param RsProgramFragment pf
350 param uint32_t slot
351 param RsSampler s
352 }
353
Jason Sams326e0dd2009-05-22 14:03:28 -0700354ProgramFragmentCreate {
Jason Samsf2e4fa22009-12-15 13:27:04 -0800355 param const char * shaderText
Jason Samsf2e4fa22009-12-15 13:27:04 -0800356 param const uint32_t * params
Jason Samsf2e4fa22009-12-15 13:27:04 -0800357 ret RsProgramFragment
358 }
359
Jason Sams326e0dd2009-05-22 14:03:28 -0700360ProgramVertexCreate {
Jason Sams4815c0d2009-12-15 12:58:36 -0800361 param const char * shaderText
Jason Sams4815c0d2009-12-15 12:58:36 -0800362 param const uint32_t * params
Jason Samsf2e4fa22009-12-15 13:27:04 -0800363 ret RsProgramVertex
Jason Samsb5909ce2009-07-21 12:20:54 -0700364 }
365
Alex Sakhartchoukd3e0ad42010-06-24 17:15:34 -0700366FontCreateFromFile {
367 param const char *name
Alex Sakhartchoukc17ace22010-12-17 11:41:08 -0800368 param float fontSize
Alex Sakhartchoukd3e0ad42010-06-24 17:15:34 -0700369 param uint32_t dpi
370 ret RsFont
371 }
372
Alex Sakhartchouk5224a272011-01-07 11:12:08 -0800373FontCreateFromMemory {
374 param const char *name
375 param float fontSize
376 param uint32_t dpi
Alex Sakhartchouk70b83c12011-04-06 10:57:51 -0700377 param const void *data
Alex Sakhartchouk5224a272011-01-07 11:12:08 -0800378 ret RsFont
379 }
380
Alex Sakhartchouk4e9a7a82010-07-01 16:14:06 -0700381MeshCreate {
Alex Sakhartchouk9003e562011-05-12 10:38:03 -0700382 param RsAllocation *vtx
383 param RsAllocation *idx
384 param uint32_t *primType
Alex Sakhartchouk4e9a7a82010-07-01 16:14:06 -0700385 ret RsMesh
Alex Sakhartchouk4e9a7a82010-07-01 16:14:06 -0700386 }