blob: 6177d447aeacdc34de230c1038a6b24ef2ae1edd [file] [log] [blame]
Jean-Luc Brouilletc5184e22015-03-13 13:51:24 -07001#
2# Copyright (C) 2015 The Android Open Source Project
3#
4# Licensed under the Apache License, Version 2.0 (the "License");
5# you may not use this file except in compliance with the License.
6# You may obtain a copy of the License at
7#
8# http://www.apache.org/licenses/LICENSE-2.0
9#
10# Unless required by applicable law or agreed to in writing, software
11# distributed under the License is distributed on an "AS IS" BASIS,
12# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13# See the License for the specific language governing permissions and
14# limitations under the License.
15#
16
17header:
18summary: TODO
19description:
20# TODO move elsewhere?
21 RenderScript is a high-performance runtime that provides
22 compute operations at the native level. RenderScript code is compiled on devices
23 at runtime to allow platform-independence as well.
24 This reference documentation describes the RenderScript runtime APIs, which you
25 can utilize to write RenderScript code in C99. The RenderScript compute header
26 files are automatically included for you.
27
28 To use RenderScript, you need to utilize the RenderScript runtime APIs documented here
29 as well as the Android framework APIs for RenderScript.
30 For documentation on the Android framework APIs, see the <a target="_parent" href="http://developer.android.com/reference/android/renderscript/package-summary.html">android.renderscript</a> package reference.
31 For more information on how to develop with RenderScript and how the runtime and
32 Android framework APIs interact, see the <a target="_parent" href="http://developer.android.com/guide/topics/renderscript/index.html">RenderScript developer guide</a>
33 and the <a target="_parent" href="http://developer.android.com/resources/samples/RenderScript/index.html">RenderScript samples</a>.
34include:
35 #define RS_KERNEL __attribute__((kernel))
36
Jean-Luc Brouilletbe216382015-03-22 12:44:27 -070037 #include "stdbool.h"
38
39 #include "rs_value_types.rsh"
40 #include "rs_object_types.rsh"
41
42 #include "rs_allocation_data.rsh"
Jean-Luc Brouilletc5184e22015-03-13 13:51:24 -070043 #include "rs_atomic.rsh"
Jean-Luc Brouilletbe216382015-03-22 12:44:27 -070044 #include "rs_convert.rsh"
Jean-Luc Brouilletc5184e22015-03-13 13:51:24 -070045 #include "rs_debug.rsh"
Jean-Luc Brouilletbe216382015-03-22 12:44:27 -070046 #include "rs_for_each.rsh"
47 #include "rs_io.rsh"
Jean-Luc Brouilletc5184e22015-03-13 13:51:24 -070048 #include "rs_math.rsh"
49 #include "rs_matrix.rsh"
Jean-Luc Brouilletbe216382015-03-22 12:44:27 -070050 #include "rs_object_info.rsh"
Jean-Luc Brouilletc5184e22015-03-13 13:51:24 -070051 #include "rs_quaternion.rsh"
Jean-Luc Brouilletc5184e22015-03-13 13:51:24 -070052 #include "rs_time.rsh"
Jean-Luc Brouilletbe216382015-03-22 12:44:27 -070053 #include "rs_vector_math.rsh"
Jean-Luc Brouilletc5184e22015-03-13 13:51:24 -070054end: