blob: 05722b7f1131cce598d7d4ab1e687e441927665f [file] [log] [blame]
Jean-Luc Brouilletbe216382015-03-22 12:44:27 -07001#
2# Copyright (C) 2015 The Android Open Source Project
3#
4# Licensed under the Apache License, Version 2.0 (the "License");
5# you may not use this file except in compliance with the License.
6# You may obtain a copy of the License at
7#
8# http://www.apache.org/licenses/LICENSE-2.0
9#
10# Unless required by applicable law or agreed to in writing, software
11# distributed under the License is distributed on an "AS IS" BASIS,
12# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13# See the License for the specific language governing permissions and
14# limitations under the License.
15#
16
17header:
18summary: Input/output functions
19description:
20 TODO Add documentation
21end:
22
23function: rsAllocationIoReceive
24version: 16
25ret: void
26arg: rs_allocation a, "allocation to work on"
27summary: Receive new content from the queue
28description:
29 Receive a new set of contents from the queue.
30test: none
31end:
32
33function: rsAllocationIoSend
34version: 16
35ret: void
36arg: rs_allocation a, "allocation to work on"
37summary: Send new content to the queue
38description:
39 Send the contents of the Allocation to the queue.
40test: none
41end:
42
43function: rsSendToClient
44ret: bool
45arg: int cmdID
46summary:
47description:
48 Send a message back to the client. Will not block and returns true
49 if the message was sendable and false if the fifo was full.
50 A message ID is required. Data payload is optional.
51test: none
52end:
53
54function: rsSendToClient
55ret: bool
56arg: int cmdID
57arg: const void* data
58arg: uint len
59test: none
60end:
61
62function: rsSendToClientBlocking
63ret: void
64arg: int cmdID
65summary:
66description:
67 Send a message back to the client, blocking until the message is queued.
68 A message ID is required. Data payload is optional.
69test: none
70end:
71
72function: rsSendToClientBlocking
73ret: void
74arg: int cmdID
75arg: const void* data
76arg: uint len
77test: none
78end: