blob: 1e6eeed0cf01ee46a5d5e5f1a6bd8382436c8be9 [file] [log] [blame]
Jean-Luc Brouilletbe216382015-03-22 12:44:27 -07001#
2# Copyright (C) 2015 The Android Open Source Project
3#
4# Licensed under the Apache License, Version 2.0 (the "License");
5# you may not use this file except in compliance with the License.
6# You may obtain a copy of the License at
7#
8# http://www.apache.org/licenses/LICENSE-2.0
9#
10# Unless required by applicable law or agreed to in writing, software
11# distributed under the License is distributed on an "AS IS" BASIS,
12# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13# See the License for the specific language governing permissions and
14# limitations under the License.
15#
16
17header:
18summary: Standard RenderScript types
19description:
20 Integers:<ul>
21 <li>8 bit: char, int8_t</li>
22 <li>16 bit: short, int16_t</li>
23 <li>32 bit: int, in32_t</li>
24 <li>64 bit: long, long long, int64_t</li></ul>
25
26 Unsigned integers:<ul>
27 <li>8 bit: uchar, uint8_t</li>
28 <li>16 bit: ushort, uint16_t</li>
29 <li>32 bit: uint, uint32_t</li>
30 <li>64 bit: ulong, uint64_t</li></ul>
31
32 Floating point:<ul>
33 <li>32 bit: float</li>
34 <li>64 bit: double</li></ul>
35
36 Vectors of length 2, 3, and 4 are supported for all the types above.
37end:
38
39type: int8_t
40simple: char
41summary: 8 bit signed integer
42description:
43 8 bit integer type
44end:
45
46type: int16_t
47simple: short
48summary: 16 bit signed integer
49description:
50 16 bit integer type
51end:
52
53type: int32_t
54simple: int
55summary: 32 bit signed integer
56description:
57 32 bit integer type
58end:
59
60type: int64_t
61version: 9 20
62simple: long long
63summary: 64 bit signed integer
64description:
65 64 bit integer type
66end:
67
68type: int64_t
69version: 21
70simple: long
71end:
72
73type: uint8_t
74simple: unsigned char
75summary: 8 bit unsigned integer
76description:
77 8 bit unsigned integer type
78end:
79
80type: uint16_t
81simple: unsigned short
82summary: 16 bit unsigned integer
83description:
84 16 bit unsigned integer type
85end:
86
87type: uint32_t
88simple: unsigned int
89summary: 32 bit unsigned integer
90description:
91 32 bit unsigned integer type
92end:
93
94type: uint64_t
95version: 9 20
96simple: unsigned long long
97summary: 64 bit unsigned integer
98description:
99 64 bit unsigned integer type
100end:
101
102type: uint64_t
103version: 21
104simple: unsigned long
105end:
106
107type: uchar
108simple: uint8_t
109summary: 8 bit unsigned integer
110description:
111 8 bit unsigned integer type
112end:
113
114type: ushort
115simple: uint16_t
116summary: 16 bit unsigned integer
117description:
118 16 bit unsigned integer type
119end:
120
121type: uint
122simple: uint32_t
123summary: 32 bit unsigned integer
124description:
125 32 bit unsigned integer type
126end:
127
128type: ulong
129simple: uint64_t
130summary: 64 bit unsigned integer
131description:
132 Typedef for unsigned long (use for 64-bit unsigned integers)
133end:
134
135type: size_t
136size: 64
137simple: uint64_t
138summary: Unsigned size type
139description:
140 Typedef for size_t
141end:
142
143type: size_t
144size: 32
145simple: uint32_t
146end:
147
148type: ssize_t
149size: 64
150simple: int64_t
151summary: Signed size type
152description:
153 Typedef for ssize_t
154end:
155
156type: ssize_t
157size: 32
158simple: int32_t
159end:
160
161type: float2
162simple: float __attribute__((ext_vector_type(2)))
163summary: Two 32 bit floats
164description:
165 Vector version of the basic float type.
166 Provides two float fields packed into a single 64 bit field with 64 bit alignment.
167end:
168
169type: float3
170simple: float __attribute__((ext_vector_type(3)))
171summary: Three 32 bit floats
172description:
173 Vector version of the basic float type.
174 Provides three float fields packed into a single 128 bit field with 128 bit alignment.
175end:
176
177type: float4
178simple: float __attribute__((ext_vector_type(4)))
179summary: Four 32 bit floats
180description:
181 Vector version of the basic float type.
182 Provides four float fields packed into a single 128 bit field with 128 bit alignment.
183end:
184
185
186type: double2
187simple: double __attribute__((ext_vector_type(2)))
188summary: Two 64 bit floats
189description:
190 Vector version of the basic double type. Provides two double fields packed
191 into a single 128 bit field with 128 bit alignment.
192end:
193
194type: double3
195simple: double __attribute__((ext_vector_type(3)))
196summary: Three 64 bit floats
197description:
198 Vector version of the basic double type. Provides three double fields packed
199 into a single 256 bit field with 256 bit alignment.
200end:
201
202type: double4
203simple: double __attribute__((ext_vector_type(4)))
204summary: Four 64 bit floats
205description:
206 Vector version of the basic double type. Provides four double fields packed
207 into a single 256 bit field with 256 bit alignment.
208end:
209
210
211type: uchar2
212simple: uchar __attribute__((ext_vector_type(2)))
213summary: Two 8 bit unsigned integers
214description:
215 Vector version of the basic uchar type. Provides two uchar fields packed
216 into a single 16 bit field with 16 bit alignment.
217end:
218
219type: uchar3
220simple: uchar __attribute__((ext_vector_type(3)))
221summary: Three 8 bit unsigned integers
222description:
223 Vector version of the basic uchar type. Provides three uchar fields packed
224 into a single 32 bit field with 32 bit alignment.
225end:
226
227type: uchar4
228simple: uchar __attribute__((ext_vector_type(4)))
229summary: Four 8 bit unsigned integers
230description:
231 Vector version of the basic uchar type. Provides four uchar fields packed
232 into a single 32 bit field with 32 bit alignment.
233end:
234
235
236type: ushort2
237simple: ushort __attribute__((ext_vector_type(2)))
238summary: Two 16 bit unsigned integers
239description:
240 Vector version of the basic ushort type. Provides two ushort fields packed
241 into a single 32 bit field with 32 bit alignment.
242end:
243
244type: ushort3
245simple: ushort __attribute__((ext_vector_type(3)))
246summary: Three 16 bit unsigned integers
247description:
248 Vector version of the basic ushort type. Provides three ushort fields packed
249 into a single 64 bit field with 64 bit alignment.
250end:
251
252type: ushort4
253simple: ushort __attribute__((ext_vector_type(4)))
254summary: Four 16 bit unsigned integers
255description:
256 Vector version of the basic ushort type. Provides four ushort fields packed
257 into a single 64 bit field with 64 bit alignment.
258end:
259
260
261type: uint2
262simple: uint __attribute__((ext_vector_type(2)))
263summary: Two 32 bit unsigned integers
264description:
265 Vector version of the basic uint type. Provides two uint fields packed into a
266 single 64 bit field with 64 bit alignment.
267end:
268
269type: uint3
270simple: uint __attribute__((ext_vector_type(3)))
271summary: Three 32 bit unsigned integers
272description:
273 Vector version of the basic uint type. Provides three uint fields packed into
274 a single 128 bit field with 128 bit alignment.
275end:
276
277type: uint4
278simple: uint __attribute__((ext_vector_type(4)))
279summary: Four 32 bit unsigned integers
280description:
281 Vector version of the basic uint type. Provides four uint fields packed into
282 a single 128 bit field with 128 bit alignment.
283end:
284
285
286type: ulong2
287simple: ulong __attribute__((ext_vector_type(2)))
288summary: Two 64 bit unsigned integers
289description:
290 Vector version of the basic ulong type. Provides two ulong fields packed into
291 a single 128 bit field with 128 bit alignment.
292end:
293
294type: ulong3
295simple: ulong __attribute__((ext_vector_type(3)))
296summary: Three 64 bit unsigned integers
297description:
298 Vector version of the basic ulong type. Provides three ulong fields packed
299 into a single 256 bit field with 256 bit alignment.
300end:
301
302type: ulong4
303simple: ulong __attribute__((ext_vector_type(4)))
304summary: Four 64 bit unsigned integers
305description:
306 Vector version of the basic ulong type. Provides four ulong fields packed
307 into a single 256 bit field with 256 bit alignment.
308end:
309
310
311type: char2
312simple: char __attribute__((ext_vector_type(2)))
313summary: Two 8 bit signed integers
314description:
315 Vector version of the basic char type. Provides two char fields packed into a
316 single 16 bit field with 16 bit alignment.
317end:
318
319type: char3
320simple: char __attribute__((ext_vector_type(3)))
321summary: Three 8 bit signed integers
322description:
323 Vector version of the basic char type. Provides three char fields packed into
324 a single 32 bit field with 32 bit alignment.
325end:
326
327type: char4
328simple: char __attribute__((ext_vector_type(4)))
329summary: Four 8 bit signed integers
330description:
331 Vector version of the basic char type. Provides four char fields packed into
332 a single 32 bit field with 32 bit alignment.
333end:
334
335type: short2
336simple: short __attribute__((ext_vector_type(2)))
337summary: Two 16 bit signed integers
338description:
339 Vector version of the basic short type. Provides two short fields packed into
340 a single 32 bit field with 32 bit alignment.
341end:
342
343type: short3
344simple: short __attribute__((ext_vector_type(3)))
345summary: Three 16 bit signed integers
346description:
347 Vector version of the basic short type. Provides three short fields packed
348 into a single 64 bit field with 64 bit alignment.
349end:
350
351type: short4
352simple: short __attribute__((ext_vector_type(4)))
353summary: Four 16 bit signed integers
354description:
355 Vector version of the basic short type. Provides four short fields packed
356 into a single 64 bit field with 64 bit alignment.
357end:
358
359
360type: int2
361simple: int __attribute__((ext_vector_type(2)))
362summary: Two 32 bit signed integers
363description:
364 Vector version of the basic int type. Provides two int fields packed into a
365 single 64 bit field with 64 bit alignment.
366end:
367
368type: int3
369simple: int __attribute__((ext_vector_type(3)))
370summary: Three 32 bit signed integers
371description:
372 Vector version of the basic int type. Provides three int fields packed into a
373 single 128 bit field with 128 bit alignment.
374end:
375
376type: int4
377simple: int __attribute__((ext_vector_type(4)))
378summary: Four 32 bit signed integers
379description:
380 Vector version of the basic int type. Provides two four fields packed into a
381 single 128 bit field with 128 bit alignment.
382end:
383
384
385type: long2
386simple: long __attribute__((ext_vector_type(2)))
387summary: Two 64 bit signed integers
388description:
389 Vector version of the basic long type. Provides two long fields packed into a
390 single 128 bit field with 128 bit alignment.
391end:
392
393type: long3
394simple: long __attribute__((ext_vector_type(3)))
395summary: Three 64 bit signed integers
396description:
397 Vector version of the basic long type. Provides three long fields packed into
398 a single 256 bit field with 256 bit alignment.
399end:
400
401type: long4
402simple: long __attribute__((ext_vector_type(4)))
403summary: Four 64 bit signed integers
404description:
405 Vector version of the basic long type. Provides four long fields packed into
406 a single 256 bit field with 256 bit alignment.
407end: