blob: 80f4642f46026ff331db600c5159bc325ff7b1fc [file] [log] [blame]
Brenden Blancobd8fea42015-08-25 23:14:25 -07001#!/usr/bin/make -f
2# -*- makefile -*-
3
4# Uncomment this to turn on verbose mode.
5#export DH_VERBOSE=1
6
Brenden Blanco9e5c3522015-08-26 00:13:23 -07007DEBIAN_VERSION := $(shell dpkg-parsechangelog | sed -rne "s,^Version: (.*),\1,p")
8DEBIAN_REVISION := $(shell dpkg-parsechangelog | sed -rne "s,^Version: ([0-9.]+)(~|-)(.*),\3,p")
9UPSTREAM_VERSION := $(shell dpkg-parsechangelog | sed -rne "s,^Version: ([0-9.]+)(~|-)(.*),\1,p")
10
Brenden Blancobd8fea42015-08-25 23:14:25 -070011%:
12 dh $@ --buildsystem=cmake --parallel
Brenden Blanco9e5c3522015-08-26 00:13:23 -070013
Florian Schmidt6e632ad2017-03-06 17:30:55 +010014# tests cannot be run in parallel
15override_dh_auto_test:
16 dh_auto_test -O--buildsystem=cmake -O--no-parallel
17
Brenden Blanco7e00fc12015-10-12 11:13:48 -070018# FIXME: LLVM_DEFINITIONS is broken somehow in LLVM cmake upstream
Brenden Blanco9e5c3522015-08-26 00:13:23 -070019override_dh_auto_configure:
Brenden Blanco639498a2016-08-15 11:58:16 -070020 dh_auto_configure -- -DREVISION_LAST=$(UPSTREAM_VERSION) -DREVISION=$(UPSTREAM_VERSION) -DLLVM_DEFINITIONS="-D_GNU_SOURCE -D__STDC_CONSTANT_MACROS -D__STDC_FORMAT_MACROS -D__STDC_LIMIT_MACROS"