blob: 032485cd6c29b11449ffdeeea5a6911a6ebd699b [file] [log] [blame]
Heather Lee Wilsonbdd62c52013-12-28 15:12:39 -08001## This is a boilerplate file for Google opensource projects.
2## To make it useful, replace <<TEXT>> with actual text for your project.
3## Also, look at comments with "## double hashes" to see if any are worth
4## uncommenting or modifying.
5
6%define RELEASE 1
7%define rel %{?CUSTOM_RELEASE} %{!?CUSTOM_RELEASE:%RELEASE}
8%define prefix /usr
9
10Name: %NAME
11Summary: Lightweight C unit testing framework.
12Version: %VERSION
13Release: %rel
14Group: Development/Libraries
15URL: http://code.google.com/p/cmockery
16License: Apache
17Vendor: Google
18Packager: Google Inc. <opensource@google.com>
19Source: http://%{NAME}.googlecode.com/files/%{NAME}-%{VERSION}.tar.gz
20Distribution: Redhat 7 and above.
21Buildroot: %{_tmppath}/%{name}-root
22Prefix: %prefix
23
24%description
25The %name package contains a lightweight library to simplify and generalize the
26process of writing unit tests for C applications.
27
28%package devel
29Summary: Lightweight C unit testing framework.
30Group: Development/Libraries
31Requires: %{NAME} = %{VERSION}
32
33%description devel
34The %name package contains static and debug libraries and header files for the
35development of test applications using %name.
36
37%changelog
38 * Mon Aug 25 2008 <opensource@google.com>
39 - First draft
40
41%prep
42%setup
43
44%build
45./configure
46make prefix=%prefix
47
48%install
49rm -rf $RPM_BUILD_ROOT
50make prefix=$RPM_BUILD_ROOT%{prefix} install
51
52%clean
53rm -rf $RPM_BUILD_ROOT
54
55%files
56%defattr(-,root,root)
57
58## Mark all installed files within /usr/share/doc/{package name} as
59## documentation. This depends on the following two lines appearing in
60## Makefile.am:
61## docdir = $(prefix)/share/doc/$(PACKAGE)-$(VERSION)
62## dist_doc_DATA = AUTHORS COPYING ChangeLog INSTALL NEWS README
63%docdir %{prefix}/share/doc/%{NAME}-%{VERSION}
64%{prefix}/share/doc/%{NAME}-%{VERSION}/*
65
66%{prefix}/lib/libcmockery.so.0
67%{prefix}/lib/libcmockery.so.0.0.0
68
69
70%files devel
71%defattr(-,root,root)
72
73%{prefix}/include/google
74%{prefix}/lib/libcmockery.a
75%{prefix}/lib/libcmockery.la
76%{prefix}/lib/libcmockery.so