Brian Gaeke | 9f4b90d | 2004-02-10 03:57:51 +0000 | [diff] [blame] | 1 | Summary: Static and JIT research compiler infrastructure |
| 2 | Name: llvm |
Misha Brukman | 0e9dfcb | 2005-05-18 20:23:20 +0000 | [diff] [blame] | 3 | Version: 1.6cvs |
Brian Gaeke | 9f4b90d | 2004-02-10 03:57:51 +0000 | [diff] [blame] | 4 | Release: 0 |
| 5 | License: U of Illinois/NCSA Open Source License |
| 6 | Group: Development/Languages |
| 7 | Source0: llvm.tar.gz |
| 8 | URL: http://llvm.cs.uiuc.edu/releases/index.html |
| 9 | #BuildRequires: llvm-gcc |
| 10 | # (someday...) |
| 11 | BuildRoot: %{_tmppath}/%{name}-root |
| 12 | Requires: /sbin/ldconfig |
| 13 | |
| 14 | %description |
Reid Spencer | 0b2bc7e | 2005-05-14 05:52:07 +0000 | [diff] [blame] | 15 | LLVM is a compiler infrastructure designed for compile-time, link-time, runtime, |
Brian Gaeke | 9f4b90d | 2004-02-10 03:57:51 +0000 | [diff] [blame] | 16 | and "idle-time" optimization of programs from arbitrary programming languages. |
Misha Brukman | 0e9dfcb | 2005-05-18 20:23:20 +0000 | [diff] [blame] | 17 | LLVM is written in C++ and has been developed since 2000 at the University of |
| 18 | Illinois. It currently supports compilation of C and C++ programs, using |
| 19 | front-ends derived from GCC 3.4. The compiler infrastructure includes mirror |
| 20 | sets of programming tools as well as libraries with equivalent |
Reid Spencer | 0b2bc7e | 2005-05-14 05:52:07 +0000 | [diff] [blame] | 21 | functionality. |
Brian Gaeke | 9f4b90d | 2004-02-10 03:57:51 +0000 | [diff] [blame] | 22 | |
| 23 | %prep |
| 24 | %setup -q -n llvm |
| 25 | |
| 26 | %build |
| 27 | ./configure \ |
| 28 | --prefix=%{_prefix} \ |
| 29 | --bindir=%{_bindir} \ |
| 30 | --datadir=%{_datadir} \ |
| 31 | --includedir=%{_includedir} \ |
Reid Spencer | 2583f6b | 2006-04-07 16:07:37 +0000 | [diff] [blame] | 32 | --libdir=%{_libdir} \ |
| 33 | --enable-optimized \ |
| 34 | --enable-assertions \ |
Brian Gaeke | 9f4b90d | 2004-02-10 03:57:51 +0000 | [diff] [blame] | 35 | make |
| 36 | |
| 37 | %install |
| 38 | rm -rf %{buildroot} |
| 39 | make install DESTDIR=%{buildroot} |
| 40 | |
| 41 | %clean |
| 42 | rm -rf %{buildroot} |
| 43 | |
| 44 | %post -p /sbin/ldconfig |
| 45 | |
| 46 | %postun -p /sbin/ldconfig |
| 47 | |
| 48 | %files |
| 49 | %defattr(-, root, root) |
| 50 | %doc CREDITS.TXT LICENSE.TXT README.txt docs/*.{html,css,gif,jpg} docs/CommandGuide |
| 51 | %{_bindir}/* |
| 52 | %{_libdir}/*.o |
| 53 | %{_libdir}/*.a |
| 54 | %{_libdir}/*.so |
| 55 | %{_includedir}/llvm |
| 56 | |
| 57 | %changelog |
Reid Spencer | 2583f6b | 2006-04-07 16:07:37 +0000 | [diff] [blame] | 58 | * Fri Apr 07 2006 Reid Spencer |
| 59 | - Make the build be optimized+assertions |
Reid Spencer | 0b2bc7e | 2005-05-14 05:52:07 +0000 | [diff] [blame] | 60 | * Fri May 13 2005 Reid Spencer |
| 61 | - Minor adjustments for the 1.5 release |
Brian Gaeke | 9f4b90d | 2004-02-10 03:57:51 +0000 | [diff] [blame] | 62 | * Mon Feb 09 2003 Brian R. Gaeke |
| 63 | - Initial working version of RPM spec file. |
| 64 | |