blob: 38cde0d11846a1473cf1f921b8646c7451564a3e [file] [log] [blame]
Brian Gaeke9f4b90d2004-02-10 03:57:51 +00001Summary: Static and JIT research compiler infrastructure
2Name: llvm
John Criswell1ae40132004-08-16 15:17:40 +00003Version: 1.3
Brian Gaeke9f4b90d2004-02-10 03:57:51 +00004Release: 0
5License: U of Illinois/NCSA Open Source License
6Group: Development/Languages
7Source0: llvm.tar.gz
8URL: http://llvm.cs.uiuc.edu/releases/index.html
9#BuildRequires: llvm-gcc
10# (someday...)
11BuildRoot: %{_tmppath}/%{name}-root
12Requires: /sbin/ldconfig
13
14%description
15LLVM is a new infrastructure designed for compile-time, link-time, runtime,
16and "idle-time" optimization of programs from arbitrary programming languages.
17LLVM is written in C++ and has been developed since 2000 at the
18University of Illinois. It currently supports compilation of C and C++
19programs, using front-ends derived from GCC 3.4.
20
21%prep
22%setup -q -n llvm
23
24%build
25./configure \
26--prefix=%{_prefix} \
27--bindir=%{_bindir} \
28--datadir=%{_datadir} \
29--includedir=%{_includedir} \
30--libdir=%{_libdir}
31make
32
33%install
34rm -rf %{buildroot}
35make install DESTDIR=%{buildroot}
36
37%clean
38rm -rf %{buildroot}
39
40%post -p /sbin/ldconfig
41
42%postun -p /sbin/ldconfig
43
44%files
45%defattr(-, root, root)
46%doc CREDITS.TXT LICENSE.TXT README.txt docs/*.{html,css,gif,jpg} docs/CommandGuide
47%{_bindir}/*
48%{_libdir}/*.o
49%{_libdir}/*.a
50%{_libdir}/*.so
51%{_includedir}/llvm
52
53%changelog
54* Mon Feb 09 2003 Brian R. Gaeke
55- Initial working version of RPM spec file.
56