Brian Paul | 7b2c0f9 | 2000-06-09 00:22:02 +0000 | [diff] [blame] | 1 | Name |
| 2 | |
| 3 | MESA_set_3dfx_mode |
| 4 | |
| 5 | Name Strings |
| 6 | |
| 7 | GLX_MESA_set_3dfx_mode |
| 8 | |
| 9 | Contact |
| 10 | |
Brian Paul | d3b09fe | 2004-03-25 01:42:41 +0000 | [diff] [blame] | 11 | Brian Paul (brian.paul 'at' tungstengraphics.com) |
Brian Paul | 7b2c0f9 | 2000-06-09 00:22:02 +0000 | [diff] [blame] | 12 | |
| 13 | Status |
| 14 | |
| 15 | Shipping since Mesa 2.6 in February, 1998. |
| 16 | |
| 17 | Version |
| 18 | |
| 19 | Last Modified Date: 8 June 2000 |
| 20 | |
| 21 | Number |
| 22 | |
Brian Paul | dd18a4f | 2000-06-23 17:34:47 +0000 | [diff] [blame] | 23 | 218 |
Brian Paul | 7b2c0f9 | 2000-06-09 00:22:02 +0000 | [diff] [blame] | 24 | |
| 25 | Dependencies |
| 26 | |
| 27 | OpenGL 1.0 or later is required. |
| 28 | GLX 1.0 or later is required. |
| 29 | |
| 30 | Overview |
| 31 | |
| 32 | The Mesa Glide driver allows full-screen rendering or rendering into |
| 33 | an X window. The glXSet3DfxModeMESA() function allows an application |
| 34 | to switch between full-screen and windowed rendering. |
| 35 | |
| 36 | IP Status |
| 37 | |
| 38 | Open-source; freely implementable. |
| 39 | |
| 40 | Issues |
| 41 | |
| 42 | None. |
| 43 | |
| 44 | New Procedures and Functions |
| 45 | |
| 46 | GLboolean glXSet3DfxModeMESA( GLint mode ); |
| 47 | |
| 48 | New Tokens |
| 49 | |
Brian Paul | dd18a4f | 2000-06-23 17:34:47 +0000 | [diff] [blame] | 50 | GLX_3DFX_WINDOW_MODE_MESA 0x1 |
Brian Paul | 7b2c0f9 | 2000-06-09 00:22:02 +0000 | [diff] [blame] | 51 | GLX_3DFX_FULLSCREEN_MODE_MESA 0x2 |
| 52 | |
| 53 | Additions to Chapter 3 of the GLX 1.3 Specification (Functions and Errors) |
| 54 | |
| 55 | The Mesa Glide device driver allows either rendering in full-screen |
| 56 | mode or rendering into an X window. An application can switch between |
| 57 | full-screen and window rendering with the command: |
| 58 | |
Brian Paul | dd18a4f | 2000-06-23 17:34:47 +0000 | [diff] [blame] | 59 | GLboolean glXSet3DfxModeMESA( GLint mode ); |
Brian Paul | 7b2c0f9 | 2000-06-09 00:22:02 +0000 | [diff] [blame] | 60 | |
| 61 | <mode> may either be GLX_3DFX_WINDOW_MODE_MESA to indicate window |
| 62 | rendering or GLX_3DFX_FULLSCREEN_MODE_MESA to indicate full-screen mode. |
| 63 | |
| 64 | GL_TRUE is returned if <mode> is valid and the operation completed |
| 65 | normally. GL_FALSE is returned if <mode> is invalid or if the Glide |
| 66 | driver is not being used. |
| 67 | |
| 68 | Note that only one drawable and context can be created at any given |
| 69 | time with the Mesa Glide driver. |
| 70 | |
| 71 | GLX Protocol |
| 72 | |
| 73 | None since this is a client-side extension. |
| 74 | |
| 75 | Errors |
| 76 | |
| 77 | None. |
| 78 | |
| 79 | New State |
| 80 | |
| 81 | None. |
| 82 | |
| 83 | Revision History |
| 84 | |
| 85 | 8 June 2000 - initial specification |