Wichert Akkerman | d321ff9 | 2002-03-31 18:45:45 +0000 | [diff] [blame^] | 1 | #! /usr/bin/make -f |
| 2 | |
| 3 | # Debian package information |
| 4 | package = strace |
| 5 | |
| 6 | all build: Makefile |
| 7 | $(MAKE) $(MFLAGS) |
| 8 | touch stamp-build |
| 9 | |
| 10 | Makefile: |
| 11 | sh configure --prefix=/usr |
| 12 | clean: |
| 13 | -make -f Makefile.in distclean |
| 14 | rm -f stamp-build |
| 15 | rm -rf debian/tmp debian/substvars debian/files |
| 16 | |
| 17 | binary: binary-indep binary-arch |
| 18 | |
| 19 | binary-indep: |
| 20 | |
| 21 | binary-arch: checkroot |
| 22 | test -f stamp-build || make $(MFLAGS) -f debian/rules build |
| 23 | -rm -rf debian/tmp debian/files debian/substvars |
| 24 | |
| 25 | install -d -m 755 -o root -g root debian/tmp |
| 26 | # reset the mode to work around a bug in install |
| 27 | chown 755 debian/tmp |
| 28 | install -d -m 755 -o root -g root debian/tmp/DEBIAN |
| 29 | |
| 30 | # Install documentation |
| 31 | install -d -o root -g root -m 755 debian/tmp/usr/share/doc/$(package) |
| 32 | install -p -o root -g root -m 644 debian/changelog \ |
| 33 | debian/tmp/usr/share/doc/$(package)/changelog.Debian |
| 34 | install -p -o root -g root -m 644 TODO \ |
| 35 | debian/tmp/usr/share/doc/$(package)/TODO |
| 36 | install -p -o root -g root -m 644 NEWS \ |
| 37 | debian/tmp/usr/share/doc/$(package)/changelog |
| 38 | gzip -9 debian/tmp/usr/share/doc/$(package)/* |
| 39 | install -p -o root -g root -m 644 debian/copyright \ |
| 40 | debian/tmp/usr/share/doc/$(package)/copyright |
| 41 | |
| 42 | # Install strace |
| 43 | install -d -o root -g root -m 755 debian/tmp/usr/bin debian/tmp/usr/share/man/man1 |
| 44 | install -s -o root -g root -m 755 strace debian/tmp/usr/bin/strace |
| 45 | install -p -o root -g root -m 644 strace.1 debian/tmp/usr/share/man/man1/strace.1 |
| 46 | gzip -9 debian/tmp/usr/share/man/man1/strace.1 |
| 47 | |
| 48 | install -p -o root -g root -m 755 debian/prerm debian/tmp/DEBIAN/ |
| 49 | install -p -o root -g root -m 755 debian/postinst debian/tmp/DEBIAN/ |
| 50 | |
| 51 | dpkg-shlibdeps strace |
| 52 | dpkg-gencontrol -isp |
| 53 | dpkg --build debian/tmp .. |
| 54 | |
| 55 | checkroot: |
| 56 | test root = "`whoami`" |
| 57 | |