blob: 4f91a680f1efeae14d7fbc513c2a9c795d46c053 [file] [log] [blame]
Jean-Luc Brouilletc5184e22015-03-13 13:51:24 -07001#
2# Copyright (C) 2015 The Android Open Source Project
3#
4# Licensed under the Apache License, Version 2.0 (the "License");
5# you may not use this file except in compliance with the License.
6# You may obtain a copy of the License at
7#
8# http://www.apache.org/licenses/LICENSE-2.0
9#
10# Unless required by applicable law or agreed to in writing, software
11# distributed under the License is distributed on an "AS IS" BASIS,
12# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13# See the License for the specific language governing permissions and
14# limitations under the License.
15#
16
17header:
Jean-Luc Brouillet20b27d62015-04-03 14:39:53 -070018summary: Debugging Functions
Jean-Luc Brouilletc5184e22015-03-13 13:51:24 -070019description:
Jean-Luc Brouillet20b27d62015-04-03 14:39:53 -070020 The functions below are intended to be used during application developement.
21 They should not be used in shipping applications.
Jean-Luc Brouilletc5184e22015-03-13 13:51:24 -070022include:
23 #define RS_DEBUG(a) rsDebug(#a, a)
24 #define RS_DEBUG_MARKER rsDebug(__FILE__, __LINE__)
25end:
26
27function: rsDebug
28t: i32, u32, i64, u64, f64
29ret: void
30arg: const char* message
31arg: #1 a
Jean-Luc Brouillet20b27d62015-04-03 14:39:53 -070032summary: Log a message and values
Jean-Luc Brouilletc5184e22015-03-13 13:51:24 -070033description:
Jean-Luc Brouillet20b27d62015-04-03 14:39:53 -070034 This function prints a message to the standard log, followed by the provided values.
35
36 This function is intended for debugging only and should not be used in shipping
37 applications.
Jean-Luc Brouilletc5184e22015-03-13 13:51:24 -070038test: none
39end:
40
41function: rsDebug
42version: 17
43w: 2, 3, 4
44# TODO We're not doing it for f64?
45t: i32, u32, i64, u64
46ret: void
47arg: const char* message
48arg: #2#1 a
49test: none
50end:
51
52function: rsDebug
53w: 1, 2, 3, 4
54ret: void
55arg: const char* message
56arg: float#1 a
57test: none
58end:
59
60function: rsDebug
61version: 17
62w: 1, 2, 3, 4
63t: i8, u8, i16, u16
64ret: void
65arg: const char* message
66arg: #2#1 a
67test: none
68end:
69
70function: rsDebug
71ret: void
72arg: const char* message
73arg: float a
74arg: float b
75test: none
76end:
77
78function: rsDebug
79ret: void
80arg: const char* message
81arg: float a
82arg: float b
83arg: float c
84test: none
85end:
86
87function: rsDebug
88ret: void
89arg: const char* message
90arg: float a
91arg: float b
92arg: float c
93arg: float d
94test: none
95end:
96
97function: rsDebug
98ret: void
99arg: const char* message
100arg: long long a
101test: none
102end:
103
104function: rsDebug
105ret: void
106arg: const char* message
107arg: unsigned long long a
108test: none
109end:
110
111function: rsDebug
112ret: void
113arg: const char* message
114arg: const void* a
115test: none
116end:
117
118function: rsDebug
119ret: void
120arg: const char* message
121arg: const rs_matrix4x4* a
122test: none
123end:
124
125function: rsDebug
126ret: void
127arg: const char* message
128arg: const rs_matrix3x3* a
129test: none
130end:
131
132function: rsDebug
133ret: void
134arg: const char* message
135arg: const rs_matrix2x2* a
136test: none
137end:
138
139#define RS_DEBUG(a) rsDebug(#a, a)
140#define RS_DEBUG_MARKER rsDebug(__FILE__, __LINE__)