blob: 4867cadec9ec5da58cd9ed996fad15418a53fe0e [file] [log] [blame]
Jason Sams326e0dd2009-05-22 14:03:28 -07001
2
Jason Sams326e0dd2009-05-22 14:03:28 -07003ContextBindRootScript {
4 param RsScript sampler
5 }
6
Jason Samsccc010b2010-05-13 18:30:11 -07007ContextBindProgramStore {
8 param RsProgramStore pgm
Jason Sams326e0dd2009-05-22 14:03:28 -07009 }
10
11ContextBindProgramFragment {
12 param RsProgramFragment pgm
13 }
14
15ContextBindProgramVertex {
16 param RsProgramVertex pgm
17 }
18
Jason Sams5fd09d82009-09-23 13:57:02 -070019ContextBindProgramRaster {
20 param RsProgramRaster pgm
21 }
22
Jason Sams86f1b232009-09-24 17:38:20 -070023ContextPause {
24 }
25
26ContextResume {
27 }
28
Jason Sams458f2dc2009-11-03 13:58:36 -080029ContextSetSurface {
Jason Sams613cad12009-11-12 15:10:25 -080030 param uint32_t width
31 param uint32_t height
Mathias Agopianfa402862010-02-12 14:04:35 -080032 param android_native_window_t *sur
Jason Sams458f2dc2009-11-03 13:58:36 -080033 }
34
Jason Samsc21cf402009-11-17 17:26:46 -080035ContextDump {
36 param int32_t bits
37}
38
Jason Samsa2cf7552010-03-03 13:03:18 -080039ContextGetError {
40 param RsError *err
41 ret const char *
42 }
43
Jason Sams613cad12009-11-12 15:10:25 -080044ContextSetPriority {
Jason Sams15832442009-11-15 12:14:26 -080045 param int32_t priority
Jason Sams613cad12009-11-12 15:10:25 -080046 }
47
Jason Samsa0a1b6f2009-06-10 15:04:38 -070048AssignName {
49 param void *obj
50 param const char *name
Jason Samsa4a54e42009-06-10 18:39:40 -070051 param size_t len
Jason Samsa0a1b6f2009-06-10 15:04:38 -070052 }
Jason Sams326e0dd2009-05-22 14:03:28 -070053
Jason Sams707aaf32009-08-18 14:14:24 -070054ObjDestroy {
55 param void *obj
56 }
57
Jason Samsd01d9702009-12-23 14:35:29 -080058ElementCreate {
59 param RsDataType mType
60 param RsDataKind mKind
61 param bool mNormalized
62 param uint32_t mVectorSize
63 ret RsElement
Jason Sams326e0dd2009-05-22 14:03:28 -070064 }
65
Jason Samsd01d9702009-12-23 14:35:29 -080066ElementCreate2 {
67 param size_t count
68 param const RsElement * elements
69 param const char ** names
70 param const size_t * nameLengths
Jason Sams326e0dd2009-05-22 14:03:28 -070071 ret RsElement
72 }
73
Jason Sams326e0dd2009-05-22 14:03:28 -070074TypeBegin {
75 param RsElement type
76 }
77
78TypeAdd {
79 param RsDimension dim
80 param size_t value
81 }
82
83TypeCreate {
84 ret RsType
85 }
86
Jason Sams326e0dd2009-05-22 14:03:28 -070087AllocationCreateTyped {
88 param RsType type
89 ret RsAllocation
90 }
91
Jason Sams326e0dd2009-05-22 14:03:28 -070092AllocationCreateSized {
93 param RsElement e
94 param size_t count
95 ret RsAllocation
96 }
97
Jason Samsfa84da22010-03-01 15:31:04 -080098AllocationCreateBitmapRef {
99 param RsType type
100 param void * bmpPtr
101 param void * callbackData
102 param RsBitmapCallback_t callback
103 ret RsAllocation
104 }
105
Jason Sams6678e9b2009-05-27 14:45:32 -0700106AllocationCreateFromBitmap {
107 param uint32_t width
108 param uint32_t height
Jason Samsa57c0a72009-09-04 14:42:41 -0700109 param RsElement dstFmt
110 param RsElement srcFmt
Jason Sams6678e9b2009-05-27 14:45:32 -0700111 param bool genMips
112 param const void * data
113 ret RsAllocation
114 }
115
Jason Samsc9d43db2009-07-28 12:02:16 -0700116AllocationCreateFromBitmapBoxed {
117 param uint32_t width
118 param uint32_t height
Jason Samsa57c0a72009-09-04 14:42:41 -0700119 param RsElement dstFmt
120 param RsElement srcFmt
Jason Samsc9d43db2009-07-28 12:02:16 -0700121 param bool genMips
122 param const void * data
123 ret RsAllocation
124 }
125
Jason Sams6678e9b2009-05-27 14:45:32 -0700126
Jason Sams326e0dd2009-05-22 14:03:28 -0700127AllocationUploadToTexture {
128 param RsAllocation alloc
Jason Sams7fabe1a2010-02-23 17:44:28 -0800129 param bool genMipMaps
Jason Sams326e0dd2009-05-22 14:03:28 -0700130 param uint32_t baseMipLevel
131 }
132
133AllocationUploadToBufferObject {
134 param RsAllocation alloc
135 }
136
Jason Sams326e0dd2009-05-22 14:03:28 -0700137
138AllocationData {
139 param RsAllocation va
140 param const void * data
Jason Sams9397e302009-08-27 20:23:34 -0700141 param uint32_t bytes
142 handcodeApi
143 togglePlay
Jason Samsd34b7252009-08-04 16:58:20 -0700144 }
Jason Sams326e0dd2009-05-22 14:03:28 -0700145
146Allocation1DSubData {
147 param RsAllocation va
148 param uint32_t xoff
149 param uint32_t count
150 param const void *data
Jason Sams9397e302009-08-27 20:23:34 -0700151 param uint32_t bytes
152 handcodeApi
153 togglePlay
Jason Samsd34b7252009-08-04 16:58:20 -0700154 }
Jason Sams326e0dd2009-05-22 14:03:28 -0700155
156Allocation2DSubData {
157 param RsAllocation va
158 param uint32_t xoff
159 param uint32_t yoff
160 param uint32_t w
161 param uint32_t h
162 param const void *data
Jason Sams9397e302009-08-27 20:23:34 -0700163 param uint32_t bytes
Jason Sams326e0dd2009-05-22 14:03:28 -0700164 }
165
Jason Samse579df42009-08-10 14:55:26 -0700166AllocationRead {
167 param RsAllocation va
168 param void * data
169 }
Jason Sams326e0dd2009-05-22 14:03:28 -0700170
171Adapter1DCreate {
172 ret RsAdapter1D
173 }
174
175Adapter1DBindAllocation {
176 param RsAdapter1D adapt
177 param RsAllocation alloc
178 }
179
Jason Sams326e0dd2009-05-22 14:03:28 -0700180Adapter1DSetConstraint {
181 param RsAdapter1D adapter
182 param RsDimension dim
183 param uint32_t value
184 }
185
186Adapter1DData {
187 param RsAdapter1D adapter
188 param const void * data
Jason Samsd34b7252009-08-04 16:58:20 -0700189 }
Jason Sams326e0dd2009-05-22 14:03:28 -0700190
191Adapter1DSubData {
192 param RsAdapter1D adapter
193 param uint32_t xoff
194 param uint32_t count
195 param const void *data
Jason Samsd34b7252009-08-04 16:58:20 -0700196 }
Jason Sams326e0dd2009-05-22 14:03:28 -0700197
198Adapter2DCreate {
199 ret RsAdapter2D
200 }
201
202Adapter2DBindAllocation {
203 param RsAdapter2D adapt
204 param RsAllocation alloc
205 }
206
Jason Sams326e0dd2009-05-22 14:03:28 -0700207Adapter2DSetConstraint {
208 param RsAdapter2D adapter
209 param RsDimension dim
210 param uint32_t value
211 }
212
213Adapter2DData {
214 param RsAdapter2D adapter
215 param const void *data
Jason Samsd34b7252009-08-04 16:58:20 -0700216 }
Jason Sams326e0dd2009-05-22 14:03:28 -0700217
218Adapter2DSubData {
219 param RsAdapter2D adapter
220 param uint32_t xoff
221 param uint32_t yoff
222 param uint32_t w
223 param uint32_t h
224 param const void *data
225 }
226
227SamplerBegin {
228 }
229
230SamplerSet {
231 param RsSamplerParam p
232 param RsSamplerValue value
233 }
234
235SamplerCreate {
236 ret RsSampler
237 }
238
239
Jason Sams326e0dd2009-05-22 14:03:28 -0700240
241ScriptBindAllocation {
242 param RsScript vtm
243 param RsAllocation va
244 param uint32_t slot
245 }
246
247
248ScriptCBegin {
249 }
250
Jason Sams326e0dd2009-05-22 14:03:28 -0700251
Jason Samsd34b7252009-08-04 16:58:20 -0700252ScriptSetTimeZone {
253 param RsScript s
Romain Guy98e10fd2009-07-30 18:45:01 -0700254 param const char * timeZone
255 param uint32_t length
256 }
257
Jason Sams8c6bc692009-09-16 15:04:38 -0700258
259ScriptInvoke {
260 param RsScript s
261 param uint32_t slot
262 }
263
Jason Samsbe36bf32010-05-11 14:03:58 -0700264ScriptInvokeData {
265 param RsScript s
266 param uint32_t slot
267 param void * data
268 }
269
270ScriptInvokeV {
271 param RsScript s
272 param uint32_t slot
273 param const void * data
274 param uint32_t dataLen
275 handcodeApi
276 togglePlay
277 }
278
Jason Samsbe36bf32010-05-11 14:03:58 -0700279ScriptSetVarI {
280 param RsScript s
281 param uint32_t slot
282 param int value
283 }
284
285ScriptSetVarF {
286 param RsScript s
287 param uint32_t slot
288 param float value
289 }
290
291ScriptSetVarV {
292 param RsScript s
293 param uint32_t slot
294 param const void * data
295 param uint32_t dataLen
296 handcodeApi
297 togglePlay
298 }
Jason Samsfa517192009-08-13 12:59:04 -0700299
300
Jason Sams326e0dd2009-05-22 14:03:28 -0700301ScriptCSetScript {
Jack Palevich1ef8b802009-05-28 15:53:04 -0700302 param void * codePtr
Jason Sams326e0dd2009-05-22 14:03:28 -0700303 }
304
Jason Sams1f526332009-06-05 17:35:09 -0700305ScriptCSetText {
306 param const char * text
307 param uint32_t length
308 }
309
Jason Sams326e0dd2009-05-22 14:03:28 -0700310ScriptCCreate {
311 ret RsScript
312 }
313
314
Jason Samsccc010b2010-05-13 18:30:11 -0700315ProgramStoreBegin {
Jason Sams326e0dd2009-05-22 14:03:28 -0700316 param RsElement in
317 param RsElement out
318 }
319
Jason Samsccc010b2010-05-13 18:30:11 -0700320ProgramStoreColorMask {
Jason Sams326e0dd2009-05-22 14:03:28 -0700321 param bool r
322 param bool g
323 param bool b
324 param bool a
325 }
326
Jason Samsccc010b2010-05-13 18:30:11 -0700327ProgramStoreBlendFunc {
Jason Sams326e0dd2009-05-22 14:03:28 -0700328 param RsBlendSrcFunc srcFunc
329 param RsBlendDstFunc destFunc
330 }
331
Jason Samsccc010b2010-05-13 18:30:11 -0700332ProgramStoreDepthMask {
Jason Sams326e0dd2009-05-22 14:03:28 -0700333 param bool enable
334}
335
Jason Samsccc010b2010-05-13 18:30:11 -0700336ProgramStoreDither {
Jason Sams326e0dd2009-05-22 14:03:28 -0700337 param bool enable
338}
339
Jason Samsccc010b2010-05-13 18:30:11 -0700340ProgramStoreDepthFunc {
Jason Sams326e0dd2009-05-22 14:03:28 -0700341 param RsDepthFunc func
342}
343
Jason Samsccc010b2010-05-13 18:30:11 -0700344ProgramStoreCreate {
345 ret RsProgramStore
Jason Sams326e0dd2009-05-22 14:03:28 -0700346 }
347
Jason Sams5fd09d82009-09-23 13:57:02 -0700348ProgramRasterCreate {
349 param RsElement in
350 param RsElement out
351 param bool pointSmooth
352 param bool lineSmooth
353 param bool pointSprite
354 ret RsProgramRaster
355}
356
357ProgramRasterSetLineWidth {
358 param RsProgramRaster pr
359 param float lw
360}
361
362ProgramRasterSetPointSize{
363 param RsProgramRaster pr
364 param float ps
365}
Jason Sams326e0dd2009-05-22 14:03:28 -0700366
367
Jason Sams4815c0d2009-12-15 12:58:36 -0800368ProgramBindConstants {
369 param RsProgram vp
370 param uint32_t slot
371 param RsAllocation constants
372 }
373
Jason Sams326e0dd2009-05-22 14:03:28 -0700374
Jason Sams7dad9c32009-12-17 16:55:08 -0800375ProgramBindTexture {
Jason Sams326e0dd2009-05-22 14:03:28 -0700376 param RsProgramFragment pf
377 param uint32_t slot
378 param RsAllocation a
379 }
380
Jason Sams7dad9c32009-12-17 16:55:08 -0800381ProgramBindSampler {
Jason Sams326e0dd2009-05-22 14:03:28 -0700382 param RsProgramFragment pf
383 param uint32_t slot
384 param RsSampler s
385 }
386
Jason Sams326e0dd2009-05-22 14:03:28 -0700387ProgramFragmentCreate {
Jason Sams7dad9c32009-12-17 16:55:08 -0800388 param const uint32_t * params
389 param uint32_t paramLength
Jason Sams326e0dd2009-05-22 14:03:28 -0700390 ret RsProgramFragment
391 }
392
Jason Samsf2e4fa22009-12-15 13:27:04 -0800393ProgramFragmentCreate2 {
394 param const char * shaderText
395 param uint32_t shaderLength
396 param const uint32_t * params
397 param uint32_t paramLength
398 ret RsProgramFragment
399 }
400
Jason Sams326e0dd2009-05-22 14:03:28 -0700401ProgramVertexCreate {
Jason Sams4815c0d2009-12-15 12:58:36 -0800402 param bool texMat
Jason Sams326e0dd2009-05-22 14:03:28 -0700403 ret RsProgramVertex
404 }
405
Jason Sams4815c0d2009-12-15 12:58:36 -0800406ProgramVertexCreate2 {
407 param const char * shaderText
408 param uint32_t shaderLength
409 param const uint32_t * params
410 param uint32_t paramLength
Jason Samsf2e4fa22009-12-15 13:27:04 -0800411 ret RsProgramVertex
Jason Samsb5909ce2009-07-21 12:20:54 -0700412 }
413
Jason Sams62bc1db2009-06-22 15:49:21 -0700414LightBegin {
415 }
416
417LightSetLocal {
418 param bool isLocal
419 }
420
421LightSetMonochromatic {
422 param bool isMono
423 }
424
425LightCreate {
426 ret RsLight light
427 }
428
Jason Sams62bc1db2009-06-22 15:49:21 -0700429
430LightSetPosition {
431 param RsLight light
432 param float x
433 param float y
434 param float z
435 }
436
437LightSetColor {
438 param RsLight light
439 param float r
440 param float g
441 param float b
442 }
443
Alex Sakhartchoukb825f672010-06-04 10:06:50 -0700444FileA3DCreateFromAssetStream {
445 param const void * data
446 param size_t len
447 ret RsFile
448 }
449
Jason Samsa5597fc2009-07-08 18:01:53 -0700450FileOpen {
451 ret RsFile
452 param const char *name
453 param size_t len
454 }
455
Alex Sakhartchoukb825f672010-06-04 10:06:50 -0700456FileA3DGetNumIndexEntries {
457 param int32_t * numEntries
458 param RsFile file
459 }
460
461FileA3DGetIndexEntries {
462 param RsFileIndexEntry * fileEntries
463 param uint32_t numEntries
464 param RsFile fileA3D
465 }
466
467FileA3DGetEntryByIndex {
468 param uint32_t index
469 param RsFile file
470 ret RsObjectBase
471 }
Jason Samsa5597fc2009-07-08 18:01:53 -0700472
Jason Samse5ffb872009-08-09 17:01:55 -0700473SimpleMeshCreate {
474 ret RsSimpleMesh
475 param RsAllocation prim
476 param RsAllocation index
477 param RsAllocation *vtx
478 param uint32_t vtxCount
479 param uint32_t primType
480 }
481
Jason Samse5ffb872009-08-09 17:01:55 -0700482
483SimpleMeshBindIndex {
484 param RsSimpleMesh mesh
485 param RsAllocation idx
486 }
487
488SimpleMeshBindPrimitive {
489 param RsSimpleMesh mesh
490 param RsAllocation prim
491 }
492
493SimpleMeshBindVertex {
494 param RsSimpleMesh mesh
495 param RsAllocation vtx
496 param uint32_t slot
497 }
498
Jason Samsc1ed5892010-03-10 17:30:41 -0800499AnimationCreate {
500 param const float *inValues
501 param const float *outValues
502 param uint32_t valueCount
503 param RsAnimationInterpolation interp
504 param RsAnimationEdge pre
505 param RsAnimationEdge post
506 ret RsAnimation
507 }
508