blob: 5f76486c3aa355441de15660deba1c07b85eec55 [file] [log] [blame]
Jason Sams326e0dd2009-05-22 14:03:28 -07001
Jason Sams8c880902010-06-15 12:15:57 -07002ContextFinish {
3 handcodeApi
4 }
Jason Sams326e0dd2009-05-22 14:03:28 -07005
Jason Sams326e0dd2009-05-22 14:03:28 -07006ContextBindRootScript {
7 param RsScript sampler
8 }
9
Jason Samsccc010b2010-05-13 18:30:11 -070010ContextBindProgramStore {
11 param RsProgramStore pgm
Jason Sams326e0dd2009-05-22 14:03:28 -070012 }
13
14ContextBindProgramFragment {
15 param RsProgramFragment pgm
16 }
17
18ContextBindProgramVertex {
19 param RsProgramVertex pgm
20 }
21
Jason Sams5fd09d82009-09-23 13:57:02 -070022ContextBindProgramRaster {
23 param RsProgramRaster pgm
24 }
25
Jason Sams86f1b232009-09-24 17:38:20 -070026ContextPause {
27 }
28
29ContextResume {
30 }
31
Jason Sams458f2dc2009-11-03 13:58:36 -080032ContextSetSurface {
Jason Sams613cad12009-11-12 15:10:25 -080033 param uint32_t width
34 param uint32_t height
Mathias Agopianfa402862010-02-12 14:04:35 -080035 param android_native_window_t *sur
Jason Sams458f2dc2009-11-03 13:58:36 -080036 }
37
Jason Samsc21cf402009-11-17 17:26:46 -080038ContextDump {
39 param int32_t bits
40}
41
Jason Samsa2cf7552010-03-03 13:03:18 -080042ContextGetError {
43 param RsError *err
44 ret const char *
45 }
46
Jason Sams613cad12009-11-12 15:10:25 -080047ContextSetPriority {
Jason Sams15832442009-11-15 12:14:26 -080048 param int32_t priority
Jason Sams613cad12009-11-12 15:10:25 -080049 }
50
Jason Samsa0a1b6f2009-06-10 15:04:38 -070051AssignName {
52 param void *obj
53 param const char *name
Jason Samsa4a54e42009-06-10 18:39:40 -070054 param size_t len
Jason Samsa0a1b6f2009-06-10 15:04:38 -070055 }
Jason Sams326e0dd2009-05-22 14:03:28 -070056
Jason Sams707aaf32009-08-18 14:14:24 -070057ObjDestroy {
58 param void *obj
59 }
60
Jason Samsd01d9702009-12-23 14:35:29 -080061ElementCreate {
62 param RsDataType mType
63 param RsDataKind mKind
64 param bool mNormalized
65 param uint32_t mVectorSize
66 ret RsElement
Jason Sams326e0dd2009-05-22 14:03:28 -070067 }
68
Jason Samsd01d9702009-12-23 14:35:29 -080069ElementCreate2 {
70 param size_t count
71 param const RsElement * elements
72 param const char ** names
73 param const size_t * nameLengths
Jason Sams326e0dd2009-05-22 14:03:28 -070074 ret RsElement
75 }
76
Jason Sams326e0dd2009-05-22 14:03:28 -070077TypeBegin {
78 param RsElement type
79 }
80
81TypeAdd {
82 param RsDimension dim
83 param size_t value
84 }
85
86TypeCreate {
87 ret RsType
88 }
89
Jason Sams326e0dd2009-05-22 14:03:28 -070090AllocationCreateTyped {
91 param RsType type
92 ret RsAllocation
93 }
94
Jason Sams326e0dd2009-05-22 14:03:28 -070095AllocationCreateSized {
96 param RsElement e
97 param size_t count
98 ret RsAllocation
99 }
100
Jason Samsfa84da22010-03-01 15:31:04 -0800101AllocationCreateBitmapRef {
102 param RsType type
103 param void * bmpPtr
104 param void * callbackData
105 param RsBitmapCallback_t callback
106 ret RsAllocation
107 }
108
Jason Sams6678e9b2009-05-27 14:45:32 -0700109AllocationCreateFromBitmap {
110 param uint32_t width
111 param uint32_t height
Jason Samsa57c0a72009-09-04 14:42:41 -0700112 param RsElement dstFmt
113 param RsElement srcFmt
Jason Sams6678e9b2009-05-27 14:45:32 -0700114 param bool genMips
115 param const void * data
116 ret RsAllocation
117 }
118
Jason Samsc9d43db2009-07-28 12:02:16 -0700119AllocationCreateFromBitmapBoxed {
120 param uint32_t width
121 param uint32_t height
Jason Samsa57c0a72009-09-04 14:42:41 -0700122 param RsElement dstFmt
123 param RsElement srcFmt
Jason Samsc9d43db2009-07-28 12:02:16 -0700124 param bool genMips
125 param const void * data
126 ret RsAllocation
127 }
128
Jason Sams6678e9b2009-05-27 14:45:32 -0700129
Jason Sams326e0dd2009-05-22 14:03:28 -0700130AllocationUploadToTexture {
131 param RsAllocation alloc
Jason Sams7fabe1a2010-02-23 17:44:28 -0800132 param bool genMipMaps
Jason Sams326e0dd2009-05-22 14:03:28 -0700133 param uint32_t baseMipLevel
134 }
135
136AllocationUploadToBufferObject {
137 param RsAllocation alloc
138 }
139
Jason Sams326e0dd2009-05-22 14:03:28 -0700140
141AllocationData {
142 param RsAllocation va
143 param const void * data
Jason Sams9397e302009-08-27 20:23:34 -0700144 param uint32_t bytes
145 handcodeApi
146 togglePlay
Jason Samsd34b7252009-08-04 16:58:20 -0700147 }
Jason Sams326e0dd2009-05-22 14:03:28 -0700148
149Allocation1DSubData {
150 param RsAllocation va
151 param uint32_t xoff
152 param uint32_t count
153 param const void *data
Jason Sams9397e302009-08-27 20:23:34 -0700154 param uint32_t bytes
155 handcodeApi
156 togglePlay
Jason Samsd34b7252009-08-04 16:58:20 -0700157 }
Jason Sams326e0dd2009-05-22 14:03:28 -0700158
159Allocation2DSubData {
160 param RsAllocation va
161 param uint32_t xoff
162 param uint32_t yoff
163 param uint32_t w
164 param uint32_t h
165 param const void *data
Jason Sams9397e302009-08-27 20:23:34 -0700166 param uint32_t bytes
Jason Sams326e0dd2009-05-22 14:03:28 -0700167 }
168
Jason Samse579df42009-08-10 14:55:26 -0700169AllocationRead {
170 param RsAllocation va
171 param void * data
172 }
Jason Sams326e0dd2009-05-22 14:03:28 -0700173
174Adapter1DCreate {
175 ret RsAdapter1D
176 }
177
178Adapter1DBindAllocation {
179 param RsAdapter1D adapt
180 param RsAllocation alloc
181 }
182
Jason Sams326e0dd2009-05-22 14:03:28 -0700183Adapter1DSetConstraint {
184 param RsAdapter1D adapter
185 param RsDimension dim
186 param uint32_t value
187 }
188
189Adapter1DData {
190 param RsAdapter1D adapter
191 param const void * data
Jason Samsd34b7252009-08-04 16:58:20 -0700192 }
Jason Sams326e0dd2009-05-22 14:03:28 -0700193
194Adapter1DSubData {
195 param RsAdapter1D adapter
196 param uint32_t xoff
197 param uint32_t count
198 param const void *data
Jason Samsd34b7252009-08-04 16:58:20 -0700199 }
Jason Sams326e0dd2009-05-22 14:03:28 -0700200
201Adapter2DCreate {
202 ret RsAdapter2D
203 }
204
205Adapter2DBindAllocation {
206 param RsAdapter2D adapt
207 param RsAllocation alloc
208 }
209
Jason Sams326e0dd2009-05-22 14:03:28 -0700210Adapter2DSetConstraint {
211 param RsAdapter2D adapter
212 param RsDimension dim
213 param uint32_t value
214 }
215
216Adapter2DData {
217 param RsAdapter2D adapter
218 param const void *data
Jason Samsd34b7252009-08-04 16:58:20 -0700219 }
Jason Sams326e0dd2009-05-22 14:03:28 -0700220
221Adapter2DSubData {
222 param RsAdapter2D adapter
223 param uint32_t xoff
224 param uint32_t yoff
225 param uint32_t w
226 param uint32_t h
227 param const void *data
228 }
229
230SamplerBegin {
231 }
232
233SamplerSet {
234 param RsSamplerParam p
235 param RsSamplerValue value
236 }
237
238SamplerCreate {
239 ret RsSampler
240 }
241
242
Jason Sams326e0dd2009-05-22 14:03:28 -0700243
244ScriptBindAllocation {
245 param RsScript vtm
246 param RsAllocation va
247 param uint32_t slot
248 }
249
250
251ScriptCBegin {
252 }
253
Jason Sams326e0dd2009-05-22 14:03:28 -0700254
Jason Samsd34b7252009-08-04 16:58:20 -0700255ScriptSetTimeZone {
256 param RsScript s
Romain Guy98e10fd2009-07-30 18:45:01 -0700257 param const char * timeZone
258 param uint32_t length
259 }
260
Jason Sams8c6bc692009-09-16 15:04:38 -0700261
262ScriptInvoke {
263 param RsScript s
264 param uint32_t slot
265 }
266
Jason Samsbe36bf32010-05-11 14:03:58 -0700267ScriptInvokeV {
268 param RsScript s
269 param uint32_t slot
270 param const void * data
271 param uint32_t dataLen
272 handcodeApi
273 togglePlay
274 }
275
Jason Samsbe36bf32010-05-11 14:03:58 -0700276ScriptSetVarI {
277 param RsScript s
278 param uint32_t slot
279 param int value
280 }
281
282ScriptSetVarF {
283 param RsScript s
284 param uint32_t slot
285 param float value
286 }
287
288ScriptSetVarV {
289 param RsScript s
290 param uint32_t slot
291 param const void * data
292 param uint32_t dataLen
293 handcodeApi
294 togglePlay
295 }
Jason Samsfa517192009-08-13 12:59:04 -0700296
297
Jason Sams326e0dd2009-05-22 14:03:28 -0700298ScriptCSetScript {
Jack Palevich1ef8b802009-05-28 15:53:04 -0700299 param void * codePtr
Jason Sams326e0dd2009-05-22 14:03:28 -0700300 }
301
Jason Sams1f526332009-06-05 17:35:09 -0700302ScriptCSetText {
303 param const char * text
304 param uint32_t length
305 }
306
Jason Sams326e0dd2009-05-22 14:03:28 -0700307ScriptCCreate {
308 ret RsScript
309 }
310
311
Jason Samsccc010b2010-05-13 18:30:11 -0700312ProgramStoreBegin {
Jason Sams326e0dd2009-05-22 14:03:28 -0700313 param RsElement in
314 param RsElement out
315 }
316
Jason Samsccc010b2010-05-13 18:30:11 -0700317ProgramStoreColorMask {
Jason Sams326e0dd2009-05-22 14:03:28 -0700318 param bool r
319 param bool g
320 param bool b
321 param bool a
322 }
323
Jason Samsccc010b2010-05-13 18:30:11 -0700324ProgramStoreBlendFunc {
Jason Sams326e0dd2009-05-22 14:03:28 -0700325 param RsBlendSrcFunc srcFunc
326 param RsBlendDstFunc destFunc
327 }
328
Jason Samsccc010b2010-05-13 18:30:11 -0700329ProgramStoreDepthMask {
Jason Sams326e0dd2009-05-22 14:03:28 -0700330 param bool enable
331}
332
Jason Samsccc010b2010-05-13 18:30:11 -0700333ProgramStoreDither {
Jason Sams326e0dd2009-05-22 14:03:28 -0700334 param bool enable
335}
336
Jason Samsccc010b2010-05-13 18:30:11 -0700337ProgramStoreDepthFunc {
Jason Sams326e0dd2009-05-22 14:03:28 -0700338 param RsDepthFunc func
339}
340
Jason Samsccc010b2010-05-13 18:30:11 -0700341ProgramStoreCreate {
342 ret RsProgramStore
Jason Sams326e0dd2009-05-22 14:03:28 -0700343 }
344
Jason Sams5fd09d82009-09-23 13:57:02 -0700345ProgramRasterCreate {
346 param RsElement in
347 param RsElement out
348 param bool pointSmooth
349 param bool lineSmooth
350 param bool pointSprite
351 ret RsProgramRaster
352}
353
354ProgramRasterSetLineWidth {
355 param RsProgramRaster pr
356 param float lw
357}
358
359ProgramRasterSetPointSize{
360 param RsProgramRaster pr
361 param float ps
362}
Jason Sams326e0dd2009-05-22 14:03:28 -0700363
364
Jason Sams4815c0d2009-12-15 12:58:36 -0800365ProgramBindConstants {
366 param RsProgram vp
367 param uint32_t slot
368 param RsAllocation constants
369 }
370
Jason Sams326e0dd2009-05-22 14:03:28 -0700371
Jason Sams7dad9c32009-12-17 16:55:08 -0800372ProgramBindTexture {
Jason Sams326e0dd2009-05-22 14:03:28 -0700373 param RsProgramFragment pf
374 param uint32_t slot
375 param RsAllocation a
376 }
377
Jason Sams7dad9c32009-12-17 16:55:08 -0800378ProgramBindSampler {
Jason Sams326e0dd2009-05-22 14:03:28 -0700379 param RsProgramFragment pf
380 param uint32_t slot
381 param RsSampler s
382 }
383
Jason Sams326e0dd2009-05-22 14:03:28 -0700384ProgramFragmentCreate {
Jason Sams7dad9c32009-12-17 16:55:08 -0800385 param const uint32_t * params
386 param uint32_t paramLength
Jason Sams326e0dd2009-05-22 14:03:28 -0700387 ret RsProgramFragment
388 }
389
Jason Samsf2e4fa22009-12-15 13:27:04 -0800390ProgramFragmentCreate2 {
391 param const char * shaderText
392 param uint32_t shaderLength
393 param const uint32_t * params
394 param uint32_t paramLength
395 ret RsProgramFragment
396 }
397
Jason Sams326e0dd2009-05-22 14:03:28 -0700398ProgramVertexCreate {
Jason Sams4815c0d2009-12-15 12:58:36 -0800399 param bool texMat
Jason Sams326e0dd2009-05-22 14:03:28 -0700400 ret RsProgramVertex
401 }
402
Jason Sams4815c0d2009-12-15 12:58:36 -0800403ProgramVertexCreate2 {
404 param const char * shaderText
405 param uint32_t shaderLength
406 param const uint32_t * params
407 param uint32_t paramLength
Jason Samsf2e4fa22009-12-15 13:27:04 -0800408 ret RsProgramVertex
Jason Samsb5909ce2009-07-21 12:20:54 -0700409 }
410
Jason Sams62bc1db2009-06-22 15:49:21 -0700411LightBegin {
412 }
413
414LightSetLocal {
415 param bool isLocal
416 }
417
418LightSetMonochromatic {
419 param bool isMono
420 }
421
422LightCreate {
423 ret RsLight light
424 }
425
Jason Sams62bc1db2009-06-22 15:49:21 -0700426
427LightSetPosition {
428 param RsLight light
429 param float x
430 param float y
431 param float z
432 }
433
434LightSetColor {
435 param RsLight light
436 param float r
437 param float g
438 param float b
439 }
440
Alex Sakhartchoukb825f672010-06-04 10:06:50 -0700441FileA3DCreateFromAssetStream {
442 param const void * data
443 param size_t len
444 ret RsFile
445 }
446
Jason Samsa5597fc2009-07-08 18:01:53 -0700447FileOpen {
448 ret RsFile
449 param const char *name
450 param size_t len
451 }
452
Alex Sakhartchoukb825f672010-06-04 10:06:50 -0700453FileA3DGetNumIndexEntries {
454 param int32_t * numEntries
455 param RsFile file
456 }
457
458FileA3DGetIndexEntries {
459 param RsFileIndexEntry * fileEntries
460 param uint32_t numEntries
461 param RsFile fileA3D
462 }
463
464FileA3DGetEntryByIndex {
465 param uint32_t index
466 param RsFile file
467 ret RsObjectBase
468 }
Jason Samsa5597fc2009-07-08 18:01:53 -0700469
Jason Samse5ffb872009-08-09 17:01:55 -0700470SimpleMeshCreate {
471 ret RsSimpleMesh
472 param RsAllocation prim
473 param RsAllocation index
474 param RsAllocation *vtx
475 param uint32_t vtxCount
476 param uint32_t primType
477 }
478
Jason Samse5ffb872009-08-09 17:01:55 -0700479
480SimpleMeshBindIndex {
481 param RsSimpleMesh mesh
482 param RsAllocation idx
483 }
484
485SimpleMeshBindPrimitive {
486 param RsSimpleMesh mesh
487 param RsAllocation prim
488 }
489
490SimpleMeshBindVertex {
491 param RsSimpleMesh mesh
492 param RsAllocation vtx
493 param uint32_t slot
494 }
495
Jason Samsc1ed5892010-03-10 17:30:41 -0800496AnimationCreate {
497 param const float *inValues
498 param const float *outValues
499 param uint32_t valueCount
500 param RsAnimationInterpolation interp
501 param RsAnimationEdge pre
502 param RsAnimationEdge post
503 ret RsAnimation
504 }
505