blob: 6310cf6b36ab7ba510abb848e2cc1b9bd9d29bac [file] [log] [blame]
Jason Sams326e0dd2009-05-22 14:03:28 -07001
Jason Sams186e5912011-04-26 14:50:00 -07002DeviceCreate {
3 direct
4 nocontext
5 ret RsDevice
6}
7
8DeviceDestroy {
9 direct
10 nocontext
11 param RsDevice dev
12}
13
14DeviceSetConfig {
15 direct
16 nocontext
17 param RsDevice dev
18 param RsDeviceParam p
19 param int32_t value
20}
21
22ContextCreate {
23 direct
24 nocontext
25 param RsDevice dev
26 param uint32_t version
27 ret RsContext
28}
29
30ContextCreateGL {
31 direct
32 nocontext
33 param RsDevice dev
34 param uint32_t version
35 param RsSurfaceConfig sc
36 param uint32_t dpi
37 ret RsContext
38}
39
40ContextDestroy {
41 direct
42}
43
44ContextGetMessage {
45 direct
46 param void *data
47 param size_t *receiveLen
48 param uint32_t *subID
49 param bool wait
50 ret RsMessageToClientType
51}
52
53ContextPeekMessage {
54 direct
55 param size_t *receiveLen
56 param uint32_t *subID
57 param bool wait
58 ret RsMessageToClientType
59}
60
61ContextInitToClient {
62 direct
63}
64
65ContextDeinitToClient {
66 direct
67}
68
69aTypeCreate {
70 direct
71 param RsElement e
72 param uint32_t dimX
73 param uint32_t dimY
74 param uint32_t dimZ
75 param bool mips
76 param bool faces
77 ret RsType
78}
79
80aAllocationCreateTyped {
81 direct
82 param RsType vtype
83 param RsAllocationMipmapControl mips
84 param uint32_t usages
85 ret RsAllocation
86}
87
88aAllocationCreateFromBitmap {
89 direct
90 param RsType vtype
91 param RsAllocationMipmapControl mips
92 param const void *data
93 param uint32_t usages
94 ret RsAllocation
95}
96
97aAllocationCubeCreateFromBitmap {
98 direct
99 param RsType vtype
100 param RsAllocationMipmapControl mips
101 param const void *data
102 param uint32_t usages
103 ret RsAllocation
104}
105
106
107
Jason Sams8c880902010-06-15 12:15:57 -0700108ContextFinish {
109 handcodeApi
110 }
Jason Sams326e0dd2009-05-22 14:03:28 -0700111
Jason Sams326e0dd2009-05-22 14:03:28 -0700112ContextBindRootScript {
113 param RsScript sampler
114 }
115
Jason Samsccc010b2010-05-13 18:30:11 -0700116ContextBindProgramStore {
117 param RsProgramStore pgm
Jason Sams326e0dd2009-05-22 14:03:28 -0700118 }
119
120ContextBindProgramFragment {
121 param RsProgramFragment pgm
122 }
123
124ContextBindProgramVertex {
125 param RsProgramVertex pgm
126 }
127
Jason Sams5fd09d82009-09-23 13:57:02 -0700128ContextBindProgramRaster {
129 param RsProgramRaster pgm
130 }
131
Alex Sakhartchoukd3e0ad42010-06-24 17:15:34 -0700132ContextBindFont {
133 param RsFont pgm
134 }
135
Jason Sams86f1b232009-09-24 17:38:20 -0700136ContextPause {
137 }
138
139ContextResume {
140 }
141
Jason Sams458f2dc2009-11-03 13:58:36 -0800142ContextSetSurface {
Jason Sams613cad12009-11-12 15:10:25 -0800143 param uint32_t width
144 param uint32_t height
Dianne Hackborn1c769c32010-06-30 13:56:17 -0700145 param ANativeWindow *sur
Jason Sams458f2dc2009-11-03 13:58:36 -0800146 }
147
Jason Samsc21cf402009-11-17 17:26:46 -0800148ContextDump {
149 param int32_t bits
150}
151
Jason Sams613cad12009-11-12 15:10:25 -0800152ContextSetPriority {
Jason Sams15832442009-11-15 12:14:26 -0800153 param int32_t priority
Jason Sams613cad12009-11-12 15:10:25 -0800154 }
155
Jason Sams741aac92010-12-24 14:38:39 -0800156ContextDestroyWorker {
Jason Sams1dcefab2010-12-09 12:19:46 -0800157}
158
Jason Samsa0a1b6f2009-06-10 15:04:38 -0700159AssignName {
Alex Sakhartchouk70b83c12011-04-06 10:57:51 -0700160 param RsObjectBase obj
Jason Samsa0a1b6f2009-06-10 15:04:38 -0700161 param const char *name
162 }
Jason Sams326e0dd2009-05-22 14:03:28 -0700163
Jason Sams707aaf32009-08-18 14:14:24 -0700164ObjDestroy {
Jason Sams2353ae32010-10-14 17:48:46 -0700165 param RsAsyncVoidPtr objPtr
Jason Sams707aaf32009-08-18 14:14:24 -0700166 }
167
Jason Samsd01d9702009-12-23 14:35:29 -0800168ElementCreate {
169 param RsDataType mType
170 param RsDataKind mKind
171 param bool mNormalized
172 param uint32_t mVectorSize
173 ret RsElement
Jason Sams326e0dd2009-05-22 14:03:28 -0700174 }
175
Jason Samsd01d9702009-12-23 14:35:29 -0800176ElementCreate2 {
Jason Samsd01d9702009-12-23 14:35:29 -0800177 param const RsElement * elements
178 param const char ** names
179 param const size_t * nameLengths
Jason Sams46e45542010-09-02 17:35:23 -0700180 param const uint32_t * arraySize
Jason Sams326e0dd2009-05-22 14:03:28 -0700181 ret RsElement
182 }
183
Jason Sams837e3882010-12-10 16:03:15 -0800184AllocationCopyToBitmap {
185 param RsAllocation alloc
186 param void * data
Alex Sakhartchouk39f2ef62010-10-11 12:35:15 -0700187 }
188
Jason Sams326e0dd2009-05-22 14:03:28 -0700189
Jason Sams4b45b892010-12-29 14:31:29 -0800190Allocation1DData {
Jason Sams326e0dd2009-05-22 14:03:28 -0700191 param RsAllocation va
192 param uint32_t xoff
Jason Sams4b45b892010-12-29 14:31:29 -0800193 param uint32_t lod
Jason Sams326e0dd2009-05-22 14:03:28 -0700194 param uint32_t count
195 param const void *data
Jason Samsd34b7252009-08-04 16:58:20 -0700196 }
Jason Sams326e0dd2009-05-22 14:03:28 -0700197
Jason Sams4b45b892010-12-29 14:31:29 -0800198Allocation1DElementData {
Jason Sams5f0c84c2010-08-31 13:50:42 -0700199 param RsAllocation va
200 param uint32_t x
Jason Sams4b45b892010-12-29 14:31:29 -0800201 param uint32_t lod
Jason Sams5f0c84c2010-08-31 13:50:42 -0700202 param const void *data
203 param uint32_t comp_offset
Jason Sams5f0c84c2010-08-31 13:50:42 -0700204 }
205
Jason Sams4b45b892010-12-29 14:31:29 -0800206Allocation2DData {
Jason Sams326e0dd2009-05-22 14:03:28 -0700207 param RsAllocation va
208 param uint32_t xoff
209 param uint32_t yoff
Jason Sams4b45b892010-12-29 14:31:29 -0800210 param uint32_t lod
211 param RsAllocationCubemapFace face
Jason Sams326e0dd2009-05-22 14:03:28 -0700212 param uint32_t w
213 param uint32_t h
214 param const void *data
215 }
216
Jason Sams4b45b892010-12-29 14:31:29 -0800217Allocation2DElementData {
Jason Sams5f0c84c2010-08-31 13:50:42 -0700218 param RsAllocation va
219 param uint32_t x
220 param uint32_t y
Jason Sams4b45b892010-12-29 14:31:29 -0800221 param uint32_t lod
222 param RsAllocationCubemapFace face
Jason Sams5f0c84c2010-08-31 13:50:42 -0700223 param const void *data
224 param uint32_t element_offset
Jason Sams5f0c84c2010-08-31 13:50:42 -0700225 }
226
Jason Samsa2371512011-01-12 13:28:37 -0800227AllocationGenerateMipmaps {
228 param RsAllocation va
229}
230
Jason Samse579df42009-08-10 14:55:26 -0700231AllocationRead {
232 param RsAllocation va
233 param void * data
234 }
Jason Sams326e0dd2009-05-22 14:03:28 -0700235
Jason Sams366c9c82010-12-08 16:14:36 -0800236AllocationSyncAll {
237 param RsAllocation va
238 param RsAllocationUsageType src
239}
240
Jason Sams326e0dd2009-05-22 14:03:28 -0700241
Jason Sams96abf812010-10-05 13:32:49 -0700242AllocationResize1D {
243 param RsAllocation va
244 param uint32_t dimX
245 }
246
247AllocationResize2D {
248 param RsAllocation va
249 param uint32_t dimX
250 param uint32_t dimY
251 }
252
Jason Sams326e0dd2009-05-22 14:03:28 -0700253SamplerBegin {
254 }
255
256SamplerSet {
257 param RsSamplerParam p
258 param RsSamplerValue value
259 }
260
Alex Sakhartchouk1103d8e2010-09-30 11:36:37 -0700261SamplerSet2 {
262 param RsSamplerParam p
263 param float value
264 }
265
Jason Sams326e0dd2009-05-22 14:03:28 -0700266SamplerCreate {
267 ret RsSampler
268 }
269
270
Jason Sams326e0dd2009-05-22 14:03:28 -0700271
272ScriptBindAllocation {
273 param RsScript vtm
274 param RsAllocation va
275 param uint32_t slot
276 }
277
278
Jason Samsd34b7252009-08-04 16:58:20 -0700279ScriptSetTimeZone {
280 param RsScript s
Romain Guy98e10fd2009-07-30 18:45:01 -0700281 param const char * timeZone
Romain Guy98e10fd2009-07-30 18:45:01 -0700282 }
283
Jason Sams8c6bc692009-09-16 15:04:38 -0700284
285ScriptInvoke {
286 param RsScript s
287 param uint32_t slot
288 }
289
Jason Samsbe36bf32010-05-11 14:03:58 -0700290ScriptInvokeV {
291 param RsScript s
292 param uint32_t slot
293 param const void * data
Jason Samsbe36bf32010-05-11 14:03:58 -0700294 }
295
Jason Sams5fb1aeb2011-04-27 15:12:49 -0700296ScriptForEach {
297 param RsScript s
298 param uint32_t slot
299 param RsAllocation ain
300 param RsAllocation aout
301 param const void * usr
302}
303
Jason Samsbe36bf32010-05-11 14:03:58 -0700304ScriptSetVarI {
305 param RsScript s
306 param uint32_t slot
307 param int value
308 }
309
Jason Samsa5eb6e12010-11-16 17:37:02 -0800310ScriptSetVarObj {
311 param RsScript s
312 param uint32_t slot
313 param RsObjectBase value
314 }
315
Stephen Hines0977c942010-10-11 10:54:21 -0700316ScriptSetVarJ {
317 param RsScript s
318 param uint32_t slot
319 param int64_t value
320 }
321
Jason Samsbe36bf32010-05-11 14:03:58 -0700322ScriptSetVarF {
323 param RsScript s
324 param uint32_t slot
325 param float value
326 }
327
Stephen Hines6d0a0742010-09-20 17:20:30 -0700328ScriptSetVarD {
329 param RsScript s
330 param uint32_t slot
331 param double value
332 }
333
Jason Samsbe36bf32010-05-11 14:03:58 -0700334ScriptSetVarV {
335 param RsScript s
336 param uint32_t slot
337 param const void * data
Jason Samsbe36bf32010-05-11 14:03:58 -0700338 }
Jason Samsfa517192009-08-13 12:59:04 -0700339
340
Jason Sams326e0dd2009-05-22 14:03:28 -0700341ScriptCCreate {
Shih-wei Liao9503b662010-11-08 01:33:59 -0800342 param const char * resName
Shih-wei Liao15849d92010-12-10 01:03:59 -0800343 param const char * cacheDir
Jason Samsbad80742011-03-16 16:29:28 -0700344 param const char * text
Jason Sams326e0dd2009-05-22 14:03:28 -0700345 ret RsScript
346 }
347
348
Jason Sams721acc42011-04-06 11:23:54 -0700349ProgramStoreCreate {
350 param bool colorMaskR
351 param bool colorMaskG
352 param bool colorMaskB
353 param bool colorMaskA
354 param bool depthMask
355 param bool ditherEnable
Jason Sams326e0dd2009-05-22 14:03:28 -0700356 param RsBlendSrcFunc srcFunc
357 param RsBlendDstFunc destFunc
Jason Sams721acc42011-04-06 11:23:54 -0700358 param RsDepthFunc depthFunc
Jason Samsccc010b2010-05-13 18:30:11 -0700359 ret RsProgramStore
Jason Sams326e0dd2009-05-22 14:03:28 -0700360 }
361
Jason Sams5fd09d82009-09-23 13:57:02 -0700362ProgramRasterCreate {
Jason Sams5fd09d82009-09-23 13:57:02 -0700363 param bool pointSmooth
364 param bool lineSmooth
365 param bool pointSprite
Jason Sams721acc42011-04-06 11:23:54 -0700366 param float lineWidth
367 param RsCullMode cull
Jason Sams5fd09d82009-09-23 13:57:02 -0700368 ret RsProgramRaster
369}
370
Jason Sams4815c0d2009-12-15 12:58:36 -0800371ProgramBindConstants {
372 param RsProgram vp
373 param uint32_t slot
374 param RsAllocation constants
375 }
376
Jason Sams326e0dd2009-05-22 14:03:28 -0700377
Jason Sams7dad9c32009-12-17 16:55:08 -0800378ProgramBindTexture {
Jason Sams326e0dd2009-05-22 14:03:28 -0700379 param RsProgramFragment pf
380 param uint32_t slot
381 param RsAllocation a
382 }
383
Jason Sams7dad9c32009-12-17 16:55:08 -0800384ProgramBindSampler {
Jason Sams326e0dd2009-05-22 14:03:28 -0700385 param RsProgramFragment pf
386 param uint32_t slot
387 param RsSampler s
388 }
389
Jason Sams326e0dd2009-05-22 14:03:28 -0700390ProgramFragmentCreate {
Jason Samsf2e4fa22009-12-15 13:27:04 -0800391 param const char * shaderText
Jason Samsf2e4fa22009-12-15 13:27:04 -0800392 param const uint32_t * params
Jason Samsf2e4fa22009-12-15 13:27:04 -0800393 ret RsProgramFragment
394 }
395
Jason Sams326e0dd2009-05-22 14:03:28 -0700396ProgramVertexCreate {
Jason Sams4815c0d2009-12-15 12:58:36 -0800397 param const char * shaderText
Jason Sams4815c0d2009-12-15 12:58:36 -0800398 param const uint32_t * params
Jason Samsf2e4fa22009-12-15 13:27:04 -0800399 ret RsProgramVertex
Jason Samsb5909ce2009-07-21 12:20:54 -0700400 }
401
Alex Sakhartchoukd3e0ad42010-06-24 17:15:34 -0700402FontCreateFromFile {
403 param const char *name
Alex Sakhartchoukc17ace22010-12-17 11:41:08 -0800404 param float fontSize
Alex Sakhartchoukd3e0ad42010-06-24 17:15:34 -0700405 param uint32_t dpi
406 ret RsFont
407 }
408
Alex Sakhartchouk5224a272011-01-07 11:12:08 -0800409FontCreateFromMemory {
410 param const char *name
411 param float fontSize
412 param uint32_t dpi
Alex Sakhartchouk70b83c12011-04-06 10:57:51 -0700413 param const void *data
Alex Sakhartchouk5224a272011-01-07 11:12:08 -0800414 ret RsFont
415 }
416
Alex Sakhartchouk4e9a7a82010-07-01 16:14:06 -0700417MeshCreate {
418 ret RsMesh
419 param uint32_t vtxCount
420 param uint32_t idxCount
421 }
422
423MeshBindIndex {
424 param RsMesh mesh
425 param RsAllocation idx
426 param uint32_t primType
427 param uint32_t slot
428 }
429
Alex Sakhartchouk4e9a7a82010-07-01 16:14:06 -0700430MeshBindVertex {
431 param RsMesh mesh
432 param RsAllocation vtx
433 param uint32_t slot
434 }
435
Alex Sakhartchouk54929cc2010-11-08 15:10:52 -0800436MeshInitVertexAttribs {
437 param RsMesh mesh
438 }
Jason Sams186e5912011-04-26 14:50:00 -0700439