blob: 14094c4732c3e8f62240b09dfb15cb9b1768832c [file] [log] [blame]
Jason Sams326e0dd2009-05-22 14:03:28 -07001
Jason Sams8c880902010-06-15 12:15:57 -07002ContextFinish {
3 handcodeApi
4 }
Jason Sams326e0dd2009-05-22 14:03:28 -07005
Jason Sams326e0dd2009-05-22 14:03:28 -07006ContextBindRootScript {
7 param RsScript sampler
8 }
9
Jason Samsccc010b2010-05-13 18:30:11 -070010ContextBindProgramStore {
11 param RsProgramStore pgm
Jason Sams326e0dd2009-05-22 14:03:28 -070012 }
13
14ContextBindProgramFragment {
15 param RsProgramFragment pgm
16 }
17
18ContextBindProgramVertex {
19 param RsProgramVertex pgm
20 }
21
Jason Sams5fd09d82009-09-23 13:57:02 -070022ContextBindProgramRaster {
23 param RsProgramRaster pgm
24 }
25
Alex Sakhartchoukd3e0ad42010-06-24 17:15:34 -070026ContextBindFont {
27 param RsFont pgm
28 }
29
Jason Sams86f1b232009-09-24 17:38:20 -070030ContextPause {
31 }
32
33ContextResume {
34 }
35
Jason Sams458f2dc2009-11-03 13:58:36 -080036ContextSetSurface {
Jason Sams613cad12009-11-12 15:10:25 -080037 param uint32_t width
38 param uint32_t height
Dianne Hackborn1c769c32010-06-30 13:56:17 -070039 param ANativeWindow *sur
Jason Sams458f2dc2009-11-03 13:58:36 -080040 }
41
Jason Samsc21cf402009-11-17 17:26:46 -080042ContextDump {
43 param int32_t bits
44}
45
Jason Sams613cad12009-11-12 15:10:25 -080046ContextSetPriority {
Jason Sams15832442009-11-15 12:14:26 -080047 param int32_t priority
Jason Sams613cad12009-11-12 15:10:25 -080048 }
49
Jason Sams1dcefab2010-12-09 12:19:46 -080050ContextDestroy {
51}
52
Jason Samsa0a1b6f2009-06-10 15:04:38 -070053AssignName {
54 param void *obj
55 param const char *name
Jason Samsa4a54e42009-06-10 18:39:40 -070056 param size_t len
Jason Samsa0a1b6f2009-06-10 15:04:38 -070057 }
Jason Sams326e0dd2009-05-22 14:03:28 -070058
Jason Sams707aaf32009-08-18 14:14:24 -070059ObjDestroy {
Jason Sams2353ae32010-10-14 17:48:46 -070060 param RsAsyncVoidPtr objPtr
Jason Sams707aaf32009-08-18 14:14:24 -070061 }
62
Jason Samsd01d9702009-12-23 14:35:29 -080063ElementCreate {
64 param RsDataType mType
65 param RsDataKind mKind
66 param bool mNormalized
67 param uint32_t mVectorSize
68 ret RsElement
Jason Sams326e0dd2009-05-22 14:03:28 -070069 }
70
Jason Samsd01d9702009-12-23 14:35:29 -080071ElementCreate2 {
72 param size_t count
73 param const RsElement * elements
74 param const char ** names
75 param const size_t * nameLengths
Jason Sams46e45542010-09-02 17:35:23 -070076 param const uint32_t * arraySize
Jason Sams326e0dd2009-05-22 14:03:28 -070077 ret RsElement
78 }
79
Jason Sams837e3882010-12-10 16:03:15 -080080AllocationCopyFromBitmap {
Alex Sakhartchouk39f2ef62010-10-11 12:35:15 -070081 param RsAllocation alloc
Alex Sakhartchouk39f2ef62010-10-11 12:35:15 -070082 param const void * data
Jason Sams837e3882010-12-10 16:03:15 -080083 param size_t dataLen
84 }
85
86AllocationCopyToBitmap {
87 param RsAllocation alloc
88 param void * data
89 param size_t dataLen
Alex Sakhartchouk39f2ef62010-10-11 12:35:15 -070090 }
91
Jason Samsfa84da22010-03-01 15:31:04 -080092AllocationCreateBitmapRef {
93 param RsType type
Jason Sams2353ae32010-10-14 17:48:46 -070094 param RsAsyncVoidPtr bmpPtr
95 param RsAsyncVoidPtr callbackData
Jason Samsfa84da22010-03-01 15:31:04 -080096 param RsBitmapCallback_t callback
97 ret RsAllocation
98 }
99
Jason Sams326e0dd2009-05-22 14:03:28 -0700100AllocationUploadToTexture {
101 param RsAllocation alloc
Jason Sams7fabe1a2010-02-23 17:44:28 -0800102 param bool genMipMaps
Jason Sams326e0dd2009-05-22 14:03:28 -0700103 param uint32_t baseMipLevel
104 }
105
106AllocationUploadToBufferObject {
107 param RsAllocation alloc
108 }
109
Jason Sams326e0dd2009-05-22 14:03:28 -0700110
111AllocationData {
112 param RsAllocation va
113 param const void * data
Jason Sams9397e302009-08-27 20:23:34 -0700114 param uint32_t bytes
115 handcodeApi
116 togglePlay
Jason Samsd34b7252009-08-04 16:58:20 -0700117 }
Jason Sams326e0dd2009-05-22 14:03:28 -0700118
119Allocation1DSubData {
120 param RsAllocation va
121 param uint32_t xoff
122 param uint32_t count
123 param const void *data
Jason Sams9397e302009-08-27 20:23:34 -0700124 param uint32_t bytes
125 handcodeApi
126 togglePlay
Jason Samsd34b7252009-08-04 16:58:20 -0700127 }
Jason Sams326e0dd2009-05-22 14:03:28 -0700128
Jason Sams5f0c84c2010-08-31 13:50:42 -0700129Allocation1DSubElementData {
130 param RsAllocation va
131 param uint32_t x
132 param const void *data
133 param uint32_t comp_offset
134 param uint32_t bytes
135 handcodeApi
136 togglePlay
137 }
138
Jason Sams326e0dd2009-05-22 14:03:28 -0700139Allocation2DSubData {
140 param RsAllocation va
141 param uint32_t xoff
142 param uint32_t yoff
143 param uint32_t w
144 param uint32_t h
145 param const void *data
Jason Sams9397e302009-08-27 20:23:34 -0700146 param uint32_t bytes
Jason Sams326e0dd2009-05-22 14:03:28 -0700147 }
148
Jason Sams5f0c84c2010-08-31 13:50:42 -0700149Allocation2DSubElementData {
150 param RsAllocation va
151 param uint32_t x
152 param uint32_t y
153 param const void *data
154 param uint32_t element_offset
155 param uint32_t bytes
156 }
157
Jason Samse579df42009-08-10 14:55:26 -0700158AllocationRead {
159 param RsAllocation va
160 param void * data
161 }
Jason Sams326e0dd2009-05-22 14:03:28 -0700162
Jason Sams366c9c82010-12-08 16:14:36 -0800163AllocationSyncAll {
164 param RsAllocation va
165 param RsAllocationUsageType src
166}
167
Jason Sams326e0dd2009-05-22 14:03:28 -0700168Adapter1DCreate {
169 ret RsAdapter1D
170 }
171
172Adapter1DBindAllocation {
173 param RsAdapter1D adapt
174 param RsAllocation alloc
175 }
176
Jason Sams326e0dd2009-05-22 14:03:28 -0700177Adapter1DSetConstraint {
178 param RsAdapter1D adapter
179 param RsDimension dim
180 param uint32_t value
181 }
182
183Adapter1DData {
184 param RsAdapter1D adapter
185 param const void * data
Jason Samsd34b7252009-08-04 16:58:20 -0700186 }
Jason Sams326e0dd2009-05-22 14:03:28 -0700187
188Adapter1DSubData {
189 param RsAdapter1D adapter
190 param uint32_t xoff
191 param uint32_t count
192 param const void *data
Jason Samsd34b7252009-08-04 16:58:20 -0700193 }
Jason Sams326e0dd2009-05-22 14:03:28 -0700194
195Adapter2DCreate {
196 ret RsAdapter2D
197 }
198
199Adapter2DBindAllocation {
200 param RsAdapter2D adapt
201 param RsAllocation alloc
202 }
203
Jason Sams326e0dd2009-05-22 14:03:28 -0700204Adapter2DSetConstraint {
205 param RsAdapter2D adapter
206 param RsDimension dim
207 param uint32_t value
208 }
209
210Adapter2DData {
211 param RsAdapter2D adapter
212 param const void *data
Jason Samsd34b7252009-08-04 16:58:20 -0700213 }
Jason Sams326e0dd2009-05-22 14:03:28 -0700214
215Adapter2DSubData {
216 param RsAdapter2D adapter
217 param uint32_t xoff
218 param uint32_t yoff
219 param uint32_t w
220 param uint32_t h
221 param const void *data
222 }
223
Jason Sams96abf812010-10-05 13:32:49 -0700224AllocationResize1D {
225 param RsAllocation va
226 param uint32_t dimX
227 }
228
229AllocationResize2D {
230 param RsAllocation va
231 param uint32_t dimX
232 param uint32_t dimY
233 }
234
Jason Sams326e0dd2009-05-22 14:03:28 -0700235SamplerBegin {
236 }
237
238SamplerSet {
239 param RsSamplerParam p
240 param RsSamplerValue value
241 }
242
Alex Sakhartchouk1103d8e2010-09-30 11:36:37 -0700243SamplerSet2 {
244 param RsSamplerParam p
245 param float value
246 }
247
Jason Sams326e0dd2009-05-22 14:03:28 -0700248SamplerCreate {
249 ret RsSampler
250 }
251
252
Jason Sams326e0dd2009-05-22 14:03:28 -0700253
254ScriptBindAllocation {
255 param RsScript vtm
256 param RsAllocation va
257 param uint32_t slot
258 }
259
260
261ScriptCBegin {
262 }
263
Jason Sams326e0dd2009-05-22 14:03:28 -0700264
Jason Samsd34b7252009-08-04 16:58:20 -0700265ScriptSetTimeZone {
266 param RsScript s
Romain Guy98e10fd2009-07-30 18:45:01 -0700267 param const char * timeZone
268 param uint32_t length
269 }
270
Jason Sams8c6bc692009-09-16 15:04:38 -0700271
272ScriptInvoke {
273 param RsScript s
274 param uint32_t slot
275 }
276
Jason Samsbe36bf32010-05-11 14:03:58 -0700277ScriptInvokeV {
278 param RsScript s
279 param uint32_t slot
280 param const void * data
281 param uint32_t dataLen
282 handcodeApi
283 togglePlay
284 }
285
Jason Samsbe36bf32010-05-11 14:03:58 -0700286ScriptSetVarI {
287 param RsScript s
288 param uint32_t slot
289 param int value
290 }
291
Jason Samsa5eb6e12010-11-16 17:37:02 -0800292ScriptSetVarObj {
293 param RsScript s
294 param uint32_t slot
295 param RsObjectBase value
296 }
297
Stephen Hines0977c942010-10-11 10:54:21 -0700298ScriptSetVarJ {
299 param RsScript s
300 param uint32_t slot
301 param int64_t value
302 }
303
Jason Samsbe36bf32010-05-11 14:03:58 -0700304ScriptSetVarF {
305 param RsScript s
306 param uint32_t slot
307 param float value
308 }
309
Stephen Hines6d0a0742010-09-20 17:20:30 -0700310ScriptSetVarD {
311 param RsScript s
312 param uint32_t slot
313 param double value
314 }
315
Jason Samsbe36bf32010-05-11 14:03:58 -0700316ScriptSetVarV {
317 param RsScript s
318 param uint32_t slot
319 param const void * data
320 param uint32_t dataLen
321 handcodeApi
322 togglePlay
323 }
Jason Samsfa517192009-08-13 12:59:04 -0700324
325
Jason Sams1f526332009-06-05 17:35:09 -0700326ScriptCSetText {
327 param const char * text
328 param uint32_t length
329 }
330
Jason Sams326e0dd2009-05-22 14:03:28 -0700331ScriptCCreate {
Shih-wei Liao9503b662010-11-08 01:33:59 -0800332 param const char * resName
Jason Sams326e0dd2009-05-22 14:03:28 -0700333 ret RsScript
334 }
335
336
Jason Samsccc010b2010-05-13 18:30:11 -0700337ProgramStoreBegin {
Jason Sams326e0dd2009-05-22 14:03:28 -0700338 param RsElement in
339 param RsElement out
340 }
341
Jason Samsccc010b2010-05-13 18:30:11 -0700342ProgramStoreColorMask {
Jason Sams326e0dd2009-05-22 14:03:28 -0700343 param bool r
344 param bool g
345 param bool b
346 param bool a
347 }
348
Jason Samsccc010b2010-05-13 18:30:11 -0700349ProgramStoreBlendFunc {
Jason Sams326e0dd2009-05-22 14:03:28 -0700350 param RsBlendSrcFunc srcFunc
351 param RsBlendDstFunc destFunc
352 }
353
Jason Samsccc010b2010-05-13 18:30:11 -0700354ProgramStoreDepthMask {
Jason Sams326e0dd2009-05-22 14:03:28 -0700355 param bool enable
356}
357
Jason Samsccc010b2010-05-13 18:30:11 -0700358ProgramStoreDither {
Jason Sams326e0dd2009-05-22 14:03:28 -0700359 param bool enable
360}
361
Jason Samsccc010b2010-05-13 18:30:11 -0700362ProgramStoreDepthFunc {
Jason Sams326e0dd2009-05-22 14:03:28 -0700363 param RsDepthFunc func
364}
365
Jason Samsccc010b2010-05-13 18:30:11 -0700366ProgramStoreCreate {
367 ret RsProgramStore
Jason Sams326e0dd2009-05-22 14:03:28 -0700368 }
369
Jason Sams5fd09d82009-09-23 13:57:02 -0700370ProgramRasterCreate {
Jason Sams5fd09d82009-09-23 13:57:02 -0700371 param bool pointSmooth
372 param bool lineSmooth
373 param bool pointSprite
374 ret RsProgramRaster
375}
376
377ProgramRasterSetLineWidth {
378 param RsProgramRaster pr
379 param float lw
380}
381
Alex Sakhartchoukd18c7442010-07-12 15:50:32 -0700382ProgramRasterSetCullMode {
383 param RsProgramRaster pr
384 param RsCullMode mode
385}
Jason Sams326e0dd2009-05-22 14:03:28 -0700386
Jason Sams4815c0d2009-12-15 12:58:36 -0800387ProgramBindConstants {
388 param RsProgram vp
389 param uint32_t slot
390 param RsAllocation constants
391 }
392
Jason Sams326e0dd2009-05-22 14:03:28 -0700393
Jason Sams7dad9c32009-12-17 16:55:08 -0800394ProgramBindTexture {
Jason Sams326e0dd2009-05-22 14:03:28 -0700395 param RsProgramFragment pf
396 param uint32_t slot
397 param RsAllocation a
398 }
399
Jason Sams7dad9c32009-12-17 16:55:08 -0800400ProgramBindSampler {
Jason Sams326e0dd2009-05-22 14:03:28 -0700401 param RsProgramFragment pf
402 param uint32_t slot
403 param RsSampler s
404 }
405
Jason Sams326e0dd2009-05-22 14:03:28 -0700406ProgramFragmentCreate {
Jason Samsf2e4fa22009-12-15 13:27:04 -0800407 param const char * shaderText
408 param uint32_t shaderLength
409 param const uint32_t * params
410 param uint32_t paramLength
411 ret RsProgramFragment
412 }
413
Jason Sams326e0dd2009-05-22 14:03:28 -0700414ProgramVertexCreate {
Jason Sams4815c0d2009-12-15 12:58:36 -0800415 param const char * shaderText
416 param uint32_t shaderLength
417 param const uint32_t * params
418 param uint32_t paramLength
Jason Samsf2e4fa22009-12-15 13:27:04 -0800419 ret RsProgramVertex
Jason Samsb5909ce2009-07-21 12:20:54 -0700420 }
421
Jason Samsa5597fc2009-07-08 18:01:53 -0700422FileOpen {
423 ret RsFile
424 param const char *name
425 param size_t len
426 }
427
Alex Sakhartchoukd3e0ad42010-06-24 17:15:34 -0700428FontCreateFromFile {
429 param const char *name
430 param uint32_t fontSize
431 param uint32_t dpi
432 ret RsFont
433 }
434
Alex Sakhartchouk4e9a7a82010-07-01 16:14:06 -0700435MeshCreate {
436 ret RsMesh
437 param uint32_t vtxCount
438 param uint32_t idxCount
439 }
440
441MeshBindIndex {
442 param RsMesh mesh
443 param RsAllocation idx
444 param uint32_t primType
445 param uint32_t slot
446 }
447
Alex Sakhartchouk4e9a7a82010-07-01 16:14:06 -0700448MeshBindVertex {
449 param RsMesh mesh
450 param RsAllocation vtx
451 param uint32_t slot
452 }
453
Alex Sakhartchouk54929cc2010-11-08 15:10:52 -0800454MeshInitVertexAttribs {
455 param RsMesh mesh
456 }
457
Jason Samsc1ed5892010-03-10 17:30:41 -0800458AnimationCreate {
459 param const float *inValues
460 param const float *outValues
461 param uint32_t valueCount
462 param RsAnimationInterpolation interp
463 param RsAnimationEdge pre
464 param RsAnimationEdge post
465 ret RsAnimation
466 }
467