blob: 963a6e78dc29d084e007b8c76054b414e0ae2295 [file] [log] [blame]
Jason Sams326e0dd2009-05-22 14:03:28 -07001
Jason Sams186e5912011-04-26 14:50:00 -07002ContextDestroy {
3 direct
4}
5
6ContextGetMessage {
7 direct
8 param void *data
9 param size_t *receiveLen
Jason Sams1a4efa32011-05-17 15:01:29 -070010 param uint32_t *usrID
Jason Sams186e5912011-04-26 14:50:00 -070011 ret RsMessageToClientType
12}
13
14ContextPeekMessage {
15 direct
16 param size_t *receiveLen
Jason Sams1a4efa32011-05-17 15:01:29 -070017 param uint32_t *usrID
Jason Sams186e5912011-04-26 14:50:00 -070018 ret RsMessageToClientType
19}
20
21ContextInitToClient {
22 direct
23}
24
25ContextDeinitToClient {
26 direct
27}
28
Jason Samsc975cf42011-04-28 18:26:48 -070029TypeCreate {
Jason Sams186e5912011-04-26 14:50:00 -070030 direct
31 param RsElement e
32 param uint32_t dimX
33 param uint32_t dimY
34 param uint32_t dimZ
35 param bool mips
36 param bool faces
37 ret RsType
38}
39
Jason Samsc975cf42011-04-28 18:26:48 -070040AllocationCreateTyped {
Jason Sams186e5912011-04-26 14:50:00 -070041 direct
42 param RsType vtype
43 param RsAllocationMipmapControl mips
44 param uint32_t usages
45 ret RsAllocation
46}
47
Jason Samsc975cf42011-04-28 18:26:48 -070048AllocationCreateFromBitmap {
Jason Sams186e5912011-04-26 14:50:00 -070049 direct
50 param RsType vtype
51 param RsAllocationMipmapControl mips
52 param const void *data
53 param uint32_t usages
54 ret RsAllocation
55}
56
Jason Samsc975cf42011-04-28 18:26:48 -070057AllocationCubeCreateFromBitmap {
Jason Sams186e5912011-04-26 14:50:00 -070058 direct
59 param RsType vtype
60 param RsAllocationMipmapControl mips
61 param const void *data
62 param uint32_t usages
63 ret RsAllocation
64}
65
66
67
Jason Sams8c880902010-06-15 12:15:57 -070068ContextFinish {
Jason Sams1a4efa32011-05-17 15:01:29 -070069 sync
Jason Sams8c880902010-06-15 12:15:57 -070070 }
Jason Sams326e0dd2009-05-22 14:03:28 -070071
Jason Sams326e0dd2009-05-22 14:03:28 -070072ContextBindRootScript {
73 param RsScript sampler
74 }
75
Jason Samsccc010b2010-05-13 18:30:11 -070076ContextBindProgramStore {
77 param RsProgramStore pgm
Jason Sams326e0dd2009-05-22 14:03:28 -070078 }
79
80ContextBindProgramFragment {
81 param RsProgramFragment pgm
82 }
83
84ContextBindProgramVertex {
85 param RsProgramVertex pgm
86 }
87
Jason Sams5fd09d82009-09-23 13:57:02 -070088ContextBindProgramRaster {
89 param RsProgramRaster pgm
90 }
91
Alex Sakhartchoukd3e0ad42010-06-24 17:15:34 -070092ContextBindFont {
93 param RsFont pgm
94 }
95
Jason Sams86f1b232009-09-24 17:38:20 -070096ContextPause {
97 }
98
99ContextResume {
100 }
101
Jason Sams458f2dc2009-11-03 13:58:36 -0800102ContextSetSurface {
Jason Sams613cad12009-11-12 15:10:25 -0800103 param uint32_t width
104 param uint32_t height
Alex Sakhartchouk7257c7e2011-05-17 12:32:47 -0700105 param RsNativeWindow sur
Jason Sams458f2dc2009-11-03 13:58:36 -0800106 }
107
Jason Samsc21cf402009-11-17 17:26:46 -0800108ContextDump {
109 param int32_t bits
110}
111
Jason Sams613cad12009-11-12 15:10:25 -0800112ContextSetPriority {
Jason Sams15832442009-11-15 12:14:26 -0800113 param int32_t priority
Jason Sams613cad12009-11-12 15:10:25 -0800114 }
115
Jason Sams741aac92010-12-24 14:38:39 -0800116ContextDestroyWorker {
Jason Sams1dcefab2010-12-09 12:19:46 -0800117}
118
Jason Samsa0a1b6f2009-06-10 15:04:38 -0700119AssignName {
Alex Sakhartchouk70b83c12011-04-06 10:57:51 -0700120 param RsObjectBase obj
Jason Samsa0a1b6f2009-06-10 15:04:38 -0700121 param const char *name
122 }
Jason Sams326e0dd2009-05-22 14:03:28 -0700123
Jason Sams707aaf32009-08-18 14:14:24 -0700124ObjDestroy {
Jason Sams2353ae32010-10-14 17:48:46 -0700125 param RsAsyncVoidPtr objPtr
Jason Sams707aaf32009-08-18 14:14:24 -0700126 }
127
Jason Samsd01d9702009-12-23 14:35:29 -0800128ElementCreate {
129 param RsDataType mType
130 param RsDataKind mKind
131 param bool mNormalized
132 param uint32_t mVectorSize
133 ret RsElement
Jason Sams326e0dd2009-05-22 14:03:28 -0700134 }
135
Jason Samsd01d9702009-12-23 14:35:29 -0800136ElementCreate2 {
Jason Samsd01d9702009-12-23 14:35:29 -0800137 param const RsElement * elements
138 param const char ** names
Jason Sams46e45542010-09-02 17:35:23 -0700139 param const uint32_t * arraySize
Jason Sams326e0dd2009-05-22 14:03:28 -0700140 ret RsElement
141 }
142
Jason Sams837e3882010-12-10 16:03:15 -0800143AllocationCopyToBitmap {
144 param RsAllocation alloc
145 param void * data
Alex Sakhartchouk39f2ef62010-10-11 12:35:15 -0700146 }
147
Jason Sams326e0dd2009-05-22 14:03:28 -0700148
Jason Sams4b45b892010-12-29 14:31:29 -0800149Allocation1DData {
Jason Sams326e0dd2009-05-22 14:03:28 -0700150 param RsAllocation va
151 param uint32_t xoff
Jason Sams4b45b892010-12-29 14:31:29 -0800152 param uint32_t lod
Jason Sams326e0dd2009-05-22 14:03:28 -0700153 param uint32_t count
154 param const void *data
Jason Samsd34b7252009-08-04 16:58:20 -0700155 }
Jason Sams326e0dd2009-05-22 14:03:28 -0700156
Jason Sams4b45b892010-12-29 14:31:29 -0800157Allocation1DElementData {
Jason Sams5f0c84c2010-08-31 13:50:42 -0700158 param RsAllocation va
159 param uint32_t x
Jason Sams4b45b892010-12-29 14:31:29 -0800160 param uint32_t lod
Jason Sams5f0c84c2010-08-31 13:50:42 -0700161 param const void *data
162 param uint32_t comp_offset
Jason Sams5f0c84c2010-08-31 13:50:42 -0700163 }
164
Jason Sams4b45b892010-12-29 14:31:29 -0800165Allocation2DData {
Jason Sams326e0dd2009-05-22 14:03:28 -0700166 param RsAllocation va
167 param uint32_t xoff
168 param uint32_t yoff
Jason Sams4b45b892010-12-29 14:31:29 -0800169 param uint32_t lod
170 param RsAllocationCubemapFace face
Jason Sams326e0dd2009-05-22 14:03:28 -0700171 param uint32_t w
172 param uint32_t h
173 param const void *data
174 }
175
Jason Sams4b45b892010-12-29 14:31:29 -0800176Allocation2DElementData {
Jason Sams5f0c84c2010-08-31 13:50:42 -0700177 param RsAllocation va
178 param uint32_t x
179 param uint32_t y
Jason Sams4b45b892010-12-29 14:31:29 -0800180 param uint32_t lod
181 param RsAllocationCubemapFace face
Jason Sams5f0c84c2010-08-31 13:50:42 -0700182 param const void *data
183 param uint32_t element_offset
Jason Sams5f0c84c2010-08-31 13:50:42 -0700184 }
185
Jason Samsa2371512011-01-12 13:28:37 -0800186AllocationGenerateMipmaps {
187 param RsAllocation va
188}
189
Jason Samse579df42009-08-10 14:55:26 -0700190AllocationRead {
191 param RsAllocation va
192 param void * data
193 }
Jason Sams326e0dd2009-05-22 14:03:28 -0700194
Jason Sams366c9c82010-12-08 16:14:36 -0800195AllocationSyncAll {
196 param RsAllocation va
197 param RsAllocationUsageType src
198}
199
Jason Sams326e0dd2009-05-22 14:03:28 -0700200
Jason Sams96abf812010-10-05 13:32:49 -0700201AllocationResize1D {
202 param RsAllocation va
203 param uint32_t dimX
204 }
205
206AllocationResize2D {
207 param RsAllocation va
208 param uint32_t dimX
209 param uint32_t dimY
210 }
211
Alex Sakhartchouk74a82792011-06-14 11:13:19 -0700212AllocationCopy2DRange {
213 param RsAllocation dest
214 param uint32_t destXoff
215 param uint32_t destYoff
216 param uint32_t destMip
217 param uint32_t destFace
218 param uint32_t width
219 param uint32_t height
220 param RsAllocation src
221 param uint32_t srcXoff
222 param uint32_t srcYoff
223 param uint32_t srcMip
224 param uint32_t srcFace
225 }
226
Jason Sams326e0dd2009-05-22 14:03:28 -0700227SamplerCreate {
Alex Sakhartchoukc2c02a82011-05-04 17:45:36 -0700228 param RsSamplerValue magFilter
229 param RsSamplerValue minFilter
230 param RsSamplerValue wrapS
231 param RsSamplerValue wrapT
232 param RsSamplerValue wrapR
233 param float mAniso
234 ret RsSampler
235}
Jason Sams326e0dd2009-05-22 14:03:28 -0700236
237ScriptBindAllocation {
238 param RsScript vtm
239 param RsAllocation va
240 param uint32_t slot
241 }
242
Jason Samsd34b7252009-08-04 16:58:20 -0700243ScriptSetTimeZone {
244 param RsScript s
Romain Guy98e10fd2009-07-30 18:45:01 -0700245 param const char * timeZone
Romain Guy98e10fd2009-07-30 18:45:01 -0700246 }
247
Jason Sams8c6bc692009-09-16 15:04:38 -0700248ScriptInvoke {
249 param RsScript s
250 param uint32_t slot
251 }
252
Jason Samsbe36bf32010-05-11 14:03:58 -0700253ScriptInvokeV {
254 param RsScript s
255 param uint32_t slot
256 param const void * data
Jason Samsbe36bf32010-05-11 14:03:58 -0700257 }
258
Alex Sakhartchoukc2c02a82011-05-04 17:45:36 -0700259ScriptForEach {
Jason Sams5fb1aeb2011-04-27 15:12:49 -0700260 param RsScript s
261 param uint32_t slot
262 param RsAllocation ain
263 param RsAllocation aout
264 param const void * usr
265}
266
Jason Samsbe36bf32010-05-11 14:03:58 -0700267ScriptSetVarI {
268 param RsScript s
269 param uint32_t slot
270 param int value
271 }
272
Jason Samsa5eb6e12010-11-16 17:37:02 -0800273ScriptSetVarObj {
274 param RsScript s
275 param uint32_t slot
276 param RsObjectBase value
277 }
278
Stephen Hines0977c942010-10-11 10:54:21 -0700279ScriptSetVarJ {
280 param RsScript s
281 param uint32_t slot
282 param int64_t value
283 }
284
Jason Samsbe36bf32010-05-11 14:03:58 -0700285ScriptSetVarF {
286 param RsScript s
287 param uint32_t slot
288 param float value
289 }
290
Stephen Hines6d0a0742010-09-20 17:20:30 -0700291ScriptSetVarD {
292 param RsScript s
293 param uint32_t slot
294 param double value
295 }
296
Jason Samsbe36bf32010-05-11 14:03:58 -0700297ScriptSetVarV {
298 param RsScript s
299 param uint32_t slot
300 param const void * data
Jason Samsbe36bf32010-05-11 14:03:58 -0700301 }
Jason Samsfa517192009-08-13 12:59:04 -0700302
303
Jason Sams326e0dd2009-05-22 14:03:28 -0700304ScriptCCreate {
Shih-wei Liao9503b662010-11-08 01:33:59 -0800305 param const char * resName
Shih-wei Liao15849d92010-12-10 01:03:59 -0800306 param const char * cacheDir
Jason Samsbad80742011-03-16 16:29:28 -0700307 param const char * text
Jason Sams326e0dd2009-05-22 14:03:28 -0700308 ret RsScript
309 }
310
311
Jason Sams721acc42011-04-06 11:23:54 -0700312ProgramStoreCreate {
313 param bool colorMaskR
314 param bool colorMaskG
315 param bool colorMaskB
316 param bool colorMaskA
317 param bool depthMask
318 param bool ditherEnable
Jason Sams326e0dd2009-05-22 14:03:28 -0700319 param RsBlendSrcFunc srcFunc
320 param RsBlendDstFunc destFunc
Jason Sams721acc42011-04-06 11:23:54 -0700321 param RsDepthFunc depthFunc
Jason Samsccc010b2010-05-13 18:30:11 -0700322 ret RsProgramStore
Jason Sams326e0dd2009-05-22 14:03:28 -0700323 }
324
Jason Sams5fd09d82009-09-23 13:57:02 -0700325ProgramRasterCreate {
Jason Sams5fd09d82009-09-23 13:57:02 -0700326 param bool pointSmooth
327 param bool lineSmooth
328 param bool pointSprite
Jason Sams721acc42011-04-06 11:23:54 -0700329 param float lineWidth
330 param RsCullMode cull
Jason Sams5fd09d82009-09-23 13:57:02 -0700331 ret RsProgramRaster
332}
333
Jason Sams4815c0d2009-12-15 12:58:36 -0800334ProgramBindConstants {
335 param RsProgram vp
336 param uint32_t slot
337 param RsAllocation constants
338 }
339
Jason Sams326e0dd2009-05-22 14:03:28 -0700340
Jason Sams7dad9c32009-12-17 16:55:08 -0800341ProgramBindTexture {
Jason Sams326e0dd2009-05-22 14:03:28 -0700342 param RsProgramFragment pf
343 param uint32_t slot
344 param RsAllocation a
345 }
346
Jason Sams7dad9c32009-12-17 16:55:08 -0800347ProgramBindSampler {
Jason Sams326e0dd2009-05-22 14:03:28 -0700348 param RsProgramFragment pf
349 param uint32_t slot
350 param RsSampler s
351 }
352
Jason Sams326e0dd2009-05-22 14:03:28 -0700353ProgramFragmentCreate {
Jason Samsf2e4fa22009-12-15 13:27:04 -0800354 param const char * shaderText
Jason Samsf2e4fa22009-12-15 13:27:04 -0800355 param const uint32_t * params
Jason Samsf2e4fa22009-12-15 13:27:04 -0800356 ret RsProgramFragment
357 }
358
Jason Sams326e0dd2009-05-22 14:03:28 -0700359ProgramVertexCreate {
Jason Sams4815c0d2009-12-15 12:58:36 -0800360 param const char * shaderText
Jason Sams4815c0d2009-12-15 12:58:36 -0800361 param const uint32_t * params
Jason Samsf2e4fa22009-12-15 13:27:04 -0800362 ret RsProgramVertex
Jason Samsb5909ce2009-07-21 12:20:54 -0700363 }
364
Alex Sakhartchoukd3e0ad42010-06-24 17:15:34 -0700365FontCreateFromFile {
366 param const char *name
Alex Sakhartchoukc17ace22010-12-17 11:41:08 -0800367 param float fontSize
Alex Sakhartchoukd3e0ad42010-06-24 17:15:34 -0700368 param uint32_t dpi
369 ret RsFont
370 }
371
Alex Sakhartchouk5224a272011-01-07 11:12:08 -0800372FontCreateFromMemory {
373 param const char *name
374 param float fontSize
375 param uint32_t dpi
Alex Sakhartchouk70b83c12011-04-06 10:57:51 -0700376 param const void *data
Alex Sakhartchouk5224a272011-01-07 11:12:08 -0800377 ret RsFont
378 }
379
Alex Sakhartchouk4e9a7a82010-07-01 16:14:06 -0700380MeshCreate {
Alex Sakhartchouk9003e562011-05-12 10:38:03 -0700381 param RsAllocation *vtx
382 param RsAllocation *idx
383 param uint32_t *primType
Alex Sakhartchouk4e9a7a82010-07-01 16:14:06 -0700384 ret RsMesh
Alex Sakhartchouk4e9a7a82010-07-01 16:14:06 -0700385 }